СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Каталог заданий.
Квадратичная функция

Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 21 № 3330

Опре­де­ли­те, какое число будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­ще­го ал­го­рит­ма:

 

 

Бэй­сик Пас­каль

DIM A, B, T, M, R AS INTEGER

A = -20: B = 20

M = A: R = F(A)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT R

 

FUNCTION F(x)

    F := 4*(x-5)*(x+3)

END FUNCTION

var a,b,t,M,R :integer;

    Function F(x: integer):integer;

    begin

        F := 4*(x-5)*(x+3);

    end;

BEGIN

    a := -20; b := 20;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t)< R) then begin

            M := t;

            R := F(t);

        end;

    end;

write(R);

END.

Си++ Ал­го­рит­ми­че­ский

#include <iostream>

using namespace std;

int F(int x)

{

    return 4*(x-5)*(x+3)

}

int main()

{

    int a, b, t, M, R;

    a = -20; b = 20;

    M = a; R = F(a);

    for (t=a; t<=b; t++){

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « R « endl;

}

алг

нач

цел a, b, t, R, M

a := -20; b := 20

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод R

кон

алг цел F(цел x)

нач

знач := 4*(x-5)*(x+3)

кон

Python

def f(x):

    return 4*(x-5)*(x+3)

a = -20

b = 20

M = a

R = f(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(R)

 


2
Задание 21 № 3331

Определите, какое число будет напечатано в результате выполнения следующего алгоритма:

 

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A = -5: B = 5

M = A: R = F(А)

FOR T = A TO B

    IF F(T) > R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT R

FUNCTION F(x)

    F = (x+5)*(x+3)

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := (x+5)*(x+3)

        end;

begin

    a := -5; b := 5;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) > R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(R)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return (x+5)*(x+3);

}

int main()

{

    int a, b, t, M, R;

    a = -5; b = 5;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) > R) {

            M = t; R = F(t);

        }

    }

    cout « R « endl;

}

алг

нач

цел a, b, t, M, R

a := -5; b := 5

M := a; R := F(a)

нц для t от a до b

если F(t) > R

то

M := t; R := F(t)

все

кц

вывод R

кон

алг цел F(цел x)

нач

знач := (x+5)*(x+3)

кон

Python

def f(x):

    return (x+5)*(x+3)

a = -5

b = 5

M = a

R = F(a)

for t in range(a, b+1):

    if (f(t) > R):

        M = t

        R = f(t);

print(R)

 


Аналоги к заданию № 3331: 3334 3338 3345 3348 3350 3351 3748 7280 Все


3
Задание 21 № 7678

На­пи­ши­те в от­ве­те ко­ли­че­ство раз­лич­ных зна­че­ний вход­ной пе­ре­мен­ной k, при ко­то­рых про­грам­ма выдаёт тот же ответ, что и при вход­ном зна­че­нии k = 64. Зна­че­ние k = 64 также вклю­ча­ет­ся в подсчёт раз­лич­ных зна­че­ний k. Для Ва­ше­го удоб­ства про­грам­ма при­ве­де­на на пяти язы­ках про­грам­ми­ро­ва­ния.

 

Бей­сикPython

DIM K, I AS LONG

INPUT K

I = 12

WHILE I > 0 AND F(I) >= K

    I = I - 1

WEND

PRINT I

FUNCTION F(N)

    F = N * N + 20

END FUNCTION

def f(n):

    return n * n + 20

k = int(input())

i = 12

while i > 0 and f(i) >= k:

    i = i - 1

print(i)

Пас­кальАл­го­рит­ми­че­ский язык

var k, i : longint;

    function f(n: longint) : longint;

        begin

            f := n * n + 20

        end;

begin

    readln(k);

    i := 12;

    while (i>0) and (f(i)>=k) do

        i := i-1;

    writeln(i)

end.

алг

нач

цел i, k

ввод k

i := 12

нц пока i > 0 и f(i) >= k

i := i - 1

кц

вывод i

кон

алг цел f(цел n)

нач

знач := n * n + 20

кон

Си++

#include <iostream>

using namespace std;

long f(long n) { return n * n + 20; }

int main()

{

    long k, i;

    cin >> k;

    i = 12;

    while (i>0 && f(i)>=k) i––;

    cout << i << endl;

}

 


Аналоги к заданию № 7678: 7467 7705 7766 7793 8109 Все


4
Задание 21 № 7932

При каком наименьшем значении входной переменной k программа выдаёт тот же ответ, что и при входном значении k = 64? Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 12

WHILE I > 0 AND F(I) > K

    I = I - 1

WEND

PRINT I

FUNCTION F(N)

    F = N * N - 20

END FUNCTION

def f(n):

    return n * n - 20

k = int(input())

i = 12

while i > 0 and f(i) > k:

    i = i - 1

print(i)

ПаскальАлгоритмический язык

var k, i : longint;

    function f(n: longint) : longint;

        begin

            f := n * n - 20

        end;

begin

    readln(k);

    i := 12;

    while (i>0) and (f(i)> k) do

        i := i-1;

    writeln(i)

end.

алг

нач

цел i, k

ввод k

i := 12

нц пока i > 0 и f(i) > k

i := i - 1

кц

вывод i

кон

алг цел f(цел n)

нач

знач := n * n - 20

кон

Си++

#include <iostream>

using namespace std;

long f(long n) { return n * n - 20; }

int main()

{

    long k, i;

    cin >> k;

    i = 12;

    while (i>0 && f(i)>k) i––;

    cout << i << endl;

    return 0;

}

 


Аналоги к заданию № 7932: 9372 7997 9771 9807 Все


5
Задание 21 № 8669

Напишите в ответе число различных значений входной переменной k, при которых программа выдаёт тот же ответ, что и при входном значении k = 55. Значение k = 55 также включается в подсчёт различных значений k. Для Вашего удобства программа приведена на пяти языках программирования.

 

 

Бейсик Python

DIM K, I AS LONG

INPUT K

I = 0

WHILE F(I) < K

    I = I + 1

WEND

PRINT I

FUNCTION F(N)

    F = 3*N*N+1

END FUNCTION

def f(n):

    return 3*n*n+1

k = int(input())

i = 0

while f(i) < k:

    i = i + 1

print(i)

Алгоритмический язык Паскаль

алг

нач

    цел i, k

    ввод k

    i := 0

    нц пока f(i) < k

        i := i+1

    кц

    вывод i

кон

алг цел f(цел n)

нач

    знач := 3*n*n+1

кон

var k, i : longint;

function f(n: longint):longint;

begin

    f := 3*n*n+1

end;

begin

    readln(k);

    i := 0;

    while (f(i)<k) do

        i := i+1;

    writeln(i)

end.

Си++

#include <iostream>

using namespace std;

long f(long n) {

    return 3*n*n+1;

}

int main()

{

    long k, i;

    cin >> k;

    i = 0;

    while (f(i)<k)

        i++;

    cout << i << endl;

}

 


Аналоги к заданию № 8669: 9173 9205 9313 Все


6
Задание 21 № 9372

На­пи­ши­те в от­ве­те наи­мень­шее зна­че­ние вход­ной пе­ре­мен­ной k, при ко­то­ром про­грам­ма выдаёт тот же ответ, что и при вход­ном зна­че­нии k = 10. Для Ва­ше­го удоб­ства про­грам­ма при­ве­де­на на пяти язы­ках про­грам­ми­ро­ва­ния.

 

Бей­сикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) < G(K)

    I = I + 1

WEND

PRINT I

 

FUNCTION F(N)

    F = N * N * N

END FUNCTION

 

FUNCTION G(N)

    G = 2*N + 3

END FUNCTION

def f(n):

    return n*n*n

 

def g(n):

    return 2*n+3

 

k = int(input())

i = 1

while f(i) < g(k):

    i+=1

print (i)

Пас­кальАл­го­рит­ми­че­ский язык

var

    k, i : longint;

 

function f(n: longint): longint;

begin

    f := n * n * n;

end;

 

function g(n: longint): longint;

begin

    g := 2*n + 3;

end;

 

begin

    readln(k);

    i := 1;

    while f(i) < g(k) do

        i := i+1;

    writeln(i)

end.

алг

нач

    цел i, k

    ввод k

    i := 1

    нц пока f(i) < g(k)

        i := i + 1

    кц

    вывод i

кон

 

алг цел f(цел n)

нач

    знач := n * n * n

кон

 

алг цел g(цел n)

нач

    знач := 2*n + 3

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

    return n * n * n;

}

 

long g(long n) {

    return 2*n + 3;

}

 

int main()

{

    long k, i;

    cin >> k;

    i = 1;

    while(f(i) < g(k))

        i++;

    cout << i << endl;

    return 0;

}

 


7
Задание 21 № 4953

Определите, какое число будет напечатано в результате выполнения следующего алгоритма (для Вашего удобства алгоритм представлен на пяти языках):

 

 

Бэйсик Паскаль

DIM A, B, T, M, R AS INTEGER

A = -20: B = 20

M = A: R = F(A)

FOR T = A TO B

    IF F(T) > R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT M

 

FUNCTION F(x)

    F := 16*(9+x)*(9+x)+127

END FUNCTION

var a,b,t,M,R :integer;

    Function F(x: integer):integer;

    begin

        F := 16*(9+x)*(9+x)+127;

    end;

BEGIN

    a := -20; b := 20;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t)> R) then begin

            M := t;

            R := F(t);

        end;

    end;

write(M);

END.

Си++ Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

    return 16*(9+x)*(9+x)+127

}

int main()

{

    int a, b, t, M, R;

    a = -20; b = 20;

    M = a; R = F(a);

    for (t=a; t<=b; t++){

        if (F(t) >R) {

            M = t; R = F(t);

        }

    }

    cout « M « endl;

}

алг

нач

цел a, b, t, R, M

a := -20; b := 20

M := a; R := F(a)

нц для t от a до b

если F(t) > R

то

M := t; R := F(t)

все

кц

вывод M

кон

алг цел F(цел x)

нач

знач := 16*(9+x)*(9+x)+127

кон

Python

def f(x):

    return 16*(9+x)*(9+x)+127

a = -20

b = 20

M = a

R = f(a)

for t in range(a, b+1):

    if (f(t) > R):

        M = t

        R = f(t);

print(M)

 


Аналоги к заданию № 4953: 4986 5370 5402 5562 5658 6197 6242 6274 7348 11122 Все


8
Задание 21 № 5221

Определите, какое число будет напечатано в результате выполнения следующего алгоритма (для Вашего удобства алгоритм представлен на четырёх языках):

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A = -7: B = 25

M = A: R = F(A)

FOR T = A TO B

    IF F(T) > R THEN

        M = T

        R = F(T)

    ENDIF

NEXT T

PRINT R

 

FUNCTION F(x)

    F = 281 - 2 * (17 + x) * (17 + x);

END FUNCTION

var a,b,t,M,R :integer;

    Function F(x:integer):integer;

        begin

            F : = 281 - 2 * (17 + x) * (17 + x);

        end;

begin

    a : = -7; b : = 25;

    M : = a; R : = F(a);

    for t : = a to b do begin

        if (F(t) > R ) then begin

            M : = t;

            R : = F(t)

        end

    end;

write(R);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int F(int x)

{

    return 281 - 2 * (17 + x) * (17 + x);

}

int main()

{

    int a, b, t, M, R;

    a = -7; b = 25;

    M = a; R = F(a);

    for (t = a; t <= b; t++){

        if (F(t) > R) {

            M = t; R = F(t);

        }

    }

    cout « R « endl;

}

алг

нач

цел a, b, t, R, M

a : = -7; b : = 25

M : = a; R : = F(a)

нц для t от a до b

если F(t) > R

то

M : = t; R : = F(t)

все

кц

вывод R

кон

алг цел F(цел x)

нач

знач : = 281 - 2 * (17 + x) * (17 + x)

кон

Python

def f(x):

    return 281 - 2 * (17 + x) * (17 + x)

a = -7

b = 25

M = a

R = f(a)

for t in range(a, b+1):

    if (f(t) > R):

        M = t

        R = f(t);

print(R)

 


Аналоги к заданию № 5221: 5253 6998 Все


9
Задание 21 № 3512

Опре­де­ли­те, какое число будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­ще­го ал­го­рит­ма (для Ва­ше­го удоб­ства ал­го­ритм пред­став­лен на че­ты­рех язы­ках):

 

Бэй­сик Пас­каль

DIM A, B, T, M, R AS INTEGER

A = -20: B = 20

T = A: M = A: R = F(A)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    ENDIF

NEXT T

PRINT M

FUNCTION F(x)

    F = 2*(x-9)*(x-9);

END FUNCTION

var a,b,t,M,R :integer;

    Function F(x: integer):integer;

        begin

            F := 2*(x-9)*(x-9);

        end;

BEGIN

    a := -20; b := 20;

    M := a; R := F(a);

    for t := a to b do

        if (F(t)< R) then begin

            M := t;

            R := F(t);

        end;

    write(M);

END.

Си++ Ал­го­рит­ми­че­ский

#include <iostream>

using namespace std;

int F(int x)

{

    return 2*(x-9)*(x-9);

}

int main()

{

    int a, b, t, M, R;

    a = -20; b = 20;

    M = a; R = F(a);

    for (t=a; t<=b; t++){

        if (F(t) < R ) {

            M = t; R = F(t);

        }

    }

    cout « M « endl;

}

алг

нач

цел a, b, t, R, M

a := -20; b := 20

M := a; R := F(a)

нц для t от a до b

если F(t)< R

то

M := t; R := F(t)

все

кц

вывод M

кон

алг цел F(цел x)

нач

знач := 2*(x-9)*(x-9)

кон

Python

def f(x):

    return 2*(x-9)*(x-9)

a = -20

b = 20

M = a

R = f(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(M)

 


10
Задание 21 № 4566

Опре­де­ли­те, какое число будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­ще­го ал­го­рит­ма (для Ва­ше­го удоб­ства ал­го­ритм пред­став­лен на четырёх язы­ках).

 

Бей­сикПас­каль

DIM A, B, T, M, R AS INTEGER

A = -20: B = 20

M = A: R = F(A)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    ENDIF

NEXT T

PRINT M

FUNCTION F(x)

    F = 3*(x-8)*(x-8)

END FUNCTION

var a,b,t,M,R :integer;

    Function F(x:integer):integer;

        begin

            F := 3*(x-8)*(x-8)

        end;

begin

    a := -20; b := 20;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t);

        end

    end;

    write(M);

end.

Си++Ал­го­рит­ми­че­ский язык

#include <iostream>

using namespace std;

int F(int x)

{

    return 3*(x-8)*(x-8);

}

int main()

{

    int a, b, t, M, R;

    a = -20; b = 20;

    M = a; R = F(a);

    for (t=a; t<=b; t++){

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « M « endl;

}

алг

нач

цел a, b, t, R, M

a := -20; b := 20

M := a; R := F(a)

нц для t от a до b

если F(t)< R

то

M := t; R := F(t)

все

кц

вывод M

кон

алг цел F(цел x)

нач

знач := 3*(x-8)*(x-8)

кон

Python

def f(x):

    return 3*(x-8)*(x-8)

a = -20

b = 20

M = a

R = f(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(M)

 


11
Задание 21 № 7467

Напишите в ответе число различных значений входной переменной k, при которых программа выдаёт тот же ответ, что и при входном значении k = 64. Значение k = 64 также включается в подсчёт различных значений k. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 12

WHILE I > 0 AND F(I) >= K

    I = I - 1

WEND

PRINT I

FUNCTION F(N)

    F = N * N

END FUNCTION

def f(n):

    return n * n

 

k = int(input())

i = 12

while i > 0 and f(i) >= k:

    i = i - 1

print(i)

ПаскальАлгоритмический язык

var k, i : longint;

function f(n: longint) : longint;

    begin

        f := n * n

    end;

begin

    readln(k);

    i := 12;

    while (i>0) and (f(i)>=k) do

        i := i-1;

    writeln(i)

end.

нач

цел i, k

ввод k

i := 12

нц пока i > 0 и f(i) >= k

    i := i - 1

кц

вывод i

кон

алг цел f(цел n)

нач

    знач := n * n

кон

Си++

#include <iostream>

using namespace std;

 

int f(int n)

{

    return n * n;

}

 

int main(void)

{

    int k, i;

    cin >> k;

    i = 12;

    while (i > 0 && f(i) >= k)

        i––;

    cout « i « endl;

}

 


12
Задание 21 № 11357

На­пи­ши­те в от­ве­те число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­ще­го ал­го­рит­ма (для Ва­ше­го удоб­ства ал­го­ритм пред­став­лен на пяти язы­ках про­грам­ми­ро­ва­ния).

 

Бей­сикPython

DIM A, B, N, t AS INTEGER

A = -100: B = 100

N = 0

FOR t = A TO B

    IF F(t) <= 0 THEN

        N = N + 1

    END IF

NEXT t

PRINT N

 

FUNCTION F (x)

    F = (x - 16)*(x + 25)

END FUNCTION

def f(x):

    return (x - 16)*(x + 25)

 

a = -100

b = 100

n = 0

 

for t in range(a, b + 1):

    if f(t) <= 0:

        n = n + 1

print(n)

Пас­кальАл­го­рит­ми­че­ский язык

var a, b, N, t: integer;

Function F(x: integer):integer;

    begin

        F := (x - 16)*(x + 25)

    end;

begin

    a := -100; b := 100;

    N := 0;

    for t := a to b do begin

        if (F(t) <= 0) then

            N := N + 1

    end;

    write(N)

end.

алг

нач

    цел a, b, N, t

    a := -100; b := 100

    N := 0

    нц для t от a до b

        если F(t) <= 0

            то

                N := N + 1

        все

    кц

    вывод N

кон

алг цел F(цел x)

нач

    знач := (x - 16)*(x + 25)

кон

Си++

#include <iostream>

using namespace std;

int F(int x) {

    return (x - 16)*(x + 25);

}

 

int main() {

    int a, b, N, t;

    a = -100; b = 100;

    N = 0;

    for (t = a; t <= b; t++) {

        if (F(t) <= 0) {

            N++;

        }

    }

    cout « N « endl;

}

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2017 по информатике.

13
Задание 21 № 14236

Напишите в ответе наименьшее значение входной переменной k, при котором программа выдаёт ответ 11. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) < K

  I = I + 1

WEND

PRINT I

 

FUNCTION F(N)

  F = N * N

END FUNCTION

def f(n):

  return n*n

k = int(input())

i = 1

while f(i) < k:

  i += 1

print (i)

ПаскальАлгоритмический язык

var

  k, i : longint;

 

function f(n: longint): longint;

begin

  f := n * n;

end;

 

begin

  readln(k);

  i := 1;

  while f(i) < k do

    i := i+1;

  writeln(i)

end.

алг

нач

  цел k, i

  ввод k

  i := 1

  нц пока f(i) < k

    i := i + 1

  кц

  вывод i

кон

 

алг цел f(цел n)

нач

  знач := n * n

кон

Си++

#include <iostream>

using namespace std;

 

long f(long n) {

  return n * n;

}

int main()

{

  long k, i;

  cin >> k;

  i = 1;

  while (f(i) < k)

    i++;

  cout << i;

  return 0;

}

 


14
Задание 21 № 14280

Напишите в ответе наименьшее значение входной переменной k, при котором программа выдаёт ответ 10. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) < K

  I = I + 1

WEND

PRINT I

 

FUNCTION F(N)

  F = N * N

END FUNCTION

def f(n):

  return n*n

k = int(input())

i = 1

while f(i) < k:

  i += 1

print (i)

ПаскальАлгоритмический язык

var

  k, i : longint;

 

function f(n: longint): longint;

begin

  f := n * n;

end;

 

begin

  readln(k);

  i := 1;

  while f(i) < k do

    i := i+1;

  writeln(i)

end.

алг

нач

  цел k, i

  ввод k

  i := 1

  нц пока f(i) < k

    i := i + 1

  кц

  вывод i

кон

 

алг цел f(цел n)

нач

  знач := n * n

кон

Си++

#include <iostream>

using namespace std;

 

long f(long n) {

  return n * n;

}

int main()

{

  long k, i;

  cin >> k;

  i = 1;

  while (f(i) < k)

    i++;

  cout << i;

  return 0;

}

 


15
Задание 21 № 15116

На­пи­ши­те в от­ве­те наи­боль­шее зна­че­ние вход­ной пе­ре­мен­ной k, при ко­то­ром про­грам­ма выдаёт ответ 7. Для Ва­ше­го удоб­ства про­грам­ма при­ве­де­на на пяти язы­ках про­грам­ми­ро­ва­ния.

 

 

Бей­сикPython

DIM K, I AS LONG

INPUT K

I = 20

WHILE F(I) > K

    I = I - 1

WEND

PRINT I

 

FUNCTION F(N)

    F = N * N + N

END FUNCTION

def f(n):

    return n * n + n

 

k = int(input())

i = 20

while f(i) > k:

    i -= 1

print(i)

 

Пас­кальАл­го­рит­ми­че­ский язык

var

    k, i : longint;

 

function f(n: longint): longint;

begin

    f := n * n + n

end;

 

begin

    readln(k);

    i := 20;

    while f(i) > k do

        i := i-1;

    writeln(i)

end.

 

алг

нач

    цел k, i

    ввод k i := 20

    нц пока f(i) > k

        i := i - 1

    кц

    вывод i

кон

 

алг цел f(цел n)

нач

    знач := n * n + n

кон

 

С++

#include <iostream>

using namespace std;

long f(long n) {

    return n * n + n;

}

 

int main()

{

    long k, i;

    cin >> k;

    i = 20;

    while (f(i) > k) --i;

    cout << i;

    return 0;

}

 


16
Задание 21 № 15143

На­пи­ши­те в от­ве­те наи­боль­шее зна­че­ние вход­ной пе­ре­мен­ной k, при ко­то­ром про­грам­ма выдаёт ответ 9. Для Ва­ше­го удоб­ства про­грам­ма при­ве­де­на на пяти язы­ках про­грам­ми­ро­ва­ния.

 

 

Бей­сикPython

DIM K, I AS LONG

INPUT K

I = 20

WHILE F(I) > K

    I = I - 1

WEND

PRINT I

 

FUNCTION F(N)

    F = N * N + N

END FUNCTION

def f(n):

    return n * n + n

 

k = int(input())

i = 20

while f(i) > k:

    i -= 1

print(i)

 

Пас­кальАл­го­рит­ми­че­ский язык

var

    k, i : longint;

 

function f(n: longint): longint;

begin

    f := n * n + n

end;

 

begin

    readln(k);

    i := 20;

    while f(i) > k do

        i := i-1;

    writeln(i)

end.

 

алг

нач

    цел k, i

    ввод k i := 20

    нц пока f(i) > k

        i := i - 1

    кц

    вывод i

кон

 

алг цел f(цел n)

нач

    знач := n * n + n

кон

 

С++

#include <iostream>

using namespace std;

long f(long n) {

    return n * n + n;

}

 

int main()

{

    long k, i;

    cin >> k;

    i = 20;

    while (f(i) > k) --i;

    cout << i;

    return 0;

}

 


17
Задание 21 № 15637

Какое зна­че­ние будет вы­ве­де­но на экран после вы­пол­не­ния дан­ной про­грам­мы?

 

Бей­сикPython

DIM A, B, T, M, R AS INTEGER

    A = -20: B = 20

    M = A: R = F(A)

    FOR T = A TO B

        IF F(T) > R THEN

            M = T

            R = F(T)

        END IF

    NEXT T

    PRINT M+24

    FUNCTION F(x)

        F := 2*(x-19)*(x-19)+7

    END FUNCTION

def f(x):

    return 2*(x-19)*(x-19)+7

a = -20

b = 20

M = a

R = f(a)

for t in range(a, b+1):

    if (f(t) > R):

        M = t

        R = f(t);

print(M+24)

Пас­кальАл­го­рит­ми­че­ский язык

var a,b,t,M,R :integer;

Function F(x: integer):integer;

    begin

        F := 2*(x-19)*(x-19)+7;

    end;

BEGIN

     a := -20; b := 20;

     M := a; R := F(a);

     for t := a to b do begin

         if (F(t) > R) then begin

             M := t;

            R := F(t);

        end;

    end;

write(M+24);

END.

алг

нач

    цел a, b, t, M, R

    a:=-20; b:=20

    M:=a; R:=F(a)

    нц для t от a до b

         если F(t) > R то

            то

                 M:=t; R:=F(t)

        все

    кц

    вывод M+24

кон

алг цел F(цел x)

нач

    знач :=2*(x-19)*(x-19)+7;

кон

Си++

#include <iostream>

using namespace std;

 

int F(int x)

{

    return 2*(x-19)*(x-19)+7

}

int main()

{

    int a, b, t, M, R;

    a = -20; b = 20;

    M = a; R = F(a);

    for (t=a; t<=b; t++){

        if (F(t) > R) {

            M = t; R = F(t);

        }

    }

    cout << (M+24) << endl;

}

 

Источник: ЕГЭ — 2018. До­сроч­ная волна. Вариант 1., ЕГЭ — 2018. До­сроч­ная волна. Вариант 2.

18
Задание 21 № 15806

Какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей про­грам­мы? Для Ва­ше­го удоб­ства про­грам­ма при­ве­де­на на пяти язы­ках про­грам­ми­ро­ва­ния.

 

 

Бей­сикPython

DIM A, B, T, M, R AS INTEGER

A = −9: B = 9

M = A : R = F(A)

FOR T = A TO B

    IF F(T) > R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT M+R

 

FUNCTION F(x)

    F = 2 * (x−1) * (x−3) + 7

END FUNCTION

def F(x):

    return 2 * (x−1) * (x−3) + 7

 

a = −9; b = 9

M = a; R = F(a)

for t in range(a,b+1):

    if F(t) > R:

        M = t; R = F(t)

print(M+R)

 

Пас­кальАл­го­рит­ми­че­ский язык

var

    a, b, t, M, R: integer;

 

function F(x: integer): integer;

begin

    f := 2 * (x−1) * (x−3) + 7;

end;

 

begin

    a := −9; b := 9;

    M := a; R:= F(a)

    for t := a to b do begin

        if F(t) > R then begin

            M := t;

            R := F(t);

        end;

    end;

    write(M+R);

end.

 

алг

нач

    цел a, b, t, M, R

    a := −9; b := 9

    M := a; R := F(a)

    нц для t от a до b

        если F(t) > R

            то M := t; R := F(t)

        все

    кц

    вывод M + R

кон

 

алг цел f(цел x)

нач

    знач := 2 * (x−1) * (x−3) + 7

кон

 

С++

#include <iostream>

using namespace std;

long f(int x) {

    return 2 * (x−1) * (x−3) + 7;

}

 

int main()

{

    int a, b, t, M, R;

    a = −9; b = 9;

    M = a; R = F(a);

    for (t = a; t <=b; ++t) {

        if (F(t) > R) {

            M = t; R = F(t);

        }

    }

    cout << M + R;

    return 0;

}

 


19
Задание 21 № 15833

Какое число будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей про­грам­мы? Для Ва­ше­го удоб­ства про­грам­ма при­ве­де­на на пяти язы­ках про­грам­ми­ро­ва­ния.

 

 

Бей­сикPython

DIM A, B, T, M, R AS INTEGER

A = −8: B = 8

M = A : R = F(A)

FOR T = A TO B

    IF F(T) > R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT M+R

 

FUNCTION F(x)

    F = 2 * (x−2) * (x−4) + 3

END FUNCTION

def F(x):

    return 2 * (x−2) * (x−4) + 3

 

a = −8; b = 8

M = a; R = F(a)

for t in range(a,b+1):

    if F(t) > R:

        M = t; R = F(t)

print(M+R)

 

Пас­кальАл­го­рит­ми­че­ский язык

var

    a, b, t, M, R: integer;

 

function F(x: integer): integer;

begin

    f := 2 * (x−2) * (x−4) + 3;

end;

 

begin

    a := −8; b := 8;

    M := a; R:= F(a)

    for t := a to b do begin

        if F(t) > R then begin

            M := t;

            R := F(t);

        end;

    end;

    write(M+R);

end.

 

алг

нач

    цел a, b, t, M, R

    a := −8; b := 8

    M := a; R := F(a)

    нц для t от a до b

        если F(t) > R

            то M := t; R := F(t)

        все

    кц

    вывод M + R

кон

 

алг цел f(цел x)

нач

    знач := 2 * (x−2) * (x−4) + 3

кон

 

С++

#include <iostream>

using namespace std;

long f(int x) {

    return 2 * (x−2) * (x−4) + 3;

}

 

int main()

{

    int a, b, t, M, R;

    a = −8; b = 8;

    M = a; R = F(a);

    for (t = a; t <=b; ++t) {

        if (F(t) > R) {

            M = t; R = F(t);

        }

    }

    cout << M + R;

    return 0;

}

 


Пройти тестирование по этим заданиям