СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
Информатика
Cайты, меню, вход, новости


Варианты заданий
Версия для печати и копирования в MS Word
1
Задание 21 № 7467

Напишите в ответе число различных значений входной переменной k, при которых программа выдаёт тот же ответ, что и при входном значении k = 64. Значение k = 64 также включается в подсчёт различных значений k. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 12

WHILE I > 0 AND F(I) >= K

    I = I - 1

WEND

PRINT I

FUNCTION F(N)

    F = N * N

END FUNCTION

def f(n):

    return n * n

 

k = int(input())

i = 12

while i > 0 and f(i) >= k:

    i = i - 1

print(i)

ПаскальАлгоритмический язык

var k, i : longint;

function f(n: longint) : longint;

    begin

        f := n * n

    end;

begin

    readln(k);

    i := 12;

    while (i>0) and (f(i)>=k) do

        i := i-1;

    writeln(i)

end.

нач

цел i, k

ввод k

i := 12

нц пока i > 0 и f(i) >= k

    i := i - 1

кц

вывод i

кон

алг цел f(цел n)

нач

    знач := n * n

кон

Си++

#include <iostream>

using namespace std;

 

int f(int n)

{

    return n * n;

}

 

int main(void)

{

    int k, i;

    cin >> k;

    i = 12;

    while (i > 0 && f(i) >= k)

        i––;

    cout « i « endl;

}

 


Аналоги к заданию № 7678: 7467 7705 7766 7793 8109 Все

Источник: Демонстрационная версия ЕГЭ—2015 по информатике.

2
Задание 21 № 7705

Напишите в ответе количество различных значений входной переменной k, при которых программа выдаёт тот же ответ, что и при входном значении k = 64. Значение k = 64 также включается в подсчёт различных значений k. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 12

WHILE I > 0 AND F(I) >= K

I = I - 1

WEND

PRINT I

FUNCTION F(N)

F = N * N + 30

END FUNCTION

def f(n):

return n * n + 30

k = int(input())

i = 12

while i > 0 and f(i) >= k:

i = i - 1

print(i)

ПаскальАлгоритмический язык

var k, i : longint;

function f(n: longint) : longint;

begin

f := n * n + 30

end;

begin

readln(k);

i := 12;

while (i>0) and (f(i)>=k) do

i := i-1;

writeln(i)

end.

алг

нач

цел i, k

ввод k

i := 12

нц пока i > 0 и f(i) >= k

i := i - 1

кц

вывод i

кон

алг цел f(цел n)

нач

знач := n * n + 30

кон

Си++

#include <iostream>

using namespace std;

long f(long n) { return n * n + 30; }

int main()

{ long k, i;

cin >> k;

i = 12;

while (i>0 && f(i)>=k) i––;

cout << i << endl;

}

 


Аналоги к заданию № 7678: 7467 7705 7766 7793 8109 Все


3
Задание 21 № 7766

Напишите в ответе число различных значений входной переменной k, при которых программа выдаёт тот же ответ, что и при входном значении k = 36. Значение k = 36 также включается в подсчёт различных значений k. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 0

WHILE F(I) < K

    I = I + 1

WEND

PRINT I

FUNCTION F(N)

    F = N*(N-1)+10

END FUNCTION

def f(n):

    return n*(n-1)+10

k = int(input())

i = 0

while f(i) < k:

    i = i + 1

print(i)

ПаскальАлгоритмический язык

var k, i : longint;

    function f(n: longint) : longint;

        begin

            f := n*(n-1)+10

        end;

begin

    readln(k);

    i := 0;

    while (f(i) < k) do

        i := i+1;

    writeln(i)

end.

алг

нач

цел i, k

ввод k

i := 0

нц пока f(i) < k

i := i+1

кц

вывод i

кон

алг цел f(цел n)

нач

знач := n*(n-1)+10

кон

Си++

#include <iostream>

using namespace std;

long f(long n)

{

    return n*(n-1)+10;

}

int main()

{

    long k, i;

    cin >> k;

    i = 0;

    while (f(i) < k)

        i++;

    cout << i << endl;

}

 


Аналоги к заданию № 7678: 7467 7705 7766 7793 8109 Все


4
Задание 21 № 7793

Напишите в ответе число различных значений входной переменной k, при которых программа выдаёт тот же ответ, что и при входном значении k = 47. Значение k = 47 также включается в подсчёт различных значений k. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 0

WHILE F(I) <= K

    I = I + 1

WEND

PRINT I

FUNCTION F(N)

    F = N*(N+1)- 5

END FUNCTION

def f(n):

    return n*(n+1)-5

k = int(input())

i = 0

while f(i) <= k:

    i = i + 1

print(i)

ПаскальАлгоритмический язык

var k, i : longint;

    function f(n: longint) : longint;

        begin

            f := n*(n+1)-5

        end;

begin

    readln(k);

    i := 0;

    while (f(i)<=k) do

        i := i+1;

    writeln(i)

end.

алг

нач

цел i, k

ввод k

i := 0

нц пока f(i) <= k

i := i+1

кц

вывод i

кон

алг цел f(цел n)

нач

знач := n*(n+1)-5

кон

Си++

#include <iostream>

using namespace std;

long f(long n)

{

    return n*(n+1)-5;

}

int main()

{

    long k, i;

    cin >> k;

    i = 0;

    while (f(i) <=k)

        i++;

    cout << i << endl;

}

 


Аналоги к заданию № 7678: 7467 7705 7766 7793 8109 Все


5
Задание 21 № 8109

Напишите в ответе число, равное количеству различных значений входной переменной k, при которых приведённая ниже программа выводит тот же ответ, что и при входном значении k = 10. Значение k = 10 также включается в подсчёт различных значений k. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) < K

    I = I + 1

WEND

IF F(I)-K <= K-F(I-1) THEN

    PRINT I

ELSE

    PRINT I-1

END IF

 

FUNCTION F(N)

    F = N * N * N

END FUNCTION

def f(n):

    return n*n*n

i = 1

k = int(input())

while f(i) < k:

    i+=1

if (f(i)-k <= k-f(i-1)):

    print (i)

else:

    print (i - 1)

ПаскальАлгоритмический язык

var

    k, i : longint;

 

function f(n: longint) : longint;

begin

    f := n * n * n;

end;

begin

    readln(k);

    i := 1;

    while f(i) < k do

        i := i+1;

    if f(i)-k <= k-f(i-1) then

        writeln(i)

    else

        writeln(i-1);

end.

алг

нач

    цел i, k

    ввод k

    i := 1

    нц пока f(i) < k

        i := i + 1

    кц

    если f(i)-k <= k-f(i-1) то

        вывод i

    иначе

        вывод i-1

    все

кон

алг цел f(цел n)

нач

    знач := n * n * n

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

    return n * n * n;

}

 

int main()

{

    long k, i;

    cin >> k;

    i = 1;

    while (f(i) < k)

        i++;

    if (f(i)-k <= k-f(i-1)){

        cout << i << endl;

    } else {

        cout << i-1 << endl;

    }

}

 


Аналоги к заданию № 7678: 7467 7705 7766 7793 8109 Все

Источник: ЕГЭ 05.05.2015. Досрочная волна.