СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Варианты заданий
Версия для печати и копирования в MS Word
1
Задание 21 № 3333

Определите, какое число будет напечатано в результате выполнения следующего алгоритма:

 

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A = -10: B = 10

M = A: R = F(А)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT R

FUNCTION F(x)

    F = 2*x*x+8*x+10

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := 2*x*x+8*x+10

        end;

begin

    a := -10; b := 10;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(R)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return 2*x*x+8*x+10;

}

int main()

{

    int a, b, t, M, R;

    a = -10; b = 10;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « R « endl;

}

алг

нач

цел a, b, t, M, R

a := -10; b := 10

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод R

кон

алг цел F(цел x)

нач

знач := 2*x*x+8*x+10

кон

Python

def f(x):

    return 2*x*x+8*x+10

a = -10

b = 10

M = a

R = f(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(R)

 


2
Задание 21 № 3335

Определите, какое число будет напечатано в результате выполнения следующего алгоритма:

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A = 0: B = 10

M = A: R = F(А)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT R

FUNCTION F(x)

    F = 2*x*x+8*x+10

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := 2*x*x+8*x+10

        end;

begin

    a := 0; b := 10;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(R)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return 2*x*x+8*x+10;

}

int main()

{

    int a, b, t, M, R;

    a = 0; b = 10;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « R « endl;

}

алг

нач

цел a, b, t, M, R

a := 0; b := 10

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод R

кон

алг цел F(цел x)

нач

знач := 2*x*x+8*x+10

кон

Python

def f(x):

    return 2*x*x+8*x+10

a = 0

b = 10

M = a

R = F(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(R)

 


3
Задание 21 № 3336

Определите, какое число будет напечатано в результате выполнения следующего алгоритма:

 

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A =-20: B = 20

M = A: R = F(А)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT R

FUNCTION F(x)

    F = 9*(x-15)*(x+17)+2

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := 9*(x-15)*(x+17)+2

        end;

begin

    a :=-20; b := 20;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(R)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return 9*(x-15)*(x+17)+2;

}

int main()

{

    int a, b, t, M, R;

    a =-20; b = 20;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « R « endl;

}

алг

нач

цел a, b, t, M, R

a :=-20; b := 20

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод R

кон

алг цел F(цел x)

нач

знач := 9*(x-15)*(x+17)+2

кон

Python

def f(x):

    return 9*(x-15)*(x+17)+2

a =-20

b = 20

M = a

R = F(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(R)

 


4
Задание 21 № 3337

Определите, какое число будет напечатано в результате выполнения следующего алгоритма:

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A =-10: B = 10

M = A: R = F(А)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT R

FUNCTION F(x)

    F = x*x+6*x+10

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := x*x+6*x+10

        end;

begin

    a :=-10; b := 10;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(R)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return x*x+6*x+10;

}

int main()

{

    int a, b, t, M, R;

    a =-10; b = 10;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « R « endl;

}

алг

нач

цел a, b, t, M, R

a :=-10; b := 10

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод R

кон

алг цел F(цел x)

нач

знач := x*x+6*x+10

кон

Python

def f(x):

    return x*x+6*x+10

a =-10

b = 10

M = a

R = F(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(R)

 


5
Задание 21 № 3339

Определите, какое число будет напечатано в результате выполнения следующего алгоритма:

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A =-20: B = 20

M = A: R = F(А)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT R

FUNCTION F(x)

    F = 5*(x+10)*(x+2)+2

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := 5*(x+10)*(x+2)+2

        end;

begin

    a :=-20; b := 20;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(R)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return 5*(x+10)*(x+2)+2;

}

int main()

{

    int a, b, t, M, R;

    a =-20; b = 20;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « R « endl;

}

алг

нач

цел a, b, t, M, R

a :=-20; b := 20

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод R

кон

алг цел F(цел x)

нач

знач := 5*(x+10)*(x+2)+2

кон

Python

def f(x):

    return 5*(x+10)*(x+2)+2

a =-20

b = 20

M = a

R = F(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(R)

 


6
Задание 21 № 3340

Определите, какое число будет напечатано в результате выполнения следующего алгоритма:

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A =-10: B = 10

M = A: R = F(А)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT R

FUNCTION F(x)

    F = x*x+2*x+10

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := x*x+2*x+10

        end;

begin

    a :=-10; b := 10;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(R)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return x*x+2*x+10;

}

int main()

{

    int a, b, t, M, R;

    a =-10; b = 10;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « R « endl;

}

алг

нач

цел a, b, t, M, R

a :=-10; b := 10

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод R

кон

алг цел F(цел x)

нач

знач := x*x+2*x+10

кон

Python

def f(x):

    return x*x+2*x+10

a =-10

b = 10

M = a

R = F(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(R)

 


7
Задание 21 № 3341

Определите, какое число будет напечатано в результате выполнения следующего алгоритма:

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A =-5: B = 5

M = A: R = F(А)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT R

FUNCTION F(x)

    F = (x+7)*(1-x)

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := (x+7)*(1-x)

        end;

begin

    a :=-5; b := 5;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(R)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return (x+7)*(1-x);

}

int main()

{

    int a, b, t, M, R;

    a =-5; b = 5;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « R « endl;

}

алг

нач

цел a, b, t, M, R

a :=-5; b := 5

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод R

кон

алг цел F(цел x)

нач

знач := (x+7)*(1-x)

кон

Python

def f(x):

    return (x+7)*(1-x)

a =-5

b = 5

M = a

R = F(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(R)

 


8
Задание 21 № 3343

Определите, какое число будет напечатано в результате выполнения следующего алгоритма:

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A =-5: B = 5

M = A: R = F(А)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT R

FUNCTION F(x)

    F = (x+3)*(1-x)

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := (x+3)*(1-x)

        end;

begin

    a :=-5; b := 5;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(R)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return (x+3)*(1-x);

}

int main()

{

    int a, b, t, M, R;

    a =-5; b = 5;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « R « endl;

}

алг

нач

цел a, b, t, M, R

a :=-5; b := 5

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод R

кон

алг цел F(цел x)

нач

знач := (x+3)*(1-x)

кон

Python

def f(x):

    return (x+3)*(1-x)

a =-5

b = 5

M = a

R = F(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(R)

 


9
Задание 21 № 3346

Определите, какое число будет напечатано в результате выполнения следующего алгоритма:

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A =-5: B = 5

M = A: R = F(А)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT R

FUNCTION F(x)

    F = (x+5)*(1-x)

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := (x+5)*(1-x)

        end;

begin

    a :=-5; b := 5;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(R)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return (x+5)*(1-x);

}

int main()

{

    int a, b, t, M, R;

    a =-5; b = 5;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « R « endl;

}

алг

нач

цел a, b, t, M, R

a :=-5; b := 5

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод R

кон

алг цел F(цел x)

нач

знач := (x+5)*(1-x)

кон

Python

def f(x):

    return (x+5)*(1-x)

a =-5

b = 5

M = a

R = f(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t)

print(R)

 


10
Задание 21 № 7282

Определите, какое число будет напечатано в результате выполнения следующего алгоритма:

 

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A = -20: B = 20

M = A: R = F(А)

t = a

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT M

FUNCTION F(x)

    F = 3*(x-8)*(x-8)

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := 3*(x-8)*(x-8)

        end;

begin

    a := -20; b := 20;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(M)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return 3*(x-8)*(x-8);

}

int main()

{

    int a, b, t, M, R;

    a = -20; b = 20;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « M « endl;

}

алг

нач

цел a, b, t, M, R

a := -20; b := 20

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод M

кон

алг цел F(цел x)

нач

знач := 3*(x-8)*(x-8)

кон

Python

def f(x):

    return 3*(x-8)*(x-8)

a = -20

b = 20

M = a

R = F(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(M)

 


11
Задание 21 № 3347

Определите, какое число будет напечатано в результате выполнения следующего алгоритма:

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A =-20: B = 0

M = A: R = F(А)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT R

FUNCTION F(x)

    F = 4*(x-5)*(x+3)

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := 4*(x-5)*(x+3)

        end;

begin

    a :=-20; b := 0;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(R)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return 4*(x-5)*(x+3);

}

int main()

{

    int a, b, t, M, R;

    a =-20; b = 0;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « R « endl;

}

алг

нач

цел a, b, t, M, R

a :=-20; b := 0

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод R

кон

алг цел F(цел x)

нач

знач := 4*(x-5)*(x+3)

кон

Python

def f(x):

    return 4*(x-5)*(x+3)

a =-20

b = 0

M = a

R = F(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(R)

 


12
Задание 21 № 3349

Определите, какое число будет напечатано в результате выполнения следующего алгоритма:

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A = -20: B = 20

M = A: R = F(А)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT M

FUNCTION F(x)

    F = 2*(x-9)*(x-9)+12

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := 2*(x-9)*(x-9)+12

        end;

begin

    a := -20; b := 20;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(M)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return 2*(x-9)*(x-9)+12;

}

int main()

{

    int a, b, t, M, R;

    a = -20; b = 20;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « M « endl;

}

алг

нач

цел a, b, t, M, R

a := -20; b := 20

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод M

кон

алг цел F(цел x)

нач

знач := 2*(x-9)*(x-9)+12

кон

Python

def f(x):

    return 2*(x-9)*(x-9)+12

a = -20

b = 20

M = a

R = F(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(M)

 


13
Задание 21 № 3742

Определите, какое число будет напечатано в результате выполнения

следующего алгоритма.

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A = -20: B = 20

M = A: R = F(А)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT M

FUNCTION F(x)

    F = 4*(x-1)*(x-3)

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := 4*(x-1)*(x-3)

        end;

begin

    a := -20; b := 20;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(M)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return 4*(x-1)*(x-3);

}

int main()

{

    int a, b, t, M, R;

    a = -20; b = 20;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « M « endl;

}

алг

нач

цел a, b, t, M, R

a := -20; b := 20

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод M

кон

алг цел F(цел x)

нач

знач := 4*(x-1)*(x-3)

кон

Python

def f(x):

    return 4*(x-1)*(x-3)

a = -20

b = 20

M = a

R = F(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(M)

 


14
Задание 21 № 3744

Определите, какое число будет напечатано в результате выполнения следующего алгоритма:

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A = -20: B = 20

M = A: R = F(А)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT R

FUNCTION F(x)

    F = 3*(x-2)*(x+6)

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := 3*(x-2)*(x+6)

        end;

begin

    a := -20; b := 20;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(R)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return 3*(x-2)*(x+6);

}

int main()

{

    int a, b, t, M, R;

    a = -20; b = 20;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « R « endl;

}

алг

нач

цел a, b, t, M, R

a := -20; b := 20

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод R

кон

алг цел F(цел x)

нач

знач := 3*(x-2)*(x+6)

кон

Python

def f(x):

    return 3*(x-2)*(x+6)

a = -20

b = 20

M = a

R = F(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(R)

 

Решение · ·

15
Задание 21 № 3747

Определите, какое число будет напечатано в результате выполнения следующего алгоритма.

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A = -10: B = 10

M = A: R = F(А)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT M

FUNCTION F(x)

    F = x*x + 6*x + 10

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := x*x + 6*x + 10

        end;

begin

    a := -10; b := 10;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(M)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return x*x + 6*x + 10;

}

int main()

{

    int a, b, t, M, R;

    a = -10; b = 10;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « M « endl;

}

алг

нач

цел a, b, t, M, R

a := -10; b := 10

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод M

кон

алг цел F(цел x)

нач

знач := x*x + 6*x + 10

кон

Python

def f(x):

    return x*x + 6*x + 10

a = -10

b = 10

M = a

R = F(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(M)

 


16
Задание 21 № 3749

Определите, какое число будет напечатано в результате выполнения следующего алгоритма:

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A = -10: B = 10

M = A: R = F(А)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT M

FUNCTION F(x)

    F = x*x + 2*x + 10

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := x*x + 2*x + 10

        end;

begin

    a := -10; b := 10;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(M)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return x*x + 2*x + 10;

}

int main()

{

    int a, b, t, M, R;

    a = -10; b = 10;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « M « endl;

}

алг

нач

цел a, b, t, M, R

a := -10; b := 10

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод M

кон

алг цел F(цел x)

нач

знач := x*x + 2*x + 10

кон

Python

def f(x):

    return x*x + 2*x + 10

a = -10

b = 10

M = a

R = F(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(M)

 


17
Задание 21 № 3751

Определите, какое число будет напечатано в результате выполнения следующего алгоритма:

 

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A = -10: B = 10

M = A: R = F(А)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT R

FUNCTION F(x)

    F = 2*x*x + 8*x + 10

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := 2*x*x + 8*x + 10

        end;

begin

    a := -10; b := 10;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(R)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return 2*x*x + 8*x + 10;

}

int main()

{

    int a, b, t, M, R;

    a = -10; b = 10;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « R « endl;

}

алг

нач

цел a, b, t, M, R

a := -10; b := 10

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод R

кон

алг цел F(цел x)

нач

знач := 2*x*x + 8*x + 10

кон

Python

def f(x):

    return 2*x*x + 8*x + 10

a = -10

b = 10

M = a

R = F(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(R)

 


18
Задание 21 № 3752

Определите, какое число будет напечатано в результате выполнения следующего алгоритма:

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A = -11: B = 11

M = A: R = F(А)

t = a

WHILE T < B

    IF F(T) >= R THEN

        M = T

        R = F(T)

    END IF

    t = t + 2

NEXT T

PRINT M

FUNCTION F(x)

    F = -2*(x+2)*(x-6)

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := -2*(x+2)*(x-6)

        end;

begin

    a := -11; b := 11;

    M := a; R := F(a); t:=a;

     while t < b do begin

        if (F(t) >= R) then begin

            M := t;

            R := F(t);

        end;

        t:=t+2;

    end;

    write(M)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return -2*(x+2)*(x-6);

}

int main()

{

    int a, b, t, M, R;

    a = -11; b = 11;

    M = a; R = F(a); t=a;

    while (t < b) {

        if (F(t) >= R) {

            M = t; R = F(t);

        }

        t=t+2;

    }

    cout « M « endl;

}

алг

нач

цел a, b, t, M, R

a := -11; b := 11

M := a; R := F(a)

t:=a

нц пока t < b

если F(t) >= R

то

M := t; R := F(t)

все

t:=t+2

кц

вывод M

кон

алг цел F(цел x)

нач

знач := -2*(x+2)*(x-6)

кон

Python

def f(x):

    return -2*(x+2)*(x-6)

a = -11

b = 11

M = a

R = F(a)

t = a

while t < b:

    if (f(t) >= R):

        M = t

        R = f(t);

    t += 2

print(M)

 


19
Задание 21 № 5065

Определите, какое число будет напечатано в результате выполнения следующего алгоритма.

 

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A = -3: B = 25

M = A: R = F(А)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT R

FUNCTION F(x)

    F = 6*(13+x)*(13+x)+127

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := 6*(13+x)*(13+x)+127

        end;

begin

    a := -3; b := 25;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(R)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return 6*(13+x)*(13+x)+127;

}

int main()

{

    int a, b, t, M, R;

    a = -3; b = 25;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « R « endl;

}

алг

нач

цел a, b, t, M, R

a := -3; b := 25

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод R

кон

алг цел F(цел x)

нач

знач := 6*(13+x)*(13+x)+127

кон

Python

def f(x):

    return 6*(13+x)*(13+x)+127

a = -3

b = 25

M = a

R = F(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(R)

 


20
Задание 21 № 5097

Определите, какое число будет напечатано в результате выполнения следующего алгоритма.

 

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A = -7: B = 25

M = A: R = F(А)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT R

FUNCTION F(x)

    F = 3*(17+x)*(17+x)+214

END FUNCTION

var a,b,t,M,R: integer;

    Function F(x:integer): integer;

        begin

            F := 3*(17+x)*(17+x)+214

        end;

begin

    a := -7; b := 25;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(R)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

return 3*(17+x)*(17+x)+214;

}

int main()

{

    int a, b, t, M, R;

    a = -7; b = 25;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « R « endl;

}

алг

нач

цел a, b, t, M, R

a := -7; b := 25

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод R

кон

алг цел F(цел x)

нач

знач := 3*(17+x)*(17+x)+214

кон

Python

def f(x):

    return 3*(17+x)*(17+x)+214

a = -7

b = 25

M = a

R = F(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(R)