СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
Информатика
Cайты, меню, вход, новости


Варианты заданий
Версия для печати и копирования в MS Word
1
Задание 21 № 9372

Напишите в ответе наименьшее значение входной переменной k, при котором программа выдаёт тот же ответ, что и при входном значении k = 10. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) < G(K)

    I = I + 1

WEND

PRINT I

 

FUNCTION F(N)

    F = N * N * N

END FUNCTION

 

FUNCTION G(N)

    G = 2*N + 3

END FUNCTION

def f(n):

    return n*n*n

 

def g(n):

    return 2*n+3

 

k = int(input())

i = 1

while f(i) < g(k):

    i+=1

print (i)

ПаскальАлгоритмический язык

var

    k, i : longint;

 

function f(n: longint): longint;

begin

    f := n * n * n;

end;

 

function g(n: longint): longint;

begin

    g := 2*n + 3;

end;

 

begin

    readln(k);

    i := 1;

    while f(i) < g(k) do

        i := i+1;

    writeln(i)

end.

алг

нач

    цел i, k

    ввод k

    i := 1

    нц пока f(i) < g(k)

        i := i + 1

    кц

    вывод i

кон

 

алг цел f(цел n)

нач

    знач := n * n * n

кон

 

алг цел g(цел n)

нач

    знач := 2*n + 3

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

    return n * n * n;

}

 

long g(long n) {

    return 2*n + 3;

}

 

int main()

{

    long k, i;

    cin >> k;

    i = 1;

    while(f(i) < g(k))

        i++;

    cout << i << endl;

    return 0;

}

 


Аналоги к заданию № 7932: 9372 7997 9771 9807 Все

Источник: Демонстрационная версия ЕГЭ—2016 по информатике.

2
Задание 21 № 7997

При каком наибольшем значении входной переменной k программа выдаёт тот же ответ, что и при входном значении k = 64? Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 12

WHILE I > 0 AND F(I) > K

    I = I - 1

WEND

PRINT I

FUNCTION F(N)

    F = N * N - 20

END FUNCTION

def f(n):

    return n * n - 20

k = int(input())

i = 12

while i > 0 and f(i) > k:

    i = i - 1

print(i)

ПаскальАлгоритмический язык

var k, i : longint;

    function f(n: longint) : longint;

        begin

            f := n * n - 20

        end;

begin

    readln(k);

    i := 12;

    while (i>0) and (f(i)> k) do

        i := i-1;

    writeln(i)

end.

алг

нач

цел i, k

ввод k

i := 12

нц пока i > 0 и f(i) > k

i := i - 1

кц

вывод i

кон

алг цел f(цел n)

нач

знач := n * n - 20

кон

Си++

#include <iostream>

using namespace std;

long f(long n) { return n * n - 20; }

int main()

{

    long k, i;

    cin >> k;

    i = 12;

    while (i>0 && f(i)>k) i––;

    cout << i << endl;

    return 0;

}

 


Аналоги к заданию № 7932: 9372 7997 9771 9807 Все


3
Задание 21 № 9771

Напишите в ответе наименьшее значение входной переменной k, при котором программа выдаёт тот же ответ, что и при входном значении k = 20. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) < G(K)

  I = I + 1

WEND

PRINT I

FUNCTION F(N)

   F = N * N * N

END FUNCTION

FUNCTION G(N)

  G = 3*N + 3

END FUNCTION

def f(n):

  return n*n*n

def g(n):

  return 3*n+3

k = int(input())

i = 1

while f(i) < g(k):

  i+=1

print (i)

ПаскальАлгоритмический язык

var

  k, i : longint;

function f(n: longint): longint;

begin

  f := n * n * n;

end;

function g(n: longint): longint;

begin

  g := 3*n + 3;

end;

begin

  readln(k);

  i := 1;

  while f(i) < g(k) do

    i := i+1;

  writeln(i)

end.

алг

нач

  цел i, k

  ввод k

  i := 1

  нц пока f(i) < g(k)

    i := i + 1

  кц

  вывод i

кон

алг цел f(цел n)

нач

  знач := n * n * n

кон

алг цел g(цел n)

нач

  знач := 3*n + 3

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

  return n * n * n;

}

long g(long n) {

  return 3*n + 3;

}

int main()

{

  long k, i;

  cin >> k;

  i = 1;

  while(f(i) < g(k))

    i++;

  cout << i << endl;

  return 0;

}

 


Аналоги к заданию № 7932: 9372 7997 9771 9807 Все


4
Задание 21 № 9807

Напишите в ответе наименьшее значение входной переменной k, при котором программа выдаёт тот же ответ, что и при входном значении k = 20. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) < G(K)

  I = I + 1

WEND

PRINT I

FUNCTION F(N)

   F = N * N

END FUNCTION

FUNCTION G(N)

  G = 3*N + 3

END FUNCTION

def f(n):

  return n*n

def g(n):

  return 3*n+3

k = int(input())

i = 1

while f(i) < g(k):

  i+=1

print (i)

ПаскальАлгоритмический язык

var

  k, i : longint;

function f(n: longint): longint;

begin

  f := n * n;

end;

function g(n: longint): longint;

begin

  g := 3*n + 3;

end;

begin

  readln(k);

  i := 1;

  while f(i) < g(k) do

    i := i+1;

  writeln(i)

end.

алг

нач

  цел i, k

  ввод k

  i := 1

  нц пока f(i) < g(k)

    i := i + 1

  кц

  вывод i

кон

алг цел f(цел n)

нач

  знач := n * n

кон

алг цел g(цел n)

нач

  знач := 3*n + 3

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

  return n * n;

}

long g(long n) {

  return 3*n + 3;

}

int main()

{

  long k, i;

  cin >> k;

  i = 1;

  while(f(i) < g(k))

    i++;

  cout << i << endl;

  return 0;

}

 


Аналоги к заданию № 7932: 9372 7997 9771 9807 Все