СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
Информатика
Cайты, меню, вход, новости


Варианты заданий
Версия для печати и копирования в MS Word
1
Задание 20 № 4560

Ниже на четырёх языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 21.

 

 

БейсикПаскаль

DIM X, A, B AS INTEGER

INPUT X

A=0: B=1

WHILE X > 0

    A = A+1

    B = B*(X MOD 10)

    X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b: integer;

begin

    readln(x);

    a:=0; b:=1;

    while x>0 do

        begin

            a:=a+1;

            b:=b*(x mod 10);

            x:= x div 10

        end;

    writeln(a); write(b);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a=0; b=1;

    while (x>0){

        a=a+1;

        b=b*(x%10);

        x= x/10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a:=0; b:=1

нц пока x>0

    a:=a+1

    b:=b*mod(x,10)

    x:=div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 1

while x > 0:

    a += 1

    b *= (x % 10)

    x //= 10

print(a)

print(b)

 


Аналоги к заданию № 7931: 4560 7461 3846 7342 Все

Источник: Демонстрационная версия ЕГЭ—2013 по информатике.

2
Задание 20 № 7461

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 15.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A=0: B=1

WHILE X > 0

    A = A+1

    B = B*(X MOD 10)

    X = X \ 10

WEND

PRINT A

PRINT B

x = int(input())

a = 0

b = 1

while x > 0:

    a = a + 1

    b = b * (x % 10)

    x = x // 10

print(a)

print(b)

ПаскальАлгоритмический язык

var x, a, b: integer;

begin

    readln(x);

    a:=0; b:=1;

    while x>0 do

        begin

            a:=a+1;

            b:=b*(x mod 10);

            x:= x div 10

        end;

    writeln(a); write(b)

end.

алг

нач

цел x, a, b

ввод x

a:=0; b:=1

нц пока x>0

    a:=a+1

    b:=b*mod(x,10)

    x:=div(x,10)

кц

вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main(void)

{

    int x, a, b;

    cin >> x;

    a = 0;

    b = 1;

    while (x > 0){

        a = a + 1;

        b = b * (x % 10);

        x = x / 10;

    }

    cout << a << endl << b endl;

}

 


Аналоги к заданию № 7931: 4560 7461 3846 7342 Все

Источник: Демонстрационная версия ЕГЭ—2015 по информатике.

3
Задание 20 № 3846

Ниже на 5-ти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b.

 

 

БейсикПаскаль

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 1

WHILE X > 0

    A = A + 1

    B = B * (X MOD 10)

    X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b: integer;

begin

    readln(x);

    a: = 0; b: = 1;

    while x>0 do

        begin

            a : = a + 1;

            b : = b * (x mod 10);

            x : = x div 10

        end;

    writeln(a);

    write(b);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 1;

    while (x>0){

        a = a + 1;

        b = b * (x%10);

        x = x/10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a: = 0; b: = 1

нц пока x>0

    a : = a + 1

    b : = b * mod(x,10)

    x : = div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 1

while x > 0:

    a += 1

    b *= x % 10

    x = x // 10

print(a)

print(b)

 

Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 14.


Аналоги к заданию № 7931: 4560 7461 3846 7342 Все

Источник: Яндекс: Тренировочная работа ЕГЭ по информатике. Вариант 2.

4
Задание 20 № 7342

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите такое наименьшее число x, что при вводе x алгоритм печатает сначала 2, а потом 0.

 

БейсикПаскаль

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 1

WHILE X > 0

    A = A + 1

    B = B*(X MOD 10)

    X = X\10

WEND

PRINT A

PRINT B

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 1;

    while x > 0 do

        begin

            a := a+1;

            b := b*(x mod 10);

            x := x div 10;

        end;

    writeln(a); write(b);

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 1;

    while (x > 0){

        a = a+1;

        b = b*(x%10);

        x = x/10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a := 0; b := 1

нц пока x > 0

    a := a+1

    b := b*mod(x,10)

    x := div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 1

while x > 0:

    a += 1

    b *=x % 10

    x //= 10

print(a)

print(b)

 


Аналоги к заданию № 7931: 4560 7461 3846 7342 Все