СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Каталог заданий.
Разное

Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 20 № 9371

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает число M. Известно, что x > 100. Укажите наименьшее такое (т.е. большее 100) число x, при вводе которого алгоритм печатает 26.

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = X

M = 65

IF L MOD 2 = 0 THEN

    M = 52

ENDIF

WHILE L <> M

IF L > M THEN

    L = L – M

ELSE

    M = M – L

ENDIF

WEND

PRINT M

x = int(input())

L = x

M = 65

if L % 2 == 0:

    M = 52

while L != M:

    if L > M:

        L = L - M

    else:

        M = M - L

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

    readln(x);

    L := x;

    M := 65;

    if L mod 2 = 0 then

        M := 52;

    while L <> M do

        if L > M then

            L := L - M

        else

            M := M – L;

    writeln(M);

end.

 

алг

нач

    цел x, L, M

    ввод x

    L := x

    M := 65

    если mod(L,2)=0

        то

            M := 52

    все

    нц пока L <> M

        если L > M

            то

                L := L – M

            иначе

                M := M – L

        все

    кц

    вывод M

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int x, L, M;

    cin >> x;

    L = x;

    M = 65;

    if (L % 2 == 0)

        M = 52;

    while (L != M){

        if(L > M)

            L = L - M;

        else

            M = M - L;

    }

    cout « M « endl;

}

 


Аналоги к заданию № 9371: 10483 10510 Все

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2016 по информатике.

2
Задание 20 № 9770

Ниже на пяти языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает число M. Известно, что x > 100. Укажите наименьшее такое (т. е. большее 100) число x, при вводе которого алгоритм печатает 30.

 

БейсикPython

DIM X, L, M AS INTEGER

INPUT X

L = X - 30

M = X + 30

WHILE L <> M

   IF L > M THEN

    L = L – M

  ELSE

    M = M – L

END IF

WEND

PRINT M

x = int(input())

L = x-30

M = x+30

while L != M:

  if L > M:

    L = L - M

  else:

    M = M - L

print(M)

ПаскальАлгоритмический язык

var x, L, M: integer;

begin

  readln(x);

  L := x-30;

  M := x+30;

  while L <> M do

    if L > M then

      L := L - M

    else

      M := M – L;

  writeln(M);

end.

алг

нач

  цел x, L, M

  ввод x

  L := x-30

  M := x+30

  нц пока L <> M

    если L > M

      то

      L := L – M

      иначе

      M := M – L

    все

  кц

  вывод M

кон

Си++

#include <iostream>

using namespace std;

int main()

{

  int x, L, M;

  cin >> x;

  L = x-30;

  M = x+30;

  while (L != M){

    if(L > M)

      L = L - M;

    else

      M = M - L;

  }

  cout « M « endl;

  return 0;

}

 


Аналоги к заданию № 9770: 9806 11249 Все


3
Задание 20 № 5215

Ниже на четырёх языках программирования записан алгоритм. Получив на вход число N, этот алгоритм печатает число q. Укажите наименьшее из таких чисел N, при вводе которых алгоритм напечатает 17.

 

 

БейсикПаскаль

DIM N, q, i AS INTEGER

INPUT N

FOR i = 1 TO N - 1

    IF N MOD i = 0 THEN q = i

NEXT i

PRINT q

var N, q, i: integer;

begin

    read(N);

    for i := 1 to N - 1 do begin

        if N mod i = 0 then q := i

    end;

    write(q)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int N, q, i;

    cin >> N;

    for (i = 1; i <= N - 1; i++) {

        if (N%i == 0) q = i;

    }

    cout « q « endl;

}

алг

нач

цел N, q, i

ввод N

нц для i от 1 до N - 1

    если mod(N, i) = 0

        то q : = i все

кц

вывод q

кон

Python

n = int(input())

for i in range(1, n):

    if n % i == 0:

        q = i

print(q)

 


Аналоги к заданию № 5215: 5247 Все


4
Задание 20 № 5059

Ниже записан алгоритм. После выполнения алгоритма было напечатано 3 числа. Первые два напечатанных числа - это числа 7 и 42. Какое наибольшее число может быть напечатано третьим?

 

 

БейсикPython

DIM X, Y, Z, R, A, B AS INTEGER

INPUT X, Y

IF Y > X THEN

    Z = X: X = Y: Y = Z

END IF

A = X: B = Y

WHILE B > 0

    R = A MOD B

    A = B

    B = R

WEND

PRINT A

PRINT X

PRINT Y

x = int(input())

y = int(input())

if y > x:

    z = x

    x = y

    y = z

a = x

b = y

while b > 0:

    r = a % b

    a = b

    b = r

print(a)

print(x)

print(y)

ПаскальАлгоритмический язык

var x, y, z: integer;

var r, a, b: integer;

begin

    readln(x, y);

    if y >x then begin

        z := x; x := y; y := z;

    end;

    a:= x; b:= y;

    while b>0 do begin

        r := a mod b;

        a := b;

        b := r;

    end;

    writeln(a);

    writeln(x);

    write(y);

end.

алг

нач

    цел x, y, z, r, a, b

    ввод x, y

    если y > x

        то

            z := x; x := y; y := z

    все

    a := x; b := y

    нц пока b>0

        r := mod (a, b)

         a := b

         b := r

    кц

    вывод a, нс, x, нс, y

кон

 

Си++

 

#include <iostream>

using namespace std;

int main()

{

    int x, y, z, r, a, b;

    cin >> x >> y;

    if (y > x){

        z = x; x = y; y = z;

    }

    a = x; b = y;

    while (b>0){

        r = a%b;

        a = b;

b = r;

}

cout « a « endl « x « endl « y « endl;

}

 


Аналоги к заданию № 5059: 5091 Все


5
Задание 20 № 11276

Ниже на пяти язы­ках про­грам­ми­ро­ва­ния за­пи­сан ал­го­ритм. По­лу­чив на вход число x, этот ал­го­ритм пе­ча­та­ет число M. Из­вест­но, что x > 100. Ука­жи­те наи­мень­шее такое (т. е. боль­шее 100) число x, при вводе ко­то­ро­го ал­го­ритм пе­ча­та­ет 60.

 

 

Бей­сикPython

DIM X, L, M AS INTEGER

INPUT X

L = X - 30

M = X + 30

WHILE L <> M

  IF L > M THEN

    L = L – M

  ELSE

    M = M – L

  END IF

WEND

PRINT M

x = int(input())

L = x-30

M = x+30

while L != M:

    if L > M:

        L = L - M

    else:

        M = M - L

print(M)

Ал­го­рит­ми­че­ский языкПас­каль

алг

нач

цел x, L, M

ввод x

L := x-30

M := x+30

нц пока L <> M

если L > M

то L := L – M

иначе M := M – L

все

кц

вывод M

кон

var x, L, M: integer;

begin

  readln(x);

  L := x-30;

  M := x+30;

  while L <> M do begin

    if L > M

      then L := L - M

      else M := M – L;

  end;

  writeln(M);

end.

Си++

#include <iostream>

using namespace std;

int main()

{

  int x, L, M;

  cin >> x;

  L = x-30;

  M = x+30;

  while (L != M) {

    if(L > M) L = L - M;

    else M = M - L;

  }

  cout « M « endl;

  return 0;

}

 


Пройти тестирование по этим заданиям