СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Каталог заданий.
Двумерные массивы

Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 19 № 3368

Значения элементов двухмерного массива A[1..100,1..100] задаются с помощью следующего фрагмента программы:

 

 

БейсикПаскаль

FOR i= 1 TO 100

    FOR k=1 TO 100

    IF i > k THEN A(i,k) = i

    ELSE

        A(i,k) = -k

    NEXT k

NEXT i

for i:=1 to 100 do

    for k:=1 to 100 do

        if i > k then

        A[i,k] := i

    else A[i,k] := -k;

Си++Алгоритмический язык

for (i=1;i<=100;i++) {

    for (k=1;k<=100;k++) {

        if (i > k) {

            A[i,k] = i;

        }

        else A[i,k] = -k;

    }

}

нц для i от 1 до 100

    нц для k от 1 до 100

        если i > k

        то A[i,k] := i

        иначе A[i,k] := -k

    кц

кц

Python

 

for i in range(1, 101):

    for k in range(1, 101):

        if i > k:

            A[i][k] = i

        else:

            A[i][k] = -k

 

 

Чему равна сумма элементов массива после выполнения этого фрагмента программы?


Аналоги к заданию № 3368: 3391 Все


2
Задание 19 № 3369

Значения элементов двумерного массива A[1..100,1..100] задаются с помощью следующего фрагмента программы:

 

 

БейсикPython

FOR i = 1 TO 100

    FOR k = 1 TO 100

        IF i = k THEN A(i,k)= 1

        ELSE A(i,k)= -1

    NEXT k

NEXT i

for i in range(1, 101):

    for k in range(1, 101):

        if i == k:

            A[i][k] = 1

        else:

            A[i][k] = -1

ПаскальАлгоритмический язык

for i:= 1 to 100 do

    for k:=1 to 100 do

        if i = k then

            A[i,k] := 1

        else A[i,k] := -1;

нц для i от 1 до 100

    нц для k от 1 до 100

        если i = k то

            A[i,k] := 1

        иначе A[i,k] := -1

    все

    кц

кц

Си++

for (i = 1; i <= 100; i++) {

    for (k = 1; k <= 100; k++) {

        if (i == k)

            A[i][k] = 1;

        else

            A[i][k] = -1;

    }

}

 

 

Чему равна сумма элементов массива после выполнения этого фрагмента программы?


3
Задание 19 № 3365

Дан фрагмент программы, обрабатывающей двухмерный массив A[1..5,1..4]:

 

 

БейсикPython

k = 4

FOR m = 1 TO 4

    k = k + 1

    FOR n = 1 TO 5

        k = m - k

        A(n,m) = n*n+m*m-2*k

    NEXT n

NEXT m

 

k = 4

for m in range(1, 5):

   k += 1

   for n in range(1, 6):

      k=m-k

      A[n][m]=n*n+m*m-2*k

ПаскальАлгоритмический язык

k:=4;

for m:=1 to 4 do begin

   k:=k+1;

   for n:=1 to 5 do begin

       k:=m-k;

       A[n,m]:=n*n+m*m-2*k;

    end;

end;

k:=4

нц для m от 1 до 4

    k:=k+1

    нц для n от 1 до 5

        k:=m-k

        A[n,m]:=n*n+m*m-2*k

    кц

кц

 

Си++

k = 4;

for (m = 1; m <= 4; m++) {

    k = k + 1;

    for (n = 1; n <= 5; n++) {

        k=m-k;

        A[n][m]=n*n+m*m-2*k;

    }

}

 

 

Чему будет равно значение A[3,1]?


4
Задание 19 № 3367

Элементы двухмерного массива A размером 10x10 первоначально были равны 1. Затем значения некоторых из них меняют с помощью следующего фрагмента программы:

 

 

БейсикPython

FOR n = 1 TO 4

    FOR k = 1 TO n+1

        A(n,k) = A(n,k) - 1

        A(n,k+1) = A(n,k) - 1

    NEXT k

NEXT n

for n in range(1, 5):

    for k in range(1, n+2):

        A[n,k] = A[n,k]-1

        A[n,k+1] = A[n,k]-1

ПаскальАлгоритмический язык

for n:= 1 to 4 do

    for k:=1 to n+1 do begin

        A[n,k]:= A[n,k]-1;

        A[n,k+1]:= A[n,k]-1;

    end;

нц для n от 1 до 4

    нц для k от 1 до n+1

        A[n,k]:= A[n,k]-1

        A[n,k+1]:= A[n,k]-1

    кц

кц

Си++

for (n = 1; n <= 4; n++) {

    for (k = 1; k <= n+1; k++) {

        A[n][k]= A[n][k]-1;

        A[n][k+1]= A[n][k]-1;

    }

}

 

 

Сколько элементов массива в результате будут равны 0?


5
Задание 19 № 3373

В программе описан двухмерный целочисленный массив A [1..6,1..6]. Ниже представлен фрагмент этой программы, в котором изменяются значения элементов массива.

 

БейсикPython

FOR n = 1 TO 6

    FOR m = 1 TO 6

        A(n,m) = A(m,n)+2*n-m

    NEXT m

NEXT n

for n in range(1, 7):

    for m in range(1, 7):

        A[n,m] = A[m,n]+2*n-m

ПаскальАлгоритмический язык

for n:= 1 to 6 do

    for m:=1 to 6 do begin

        A[n,m]:= A[m,n]+2*n-m;

    end;

нц для n от 1 до 6

    нц для m от 1 до 6

        A[n,m]:= A[m,n]+2*n-m

    кц

кц

Си++

for (n = 1; n <= 6; n++) {

    for (m = 1; m <= 6; m++) {

        A[n][m]= A[m][n]+2*n-m;

    }

}

 

 

До выполнения данного фрагмента программы значение A[4,3] было равно 10, а значение A[3,4] было равно 15. Чему будет равно значение A[4,3] после выполнения этого фрагмента программы?


6
Задание 19 № 3374

Значения двумерного массива задаются с помощью вложенного оператора цикла в представленном фрагменте программы:

 

 

БейсикPython

FOR n = 1 TO 5

    FOR k = 1 TO 5

        B(n,k) = n + k

    NEXT k

NEXT n

for n in range(1, 6):

    for k in range(1, 6):

        B[n][k] = n + k

ПаскальАлгоритмический язык

for n:= 1 to 5 do

    for k:=1 to 5 do begin

        B[n,k]:= n + k;

    end;

нц для n от 1 до 5

    нц для k от 1 до 5

        B[n,k]:= n + k

    кц

кц

Си++

for (n = 1; n <= 5; n++) {

    for (k = 1; k <= 5; k++) {

        B[n][k]= n + k;

    }

}

 

 

 

Чему будет равно значение B[2,4]?


7
Задание 19 № 3375

Значения элементов двумерного массива А размером 5x5 задаются с помощью вложенного цикла в представленном фрагменте программы:

 

 

БейсикPython

FOR i = 1 TO 5

    FOR j = 1 TO 5

        A(i,j) = i*j

    NEXT j

NEXT i

for i in range(1, 6):

    for j in range(1, 6):

        A[i,j] = i*j

ПаскальАлгоритмический язык

for i:= 1 to 5 do

    for j:=1 to 5 do begin

        A[i,j]:= i*j;

    end;

нц для i от 1 до 5

    нц для j от 1 до 5

        A[i,j]:= i*j

    кц

кц

Си++

for (i = 1; i <= 5; i++) {

    for (j = 1; j <= 5; j++) {

        A[i][j]= i*j;

    }

}

 

 

Сколько элементов массива будут иметь значения больше 10?


8
Задание 19 № 3378

Значения элементов двухмерного массива A[1..10,1..10] сначала равны 4. Затем выполняется следующий фрагмент программы:

 

БейсикPython

FOR i = 1 TO 4

    FOR j = 1 TO 5

        A(i,j) = A(i,j)+4

        A(j,i) = A(j,i)+5

    NEXT j

NEXT i

for i in range(1, 5):

    for j in range(1, 6):

        A[i,j] = A[i,j]+4

        A[j,i] = A[j,i]+5

ПаскальАлгоритмический язык

for i:= 1 to 4 do

    for j:=1 to 5 do begin

        A[i,j]:=A[i,j]+4;

        A[j,i]:=A[j,i]+5;

    end;

нц для i от 1 до 4

    нц для j от 1 до 5

        A[i,j]:=A[i,j]+4

        A[j,i]:=A[j,i]+5

    кц

кц

Си++

for (i = 1; i <= 4; i++) {

    for (j = 1; j <= 5; j++) {

        A[i][j]=A[i][j]+4;

        A[j][i]=A[j][i]+5;

    }

}

 

 

Сколько элементов массива будут равны 9?


9
Задание 19 № 3385

Дан фрагмент программы:

 

 

БейсикPython

FOR n = 1 TO 5

    FOR m = 1 TO 5

        C(n,m) = (m – n)*(m – n)

    NEXT m

NEXT n

 

for n in range(1, 6):

    for m in range(1, 6):

        C[n][m] = (m – n)*(m – n)

 

ПаскальАлгоритмический язык

for n:= 1 to 5 do

    for m:=1 to 5 do begin

        C[n,m] : = (m – n)*(m – n);

    end;

нц для n от 1 до 5

    нц для m от 1 до 5

        C[n,m] := (m – n)*(m – n)

    кц

кц

Си++

for (n = 1; n <= 5; n++) {

    for (m = 1; m <= 5; m++) {

        C[n][m] = (m – n)*(m – n);

    }

}

 

 

Сколько элементов массива С будут равны 1?


10
Задание 19 № 3390

Все элементы двумерного массива A размером 10х10 элементов первоначально были равны 0. Затем значения элементов меняются с помощью вложенного оператора цикла в представленном фрагменте программы:

 

 

БейсикPython

FOR n = 1 TO 4

    FOR k = n TO 4

        A(n,k) = A(n,k) + 1

        A(k,n) = A(k,n) + 1

 

    NEXT k

NEXT n

 

for n in range(1, 5):

    for k in range(n, 5):

        A[n][k] = A[n][k] + 1

        A[k][n] = A[k][n] + 1

ПаскальАлгоритмический язык

for n:=1 to 4 do

    for k:=n to 4 do begin

        A[n,k] : = A[n,k] + 1;

        A[k,n] : = A[k,n] + 1;

    end;

нц для n от 1 до 4

    нц для k от n до 4

        A[n,k] : = A[n,k] + 1

        A[k,n] : = A[k,n] + 1

    кц

кц

Си++

for (n = 1; n <= 4; n++) {

    for (k = n; k <= 4; k++) {

        A[n][k] = A[n][k] + 1;

        A[k][n] = A[k][n] + 1;

    }

}

 

 

Сколько элементов массива в результате будут равны 1?


11
Задание 19 № 3393

Значения элементов двухмерного массива A[1..10,1..10] сначала равны 0. Затем выполняется следующий фрагмент программы:

 

 

БейсикPython

FOR i = 1 TO 4

    FOR j = 2 TO 5

        A(i,j) = A(i,j)+4

        A(j,i) = A(j,i)+5

    NEXT j

NEXT i

 

for i in range(1, 5):

    for j in range(2, 6):

        A[i][j] = A[i][j]+4

        A[j][i] = A[j][i]+5

ПаскальАлгоритмический язык

for i:=1 to 4 do

    for j:=2 to 5 do begin

        A[i,j] : = A[i,j]+4;

        A[j,i] : = A[j,i]+5;

    end;

нц для i от 1 до 4

    нц для j от 2 до 5

        A[i,j] : = A[i,j]+4

        A[j,i] : = A[j,i]+5

    кц

кц

Си++

for (i = 1; i <= 4; i++) {

    for (j = 2; j <= 5; j++) {

        A[i][j] = A[i][j]+4;

        A[j][i] = A[j][i]+5;

    }

}

 

 

Сколько элементов массива будут равны 9?


12
Задание 19 № 7196

Ниже приведён фрагмент программы, записанный на четырёх языках программирования.

Массив A двумерный; в программе рассматривается его фрагмент, соответствующий значениям каждого индекса от 1 до 9.

 

БейсикПаскаль

FOR n=1 TO 9

    FOR k=1 TO 9

        A(n,k)=n+k+1

    NEXT k

NEXT n

for n:=1 to 9 do

    for k:=1 to 9 do

        A[n,k]:=n+k+1

Си++Алгоритмический язык

for (n=1;n<=9;n++) {

    for (k=1;k<=9;k++) {

        A[n][k]=n+k+1;

       }

}

нц для n от 1 до 9

    нц для k от 1 до 9

        A[n,k]=n+k+1

    кц

кц

Python

for n in range(1, 10):

    for k in range(1, 10):

        A[n,k] = n+k+1

 

 

Сколько элементов указанного фрагмента массива A будут принимать нечётные значения после выполнения данного фрагмента программы?

Источник: ЕГЭ по ин­фор­ма­ти­ке 05.05.2014. До­сроч­ная волна. Ва­ри­ант 1.

13
Задание 19 № 7263

Дан фрагмент программы:

 

 

БейсикPython

FOR n = 1 TO 6

    FOR m = 1 TO 5

        C(n,m)=C(n,m)+(2*n-m)

    NEXT m

NEXT n

 

for n in range(1, 7):

    for m in range(1, 6):

        C[n,m]=C[n,m]+(2*n-m)

ПаскальАлгоритмический язык

for n:=1 to 6 do

    for m:=1 to 5 do begin

        C[n,m]:=C[n,m]+(2*n-m);

    end;

нц для n от 1 до 6

    нц для m от 1 до 5

        C[n,m]:=C[n,m]+(2*n-m)

    кц

кц

Си++

for (n = 1; n <= 6; n++) {

    for (m = 1; m <= 5; m++) {

        C[n][m]=C[n][m]+(2*n-m);

    }

}

 

 

Чему будет равно значение элемента двумерного массива С[4,3], если до выполнения этих команд С[4,3]=10?


14
Задание 19 № 7365

Ниже приведён фрагмент программы, записанный на четырёх языках программирования.

Массив A двумерный; в программе рассматривается его фрагмент, соответствующий значениям каждого индекса от 1 до 9.

 

БейсикПаскаль

FOR n=1 TO 9

    FOR k=1 TO 9

    A(n,k)=2*n+k

    NEXT k

NEXT n

for n:=1 to 9 do

    for k:=1 to 9 do

        A[n,k]:=2*n+k

Си++Алгоритмический язык

for (n=1;n<=9;n++) {

    for (k=1;k<=9;k++)

        A[n][k]=2*n+k;

    }

}

нц для n от 1 до 9

    нц для k от 1 до 9

        A[n,k]=2*n+k

кц

кц

Python

 

for n in range(1, 10):

    for k in range(1, 10):

            A[n,k] = 2*n+k

 

 

Сколько элементов указанного фрагмента массива A будут принимать нечётные значения после выполнения данного фрагмента программы?

Источник: ЕГЭ по ин­фор­ма­ти­ке 05.05.2014. До­сроч­ная волна. Ва­ри­ант 2.

Пройти тестирование по этим заданиям