СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 3373

В программе описан двухмерный целочисленный массив A [1..6,1..6]. Ниже представлен фрагмент этой программы, в котором изменяются значения элементов массива.

 

БейсикPython

FOR n = 1 TO 6

    FOR m = 1 TO 6

        A(n,m) = A(m,n)+2*n-m

    NEXT m

NEXT n

for n in range(1, 7):

    for m in range(1, 7):

        A[n,m] = A[m,n]+2*n-m

ПаскальАлгоритмический язык

for n:= 1 to 6 do

    for m:=1 to 6 do begin

        A[n,m]:= A[m,n]+2*n-m;

    end;

нц для n от 1 до 6

    нц для m от 1 до 6

        A[n,m]:= A[m,n]+2*n-m

    кц

кц

Си++

for (n = 1; n <= 6; n++) {

    for (m = 1; m <= 6; m++) {

        A[n][m]= A[m][n]+2*n-m;

    }

}

 

 

До выполнения данного фрагмента программы значение A[4,3] было равно 10, а значение A[3,4] было равно 15. Чему будет равно значение A[4,3] после выполнения этого фрагмента программы?

Решение.

Итак, в начале будет меняться элемент массива A[3,4] (n=3, m=4), так что

 

A[3,4] := A[4,3] + 2 * 3 - 4 = 10 + 6 - 4 = 12.

 

А теперь найдем A[4,3]:

 

A[4,3] := A[3,4] + 2 * 4 - 3 = 12 + 8 - 3 = 17.