СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 3369

Значения элементов двумерного массива A[1..100,1..100] задаются с помощью следующего фрагмента программы:

 

 

БейсикPython

FOR i = 1 TO 100

    FOR k = 1 TO 100

        IF i = k THEN A(i,k)= 1

        ELSE A(i,k)= -1

    NEXT k

NEXT i

for i in range(1, 101):

    for k in range(1, 101):

        if i == k:

            A[i][k] = 1

        else:

            A[i][k] = -1

ПаскальАлгоритмический язык

for i:= 1 to 100 do

    for k:=1 to 100 do

        if i = k then

            A[i,k] := 1

        else A[i,k] := -1;

нц для i от 1 до 100

    нц для k от 1 до 100

        если i = k то

            A[i,k] := 1

        иначе A[i,k] := -1

    все

    кц

кц

Си++

for (i = 1; i <= 100; i++) {

    for (k = 1; k <= 100; k++) {

        if (i == k)

            A[i][k] = 1;

        else

            A[i][k] = -1;

    }

}

 

 

Чему равна сумма элементов массива после выполнения этого фрагмента программы?

Решение.

После выполнения программы на главной диагонали будут стоять 1, а во всех остальных ячейках будет стоят число −1. Всего ячеек 100 · 100 = 10 000, а ячеек в главной диагонали 100, так что сумма будет равна

 

100 * 1 + (10 000 − 100) * (−1) = 100 − 9 900 = −9 800.