СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 19 № 3367

Элементы двухмерного массива A размером 10x10 первоначально были равны 1. Затем значения некоторых из них меняют с помощью следующего фрагмента программы:

 

 

БейсикPython

FOR n = 1 TO 4

    FOR k = 1 TO n+1

        A(n,k) = A(n,k) - 1

        A(n,k+1) = A(n,k) - 1

    NEXT k

NEXT n

for n in range(1, 5):

    for k in range(1, n+2):

        A[n,k] = A[n,k]-1

        A[n,k+1] = A[n,k]-1

ПаскальАлгоритмический язык

for n:= 1 to 4 do

    for k:=1 to n+1 do begin

        A[n,k]:= A[n,k]-1;

        A[n,k+1]:= A[n,k]-1;

    end;

нц для n от 1 до 4

    нц для k от 1 до n+1

        A[n,k]:= A[n,k]-1

        A[n,k+1]:= A[n,k]-1

    кц

кц

Си++

for (n = 1; n <= 4; n++) {

    for (k = 1; k <= n+1; k++) {

        A[n][k]= A[n][k]-1;

        A[n][k+1]= A[n][k]-1;

    }

}

 

 

Сколько элементов массива в результате будут равны 0?

Решение.

Итак, идем по программе:

от n=1 до 4 выполняется

от k=1 до n+1 выполняется

 

(n=1, k=1) из ячейки вычитают 1 и ячейка принимает значение 0

ячейка, которая будет следовать дальше по счетчику, принимает значение

данной минус 1, т е значение -1.

 

(n=1, k=2) Дальше работаем с этой ячейкой и ее значение получается -2, Так что далее получим, что только ячейки с k=1, а n:=1 to 4 будут равны 0, т е только 4 ячейки.