СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Каталог заданий.
Разное

Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 19 № 11120

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 8, 4, 3, 0, 7, 2, 1, 5, 9, 6 соответственно, т.е. A[0] = 8, A[1] = 4 и т. д. Определите значение переменной s после выполнения следующего фрагмента программы (записанного ниже на разных языках программирования).

 

БейсикPython

s = 0

FOR j = 0 TO 9

  IF A(j) <=4 THEN

    s = j

  ENDIF

NEXT j

s = 0

for j in range(10):

    if A[j] <= 4:

      s = j

Алгоритмический языкПаскаль

s := 0

нц для j от 0 до 9

  если A[j] <= 4 то

    s := j

  все

кц

s := 0;

for j := 0 to 9 do

  if A[j] <= 4 then

    s := j;

Си++

s = 0;

for (j = 0; j <= 9; j++) {

    if (A[j] <= 4) {

      s = j;

    }

}

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 23.03.2016. До­сроч­ная волна
Решение · · Видеокурс ·

2
Задание 19 № 13495

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 1, 2, 18, 8, 14, 9, 23, 7, 51, 99 соответственно, то есть A[0] = 1, A[1] = 2 и т. д. Определите значение переменной t после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

БейсикPython

i = 0: j = 9

WHILE A(i) < 10

    i = i + 1

WEND

WHILE A(j) > 10

    j = j - 1

WEND

t = A(i) - A(j)

i = 0

j = 9

while A[i] < 10:

     i += 1

while A[j] > 10:

     j -= 1

t = A[i] - A[j]

ПаскальАлгоритмический язык

i = 0; j = 9;

while A[i] < 10 do

  i := i + 1;

while A[j] > 10 do

  j := j - 1;

t := A[i] - A[j];

i := 0

j := 9

нц пока A[i] < 10

   i := i + 1

кц

нц пока A[j] > 10

  j :=j - 1

кц

t := A[i] - A[j]

Си++

i = 0;

j = 9;

while (A[i] < 10) {

  i += 1;

}

while (A[j] > 10) {

  j -= 1;

}

t = A[i] - A[j];

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10203

3
Задание 19 № 13522

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 5, 28, 8, 14, 9, 23, 6, 18, 51, 99 соответственно, то есть A[0] = 5, A[1] = 28 и т. д. Определите значение переменной t после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

БейсикPython

i = 0: j = 9

WHILE A(i) < 10

    i = i + 1

WEND

WHILE A(j) > 10

    j = j - 1

WEND

t = A(i) - A(j)

i = 0

j = 9

while A[i] < 10 :

     i += 1

while A[j] > 10 :

     j -= 1

t = A[i] - A[j]

ПаскальАлгоритмический язык

i = 0; j = 9;

while A[i] < 10 do

  i := i + 1;

while A[j] > 10 do

  j := j - 1;

t := A[i] - A[j];

i := 0

j := 9

нц пока A[i] < 10

   i := i + 1

кц

нц пока A[j] > 10

  j :=j - 1

кц

t := A[i] - A[j]

Си++

i = 0;

j = 9;

while (A[i] < 10) {

  i += 1;

}

while (A[j] > 10) {

  j -= 1;

}

t = A[i] - A[j];

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10204

4
Задание 19 № 14234

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A; в представленном фрагменте обрабатываются элементы массива с индексами от 1 до 10.

 

БейсикPython

n = 10

d = 6

FOR j = 1 TO d

  s = A(1)

  FOR i = 1 TO n-1

    A(i) = A(i+1)

  NEXT i

  A(10) = s

NEXT j

n = 10

d = 6

for j in range(1,d+1):

  s = A[1]

  for i in range(1,n):

    A[i] = A[i+1]

  A[10] = s

ПаскальАлгоритмический язык

n := 10;

d := 6;

for j:=1 to d do begin

  s := A[1];

  for i:=1 to n-1 do begin

    A[i] := A[i+1];

  end;

  A[10] := s;

end;

n := 10

d := 6

нц для j от 1 до d

  s := A[1]

  нц для i от 1 до n-1

    A[i] := A[i+1]

  кц

  A[10]:= s

кц

Си++

n = 10;

d = 6;

for (j = 1; j <= d; j++) {

  s = A[1];

  for (i = 1; i <= n-1; i++) {

    A[i] = A[i+1];

  }

  A[10] = s;

}

 

Перед началом выполнения программы эти элементы массива имели значения 0, 1, 2, 3, 4, 5, 4, 3, 2, 1 (то есть A[1] = 0; A[2] = 1; …; A[10] = 1).

Значение какого из этих элементов массива будет наибольшим после выполнения фрагмента программы? В ответе укажите индекс элемента – число от 1 до 10.


5
Задание 19 № 14278

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A; в представленном фрагменте обрабатываются элементы массива с индексами от 1 до 10.

 

БейсикPython

n = 10

d = 6

FOR j = 1 TO d

  s = A(1)

  FOR i = 1 TO n-1

    A(i) = A(i+1)

  NEXT i

  A(10) = s

NEXT j

n = 10

d = 6

for j in range(1,d+1):

  s = A[1]

  for i in range(1,n):

    A[i] = A[i+1]

  A[10] = s

ПаскальАлгоритмический язык

n := 10;

d := 6;

for j:=1 to d do begin

  s := A[1];

  for i:=1 to n-1 do begin

    A[i] := A[i+1];

  end;

  A[10] := s;

end;

n := 10

d := 6

нц для j от 1 до d

  s := A[1]

  нц для i от 1 до n-1

    A[i] := A[i+1]

  кц

  A[10]:= s

кц

Си++

n = 10;

d = 6;

for (j = 1; j <= d; j++) {

  s = A[1];

  for (i = 1; i <= n-1; i++) {

    A[i] = A[i+1];

  }

  A[10] = s;

}

 

 

Перед началом выполнения программы эти элементы массива имели значения 0, 1, 4, 9, 6, 5, 6, 8, 4, 1 (т.е. A[1] = 0; A[2] = 1; …; A[10] = 1).

Значение какого из этих элементов массива будет наибольшим после выполнения фрагмента программы? В ответе укажите индекс элемента – число от 1 до 10.

 

Примечание. В языках Python и C++ нулевой элемент массива может принимать любое значение, элементы массива с индексами от 1 до 10 объявлены так, как указано в условии.


Пройти тестирование по этим заданиям