СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 19 № 13522

В про­грам­ме ис­поль­зу­ет­ся од­но­мер­ный це­ло­чис­лен­ный мас­сив A с ин­дек­са­ми от 0 до 9. Зна­че­ния эле­мен­тов равны 5, 28, 8, 14, 9, 23, 6, 18, 51, 99 со­от­вет­ствен­но, то есть A[0] = 5, A[1] = 28 и т. д. Опре­де­ли­те зна­че­ние пе­ре­мен­ной t после вы­пол­не­ния сле­ду­ю­ще­го фраг­мен­та про­грам­мы, за­пи­сан­но­го ниже на раз­ных язы­ках про­грам­ми­ро­ва­ния.

 

Бей­сикPython

i = 0: j = 9

WHILE A(i) < 10

    i = i + 1

WEND

WHILE A(j) > 10

    j = j - 1

WEND

t = A(i) - A(j)

i = 0

j = 9

while A[i] < 10 :

     i += 1

while A[j] > 10 :

     j -= 1

t = A[i] - A[j]

Пас­кальАл­го­рит­ми­че­ский язык

i = 0; j = 9;

while A[i] < 10 do

  i := i + 1;

while A[j] > 10 do

  j := j - 1;

t := A[i] - A[j];

i := 0

j := 9

нц пока A[i] < 10

   i := i + 1

кц

нц пока A[j] > 10

  j :=j - 1

кц

t := A[i] - A[j]

Си++

i = 0;

j = 9;

while (A[i] < 10) {

  i += 1;

}

while (A[j] > 10) {

  j -= 1;

}

t = A[i] - A[j];

 

Решение.

В данной программе из первого числа больше либо равного 10 вычитается последнее число меньше либо равное 10 то есть 28 − 6 = 22.

 

Ответ: 22.

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10204