СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 11120

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 8, 4, 3, 0, 7, 2, 1, 5, 9, 6 соответственно, т.е. A[0] = 8, A[1] = 4 и т. д. Определите значение переменной s после выполнения следующего фрагмента программы (записанного ниже на разных языках программирования).

 

БейсикPython

s = 0

FOR j = 0 TO 9

  IF A(j) <=4 THEN

    s = j

  ENDIF

NEXT j

s = 0

for j in range(10):

    if A[j] <= 4:

      s = j

Алгоритмический языкПаскаль

s := 0

нц для j от 0 до 9

  если A[j] <= 4 то

    s := j

  все

кц

s := 0;

for j := 0 to 9 do

  if A[j] <= 4 then

    s := j;

Си++

s = 0;

for (j = 0; j <= 9; j++) {

    if (A[j] <= 4) {

      s = j;

    }

}

 

Решение.

Заметим, что в переменную s записывается индекс последнего числа массива, которое меньше либо равно 4. Значит, в переменную s будет записано число 6.

 

Ответ: 6.

Источник: ЕГЭ по ин­фор­ма­ти­ке 23.03.2016. До­сроч­ная волна
Спрятать решение · ·
Макс Г 08.06.2016 12:22

в ответе должна быть 1 согласно условию

Сергей Никифоров

Обратите внимание, записывается не само число, а его индекс.