информатика
Информатика
Русский язык
Английский язык
Немецкий язык
Французcкий язык
Испанский язык
Физика
Химия
Биология
География
Обществознание
Литература
История
сайты - меню - вход - новости




Каталог заданий.
Алгоритмы, меняющие элементы массива местами
Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 19 № 7764

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 5; 1; 6; 7; 8; 8; 7; 7; 6; 9 соответственно, т.е. A[0] = 5; A[1] = 1 и т.д. Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

БейсикPython

c = 0

FOR i = 1 TO 9

    IF A(i - 1) >= A(i) THEN

        t = A(i)

        A(i) = A(i - 1)

        A(i - 1) = t

    ELSE

        c = c + 1

    ENDIF

NEXT i

c = 0

for i in range(1, 10):

    if A[i - 1] >= A[i]:

        t = A[i]

        A[i] = A[i - 1]

        A[i - 1] = t

    else:

        c = c + 1

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do

    if A[i - 1] >= A[i] then

        begin

            t := A[i];

            A[i] := A[i - 1];

            A[i - 1] := t

        end

    else

        c := c + 1;

c := 0

нц для i от 1 до 9

если A[i - 1] >= A[i] то

    t := A[i]

    A[i] := A[i - 1]

    A[i - 1] := t

иначе

    c := c + 1

все

кц

Си++

c = 0;

for (i = 1; i <= 9; i++)

    if (A[i-1] >= A[i])

    {

        t = A[i];

        A[i] = A[i - 1];

        A[i - 1] = t;

    }

    else

        c++;

 


Аналоги к заданию № 7764: 7791 Все


2
Задание 19 № 11355

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 1, 2, 5, 8, 9, 3, 4, 0, 7, 6 соответственно, т. е. A[0] = 1, A[1] = 2 и т. д.

Определите значение переменной j после выполнения следующего фрагмента программы (записанного ниже на пяти языках программирования).

 

БейсикPython

j = 5

WHILE A(j) < A(j-1)

    t = A(j)

    A(j) = A(j-1)

    A(j-1) = t

    j = j - 1

WEND

j = 5

while A[j] < A[j-1]:

    A[j],A[j-1]=A[j-1],A[j]

    j -= 1

ПаскальАлгоритмический язык

j := 5;

while A[j] < A[j-1] do

    begin

        t := A[j];

        A[j] := A[j-1];

        A[j-1] := t;

        j := j - 1;

    end;

j := 5

нц пока A[j] < A[j-1]

    t := A[j]

    A[j] := A[j-1]

    A[j-1] := t

    j := j - 1

кц

Си++

j = 5;

while (A[j] < A[j-1])

    {

        t = A[j];

        A[j] = A[j-1];

        A[j-1] = t;

        j -= 1;

    }

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2017 по информатике.

3
Задание 19 № 13365

В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент этой программы.

 

БейсикPython

s = 0

n = 10

FOR i = 0 TO n-1

    s = s+A(i)-A(i+1)

NEXT i

s = 0

n = 10

for i in range(n):

    s = s + A[i] – A[i+1]

ПаскальАлгоритмический язык

s := 0;

n := 10;

for i:=0 to n-1 do begin

  s := s + A[i] - A[i+1];

end;

s := 0

n := 10

нц для i от 0 до n-1

  s := s + A[i] - A[i+1]

кц

Си++

s = 0;

n = 10;

for (i = 0; i < n; i++) {

  s = s + A[i] - A[i+1];

}

 

 

В начале выполнения этого фрагмента в массиве находились числа 27, 17, 7, 0, 7, 17, 27, 17, 10, 7, 0, т.е. A[0] = 27, A[1] = 17 и т. д. Чему будет равно значение переменной s после выполнения данного фрагмента программы?

Источник: ЕГЭ — 2017. До­сроч­ная волна по информатике

4
Задание 19 № 13415

В программе используется фрагмент одномерного целочисленного массива A с индексами от 1 до 10. Значения элементов равны 6, 7, 3, 8, 4, 1, 2, 0, 9, 5 соответственно, т. е. A[1] = 6, A[2] = 7 и т. д. Определите значение переменной s после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

s = 0

n = 10

FOR i = 3 TO n

    s = s+A(i)-A(i-2)

NEXT i

s = 0

n = 10

for i in range(3,n+1):

    s = s + A[i] – A[i-2]

ПаскальАлгоритмический язык

s := 0;

n := 10;

for i:=3 to n do begin

  s := s + A[i] - A[i-2];

end;

s := 0

n := 10

нц для i от 3 до n

  s := s + A[i] - A[i-2]

кц

Си++

s = 0;

n = 10;

for (i = 3; i <= n; i++) {

  s = s + A[i] - A[i-2];

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10303

5
Задание 19 № 13468

В программе используется фрагмент одномерного целочисленного массив A с индексами от 1 до 10. Значения элементов равны 3, 14, 15, 92, 6, 2, 7, 18, 28, 17 соответственно, т. е. A[1] = 3, A[2] = 14 и т. д.

Определите значение переменной s после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

s = 0

n = 10

FOR i = 3 TO n

    s = s+A(i)-A(i-2)

NEXT i

s = 0

n = 10

for i in range(3,n+1):

    s = s + A[i] – A[i-2]

ПаскальАлгоритмический язык

s := 0;

n := 10;

for i:=3 to n do begin

  s := s + A[i] - A[i-2];

end;

s := 0

n := 10

нц для i от 3 до n

  s := s + A[i] - A[i-2]

кц

Си++

s = 0;

n = 10;

for (i = 3; i <= n; i++) {

  s = s + A[i] - A[i-2];

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10304

6
Задание 19 № 13495

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 1, 2, 18, 8, 14, 9, 23, 7, 51, 99 соответственно, то есть A[0] = 1, A[1] = 2 и т. д. Определите значение переменной t после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

БейсикPython

i = 0: j = 9

WHILE A(i) < 10

    i = i + 1

WEND

WHILE A(j) > 10

    j = j - 1

WEND

t = A(i) - A(j)

i = 0

j = 9

while A[i] < 10:

     i += 1

while A[j] > 10:

     j -= 1

t = A[i] - A[j]

ПаскальАлгоритмический язык

i = 0; j = 9;

while A[i] < 10 do

  i := i + 1;

while A[j] > 10 do

  j := j - 1;

t := A[i] - A[j];

i := 0

j := 9

нц пока A[i] < 10

   i := i + 1

кц

нц пока A[j] > 10

  j :=j - 1

кц

t := A[i] - A[j]

Си++

i = 0;

j = 9;

while (A[i] < 10) {

  i += 1;

}

while (A[j] > 10) {

  j -= 1;

}

t = A[i] - A[j];

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10203

7
Задание 19 № 13522

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 5, 28, 8, 14, 9, 23, 6, 18, 51, 99 соответственно, то есть A[0] = 5, A[1] = 28 и т. д. Определите значение переменной t после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

БейсикPython

i = 0: j = 9

WHILE A(i) < 10

    i = i + 1

WEND

WHILE A(j) > 10

    j = j - 1

WEND

t = A(i) - A(j)

i = 0

j = 9

while A[i] < 10 :

     i += 1

while A[j] > 10 :

     j -= 1

t = A[i] - A[j]

ПаскальАлгоритмический язык

i = 0; j = 9;

while A[i] < 10 do

  i := i + 1;

while A[j] > 10 do

  j := j - 1;

t := A[i] - A[j];

i := 0

j := 9

нц пока A[i] < 10

   i := i + 1

кц

нц пока A[j] > 10

  j :=j - 1

кц

t := A[i] - A[j]

Си++

i = 0;

j = 9;

while (A[i] < 10) {

  i += 1;

}

while (A[j] > 10) {

  j -= 1;

}

t = A[i] - A[j];

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10204

8
Задание 19 № 13549

В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Значения элементов равны 4, 3, 16, 24, 35, 18, 4, 72, 10, 99, 44 соответственно, т. е. A[0] = 4, A[1] = 3 и т. д.

Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на пяти языках программирования.

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) MOD 10 = A(0) THEN

      c = c + 1

      t = A(i+1)

      A(i+1) = A(i)

      A(i) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i]%10 == A[0]:

      c = c + 1

      t = A[i+1]

     A[i+1] = A[i]

     A[i] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do begin

  if A[i] mod 10 = A[0] then

  begin

      c := c + 1;

      t := A[i+1];

      A[i+1] := A[i];

      A[i] := t;

  end;

end;

c := 0

нц для i от 1 до 9

  если mod(A[i],10) = A[0] то

      c := c + 1

      t := A[i+1]

      A[i+1] := A[i]

      A[i] := t

  все

кц

Си++

c = 0;

for (i = 1; i < 10; i++) {

  if (A[i]%10 == A[0]) {

      c++;

      t = A[i+1];

      A[i+1] = A[i];

      A[i] = t;

  }

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10103

9
Задание 19 № 13576

В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Значения элементов равны 8, 3, 16, 24, 35, 18, 4, 72, 8, 99, 44 соответственно, т. е. A[0] = 8, A[1] = 3 и т. д.

Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на пяти языках программирования.

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) MOD 10 = A(0) THEN

    c = c + 1

    t = A(i+1)

    A(i+1) = A(i)

    A(i) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i]%10 == A[0]:

    c = c + 1

    t = A[i+1]

    A[i+1] = A[i]

    A[i] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do begin

if A[i] mod 10 = A[0] then

  begin

    c := c + 1;

    t := A[i+1];

    A[i+1] := A[i];

    A[i] := t;

  end;

end;

c := 0

нц для i от 1 до 9

  если mod(A[i],10) = A[0] то

    c := c + 1

    t := A[i+1]

    A[i+1] := A[i]

    A[i] := t

  все

кц

Си++

c = 0;

for (i = 1; i < 10; i++) {

  if (A[i]%10 == A[0]) {

    c++;

    t = A[i+1];

    A[i+1] = A[i];

    A[i] = t;

  }

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10104

10
Задание 19 № 13603

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

 

БейсикPython

s = 0

n = 10

FOR i = 2 TO n

    s=s+A(i)*A(i)-A(i-1)*A(i-1)

NEXT i

s=0

n=10

for i in range(2,n+1):

    s=s + A[i]*A[i]-A[i-1]*A[i-1]

ПаскальАлгоритмический язык

s:=0;

n:=10;

for i:= 2 to n do begin

    s:=s+A[i]*A[i]-A[i-1]*A[i-1];

end;

s:=0

n:=10

нц для i от 2 до n

    s:=s + A[i]*A[i]-A[i-1]*A[i-1];

кц

Си++

s = 0;

n = 10;

for (i = 2; i <= n; i++) {

    s=s + A[i]*A[i]-A[i-1]*A[i-1];

}

 

 

В начале выполнения этого фрагмента в массиве находились числа 1, 12, 23, 34, 45, 56, 67, 78, 89, 90, т. е. A[1]=1, A[2]=12 и т.д. Чему будет равно значение переменной s после выполнения данного фрагмента?

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 12 мая 2017 года Вариант ИН10503

11
Задание 19 № 13630

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

 

БейсикPython

s = 0

n = 10

FOR i = 2 TO n

    s=s+A(i)*A(i)-A(i-1)*A(i-1)

NEXT i

s=0

n=10

for i in range(2,n+1):

    s=s + A[i]*A[i]-A[i-1]*A[i-1]

ПаскальАлгоритмический язык

s:=0;

n:=10;

for i:= 2 to n do begin

    s:=s+A[i]*A[i]-A[i-1]*A[i-1];

end;

s:=0

n:=10

нц для i от 2 до n

    s:=s + A[i]*A[i]-A[i-1]*A[i-1];

кц

Си++

s = 0;

n = 10;

for (i = 2; i <= n; i++) {

    s=s + A[i]*A[i]-A[i-1]*A[i-1];

}

 

 

В начале выполнения этого фрагмента в массиве находились числа 1, 11, 22, 33, 44, 55, 66, 77, 88, 99, т. е. A[1]=1, A[2]=11 и т.д. Чему будет равно значение переменной s после выполнения данного фрагмента?

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 12 мая 2017 года Вариант ИН10504

12
Задание 19 № 13746

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 3, 0, 4, 6, 5, 1, 8, 2, 9, 7 соответственно, т. е. A[0] = 3, A[1] = 0 и т. д. Определите значение переменной c после выполнения следующего фрагмента этой программы (записанного ниже на разных языках программирования)

 

БейсикPython

c = 0

FOR i = 1 TO 9

    IF A(i-1) > A(i) THEN

       c = c + 1

       t = A(i)

       A(i) = A(i-1)

       A(i-1) = t

    END IF

NEXT i

c = 0

for i in range(1,10):

    if A[i-1] > A[i]:

       c = c + 1

       t = A[i]

       A[i] = A[i-1]

       A[i-1] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do

    if A[i-1] > A[i] then

    begin

        c := c + 1;

        t := A[i];

        A[i] := A[i-1];

         A[i-1] := t;

    end;

c := 0

нц для i от 1 до 9

     если A[i-1] > A[i] то

       c := c + 1

       t := A[i]

       A[i] := A[i-1]

       A[i-1] := t

     все

кц

Си++

c = 0;

for (int i = 1; i < 10; i++) {

     if (A[i-1] > A[i]){

        c++;

        t = A[i];

        A[i] = A[i-1];

        A[i-1] = t;

    }

}

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2018 по информатике.

13
Задание 19 № 14234

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A; в представленном фрагменте обрабатываются элементы массива с индексами от 1 до 10.

 

БейсикPython

n = 10

d = 6

FOR j = 1 TO d

  s = A(1)

  FOR i = 1 TO n-1

    A(i) = A(i+1)

  NEXT i

  A(10) = s

NEXT j

n = 10

d = 6

for j in range(1,d+1):

  s = A[1]

  for i in range(1,n):

    A[i] = A[i+1]

  A[10] = s

ПаскальАлгоритмический язык

n := 10;

d := 6;

for j:=1 to d do begin

  s := A[1];

  for i:=1 to n-1 do begin

    A[i] := A[i+1];

  end;

  A[10] := s;

end;

n := 10

d := 6

нц для j от 1 до d

  s := A[1]

  нц для i от 1 до n-1

    A[i] := A[i+1]

  кц

  A[10]:= s

кц

Си++

n = 10;

d = 6;

for (j = 1; j <= d; j++) {

  s = A[1];

  for (i = 1; i <= n-1; i++) {

    A[i] = A[i+1];

  }

  A[10] = s;

}

 

Перед началом выполнения программы эти элементы массива имели значения 0, 1, 2, 3, 4, 5, 4, 3, 2, 1 (то есть A[1] = 0; A[2] = 1; …; A[10] = 1).

Значение какого из этих элементов массива будет наибольшим после выполнения фрагмента программы? В ответе укажите индекс элемента – число от 1 до 10.


14
Задание 19 № 14278

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A; в представленном фрагменте обрабатываются элементы массива с индексами от 1 до 10.

 

БейсикPython

n = 10

d = 6

FOR j = 1 TO d

  s = A(1)

  FOR i = 1 TO n-1

    A(i) = A(i+1)

  NEXT i

  A(10) = s

NEXT j

n = 10

d = 6

for j in range(1,d+1):

  s = A[1]

  for i in range(1,n):

    A[i] = A[i+1]

  A[10] = s

ПаскальАлгоритмический язык

n := 10;

d := 6;

for j:=1 to d do begin

  s := A[1];

  for i:=1 to n-1 do begin

    A[i] := A[i+1];

  end;

  A[10] := s;

end;

n := 10

d := 6

нц для j от 1 до d

  s := A[1]

  нц для i от 1 до n-1

    A[i] := A[i+1]

  кц

  A[10]:= s

кц

Си++

n = 10;

d = 6;

for (j = 1; j <= d; j++) {

  s = A[1];

  for (i = 1; i <= n-1; i++) {

    A[i] = A[i+1];

  }

  A[10] = s;

}

 

 

Перед началом выполнения программы эти элементы массива имели значения 0, 1, 4, 9, 6, 5, 6, 8, 4, 1 (т.е. A[1] = 0; A[2] = 1; …; A[10] = 1).

Значение какого из этих элементов массива будет наибольшим после выполнения фрагмента программы? В ответе укажите индекс элемента – число от 1 до 10.


15
Задание 19 № 14705

Представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 1 до 10. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 3, 5, 8, 10, 7, 4, 6, 12, 15 (т.е. A[1] = 2, A[2] = 3, …, A[10] = 15).

Определите значение переменной s после выполнения фрагмента этой программы (записанного ниже на разных языках программирования).

 

БейсикPython

n = 10

s = 0

FOR i = 2 TO n

    IF A(i-1) < A(i) THEN

        A(i) = A(i) + A(i-1)

        s = s + A(i)

    END IF

NEXT i

n = 10

s = 0

for i in range(2,n+1):

    if A[i-1] < A[i]:

        A[i] = A[i] + A[i-1]

        s = s + A[i]

ПаскальАлгоритмический язык

n := 10;

s := 0;

for i:=2 to n do begin

    if A[i-1] < A[i] then begin

        A[i] := A[i] + A[i-1];

        s := s + A[i]

    end

end;

n := 10

s := 0

нц для i от 2 до n

    если A[i-1] < A[i]

        то

            A[i] := A[i] + A[i-1]

            s := s + A[i]

    все

кц

Си++

n = 10;

s = 0;

for (i = 2; i <= n; ++i) {

    if (A[i-1] < A[i]) {

        A[i] = A[i] + A[i-1];

        s = s + A[i];

    }

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та 28.11.2017 ИН10203

16
Задание 19 № 14780

Представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 1 до 10. Перед началом выполнения данного фрагмента эти элементы массива имели значения 7, 4, 9, 10, 2, 3, 5, 8, 13, 19 (т.е. A[1] = 7, A[2] = 4, …, A[10] = 19).

Определите значение переменной s после выполнения фрагмента этой программы (записанного ниже на разных языках программирования).

 

БейсикPython

n = 10

s = 0

FOR i = 2 TO n

    IF A(i-1) < A(i) THEN

        A(i) = A(i) + A(i-1)

        s = s + A(i)

    END IF

NEXT i

n = 10

s = 0

for i in range(2,n+1):

    if A[i-1] < A[i]:

        A[i] = A[i] + A[i-1]

        s = s + A[i]

ПаскальАлгоритмический язык

n := 10;

s := 0;

for i:=2 to n do begin

    if A[i-1] < A[i] then begin

        A[i] := A[i] + A[i-1];

        s := s + A[i]

    end

end;

n := 10

s := 0

нц для i от 2 до n

    если A[i-1] < A[i]

        то

            A[i] := A[i] + A[i-1]

            s := s + A[i]

    все

кц

Си++

n = 10;

s = 0;

for (i = 2; i <= n; ++i) {

    if (A[i-1] < A[i]) {

        A[i] = A[i] + A[i-1];

        s = s + A[i];

    }

}

 


17
Задание 19 № 15114

Представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 1 до 10. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 3, 5, 3, 10, 7, 4, 6, 12, 9 (т. е. A[1] = 2, A[2] = 3, …, A[10] = 9). Определите значение переменной s после выполнения фрагмента, записанного ниже на пяти языках программирования.

 

 

БейсикPython

n = 10

s = 0

FOR i = 2 TO n

    IF A(i-1) < A(i) THEN

        A(i) = A(i) - A(i-1)

        s = s + A(i)

    END IF

NEXT i

 

n = 10

s = 0

for i in range(2,n):

    if A[i-1] < A[i]:

        A[i] = A[i] - A[i-1]

        s = s + A[i]

 

 

 

ПаскальАлгоритмический язык

 

n := 10;

s := 0;

for i:=2 to n do begin

    if A[i-1] < A[i] then begin

        A[i] := A[i] - A[i-1];

        s := s + A[i]

    end

end;

 

n := 10

s := 0

нц для i от 2 до n

    если A[i-1] < A[i] то

        A[i] := A[i] - A[i-1]

        s := s + A[i]

    все

кц

С++

n = 10;

s = 0;

for (i = 2; i <= n; ++i) {

    if (A[i-1] < A[i]) {

        A[i] = A[i] - A[i-1];

        s = s + A[i];

    }

}

 


18
Задание 19 № 15141

Представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 1 до 10. Перед началом выполнения данного фрагмента эти элементы массива имели значения 7, 4, 9, 10, 2, 3, 5, 3, 13, 10 (т. е. A[1] = 7, A[2] = 4, …, A[10] = 10). Определите значение переменной s после выполнения фрагмента, записанного ниже на пяти языках программирования.

 

 

БейсикPython

n = 10

s = 0

FOR i = 2 TO n

    IF A(i-1) < A(i) THEN

        A(i) = A(i) - A(i-1)

        s = s + A(i)

    END IF

NEXT i

 

n = 10

s = 0

for i in range(2,n):

    if A[i-1] < A[i]:

        A[i] = A[i] - A[i-1]

        s = s + A[i]

 

 

 

ПаскальАлгоритмический язык

 

n := 10;

s := 0;

for i:=2 to n do begin

    if A[i-1] < A[i] then begin

        A[i] := A[i] - A[i-1];

        s := s + A[i]

    end

end;

 

n := 10

s := 0

нц для i от 2 до n

    если A[i-1] < A[i] то

        A[i] := A[i] - A[i-1]

        s := s + A[i]

    все

кц

С++

n = 10;

s = 0;

for (i = 2; i <= n; ++i) {

    if (A[i-1] < A[i]) {

        A[i] = A[i] - A[i-1];

        s = s + A[i];

    }

}

 


19
Задание 19 № 15635

Ниже представлен фрагмент программы, обрабатывающей одномерный целочисленный массив с индексами от 0 до 10. Значения элементов равны 5; 1; 6; 7; 8; 8; 7; 7; 6; 9; 5 соответственно, т. е. A[0]=5; A[1]=1 и т. д. Определите значение переменной s после выполнения следующего фрагмента программы.

 

БейсикPython

S = 0

FOR i = 0 TO 9

    S = S + A(i+1) – A(i);

NEXT i

s = 0

for i in range(10):

     s = s + A[i+1] - A[i]

ПаскальАлгоритмический язык

s := 0;

for i:=0 to 9 do begin

    s := s + A[i+1] - A[i]

end;

s := 0

нц для i от 0 до 9

     s := s + A[i+1] - A[i]

     все

кц

Си++

s = 0;

for (i=0; i<10; i++)

      s = s + A[i+1] - A[i];

 

Источник: ЕГЭ — 2018. До­сроч­ная волна. Вариант 1., ЕГЭ — 2018. До­сроч­ная волна. Вариант 2.

20
Задание 19 № 15804

Представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 1 до 10. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 3, 4, 4, 10, 4, 5, 6, 12, 9 (т.е. A[1] = 2, A[2] = 3, .., A[10] = 9). Определите значение переменной s после выполнения фрагмента этой программы (записанного ниже на разных языках программирования).

 

 

БейсикPython

n = 10

s = 0

FOR i = 2 TO n

    IF A(i-1) < A(i) THEN

        T = A(i−1)

        A(i−1) = A(i)

        A(i) = T + 1

        s = s + 1

    END IF

NEXT i

 

n = 10

s = 0

for i in range(2,n+1):

    if A[i-1] < A[i]:

        t = A[i−1]

        A[i−1] = A[i]

        A[i] = t + 1

        s = s + 1

 

 

 

ПаскальАлгоритмический язык

 

n := 10;

s := 0;

for i:=2 to n do begin

    if A[i-1] < A[i] then begin

        t := A[i−1];

        A[i−1] = A[i];

        A[i] := t + 1;

        s := s + 1

    end

end;

 

n := 10

s := 0

нц для i от 2 до n

    если A[i-1] < A[i] то

        t := A[i−1]

        A[i−1] = A[i]

        A[i] := t + 1

        s := s + 1

    все

кц

С++

n = 10;

s = 0;

for (i = 2; i <= n; ++i) {

    if (A[i-1] < A[i]) {

        t = A[i-1];

        A[i-1] = A[i];

        A[i] = t + 1;

        s = s + 1;

    }

}

 


21
Задание 19 № 15831

Представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 1 до 10. Перед началом выполнения данного фрагмента эти элементы массива имели значения 7, 8, 8, 1, 2, 2, 3, 3, 8, 5 (т.е. A[1] = 7, A[2] = 4, …, A[10] = 10). Определите значение переменной s после выполнения фрагмента этой программы (записанного ниже на разных языках программирования).

 

 

БейсикPython

n = 10

s = 0

FOR i = 2 TO n

    IF A(i-1) < A(i) THEN

        T = A(i−1)

        A(i−1) = A(i)

        A(i) = T + 1

        s = s + 1

    END IF

NEXT i

 

n = 10

s = 0

for i in range(2,n):

    if A[i-1] < A[i]:

        t = A[i−1]

        A[i−1] = A[i]

        A[i] = t + 1

        s = s + 1

 

 

 

ПаскальАлгоритмический язык

 

n := 10;

s := 0;

for i:=2 to n do begin

    if A[i-1] < A[i] then begin

        t := A[i−1];

        A[i−1] = A[i];

        A[i] := t + 1;

        s := s + 1

    end

end;

 

n := 10

s := 0

нц для i от 2 до n

    если A[i-1] < A[i] то

        t := A[i−1]

        A[i−1] = A[i]

        A[i] := t + 1

        s := s + 1

    все

кц

С++

n = 10;

s = 0;

for (i = 2; i <= n; ++i) {

    if (A[i-1] < A[i]) {

        t = A[i-1];

        A[i-1] = A[i];

        A[i] = t + 1;

        s = s + 1;

    }

}

 


22
Задание 19 № 15859

В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Значения элементов равны 3, 0, 9, 7, 8, 1, 5, 10, 2, 6, 4 соответственно, т.е. A[0] = 3, A[1] = 0 и т.д.

Определите значение переменной c после выполнения следующего фрагмента этой программы, записанного ниже на пяти языках программирования.

 

БейсикPython

с = 0

FOR i = 1 TO 10

    IF A(i − 1) > A(i) THEN

        c = c + 1

        t = A(i)

        A(i) = A(i − 1)

        A(i − 1) = t

    END IF

NEXT i

c = 0

for i in range(1, 11):

    if A[i − 1] > A[i]:

        c = c + 1

        t = A[i]

        A[i] = A[i − 1]

        A[i − 1] = t

ПаскальАлгоритмический язык

c := 0;

for i:=1 to 10 do

    if A[i − 1] > A[i] then

    begin

        c := c + 1;

        t := A[i];

        A[i] = A[i − 1];

        A[i − 1] = t;

    end;

c := 0

нц для i от 1 до 10

    если A[i − 1] > A[i] то

        c := c + 1

        t := A[i]

        A[i] := A[i − 1]

        A[i − 1] := t

     все

кц

Си++

c = 0;

for (i=1; i<11; i++)

      if (A[i − 1] > A[i])

      {

        c++;

        t = A[i];

        A[i] = A[i − 1];

        A[i − 1] = t;

      }

 

Источник: ЕГЭ — 2018. До­сроч­ная волна. Вариант 2., ЕГЭ — 2018. До­сроч­ная волна. Вариант 1.

23
Задание 19 № 15929

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 4, 3, 6, 6, 6, 6, 1, 3, 2 (т. е. A[0] = 2, A[1] = 4, …, A[9] = 2). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

s = 0

FOR i = 1 TO 9

    IF A(i-1) < A(i) THEN

        A(i) = A(i-1) + 1

        s = s + 1

    END IF

NEXT i

 

s = 0

for i in range(1,n):

    if A[i-1] < A[i]:

        A[i] = A[i-1] + 1

        s = s + 1

 

 

 

ПаскальАлгоритмический язык

 

s := 0;

for i:=1 to n do begin

    if A[i-1] < A[i] then begin

        A[i] = A[i-1] + 1

        s := s + 1

    end

end;

 

s := 0

нц для i от 1 до n

    если A[i-1] < A[i] то

        A[i] = A[i-1] + 1

        s := s + 1

    все

кц

С++

s = 0;

for (i = 1; i <= n; ++i) {

    if (A[i-1] < A[i]) {

        A[i] = A[i-1] + 1

        s = s + 1;

    }

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та 04.05.2018 ИН10501

24
Задание 19 № 15956

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 7, 9, 8, 1, 2, 3, 3, 10, 8, 6 (т. е. A[0] = 7, A[1] = 9, …, A[9] = 6). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

s = 0

FOR i = 1 TO 9

    IF A(i-1) < A(i) THEN

        A(i) = A(i-1) + 1

        s = s + 1

    END IF

NEXT i

 

s = 0

for i in range(1,n):

    if A[i-1] < A[i]:

        A[i] = A[i-1] + 1

        s = s + 1

 

 

 

ПаскальАлгоритмический язык

 

s := 0;

for i:=1 to n do begin

    if A[i-1] < A[i] then begin

        A[i] = A[i-1] + 1

        s := s + 1

    end

end;

 

s := 0

нц для i от 1 до n

    если A[i-1] < A[i] то

        A[i] = A[i-1] + 1

        s := s + 1

    все

кц

С++

s = 0;

for (i = 1; i <= n; ++i) {

    if (A[i-1] < A[i]) {

        A[i] = A[i-1] + 1

        s = s + 1;

    }

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та 04.05.2018 ИН10502

25
Задание 19 № 15987

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 3, 5, 3, 7, 8, 4, 2, 5, 1 (т. е. A[0] = 2, A[1] = 3, …, A[9] = 1). Определите значение переменной b после выполнения фрагмента.

 

 

БейсикPython

b = 0

FOR i = 1 TO 9

    IF A(i-1) < A(i) THEN

        t = A(i)

        A(i) = A(i-1)

        A(i-1) = t

        b = b + 1

    END IF

NEXT i

 

b = 0

for i in range(1,10):

    if A[i-1] < A[i]:

        t = A[i]

        A[i] = A[i-1]

        A[i-1] = t

        b = b + 1

 

 

 

ПаскальАлгоритмический язык

b := 0;

for i:=1 to 9 do begin

    if A[i-1] < A[i] then begin

        t := A[i];

        A[i] := A[i-1];

        A[i-1] := t;

        b := b + 1

    end

end;

 

b := 0

нц для i от 1 до 9

    если A[i-1] < A[i] то

        t := A[i]

        A[i] := A[i-1]

        A[i-1] := t

        b := b + 1

    все

кц

С++

b = 0;

for (i = 1; i <= 9; ++i) {

    if (A[i-1] < A[i]) {

        t = A[i];

        A[i] = A[i-1];

        A[i-1] = t;

        b += 1;

    }

}

 

Источник: ЕГЭ по информатике 28.05.2018. Основная волна.

Пройти тестирование по этим заданиям