СДАМ ГИА






Каталог заданий. Алгоритмы, меняющие элементы массива местами
Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 19 № 7764

В про­грам­ме ис­поль­зу­ет­ся од­но­мер­ный це­ло­чис­лен­ный мас­сив A с ин­дек­са­ми от 0 до 9. Зна­че­ния эле­мен­тов равны 5; 1; 6; 7; 8; 8; 7; 7; 6; 9 соответственно, т.е. A[0] = 5; A[1] = 1 и т.д. Опре­де­ли­те зна­че­ние пе­ре­мен­ной c после вы­пол­не­ния сле­ду­ю­ще­го фраг­мен­та программы, за­пи­сан­но­го ниже на раз­ных язы­ках программирования.

 

БейсикPython

c = 0

FOR i = 1 TO 9

    IF A(i - 1) >= A(i) THEN

        t = A(i)

        A(i) = A(i - 1)

        A(i - 1) = t

    ELSE

        c = c + 1

    ENDIF

NEXT i

c = 0

for i in range(1, 10):

    if A[i - 1] >= A[i]:

        t = A[i]

        A[i] = A[i - 1]

        A[i - 1] = t

    else:

        c = c + 1

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do

    if A[i - 1] >= A[i] then

        begin

            t := A[i];

            A[i] := A[i - 1];

            A[i - 1] := t

        end

    else

        c := c + 1;

c := 0

нц для i от 1 до 9

если A[i - 1] >= A[i] то

    t := A[i]

    A[i] := A[i - 1]

    A[i - 1] := t

иначе

    c := c + 1

все

кц

Си

c = 0;

for (i = 1; i <= 9; i++)

    if (A[i-1] >= A[i])

    {

        t = A[i];

        A[i] = A[i - 1];

        A[i - 1] = t;

    }

    else

        c++;

 


Аналоги к заданию № 7764: 7791 Все

Источник: СтатГрад: Диагностическая работа по ин­фор­ма­ти­ке 26.01.2015 ва­ри­ант ИН10501.

2
Задание 19 № 3355

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

for i : = 0 to 10 do A[i] : = i;

    for i : = 0 to 4 do begin

        k : = A[i];

        A[i] : = A[10-i];

        A[10-i] : = k;

    end;

 

Чему будут равны элементы этого массива?

 

1) 10 9 8 7 6 5 4 3 2 1 0

2) 0 1 2 3 4 5 6 7 8 9 10

3) 0 1 2 3 4 5 4 3 2 1 0

4) 10 9 8 7 6 5 6 7 8 9 10


Аналоги к заданию № 3355: 3386 Все


3
Задание 19 № 3356

В про­грам­ме опи­сан од­но­мер­ный це­ло­чис­лен­ный мас­сив с ин­дек­са­ми от 0 до 10. В при­ве­ден­ном ниже фраг­мен­те про­грам­мы мас­сив сна­ча­ла заполняется, а потом изменяется:

for i : = 0 to 10 do

    A[i] : = i;

for i : = 1 to 11 do

    A[i-1] : = A[11-i];

 

Чему будут равны эле­мен­ты этого массива?

 

1) 10 9 8 7 6 5 4 3 2 1 0

2) 11 10 9 8 7 6 5 4 3 2 1

3) 10 9 8 7 6 5 6 7 8 9 10

4) 11 10 9 8 7 6 7 8 9 10 11

Пояснение · ·

4
Задание 19 № 3362

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

for i:=0 to 10 do A[i]:=i;

for i:=0 to 4 do begin

    k:=A[2*i];

    A[2*i]:=A[2*i+1];

    A[2*i+1]:=k;

end;

 

Чему будут равны элементы этого массива?

 

1) 5 6 7 8 9 0 1 2 3 4 10

2) 10 9 8 7 6 5 4 3 2 1 0

3) 0 1 2 3 4 5 4 3 2 1 0

4) 1 0 3 2 5 4 7 6 9 8 10


5
Задание 19 № 3371

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

for i:=0 to 10 do

    A[i]:=i-1;

for i:=10 downto 1 do

    A[i-1]:=A[i];

 

Чему будут равны элементы этого массива?

 

1) 9 9 9 9 9 9 9 9 9 9 9

2) 0 1 2 3 4 5 6 7 8 9 9

3) 0 1 2 3 4 5 6 7 8 9 10

4) -1 -1 0 1 2 3 4 5 6 7 8


6
Задание 19 № 3382

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

for i:=0 to 10 do A[i]:=i;

for i:=0 to 4 do begin

    k:=A[10-i];

    A[10-i]:=A[i];

    k:=A[i];

end;

 

Чему будут равны элементы этого массива?

 

1) 10 9 8 7 6 5 4 3 2 1 0

2) 0 1 2 3 4 5 6 7 8 9 10

3) 0 1 2 3 4 5 4 3 2 1 0

4) 10 9 8 7 6 5 6 7 8 9 10


7
Задание 19 № 3370

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленная переменная i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

for i:=0 to 10 do A[i]:=i;

for i:=0 to 9 do begin

    A[i]:=A[i+1];

end;

 

Чему будут равны элементы этого массива?

 

1) 10 0 1 2 3 4 5 6 7 8 9

2) 1 2 3 4 5 6 7 8 9 10 10

3) 0 0 1 2 3 4 5 6 7 8 9

4) 1 2 3 4 5 6 7 8 9 10 0


8
Задание 19 № 3376

В программе описан одномерный целочисленный массив с индексами от 0 до 10. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

for i:=0 to 10 do

    A[i]:= i + 1;

for i:=0 to 10 do

    A[i]:= A[10-i];

 

Чему будут равны элементы этого массива?

 

1) 10 9 8 7 6 5 4 3 2 1 0

2) 11 10 9 8 7 6 5 4 3 2 1

3) 11 10 9 8 7 6 7 8 9 10 11

4) 10 9 8 7 6 5 6 7 8 9 10


9
Задание 19 № 3384

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

for i:=0 to 10 do A[i]:=i;

for i:=0 to 4 do begin

    k:=A[i];

    A[i]:=A[i+5];

    A[i+5]:=k;

end;

 

Чему будут равны элементы этого массива?

 

1) 5 6 7 8 9 0 1 2 3 4 10

2) 10 9 8 7 6 5 4 3 2 1 0

3) 0 1 2 3 4 5 4 3 2 1 0

4) 1 0 3 2 5 4 7 6 9 8 10


10
Задание 19 № 3359

В программе описан одномерный целочисленный массив с индексами от 0 до 10. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

for i:=0 to 10 do

    A[i]:= i + 1;

for i:=1 to 10 do

    A[i]:= A[i-1];

 

Как изменяются элементы этого массива?

 

1) все элементы, кроме последнего, сдвигаются на 1 элемент вправо

2) все элементы, кроме первого, сдвигаются на 1 элемент влево

3) все элементы окажутся равны 1

4) все элементы окажутся равны своим индексам


11
Задание 19 № 3381

В программе описан одномерный целочисленный массив с индексами от 0 до 10. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

for i:=0 to 10 do

    A[i]:= i - 1;

for i:=1 to 10 do

    A[i-1]:= A[i];

A[10] := 10;

 

Как изменяются элементы этого массива?

 

1) все элементы, кроме последнего, окажутся равны между собой

2) все элементы окажутся равны своим индексам

3) все элементы, кроме последнего, сдвигаются на один элемент вправо

4) все элементы, кроме последнего, уменьшаются на единицу


12
Задание 19 № 3383

В программе обрабатывается двумерный целочисленный массив A [0..n,0..n]. Первый индекс элемента обозначает номер строки, а второй – номер столбца. Дан фрагмент программы:

 

for i:=0 to n do begin

c:=A[i,n-i];

A[i,n-i]:=A[1,i];

A[1,i]:=c;

end;

 

Что меняет этот фрагмент программы?

 

1) два столбца в таблице

2) строку и столбец в таблице

3) элементы диагонали и строки в таблице

4) элементы диагонали и столбца в таблице


13
Задание 19 № 3387

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

for i : = 0 to 10 do

A[i] : = 10-i;

for i : = 0 to 5 do begin

A[10-i] : = A[5-i];

A[5+i] : = A[i];

end;

 

Чему будут равны элементы этого массива?

 

1) 9 8 7 6 5 10 9 8 7 6 10

2) 10 9 8 7 6 5 6 7 8 9 10

3) 10 9 8 7 6 10 9 8 7 6 10

4) 5 6 7 8 9 10 9 8 7 6 5


14
Задание 19 № 3389

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

for i : = 0 to 10 do

A[i] : = i;

t : = A[0];

for i : = 1 to 10 do

A[i-1] : = A[i];

A[10] : = t;

 

Чему будут равны элементы этого массива?

 

1) 10 10 10 10 10 10 10 10 10 10

2) 1 2 3 4 5 6 7 8 9 10 0

3) 0 0 0 0 0 0 0 0 0 0

4) 1 2 3 4 5 6 7 8 9 10 1


15
Задание 19 № 3392

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

for i : = 0 to 10 do

A[i] : = i;

for i : = 0 to 5 do begin

A[10-i] : = A[9-i];

A[i] : = A[i+1];

end;

 

Чему будут равны элементы этого массива?

 

1) 0 1 2 3 4 5 6 7 8 9 10

2) 0 1 2 3 4 5 6 7 8 9 9

3) 1 2 3 4 5 5 5 6 7 8 9

4) 1 2 3 4 5 6 5 4 3 2 1


16
Задание 19 № 4551

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, записанный на разных языках программирования, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикПаскаль

FOR i=0 TO 10

    A(i)=i-1

NEXT i

FOR i=1 TO 10

    A(i-1)=A(i)

NEXT i

A(10)=10

for i:=0 to 10 do

    A[i]:=i-1;

for i:=1 to 10 do

    A[i-1]:=A[i];

A[10]:=10;

СиАлгоритмический язык

for (i = 0; i <= 10; i++)

    A[i]=i-1;

for (i = 1; i <= 10; i++)

    A[i-1]=A[i];

A[10]=10;

нц для i от 0 до 10

    A[i]:=i-1

кц

нц для i от 1 до 10

    A[i-1]:=A[i]

кц

A[10]:=10

Как изменятся элементы этого массива после выполнения фрагмента программы?

 

1) все элементы, кроме последнего, окажутся равны между собой

2) все элементы окажутся равны своим индексам

3) все элементы, кроме последнего, будут сдвинуты на один элемент вправо

4) все элементы, кроме последнего, уменьшатся на единицу

Источник: Демонстрационная версия ЕГЭ—2013 по информатике.

17
Задание 19 № 5451

В программе описаны одномерный целочисленный массив А с индексами от 0 до 9 и целочисленные переменные i и t. Ниже представлен фрагмент этой программы, записанный на разных языках программирования.

 

БейсикПаскаль

FOR i = 0 TO 9

A(i) = i + 1

NEXT i

t = A(9)

FOR i = 8 TO 0 STEP -1

A(i+1) = A(i)

NEXT i

A(0) = t

for i := 0 to 9 do

    A[i] := i+1;

t := A[9]

for i := 8 downto 0 do

    A[i+1] := A[i];

A[0] := t;

СиАлгоритмический язык

for (i = 0; i <= 9; i++)

    A[i] = i+1;

t = A[9];

for (i = 8; i >= 0; i--)

    A[i+1] = A[i];

A[0] = t;

нц для i от 0 до 9

    A[i] := i+1

кц

t := A[9]

нц для i от 8 до 0 шаг -1

    A[i+1] := A[i]

кц

A[0] := t


Чему окажутся равны элементы этого массива после выполнения фрагмента программы?

 

1) 10 3 4 5 6 7 8 9 10 10

2) 10 10 10 10 10 10 10 10 10 10

3) 10 1 1 1 1 1 1 1 1 1

4) 10 1 2 3 4 5 6 7 8 9


Аналоги к заданию № 5451: 5707 Все

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Сибирь. Ва­ри­ант 1.

18
Задание 19 № 5739

В про­грам­ме опи­сан од­но­мер­ный це­ло­чис­лен­ный мас­сив А с ин­дек­са­ми от 0 до 10. Ниже пред­став­лен фраг­мент этой программы, за­пи­сан­ный на раз­ных язы­ках программирования.

 

 

БейсикПаскаль

FOR i = 0 TO 9

A(i) = i + 1

NEXT i

t = A(0)

FOR i = 0 TO 8

A(i) = A(i+1)

NEXT i

A(9) = t

for i := 0 to 9 do

    A[i] := i+1;

t := A[0]

for i := 0 to 8 do

    A[i] := A[i+1];

A[9] := t;

СиАлгоритмический язык

for (i = 0; i <= 9; i++)

    A[i] = i+1;

t = A[0];

for (i = 0; i <= 8; i++)

    A[i] = A[i+1];

A[9] = t;

нц для i от 0 до 9

    A[i] := i+1

кц

t := A[0]

нц для i от 0 до 8

    A[i] := A[i+1]

кц

A[9] := t

 

Чему ока­жут­ся равны эле­мен­ты этого мас­си­ва после вы­пол­не­ния фраг­мен­та программы?

 

1) 1 2 3 4 5 6 7 8 9 1

2) 1 1 1 1 1 1 1 1 1 1

3) 10 10 10 10 10 10 10 10 10 1

4) 2 3 4 5 6 7 8 9 10 1


Аналоги к заданию № 5739: 5835 Все

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Урал. Ва­ри­ант 3.

19
Задание 19 № 5387

В программе описан одномерный целочисленный массив А с индексами от 0 до 10. Ниже представлен фрагмент этой программы, записанный на разных языках программирования.

 

 

Бейсик

Паскаль

FOR i = 0 ТО 10

    A (i) = i-1

NEXT i

FOR i = 1 TO 10

    A(i-1) = A(i)

NEXT i

A(10) = 10

 

for i = 0 to 10 do

    a[i] := i-1;

for i := 1 to 10 do

    a[i-1] := a[i];

a[10] := 10;

 

 

Си

Алгоритмический язык

for(i = 0; i <= 10; i++)

    a[i] = i-1;

for(i = 1; i <= 10; i++)

    a[i-1] = a[i];

a[10] = 10;

 

 

нц для i от 0 до 10

    A[i] := i-1

кц

нц для i от 1 до 10

    A[i-1] := A[i]

кц

А[10] := 10

 

 

Чему окажутся равны элементы этого массива после выполнения фрагмента программы?

 

1) 9 9 9 9 9 9 9 9 9 9 10

2) 1 2 3 4 5 6 7 8 9 10 10

3) -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 10

4) 0 1 2 3 4 5 6 7 8 9 10


Аналоги к заданию № 5387: 6259 Все

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Дальний Восток. Ва­ри­ант 2.

20
Задание 19 № 6299

В про­грам­ме опи­сан од­но­мер­ный це­ло­чис­лен­ный мас­сив A с ин­дек­са­ми от 0 до 9 и це­ло­чис­лен­ные пе­ре­мен­ные i и t. Ниже пред­став­лен фраг­мент этой программы, за­пи­сан­ный на раз­ных язы­ках программирования.

 

БейсикПаскаль

FOR i = 0 TO 9

    A(i) = i+1

NEXT i

t = A(0)

FOR i = 1 TO 9

    A(i-1) = A(i)

NEXT i

A(9) = t

for i := 0 to 9 do

    A[i] := i+1;

t := A[0];

for i := 1 to 9 do

    A[i-1] := A[i];

A[9] := t;

СиАлгоритмический язык

for (i = 0; i <= 9; i++)

    A[i] = i+1;

t = A[0];

for (i = 1; i <= 9; i++)

    A[i-1] = A[i];

A[9] = t;

нц для i от 0 до 9

    A[i] := i+1

кц

t := A[0]

нц для i от 1 до 9

    A[i-1] := A[i]

кц

A[9] := t

кц

 

Чему ока­жут­ся равны эле­мен­ты этого мас­си­ва после вы­пол­не­ния фраг­мен­та программы?

 

1) 1 2 3 4 5 6 7 8 9 1

2) 1 1 1 1 1 1 1 1 1 1

3) 10 10 10 10 10 10 10 10 10 1

4) 2 3 4 5 6 7 8 9 10 1

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 502.

21
Задание 19 № 6331

В про­грам­ме опи­сан од­но­мер­ный це­ло­чис­лен­ный мас­сив A с ин­дек­са­ми от 0 до 10 и це­ло­чис­лен­ные пе­ре­мен­ные i и t. Ниже пред­став­лен фраг­мент этой программы, за­пи­сан­ный на раз­ных язы­ках программирования.

 

БейсикПаскаль

FOR i = 0 TO 10

    A(i) = i

NEXT i

t = A(10)

FOR i = 10 TO 1 STEP -1

    A(i) = A(i-1)

NEXT i

A(0) = t

for i := 0 to 10 do

    A[i] := i;

t := A[10];

for i := 10 downto 1 do

    A[i] := A[i-1];

A[0] := t;

СиАлгоритмический язык

for (i = 0; i <= 10; i++)

     A[i] = i;

t = A[10];

for (i = 10; i >= 1; i--)

    A[i] = A[i-1];

A[0] = t;

нц для i от 0 до 10

    A[i] := i

кц

t := A[10]

нц для i от 10 до 1 шаг -1

    A[i] := A[i-1]

кц

A[0] := t

кц

 

Чему ока­жут­ся равны эле­мен­ты этого мас­си­ва после вы­пол­не­ния фраг­мен­та программы?

 

1) 10 10 10 10 10 10 10 10 10 10 10

2) 10 0 1 2 3 4 5 6 7 8 9

3) 10 0 0 0 0 0 0 0 0 0 0

4) 10 2 3 4 5 6 7 8 9 10 10

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 601.

22
Задание 19 № 6416

В про­грам­ме опи­сан од­но­мер­ный це­ло­чис­лен­ный мас­сив A с ин­дек­са­ми от 0 до 10 и це­ло­чис­лен­ные пе­ре­мен­ные i и t. Ниже пред­став­лен фраг­мент этой программы, за­пи­сан­ный на раз­ных язы­ках программирования.

 

БейсикПаскаль

FOR i = 0 TO 10

    A(i) = i-1

NEXT i

FOR i = 0 TO 9

    A(i) = A(i+1)

NEXT i

A(10) = 10

for i := 0 to 10 do

    A[i] := i-1;

for i := 0 to 9 do

    A[i] := A[i+1];

A[10] := 10;

СиАлгоритмический язык

for (i = 0; i <= 10; i++)

     A[i] = i-1;

for (i = 0; i <= 9; i++)

    A[i] = A[i+1];

A[10] = 10;

нц для i от 0 до 10

    A[i] := i-1

кц

нц для i от 0 до 9

    A[i] := A[i+1]

кц

A[10] := 10

 

Чему ока­жут­ся равны эле­мен­ты этого мас­си­ва после вы­пол­не­ния фраг­мен­та программы?

 

1) 9 9 9 9 9 9 9 9 9 9 10

2) 1 2 3 4 5 6 7 8 9 10 10

3) –1 –1 –1 –1 –1 –1 –1 –1 –1 –1 10

4) 0 1 2 3 4 5 6 7 8 9 10

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 602.

23
Задание 19 № 11355

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 1, 2, 5, 8, 9, 3, 4, 0, 7, 6 соответственно, т. е. A[0] = 1, A[1] = 2 и т. д.

Определите значение переменной j после выполнения следующего фрагмента программы (записанного ниже на пяти языках программирования).

 

БейсикPython

j = 5

WHILE A(j) < A(j-1)

    t = A(j)

    A(j) = A(j-1)

    A(j-1) = t

    j = j - 1

WEND

j = 5

while A[j] < A[j-1]:

    A[j],A[j-1]=A[j-1],A[j]

    j -= 1

ПаскальАлгоритмический язык

j := 5;

while A[j] < A[j-1] do

    begin

        t := A[j];

        A[j] := A[j-1];

        A[j-1] := t;

        j := j - 1;

    end;

j := 5

нц пока A[j] < A[j-1]

    t := A[j]

    A[j] := A[j-1]

    A[j-1] := t

    j := j - 1

кц

Си

j = 5;

while (A[j] < A[j-1])

    {

        t = A[j];

        A[j] = A[j-1];

        A[j-1] = t;

        j -= 1;

    }

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2017 по информатике.

24
Задание 19 № 13365

В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент этой программы.

 

БейсикPython

s = 0

n = 10

FOR i = 0 TO n-1

    s = s+A(i)-A(i+1)

NEXT i

s = 0

n = 10

for i in range(n):

    s = s + A[i] – A[i+1]

ПаскальАлгоритмический язык

s := 0;

n := 10;

for i:=0 to n-1 do begin

  s := s + A[i] - A[i+1];

end;

s := 0

n := 10

нц для i от 0 до n-1

  s := s + A[i] - A[i+1]

кц

Си

s = 0;

n = 10;

for (i = 0; i < n; i++)

  s = s + A[i] - A[i+1];

 

 

В начале выполнения этого фрагмента в массиве находились числа 27, 17, 7, 0, 7, 17, 27, 17, 10, 7, 0, т.е. A[0] = 27, A[1] = 17 и т. д. Чему будет равно значение переменной s после выполнения данного фрагмента программы?

Источник: ЕГЭ — 2017. До­сроч­ная волна по информатике

25
Задание 19 № 13415

В программе используется фрагмент одномерного целочисленного массива A с индексами от 1 до 10. Значения элементов равны 6, 7, 3, 8, 4, 1, 2, 0, 9, 5 соответственно, т. е. A[1] = 6, A[2] = 7 и т. д. Определите значение переменной s после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

s = 0

n = 10

FOR i = 3 TO n

    s = s+A(i)-A(i-2)

NEXT i

s = 0

n = 10

for i in range(3,n+1):

    s = s + A[i] – A[i-2]

ПаскальАлгоритмический язык

s := 0;

n := 10;

for i:=3 to n do begin

  s := s + A[i] - A[i-2];

end;

s := 0

n := 10

нц для i от 3 до n

  s := s + A[i] - A[i-2]

кц

Си

s = 0;

n = 10;

for (i = 3; i <= n; i++)

  s = s + A[i] - A[i-2];

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10303

26
Задание 19 № 13468

В программе используется фрагмент одномерного целочисленного массив A с индексами от 1 до 10. Значения элементов равны 3, 14, 15, 92, 6, 2, 7, 18, 28, 17 соответственно, т. е. A[1] = 3, A[2] = 14 и т. д.

Определите значение переменной s после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

s = 0

n = 10

FOR i = 3 TO n

    s = s+A(i)-A(i-2)

NEXT i

s = 0

n = 10

for i in range(2,n):

    s = s + A[i] – A[i-2]

ПаскальАлгоритмический язык

s := 0;

n := 10;

for i:=3 to n do begin

  s := s + A[i] - A[i-2];

end;

s := 0

n := 10

нц для i от 3 до n

  s := s + A[i] - A[i-2]

кц

Си

s = 0;

n = 10;

for (i = 3; i <= n; i++)

  s = s + A[i] - A[i-2];

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10304

27
Задание 19 № 13495

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 1, 2, 18, 8, 14, 9, 23, 7, 51, 99 соответственно, то есть A[0] = 1, A[1] = 2 и т. д. Определите значение переменной t после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

БейсикPython

i = 0: j = 9

WHILE A(i) < 10

    i = i + 1

WEND

WHILE A(j) > 10

    j = j - 1

WEND

t = A(i) - A(j)

i = 0

j = 9

while A[i] < 10 :

     i += 1

while A[j] > 10 :

     j -= 1

t = A[i] - A[j]

ПаскальАлгоритмический язык

i = 0; j = 9;

while A[i] < 10 do

  i := i + 1;

while A[j] > 10 do

  j := j - 1;

t := A[i] - A[j];

i := 0

j := 9

нц пока A[i] < 10

   i := i + 1

кц

нц пока A[j] > 10

  j :=j - 1

кц

t := A[i] - A[j]

Си

i = 0;

j = 9;

while (A[i] < 10)

  i += 1;

while (A[j] > 10)

  j -= 1;

t = A[i] - A[j];

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10203

28
Задание 19 № 13522

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 5, 28, 8, 14, 9, 23, 6, 18, 51, 99 соответственно, то есть A[0] = 5, A[1] = 28 и т. д. Определите значение переменной t после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

БейсикPython

i = 0: j = 9

WHILE A(i) < 10

    i = i + 1

WEND

WHILE A(j) > 10

    j = j - 1

WEND

t = A(i) - A(j)

i = 0

j = 9

while A[i] < 10 :

     i += 1

while A[j] > 10 :

     j -= 1

t = A[i] - A[j]

ПаскальАлгоритмический язык

i = 0; j = 9;

while A[i] < 10 do

  i := i + 1;

while A[j] > 10 do

  j := j - 1;

t := A[i] - A[j];

i := 0

j := 9

нц пока A[i] < 10

   i := i + 1

кц

нц пока A[j] > 10

  j :=j - 1

кц

t := A[i] - A[j]

Си

i = 0;

j = 9;

while (A[i] < 10)

  i += 1;

while (A[j] > 10)

  j -= 1;

t = A[i] - A[j];

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10204

29
Задание 19 № 13549

В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Значения элементов равны 4, 3, 16, 24, 35, 18, 4, 72, 10, 99, 44 соответственно, т. е. A[0] = 4, A[1] = 3 и т. д.

Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на пяти языках программирования.

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) MOD 10 = A(0) THEN

      c = c + 1

      t = A(i+1)

      A(i+1) = A(i)

      A(i) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i]%10 == A[0]:

      c = c + 1

      t = A[i+1]

     A[i+1] = A[i]

     A[i] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do begin

  if A[i] mod 10 = A[0] then

  begin

      c := c + 1;

      t := A[i+1];

      A[i+1] := A[i];

      A[i] := t;

  end;

end;

c := 0

нц для i от 1 до 9

  если mod(A[i],10) = A[0] то

      c := c + 1

      t := A[i+1]

      A[i+1] := A[i]

      A[i] := t

  все

кц

Си

c = 0;

for (i = 1; i < 10; i++) {

  if (A[i]%10 == A[0]) {

      c++;

      t = A[i+1];

      A[i+1] = A[i];

      A[i] = t;

  }

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10103

30
Задание 19 № 13576

В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Значения элементов равны 8, 3, 16, 24, 35, 18, 4, 72, 8, 99, 44 соответственно, т. е. A[0] = 8, A[1] = 3 и т. д.

Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на пяти языках программирования.

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) MOD 10 = A(0) THEN

    c = c + 1

    t = A(i+1)

    A(i+1) = A(i)

    A(i) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i]%10 == A[0]:

    c = c + 1

    t = A[i+1]

    A[i+1] = A[i]

    A[i] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do begin

if A[i] mod 10 = A[0] then

  begin

    c := c + 1;

    t := A[i+1];

    A[i+1] := A[i];

    A[i] := t;

  end;

end;

c := 0

нц для i от 1 до 9

  если mod(A[i],10) = A[0] то

    c := c + 1

    t := A[i+1]

    A[i+1] := A[i]

    A[i] := t

  все

кц

Си

c = 0;

for (i = 1; i < 10; i++) {

  if (A[i]%10 == A[0]) {

    c++;

    t = A[i+1];

    A[i+1] = A[i];

    A[i] = t;

  }

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10104

31
Задание 19 № 13603

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

 

БейсикPython

s = 0

n = 10

FOR i = 2 TO n

    s=s+A(i)*A(i)-A(i-1)*A(i-1)

NEXT i

s=0

n=10

for i in range(2,n+1):

    s=s + A[i]*A[i]-A[i-1]*A[i-1]

ПаскальАлгоритмический язык

s:=0;

n:=10;

for i:= 2 to n do begin

    s:=s+A[i]*A[i]-A[i-1]*A[i-1];

end;

s:=0

n:=10

нц для i от 2 до n

    s:=s + A[i]*A[i]-A[i-1]*A[i-1];

кц

Си

s = 0;

n = 10;

for (i = 2; i <= n; i++)

    s=s + A[i]*A[i]-A[i-1]*A[i-1];

 

 

В начале выполнения этого фрагмента в массиве находились числа 1, 12, 23, 34, 45, 56, 67, 78, 89, 90, т. е. A[1]=1, A[2]=12 и т.д. Чему будет равно значение переменной s после выполнения данного фрагмента?

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 12 мая 2017 года Вариант ИН10503

32
Задание 19 № 13630

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

 

БейсикPython

s = 0

n = 10

FOR i = 2 TO n

    s=s+A(i)*A(i)-A(i-1)*A(i-1)

NEXT i

s=0

n=10

for i in range(2,n+1):

    s=s + A[i]*A[i]-A[i-1]*A[i-1]

ПаскальАлгоритмический язык

s:=0;

n:=10;

for i:= 2 to n do begin

    s:=s+A[i]*A[i]-A[i-1]*A[i-1];

end;

s:=0

n:=10

нц для i от 2 до n

    s:=s + A[i]*A[i]-A[i-1]*A[i-1];

кц

Си

s = 0;

n = 10;

for (i = 2; i <= n; i++)

    s=s + A[i]*A[i]-A[i-1]*A[i-1];

 

 

В начале выполнения этого фрагмента в массиве находились числа 1, 11, 22, 33, 44, 55, 66, 77, 88, 99, т. е. A[1]=1, A[2]=11 и т.д. Чему будет равно значение переменной s после выполнения данного фрагмента?

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 12 мая 2017 года Вариант ИН10504

33
Задание 19 № 13746

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 3, 0, 4, 6, 5, 1, 8, 2, 9, 7 соответственно, т. е. A[0] = 3, A[1] = 0 и т. д. Определите значение переменной c после выполнения следующего фрагмента этой программы (записанного ниже на разных языках программирования)

 

БейсикPython

c = 0

FOR i = 1 TO 9

    IF A(i-1) > A(i) THEN

       c = c + 1

       t = A(i)

       A(i) = A(i-1)

       A(i-1) = t

    END IF

NEXT i

c = 0

for i in range(1,10):

    if A[i-1] > A[i]:

       c = c + 1

       t = A[i]

       A[i] = A[i-1]

       A[i-1] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do

    if A[i-1] > A[i] then

    begin

        c := c + 1;

        t := A[i];

        A[i] := A[i-1];

         A[i-1] := t;

    end;

c := 0

нц для i от 1 до 9

     если A[i-1] > A[i] то

       c := c + 1

       t := A[i]

       A[i] := A[i-1]

       A[i-1] := t

     все

кц

Си++

c = 0;

for (int i = 1; i < 10; i++)

     if (A[i-1] > A[i]){

        c++;

        t = A[i];

        A[i] = A[i-1];

        A[i-1] = t;

    }

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2018 по информатике.

34
Задание 19 № 14234

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A; в представленном фрагменте обрабатываются элементы массива с индексами от 1 до 10.

 

БейсикPython

n = 10

d = 6

FOR j = 1 TO d

  s = A(1)

  FOR i = 1 TO n-1

    A(i) = A(i+1)

  NEXT i

  A(10) = s

NEXT j

n = 10

d = 6

for j in range(1,d+1):

  s = A[1]

  for i in range(1,n):

    A[i] = A[i+1]

  A[10] = s

ПаскальАлгоритмический язык

n := 10;

d := 6;

for j:=1 to d do begin

  s := A[1];

  for i:=1 to n-1 do begin

    A[i] := A[i+1];

  end;

  A[10] := s;

end;

n := 10

d := 6

нц для j от 1 до d

  s := A[1]

  нц для i от 1 до n-1

    A[i] := A[i+1]

  кц

  A[10]:= s

кц

Си++

n = 10;

d = 6;

for (j = 1; j <= d; j++) {

  s = A[1];

  for (i = 1; i <= n-1; i++) {

    A[i] = A[i+1];

  }

  A[10] = s;

}

 

Перед началом выполнения программы эти элементы массива имели значения 0, 1, 2, 3, 4, 5, 4, 3, 2, 1 (то есть A[1] = 0; A[2] = 1; …; A[10] = 1).

Значение какого из этих элементов массива будет наибольшим после выполнения фрагмента программы? В ответе укажите индекс элемента – число от 1 до 10.

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та 14.09.2017 ИН10103

35
Задание 19 № 14278

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A; в представленном фрагменте обрабатываются элементы массива с индексами от 1 до 10.

 

БейсикPython

n = 10

d = 6

FOR j = 1 TO d

  s = A(1)

  FOR i = 1 TO n-1

    A(i) = A(i+1)

  NEXT i

  A(10) = s

NEXT j

n = 10

d = 6

for j in range(1,d+1):

  s = A[1]

  for i in range(1,n):

    A[i] = A[i+1]

  A[10] = s

ПаскальАлгоритмический язык

n := 10;

d := 6;

for j:=1 to d do begin

  s := A[1];

  for i:=1 to n-1 do begin

    A[i] := A[i+1];

  end;

  A[10] := s;

end;

n := 10

d := 6

нц для j от 1 до d

  s := A[1]

  нц для i от 1 до n-1

    A[i] := A[i+1]

  кц

  A[10]:= s

кц

Си++

n = 10;

d = 6;

for (j = 1; j <= d; j++) {

  s = A[1];

  for (i = 1; i <= n-1; i++) {

    A[i] = A[i+1];

  }

  A[10] = s;

}

 

 

Перед началом выполнения программы эти элементы массива имели значения 0, 1, 4, 9, 6, 5, 6, 8, 4, 1 (т.е. A[1] = 0; A[2] = 1; …; A[10] = 1).

Значение какого из этих элементов массива будет наибольшим после выполнения фрагмента программы? В ответе укажите индекс элемента – число от 1 до 10.

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та 14.09.2017 ИН10104

Пройти тестирование по этим заданиям



     О проекте · Редакция

© Гущин Д. Д., 2011—2017


СПб ГУТ! С! Ф! У!