СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
Информатика
Cайты, меню, вход, новости


Варианты заданий
Версия для печати и копирования в MS Word
1
Задание 19 № 9700

В программе используется одномерный целочисленный массив A с индексами от 1 до 10. Значения элементов равны 7; 3; 4; 8; 6; 9; 5; 2; 0; 1 соответственно, т. е. A[1] = 7; A[2] = 3 и т. д.

Определите значение переменной j после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

БейсикПаскаль

j = 0

FOR k = 2 TO 10

  IF A(k) > A(1) THEN

    A(1) = A(k)

    j = j + k

  END IF

NEXT k

j := 0;

for k := 2 to 10 do

begin

  if A[k] > A[1] then

  begin

    A[1] := A[k];

    j := j + k

  end

end;

Си++Алгоритмический язык

j = 0;

for (k = 2; k<= 10; k++) {

  if (A[k] > A[1]) {

    A[1] = A[k];

    j = j + k;

  }

}

k := 0

нц для k от 2 до 10

  если A[k] > A[1] то

    A[1] := A[k]

    j := j+k

  все

кц

Python

j = 0

for k in range(2, 11):

    if A[k] > A[1]:

        A[1] = A[k]

        j += k

 


Аналоги к заданию № 9654: 9700 Все