СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
Информатика
Cайты, меню, вход, новости


Задания
Версия для печати и копирования в MS Word
Задание 19 № 3394

Значения двух массивов A и B с индексами от 1 до 100 задаются при помощи следующего фрагмента программы:

 

 

БейсикPython

 

FOR i = 1 TO 100

    A(i) = i*i

NEXT i

FOR i = 1 TO 100

    B(i) = A(i)-100

NEXT i

 

 

for i in range(1, 101):

    A[i] = i*i

for i in range(1, 101):

    B[i] = A[i]-100

ПаскальАлгоритмический язык

 

for i : = 1 to 100

    do A[i] : = i*i;

for i : = 1 to 100 do begin

    B[i] : = A[i]-100;

end;

 

нц для i от 1 до 100

    A[i] : = i*i

кц

нц для i от 1 до 100

    B[i] : = A[i]-100

кц

 

Си++

 

for (i = 1; i <= 100; i++) {

    A[i] = i*i;

}

for (i = 1; i <= 100; i++) {

    B[i] = A[i]-100;

}

 

 

Сколько положительных значений будет в массиве B?

Решение.

Первый цикл, заполняем массив A:

i=1: a[1]=1,

i=2: a[2]=4,

i=3: a[3]=9

...

Значения элементов равны квадратам соответствующих индексов.

 

Рассмотрим, как задаются элементы массива В:

 

b[i] : = a[i]-100. Если a[i] > 100, то b[i] положителен, что соответствует идексу i > 10. Следовательно, в массиве B будет 100 - 10 = 90 положительных элементов. Иными словами, массив A содержит квадраты первых ста чисел, из которых первые десять квадратов не больше ста.

Спрятать решение · · Видеокурс ·
Измайлова Татьяна 15.01.2016 16:18

Здравствуйте!

Подскажите, пожалуйста, 0 это положительное число или отрицательное? И на какой источник информации вы опираетесь?

Борис Синицын

Ноль является ни положительным, ни отрицательным числом.