СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 19 № 3358

Зна­че­ния двух мас­си­вов A[1..100] и B[1..100] за­да­ют­ся с по­мо­щью сле­ду­ю­ще­го фраг­мен­та про­грам­мы:

 

 

Бей­сикPython

 

FOR n = 1 TO 100

    A(n) = n - 10

NEXT n

FOR n = 1 TO 100

    B(n) = A(n)*n;

NEXT n

 

 

for n in range(1, 101):

    A[n] = n - 10

for n in range(1, 101):

    B[n] = A[n]*n

Пас­кальАл­го­рит­ми­че­ский язык

 

for n : = 1 to 100

    do A[n] : = n - 10;

for n : = 1 to 100 do begin

    B[n]:= A[n]*n;

end;

 

нц для n от 1 до 100

    A[n] : = n - 10

кц

нц для n от 1 до 100

    B[n]:=A[n]*n

кц

 

Си++

 

for (n = 1; n <= 100; n++) {

    A[n] = n - 10;

}

for (n = 1; n <= 100; n++) {

    B[n] = A[n]*n;

}

 

 

Сколь­ко эле­мен­тов мас­си­ва B будут иметь по­ло­жи­тель­ные зна­че­ния?

 

При­ме­ча­ние. Нуль яв­ля­ет­ся ни по­ло­жи­тель­ным, ни от­ри­ца­тель­ным чис­лом.

Ре­ше­ние.

Мас­сив A:

n=1: a[1]=1-10=-9,

n=2: a[2]=2-10=-8,

n=3: a[3]=-7,

...

n=9: a[9]=-1,

n=10: a[10]=0,

...

n=100: a[100]=90.

 

Эле­мен­ты мас­си­ва B имеют такой же знак, как и со­от­вет­ству­ю­щие эле­мен­ты мас­си­ва A, по­сколь­ку n при­ни­ма­ет толь­ко по­ло­жи­тель­ные зна­че­ния и B[n]=A[n]*n. В мас­си­ве A 100-10=90 по­ло­жи­тель­ных зна­че­ний, сле­до­ва­тель­но, и в B их тоже 90.

 

При­ме­ча­ние. Нуль яв­ля­ет­ся ни по­ло­жи­тель­ным, ни от­ри­ца­тель­ным чис­лом.


Аналоги к заданию № 3358: 3360 Все