СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
Информатика
Cайты, меню, вход, новости


Задания
Версия для печати и копирования в MS Word
Задание 19 № 3360

Значения элементов двух массивов A[1..100] и B[1..100] задаются с помощью следующего фрагмента программы:

 

 

БейсикPython

 

FOR n = 1 TO 100

    A(n) = n - 50

NEXT n

FOR n = 1 TO 100

    B(101-n) = A(n)*A(n);

NEXT n

 

 

for n in range(1, 101):

    A[n] = n - 50

for n in range(1, 101):

    B[101-n] = A[n]*A[n]

ПаскальАлгоритмический язык

 

for n : = 1 to 100

    do A[n] : = n - 50;

for n : = 1 to 100 do begin

    B[101-n]:= A[n]*A[n];

end;

 

нц для n от 1 до 100

    A[n] : = n - 50

кц

нц для n от 1 до 100

    B[101-n]:=A[n]*A[n]

кц

 

Си++

 

for (n = 1; n <= 100; n++) {

    A[n] = n - 50;

}

for (n = 1; n <= 100; n++) {

    B[101-n] = A[n]*A[n];

}

 

 

Какой элемент массива B будет наименьшим?

 

1) B[1]

2) B[50]

3) B[51]

4) B[100]

Решение.

Элемент массива B будет наименьшим, когда произведение A[n]*A[n] = 0.

Найдём n. A[n] = n - 50 = 0, откуда n = 50. Следовательно, наименьший элемент массива B имеет номер

101 - n = 101 - 50 = 51.

 

Правильный ответ указан под номером 3.


Аналоги к заданию № 3358: 3360 Все

Спрятать решение · Прототип задания · · Видеокурс ·
Ольга 13.02.2013 18:43

Поясните, пожалуйста, почему минимальный элемент массива не A[50]=A[51]=0 ? Прогоняла программу вручную несколько раз - не получается.

Служба поддержки

Запросите консультацию эксперта.