информатика
Информатика
Русский язык
Английский язык
Немецкий язык
Французcкий язык
Испанский язык
Физика
Химия
Биология
География
Обществознание
Литература
История
сайты - меню - вход - новости




Каталог заданий.
Алгоритмы, меняющие элементы массива местами
Сортировка:
Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задания Д 19 № 3355

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 0 TO 4

    k = A(i)

   A(i) = A(10 - i)

   A(10 - i) = k

NEXT i

for i in range(0, 11):

    A[i] = i

for i in range(0, 5):

    k = A[i]

    A[i] = A[10 - i]

    A[10 - i] = k

ПаскальАлгоритмический язык

for i : = 0 to 10 do A[i] : = i;

for i : = 0 to 4 do begin

    k : = A[i];

    A[i] : = A[10-i];

    A[10-i] : = k;

end;

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 0 до 4

        k : = A[i];

        A[i] : = A[10-i];

        A[10-i] : = k;

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 0; i <= 4; i++) {

    k = A[i];

    A[i] = A[10-i];

    A[10-i] = k;

}

 

 

Чему будут равны элементы этого массива?

 

1) 10 9 8 7 6 5 4 3 2 1 0

2) 0 1 2 3 4 5 6 7 8 9 10

3) 0 1 2 3 4 5 4 3 2 1 0

4) 10 9 8 7 6 5 6 7 8 9 10


Аналоги к заданию № 3355: 3386 Все


2
Задания Д 19 № 3356

В программе описан одномерный целочисленный массив с индексами от 0 до 10. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 1 TO 11

    A(i - 1) = A(11 - i)

NEXT i

for i in range(0, 11):

    A[i] = i

for i in range(1, 12):

    A[i - 1] = A[11 - i]

ПаскальАлгоритмический язык

for i : = 0 to 10 do

    A[i] : = i;

for i : = 1 to 11 do

    A[i-1] : = A[11-i];

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 1 до 11

        A[i-1] := A[11-i]

кц

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 1; i <= 11; i++) {

     A[i-1] = A[11-i];

}

 

Чему будут равны элементы этого массива?

 

1) 10 9 8 7 6 5 4 3 2 1 0

2) 11 10 9 8 7 6 5 4 3 2 1

3) 10 9 8 7 6 5 6 7 8 9 10

4) 11 10 9 8 7 6 7 8 9 10 11

Пояснение · ·

3
Задания Д 19 № 3362

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 0 TO 4

    k = A(2*i)

    A(2*i) = A(2*i+1)

    A(2*i+1) = k

NEXT i

 

for i in range(0, 11):

    A[i] = i

for i in range(0, 5):

    k = A[2*i]

    A[2*i] = A[2*i+1]

    A[2*i+1] = k

ПаскальАлгоритмический язык

for i : = 0 to 10 do A[i] : = i;

for i : = 0 to 4 do begin

    k : = A[2*i];

    A[2*i] : = A[2*i+1];

    A[2*i+1] : = k;

end;

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 0 до 4

    k : = A[2*i];

        A[2*i] : = A[2*i+1];

        A[2*i+1] : = k;

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 0; i <= 4; i++) {

    k = A[2*i];

    A[2*i] = A[2*i+1];

    A[2*i+1] = k;

}

 

 

Чему будут равны элементы этого массива?

 

1) 5 6 7 8 9 0 1 2 3 4 10

2) 10 9 8 7 6 5 4 3 2 1 0

3) 0 1 2 3 4 5 4 3 2 1 0

4) 1 0 3 2 5 4 7 6 9 8 10


4
Задания Д 19 № 3371

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i-1

NEXT i

FOR i = 10 TO 1 STEP -1

    A(i-1) = A(i)

NEXT i

 

for i in range(0, 11):

    A[i] = i-1

for i in range(10, 0, -1):

    A[i-1] = A[i]

ПаскальАлгоритмический язык

for i:=0 to 10 do

    A[i]:=i-1;

for i:=10 downto 1 do

    A[i-1]:=A[i];

нц для i от 0 до 10

    A[i] : = i-1

кц

нц для i от 10 до 1 шаг -1

    A[i-1]: = A[i];

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i-1;

}

for (i = 10; i <= 1; i--) {

    A[i-1] = A[i];

}

 

 

Чему будут равны элементы этого массива?

 

1) 9 9 9 9 9 9 9 9 9 9 9

2) 0 1 2 3 4 5 6 7 8 9 9

3) 0 1 2 3 4 5 6 7 8 9 10

4) -1 -1 0 1 2 3 4 5 6 7 8


5
Задания Д 19 № 3382

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 0 TO 4

    k = A(10-i)

    A(10-i) = A(i)

    k = A(i)

NEXT i

 

for i in range(0, 11):

    A[i] = i

for i in range(0, 5):

    k = A[10-i]

    A[10-i] = A[i]

    k = A[i]

ПаскальАлгоритмический язык

for i : = 0 to 10 do A[i] : = i;

for i : = 0 to 4 do begin

    k : = A[10-i];

    A[10-i] : = A[i];

    k : = A[i];

end;

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 0 до 4

    k : = A[10-i];

        A[10-i] : = A[i];

    k : = A[i];

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 0; i <= 4; i++) {

    k = A[10-i];

    A[10-i] = A[i];

    k = A[i];

}

 

 

Чему будут равны элементы этого массива?

 

1) 10 9 8 7 6 5 4 3 2 1 0

2) 0 1 2 3 4 5 6 7 8 9 10

3) 0 1 2 3 4 5 4 3 2 1 0

4) 10 9 8 7 6 5 6 7 8 9 10


6
Задания Д 19 № 3370

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленная переменная i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 0 TO 9

    A(i) = A(i+1)

NEXT i

 

for i in range(0, 11):

    A[i] = i

for i in range(0, 10):

    A[i] = A[i+1]

ПаскальАлгоритмический язык

for i:=0 to 10 do

    A[i]:=i;

for i:=0 to 9 do

    A[i]:=A[i+1];

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 0 до 9

    A[i]: = A[i+1];

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 0; i <= 9; i++) {

    A[i] = A[i+1];

}

 

 

Чему будут равны элементы этого массива?

 

1) 10 0 1 2 3 4 5 6 7 8 9

2) 1 2 3 4 5 6 7 8 9 10 10

3) 0 0 1 2 3 4 5 6 7 8 9

4) 1 2 3 4 5 6 7 8 9 10 0


7
Задания Д 19 № 3376

В программе описан одномерный целочисленный массив с индексами от 0 до 10. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i+1

NEXT i

FOR i = 0 TO 10

    A(i) = A(10-i)

NEXT i

 

for i in range(0, 11):

    A[i] = i+1

for i in range(0, 11):

    A[i] = A[10-i]

ПаскальАлгоритмический язык

for i:=0 to 10 do

    A[i]:=i+1;

for i:=0 to 10 do

    A[i]:=A[10-i];

нц для i от 0 до 10

    A[i] : = i+1

кц

нц для i от 0 до 10

    A[i]: = A[10-i];

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i+1;

}

for (i = 0; i <= 10; i++) {

    A[i] = A[10-i];

}

 

 

Чему будут равны элементы этого массива?

 

1) 10 9 8 7 6 5 4 3 2 1 0

2) 11 10 9 8 7 6 5 4 3 2 1

3) 11 10 9 8 7 6 7 8 9 10 11

4) 10 9 8 7 6 5 6 7 8 9 10


8
Задания Д 19 № 3384

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 0 TO 4

    k = A(i)

    A(i) = A(i+5)

    A(i+5) = k

NEXT i

 

for i in range(0, 11):

    A[i] = i

for i in range(0, 5):

    k = A[i]

    A[i] = A[i+5]

    A[i+5] = k

ПаскальАлгоритмический язык

for i : = 0 to 10 do A[i] : = i;

for i : = 0 to 4 do begin

    k : = A[i];

    A[i] : = A[i+5];

    A[i+5]: = k;

end;

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 0 до 4

    k : = A[i];

    A[i] : = A[i+5];

    A[i+5]: = k;

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 0; i <= 4; i++) {

    k = A[i];

    A[i] = A[i+5];

    A[i+5] = k;

}

 

 

Чему будут равны элементы этого массива?

 

1) 5 6 7 8 9 0 1 2 3 4 10

2) 10 9 8 7 6 5 4 3 2 1 0

3) 0 1 2 3 4 5 4 3 2 1 0

4) 1 0 3 2 5 4 7 6 9 8 10


9
Задания Д 19 № 3359

В программе описан одномерный целочисленный массив с индексами от 0 до 10. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i+1

NEXT i

FOR i = 1 TO 10

    A(i) = A(i-1)

NEXT i

 

for i in range(0, 11):

    A[i] = i+1

for i in range(1, 11):

    A[i] = A[i-1]

ПаскальАлгоритмический язык

for i:=0 to 10 do

    A[i]:=i+1;

for i:=1 to 10 do

    A[i]:=A[i-1];

нц для i от 0 до 10

    A[i] : = i+1

кц

нц для i от 1 до 10

    A[i]: = A[i-1];

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i+1;

}

for (i = 1; i <= 10; i++) {

    A[i] = A[i-1];

}

 

 

Как изменяются элементы этого массива?

 

1) все элементы, кроме последнего, сдвигаются на 1 элемент вправо

2) все элементы, кроме первого, сдвигаются на 1 элемент влево

3) все элементы окажутся равны 1

4) все элементы окажутся равны своим индексам


10
Задания Д 19 № 3381

В программе описан одномерный целочисленный массив с индексами от 0 до 10. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i-1

NEXT i

FOR i = 1 TO 10

    A(i-1) = A(i)

NEXT i

A(10) = 10

 

for i in range(0, 11):

    A[i] = i-1

for i in range(1, 11):

    A[i-1] = A[i]

A[10] = 10

ПаскальАлгоритмический язык

for i:=0 to 10 do

    A[i]:=i-1;

for i:=1 to 10 do

    A[i-1]:=A[i];

A[10] := 10;

нц для i от 0 до 10

    A[i] : = i-1

кц

нц для i от 1 до 10

    A[i-1]: = A[i];

кц

A[10]: = 10;

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i-1;

}

for (i = 1; i <= 10; i++) {

    A[i-1] = A[i];

}

A[10] = 10;

 

 

Как изменяются элементы этого массива?

 

1) все элементы, кроме последнего, окажутся равны между собой

2) все элементы окажутся равны своим индексам

3) все элементы, кроме последнего, сдвигаются на один элемент вправо

4) все элементы, кроме последнего, уменьшаются на единицу


11
Задания Д 19 № 3383

В программе обрабатывается двумерный целочисленный массив A [0..n,0..n]. Первый индекс элемента обозначает номер строки, а второй – номер столбца. Дан фрагмент программы:

 

 

БейсикPython

FOR i = 0 TO n

    c = A(i,n-i)

    A(i,n-i) = A(1,i)

    A(1,i) = c

NEXT i

 

for i in range(0, n+1):

    c = A[i,n-i]

    A[i,n-i] = A[1,i]

    A[1,i] = c

ПаскальАлгоритмический язык

 

for i:=0 to n do begin

    c:=A[i,n-i];

    A[i,n-i]:=A[1,i];

    A[1,i]:=c;

end;

 

нц для i от 0 до n

    c:=A[i,n-i]

    A[i,n-i]:=A[1,i]

    A[1,i]:=c

кц

Си++

 

for (i = 0; i <= n; i++) {

    c= A[i][n-i];

    A[i][n-i]= A[1][i];

    A[1][i]= c;

}

 

 

Что меняет этот фрагмент программы?

 

1) два столбца в таблице

2) строку и столбец в таблице

3) элементы диагонали и строки в таблице

4) элементы диагонали и столбца в таблице


12
Задания Д 19 № 3387

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = 10-i

NEXT i

FOR i = 0 TO 5

    A(10-i) = A(5-i)

    A(5+i) = A(i)

NEXT i

 

for i in range(0, 11):

    A[i] = 10-i

for i in range(0, 6):

    A[10-i] = A[5-i]

    A[5+i] = A[i]

ПаскальАлгоритмический язык

for i : = 0 to 10 do

    A[i] : = 10-i;

for i : = 0 to 5 do begin

    A[10-i] : = A[5-i];

    A[5+i]: = A[i];

end;

нц для i от 0 до 10

    A[i] : = 10-i

кц

нц для i от 0 до 5

    A[10-i] : = A[5-i];

    A[5+i] : = A[i];

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = 10-i;

}

for (i = 0; i <= 5; i++) {

    A[10-i] = A[5-i];

    A[5+i] = A[i];

}

 

 

Чему будут равны элементы этого массива?

 

1) 9 8 7 6 5 10 9 8 7 6 10

2) 10 9 8 7 6 5 6 7 8 9 10

3) 10 9 8 7 6 10 9 8 7 6 10

4) 5 6 7 8 9 10 9 8 7 6 5


13
Задания Д 19 № 3389

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

    t = A(0)

NEXT i

FOR i = 1 TO 10

    A(i-1) = A(i)

NEXT i

A(10) = t

 

for i in range(0, 11):

    A[i] = i

    t = A[0]

for i in range(1, 11):

    A[i-1] = A[i]

A[10] = t

ПаскальАлгоритмический язык

for i : = 0 to 10

    do A[i] : = i;

    t : = A[0];

for i : = 1 to 10 do begin

    A[i-1] : = A[i];

end;

A[10] : = t;

нц для i от 0 до 10

    A[i] : = i

    t : = A[0]

кц

нц для i от 1 до 10

    A[i-1] : = A[i];

кц

A[10] : = t;

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

    t = A[0];

}

for (i = 1; i <= 10; i++) {

    A[i-1] = A[i];

}

A[10] = t;

 

 

Чему будут равны элементы этого массива?

 

1) 10 10 10 10 10 10 10 10 10 10

2) 1 2 3 4 5 6 7 8 9 10 0

3) 0 0 0 0 0 0 0 0 0 0

4) 1 2 3 4 5 6 7 8 9 10 1


14
Задания Д 19 № 3392

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 0 TO 5

    A(10-i) = A(9-i)

    A(i) = A(i+1)

NEXT i

 

for i in range(0, 11):

    A[i] = i

for i in range(0, 6):

    A[10-i] = A[9-i]

    A[i] = A[i+1]

ПаскальАлгоритмический язык

for i : = 0 to 10

    do A[i] : = i;

for i : = 0 to 5 do begin

    A[10-i] : = A[9-i];

    A[i] : = A[i+1];

end;

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 0 до 5

    A[10-i] : = A[9-i];

    A[i] : = A[i+1];

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 0; i <= 5; i++) {

    A[10-i] = A[9-i];

    A[i] = A[i+1];

}

 

 

Чему будут равны элементы этого массива?

 

1) 0 1 2 3 4 5 6 7 8 9 10

2) 0 1 2 3 4 5 6 7 8 9 9

3) 1 2 3 4 5 5 5 6 7 8 9

4) 1 2 3 4 5 6 5 4 3 2 1


15
Задания Д 19 № 4551

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, записанный на разных языках программирования, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикПаскаль

FOR i=0 TO 10

    A(i)=i-1

NEXT i

FOR i=1 TO 10

    A(i-1)=A(i)

NEXT i

A(10)=10

for i:=0 to 10 do

    A[i]:=i-1;

for i:=1 to 10 do

    A[i-1]:=A[i];

A[10]:=10;

Си++Алгоритмический язык

for (i = 0; i <= 10; i++) {

    A[i] = i-1;

}

for (i = 1; i <= 10; i++) {

    A[i-1] = A[i];

}

A[10] = 10;

нц для i от 0 до 10

    A[i]:=i-1

кц

нц для i от 1 до 10

    A[i-1]:=A[i]

кц

A[10]:=10

Python

 

for i in range(0, 11):

    A[i] = i-1

for i in range(1, 11):

    A[i-1] = A[i]

A[10] = 10

 

 

Как изменятся элементы этого массива после выполнения фрагмента программы?

 

1) все элементы, кроме последнего, окажутся равны между собой

2) все элементы окажутся равны своим индексам

3) все элементы, кроме последнего, будут сдвинуты на один элемент вправо

4) все элементы, кроме последнего, уменьшатся на единицу

Источник: Демонстрационная версия ЕГЭ—2013 по информатике.

16
Задания Д 19 № 5451

В программе описаны одномерный целочисленный массив А с индексами от 0 до 9 и целочисленные переменные i и t. Ниже представлен фрагмент этой программы, записанный на разных языках программирования.

 

БейсикПаскаль

FOR i = 0 TO 9

A(i) = i + 1

NEXT i

t = A(9)

FOR i = 8 TO 0 STEP -1

A(i+1) = A(i)

NEXT i

A(0) = t

for i := 0 to 9 do

    A[i] := i+1;

t := A[9]

for i := 8 downto 0 do

    A[i+1] := A[i];

A[0] := t;

Си++Алгоритмический язык

for (i = 0; i <= 9; i++) {

    A[i] = i+1;

}

t = A[9];

for (i = 8; i >= 0; i--) {

    A[i+1] = A[i];

}

A[0] = t;

нц для i от 0 до 9

    A[i] := i+1

кц

t := A[9]

нц для i от 8 до 0 шаг -1

    A[i+1] := A[i]

кц

A[0] := t

Python

 

for i in range(0, 10):

    A[i] = i+1

t = A[9]

for i in range(8, -1, -1):

    A[i+1] = A[i]

A[0] = t

 

 


Чему окажутся равны элементы этого массива после выполнения фрагмента программы?

 

1) 10 3 4 5 6 7 8 9 10 10

2) 10 10 10 10 10 10 10 10 10 10

3) 10 1 1 1 1 1 1 1 1 1

4) 10 1 2 3 4 5 6 7 8 9


Аналоги к заданию № 5451: 5707 Все

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Сибирь. Ва­ри­ант 1.

17
Задания Д 19 № 5739

В программе описан одномерный целочисленный массив А с индексами от 0 до 10. Ниже представлен фрагмент этой программы, записанный на разных языках программирования.

 

 

БейсикПаскаль

FOR i = 0 TO 9

A(i) = i + 1

NEXT i

t = A(0)

FOR i = 0 TO 8

A(i) = A(i+1)

NEXT i

A(9) = t

for i := 0 to 9 do

    A[i] := i+1;

t := A[0]

for i := 0 to 8 do

    A[i] := A[i+1];

A[9] := t;

Си++Алгоритмический язык

for (i = 0; i <= 9; i++) {

    A[i] = i+1;

}

t = A[0]

for (i = 0; i <= 8; i++) {

    A[i] = A[i+1];

}

A[9] = t;

нц для i от 0 до 9

    A[i] := i+1

кц

t := A[0]

нц для i от 0 до 8

    A[i] := A[i+1]

кц

A[9] := t

Python

 

for i in range(0, 10):

    A[i] = i+1

t = A[0]

for i in range(0, 9):

    A[i] = A[i+1]

A[9] = t

 

 

Чему окажутся равны элементы этого массива после выполнения фрагмента программы?

 

1) 1 2 3 4 5 6 7 8 9 1

2) 1 1 1 1 1 1 1 1 1 1

3) 10 10 10 10 10 10 10 10 10 1

4) 2 3 4 5 6 7 8 9 10 1


Аналоги к заданию № 5739: 5835 Все

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Урал. Ва­ри­ант 3.

18
Задания Д 19 № 5387

В программе описан одномерный целочисленный массив А с индексами от 0 до 10. Ниже представлен фрагмент этой программы, записанный на разных языках программирования.

 

 

Бейсик

Паскаль

FOR i = 0 ТО 10

    A (i) = i-1

NEXT i

FOR i = 1 TO 10

    A(i-1) = A(i)

NEXT i

A(10) = 10

 

for i = 0 to 10 do

    a[i] := i-1;

for i := 1 to 10 do

    a[i-1] := a[i];

a[10] := 10;

 

 

Си++

Алгоритмический язык

for (i = 0; i <= 10; i++) {

    A[i] = i-1;

}

for (i = 1; i <= 10; i++) {

    A[i-1] = A[i];

}

A[10] = 10;

 

 

нц для i от 0 до 10

    A[i] := i-1

кц

нц для i от 1 до 10

    A[i-1] := A[i]

кц

А[10] := 10

 

Python

 

for i in range(0, 11):

    A[i] = i-1

for i in range(1, 10):

    A[i-1] = A[i]

A[10] = 10

 

 

Чему окажутся равны элементы этого массива после выполнения фрагмента программы?

 

1) 9 9 9 9 9 9 9 9 9 9 10

2) 1 2 3 4 5 6 7 8 9 10 10

3) -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 10

4) 0 1 2 3 4 5 6 7 8 9 10


Аналоги к заданию № 5387: 6259 Все

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Дальний Восток. Ва­ри­ант 2.

19
Задания Д 19 № 6299

В программе описан одномерный целочисленный массив A с индексами от 0 до 9 и целочисленные переменные i и t. Ниже представлен фрагмент этой программы, записанный на разных языках программирования.

 

БейсикПаскаль

FOR i = 0 TO 9

    A(i) = i+1

NEXT i

t = A(0)

FOR i = 1 TO 9

    A(i-1) = A(i)

NEXT i

A(9) = t

for i := 0 to 9 do

    A[i] := i+1;

t := A[0];

for i := 1 to 9 do

    A[i-1] := A[i];

A[9] := t;

Си++Алгоритмический язык

for (i = 0; i <= 9; i++) {

    A[i] = i+1;

}

t = A[0];

for (i = 1; i <= 9; i++) {

    A[i-1] = A[i];

}

A[9] = t;

нц для i от 0 до 9

    A[i] := i+1

кц

t := A[0]

нц для i от 1 до 9

    A[i-1] := A[i]

кц

A[9] := t

кц

Python

 

for i in range(0, 10):

    A[i] = i+1

t = A[0]

for i in range(1, 10):

    A[i-1] = A[i]

A[9] = t

 

 

Чему окажутся равны элементы этого массива после выполнения фрагмента программы?

 

1) 1 2 3 4 5 6 7 8 9 1

2) 1 1 1 1 1 1 1 1 1 1

3) 10 10 10 10 10 10 10 10 10 1

4) 2 3 4 5 6 7 8 9 10 1

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 502.

20
Задания Д 19 № 6331

В программе описан одномерный целочисленный массив A с индексами от 0 до 10 и целочисленные переменные i и t. Ниже представлен фрагмент этой программы, записанный на разных языках программирования.

 

БейсикПаскаль

FOR i = 0 TO 10

    A(i) = i

NEXT i

t = A(10)

FOR i = 10 TO 1 STEP -1

    A(i) = A(i-1)

NEXT i

A(0) = t

for i := 0 to 10 do

    A[i] := i;

t := A[10];

for i := 10 downto 1 do

    A[i] := A[i-1];

A[0] := t;

Си++Алгоритмический язык

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

t = A[10];

for (i = 10; i >= 1; i--) {

    A[i] = A[i-1];

}

A[0] = t;

нц для i от 0 до 10

    A[i] := i

кц

t := A[10]

нц для i от 10 до 1 шаг -1

    A[i] := A[i-1]

кц

A[0] := t

кц

Python

 

for i in range(0, 11):

    A[i] = i

t = A[10]

for i in range(10, 0, -1):

    A[i] = A[i-1]

A[0] = t

 

 

Чему окажутся равны элементы этого массива после выполнения фрагмента программы?

 

1) 10 10 10 10 10 10 10 10 10 10 10

2) 10 0 1 2 3 4 5 6 7 8 9

3) 10 0 0 0 0 0 0 0 0 0 0

4) 10 2 3 4 5 6 7 8 9 10 10

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 601.

21
Задания Д 19 № 6416

В программе описан одномерный целочисленный массив A с индексами от 0 до 10 и целочисленные переменные i и t. Ниже представлен фрагмент этой программы, записанный на разных языках программирования.

 

БейсикПаскаль

FOR i = 0 TO 10

    A(i) = i-1

NEXT i

FOR i = 0 TO 9

    A(i) = A(i+1)

NEXT i

A(10) = 10

for i := 0 to 10 do

    A[i] := i-1;

for i := 0 to 9 do

    A[i] := A[i+1];

A[10] := 10;

Си++Алгоритмический язык

for (i = 0; i <= 10; i++) {

    A[i] = i-1;

}

for (i = 0; i <= 9; i++) {

    A[i] = A[i+1];

}

A[10] = 10;

нц для i от 0 до 10

    A[i] := i-1

кц

нц для i от 0 до 9

    A[i] := A[i+1]

кц

A[10] := 10

Python

 

for i in range(0, 11):

    A[i] = i-1

for i in range(0, 10):

    A[i] = A[i+1]

A[10] = 10

 

 

Чему окажутся равны элементы этого массива после выполнения фрагмента программы?

 

1) 9 9 9 9 9 9 9 9 9 9 10

2) 1 2 3 4 5 6 7 8 9 10 10

3) –1 –1 –1 –1 –1 –1 –1 –1 –1 –1 10

4) 0 1 2 3 4 5 6 7 8 9 10

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 602.

Пройти тестирование по этим заданиям