СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Каталог заданий.
Алгоритмы, меняющие элементы массива местами

Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задания Д16 № 3355

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 0 TO 4

    k = A(i)

   A(i) = A(10 - i)

   A(10 - i) = k

NEXT i

for i in range(0, 11):

    A[i] = i

for i in range(0, 5):

    k = A[i]

    A[i] = A[10 - i]

    A[10 - i] = k

ПаскальАлгоритмический язык

for i : = 0 to 10 do A[i] : = i;

for i : = 0 to 4 do begin

    k : = A[i];

    A[i] : = A[10-i];

    A[10-i] : = k;

end;

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 0 до 4

        k : = A[i];

        A[i] : = A[10-i];

        A[10-i] : = k;

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 0; i <= 4; i++) {

    k = A[i];

    A[i] = A[10-i];

    A[10-i] = k;

}

 

 

Чему будут равны элементы этого массива?

 

1) 10 9 8 7 6 5 4 3 2 1 0

2) 0 1 2 3 4 5 6 7 8 9 10

3) 0 1 2 3 4 5 4 3 2 1 0

4) 10 9 8 7 6 5 6 7 8 9 10


Аналоги к заданию № 3355: 3386 Все


2
Задания Д16 № 3356

В программе описан одномерный целочисленный массив с индексами от 0 до 10. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 1 TO 11

    A(i - 1) = A(11 - i)

NEXT i

for i in range(0, 11):

    A[i] = i

for i in range(1, 12):

    A[i - 1] = A[11 - i]

ПаскальАлгоритмический язык

for i : = 0 to 10 do

    A[i] : = i;

for i : = 1 to 11 do

    A[i-1] : = A[11-i];

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 1 до 11

        A[i-1] := A[11-i]

кц

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 1; i <= 11; i++) {

     A[i-1] = A[11-i];

}

 

Чему будут равны элементы этого массива?

 

1) 10 9 8 7 6 5 4 3 2 1 0

2) 11 10 9 8 7 6 5 4 3 2 1

3) 10 9 8 7 6 5 6 7 8 9 10

4) 11 10 9 8 7 6 7 8 9 10 11

Решение · · Видеокурс ·

3
Задания Д16 № 3362

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 0 TO 4

    k = A(2*i)

    A(2*i) = A(2*i+1)

    A(2*i+1) = k

NEXT i

 

for i in range(0, 11):

    A[i] = i

for i in range(0, 5):

    k = A[2*i]

    A[2*i] = A[2*i+1]

    A[2*i+1] = k

ПаскальАлгоритмический язык

for i : = 0 to 10 do A[i] : = i;

for i : = 0 to 4 do begin

    k : = A[2*i];

    A[2*i] : = A[2*i+1];

    A[2*i+1] : = k;

end;

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 0 до 4

    k : = A[2*i];

        A[2*i] : = A[2*i+1];

        A[2*i+1] : = k;

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 0; i <= 4; i++) {

    k = A[2*i];

    A[2*i] = A[2*i+1];

    A[2*i+1] = k;

}

 

 

Чему будут равны элементы этого массива?

 

1) 5 6 7 8 9 0 1 2 3 4 10

2) 10 9 8 7 6 5 4 3 2 1 0

3) 0 1 2 3 4 5 4 3 2 1 0

4) 1 0 3 2 5 4 7 6 9 8 10


4
Задания Д16 № 3371

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i-1

NEXT i

FOR i = 10 TO 1 STEP -1

    A(i-1) = A(i)

NEXT i

 

for i in range(0, 11):

    A[i] = i-1

for i in range(10, 0, -1):

    A[i-1] = A[i]

ПаскальАлгоритмический язык

for i:=0 to 10 do

    A[i]:=i-1;

for i:=10 downto 1 do

    A[i-1]:=A[i];

нц для i от 0 до 10

    A[i] : = i-1

кц

нц для i от 10 до 1 шаг -1

    A[i-1]: = A[i];

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i-1;

}

for (i = 10; i <= 1; i--) {

    A[i-1] = A[i];

}

 

 

Чему будут равны элементы этого массива?

 

1) 9 9 9 9 9 9 9 9 9 9 9

2) 0 1 2 3 4 5 6 7 8 9 9

3) 0 1 2 3 4 5 6 7 8 9 10

4) -1 -1 0 1 2 3 4 5 6 7 8


5
Задания Д16 № 3382

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 0 TO 4

    k = A(10-i)

    A(10-i) = A(i)

    k = A(i)

NEXT i

 

for i in range(0, 11):

    A[i] = i

for i in range(0, 5):

    k = A[10-i]

    A[10-i] = A[i]

    k = A[i]

ПаскальАлгоритмический язык

for i : = 0 to 10 do A[i] : = i;

for i : = 0 to 4 do begin

    k : = A[10-i];

    A[10-i] : = A[i];

    k : = A[i];

end;

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 0 до 4

    k : = A[10-i];

        A[10-i] : = A[i];

    k : = A[i];

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 0; i <= 4; i++) {

    k = A[10-i];

    A[10-i] = A[i];

    k = A[i];

}

 

 

Чему будут равны элементы этого массива?

 

1) 10 9 8 7 6 5 4 3 2 1 0

2) 0 1 2 3 4 5 6 7 8 9 10

3) 0 1 2 3 4 5 4 3 2 1 0

4) 10 9 8 7 6 5 6 7 8 9 10


Пройти тестирование по этим заданиям