СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
Информатика
Cайты, меню, вход, новости


Задания
Версия для печати и копирования в MS Word
Задания Д16 № 3362

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 0 TO 4

    k = A(2*i)

    A(2*i) = A(2*i+1)

    A(2*i+1) = k

NEXT i

 

for i in range(0, 11):

    A[i] = i

for i in range(0, 5):

    k = A[2*i]

    A[2*i] = A[2*i+1]

    A[2*i+1] = k

ПаскальАлгоритмический язык

for i : = 0 to 10 do A[i] : = i;

for i : = 0 to 4 do begin

    k : = A[2*i];

    A[2*i] : = A[2*i+1];

    A[2*i+1] : = k;

end;

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 0 до 4

    k : = A[2*i];

        A[2*i] : = A[2*i+1];

        A[2*i+1] : = k;

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 0; i <= 4; i++) {

    k = A[2*i];

    A[2*i] = A[2*i+1];

    A[2*i+1] = k;

}

 

 

Чему будут равны элементы этого массива?

 

1) 5 6 7 8 9 0 1 2 3 4 10

2) 10 9 8 7 6 5 4 3 2 1 0

3) 0 1 2 3 4 5 4 3 2 1 0

4) 1 0 3 2 5 4 7 6 9 8 10

Решение.

Первый цикл, заполняем массив:

i=0: a[0]=0,

i=1: a[1]=1,

i=2: a[2]=2,

...

i=10: a[10]=10.

 

Второй цикл, меняем значения элементов a[2*i] и a[2*i+1] местами:

i=0: a[0]=a[1]=1 и a[1]=a[0]=0,

i=1: a[2]=a[3]=3 и a[3]=a[2]=2,

...

i=4: a[8]=a[9]=9 и a[9]=a[8]=8.

 

Поэтому в результате выполнения программы элементы массива будут равны: 1, 0, 3, 2, 5, 4, 7, 6, 9, 8, 10.

 

Правильный ответ указан под номером 4.