СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
Информатика
Cайты, меню, вход, новости


Варианты заданий
Версия для печати и копирования в MS Word
1
Задания Д16 № 3386

В программе описан одномерный целочисленный массив с индексами от 0 до 10 и целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i

NEXT i

FOR i = 10 TO 0 STEP -1

    k = A(10-i)

    A(10-i) = A(i)

    A(i) = k

NEXT i

 

for i in range(0, 11):

    A[i] = i

for i in range(10, -1, -1):

    k = A[10-i]

    A[10-i] = A[i]

    A[i] = k

ПаскальАлгоритмический язык

for i:=0 to 10 do

    A[i]:=i;

for i:=10 downto 0 do begin

    k := A[10-i];

    A[10-i] := A[i];

    A[i] := k;

end;

нц для i от 0 до 10

    A[i] : = i

кц

нц для i от 10 до 0 шаг -1

    k: = A[10-i]

    A[10-i]: = A[i]

    A[i]: = k

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i;

}

for (i = 10; i >= 0; i--) {

    k = A[10-i];

    A[10-i] = A[i];

    A[i] = k;

}

 

Чему будут равны элементы этого массива?

 

1) 10 9 8 7 6 5 4 3 2 1 0

2) 0 1 2 3 4 5 6 7 8 9 10

3) 10 9 8 7 6 5 6 7 8 9 10

4) 0 1 2 3 4 5 4 3 2 1 0


Аналоги к заданию № 3355: 3386 Все