СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
Информатика
Cайты, меню, вход, новости


Задания
Версия для печати и копирования в MS Word
Задания Д16 № 3371

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

FOR i = 0 TO 10

    A(i) = i-1

NEXT i

FOR i = 10 TO 1 STEP -1

    A(i-1) = A(i)

NEXT i

 

for i in range(0, 11):

    A[i] = i-1

for i in range(10, 0, -1):

    A[i-1] = A[i]

ПаскальАлгоритмический язык

for i:=0 to 10 do

    A[i]:=i-1;

for i:=10 downto 1 do

    A[i-1]:=A[i];

нц для i от 0 до 10

    A[i] : = i-1

кц

нц для i от 10 до 1 шаг -1

    A[i-1]: = A[i];

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = i-1;

}

for (i = 10; i <= 1; i--) {

    A[i-1] = A[i];

}

 

 

Чему будут равны элементы этого массива?

 

1) 9 9 9 9 9 9 9 9 9 9 9

2) 0 1 2 3 4 5 6 7 8 9 9

3) 0 1 2 3 4 5 6 7 8 9 10

4) -1 -1 0 1 2 3 4 5 6 7 8

Решение.

Итак, пойдем по программе:

От 0 до 10 выполняем

A[i]:=i - 1, т. е. по порядку -1, 0, 1, 2, 3, 4, 5, 6, 7, 8, 9.

 

От 10 до 1 выполняем

A[i-1]:=A[i], т. е. справа налево каждый элемент массива будет принимать значение справа стоящей ячейки, так что

 

A[9]:=A[10]=9, a A[8]:=A[9]=A[10]=9 и т. д., так что все значения ячейки будут равны 9.

 

Правильный ответ указан под номером 1.