информатика
Информатика
Русский язык
Английский язык
Немецкий язык
Французcкий язык
Испанский язык
Физика
Химия
Биология
География
Обществознание
Литература
История
сайты - меню - вход - новости




Каталог заданий.
Арифметическая прогрессия
Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 8 № 3199

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM K, S AS INTEGER

S = 0

K = 1

WHILE S < 66

    K = K + 3

    S = S + K

WEND

PRINT K

s = 0

k = 1

while s < 66:

    k += 3

    s += k

print(k)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=0;

       k:=1;

      while s < 66 do begin

             k:=k+3;

            s:=s+k;

       end;

      write(k);

end.

алг

нач

    цел k, s

    s := 0

    k := 1

    нц пока s < 66

        k := k + 3

        s := s + k

    кц

    вывод k

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 0, k = 1;

    while (s < 66) {

        k = k + 3;

        s = s + k;

    }

    cout << k << endl;

    return 0;

}

 


2
Задание 8 № 9643

Определите значение переменной c после выполнения следующего фрагмента программы (записанного ниже на разных языках программирования). Ответ запишите в виде целого числа.

 

БейсикПаскаль

a = 20

b = 15

b = 3 * b - a

IF a > b THEN

c = 2 * a + b

ELSE

c = 2 * a - b

END IF

a := 20;

b := 15;

b := 3 * b - a;

if a > b then

c := 2 * a + b

else

c := 2 * a - b;

Си++Алгоритмический язык

a = 20;

b = 15;

b = 3 * b - a;

if (a > b)

c = 2 * a + b;

else

c = 2 * a - b;

a := 20

b := 15

b := 3 * b - a

если a > b

то c := 2 * a + b

иначе c := 2 * a - b

все

Python

a = 20

b = 15

b = 3 * b - a

if a > b:

    c = 2 * a + b

else:

    c = 2 * a - b

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 28.09.2015 ИН10103

3
Задание 8 № 9689

Определите значение переменной c после выполнения следующего фрагмента программы (записанного ниже на разных языках программирования). Ответ запишите в виде целого числа.

 

БейсикПаскаль

a = 17

b = 20

a = 3 * a - b

IF a > b THEN

  c = 5 * a - b

ELSE

  c = 5 * a + b

END IF

a := 17;

b := 20;

a := 3 * a - b;

if a > b then

  c := 5 * a - b

else

  c := 5 * a + b;

Си++Алгоритмический язык

a = 17;

b = 20;

a = 3 * a - b;

if (a > b)

  c = 5 * a - b;

else

  c = 5 * a + b;

a := 17

b := 20

a := 3 * a - b

если a > b

  то c := 5 * a - b

  иначе c := 5 * a + b

все

Python

a = 17

b = 20

a = 3 * a - b

if a > b:

    c = 5 * a - b

else:

    c = 5 * a + b

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 28.09.2015 ИН10104

4
Задание 8 № 3239

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

БейсикPython

DIM K, S AS INTEGER

S = 0

K = 0

WHILE K < 30

    K = K + 3

    S = S + K

WEND

PRINT S

s = 0

k = 0

while k < 30:

    k += 3

    s += k

print(s)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=0;

       k:=0;

      while k < 30 do begin

             k:=k+3;

            s:=s+k;

       end;

      write(s);

end.

алг

нач

    цел k, s

    s := 0

    k := 0

    нц пока k < 30

        k := k + 3

        s := s + k

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 0, k = 0;

    while (k < 30) {

        k = k + 3;

        s = s + k;

    }

    cout << s << endl;

    return 0;

}

 


5
Задание 8 № 3240

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM K, S AS INTEGER

S = 1

K = 0

WHILE K < 13

    S = S + 2 * K

    K = K + 4

WEND

PRINT K+S

s = 1

k = 0

while k < 13:

    s += 2*k

    k += 4

print(k+s)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=1;

       k:=0;

      while k < 13 do begin

            s:=s+2*k;

             k:=k+4;

       end;

      write(s+k);

end.

алг

нач

    цел k, s

    s := 1

    k := 0

    нц пока k < 13

        s := s + 2 * k

        k := k + 4

    кц

    вывод s+k

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 1, k = 0;

    while (k < 13) {

        s = s + 2 * k;

        k = k + 4;

    }

    cout << s+k << endl;

    return 0;

}

 


6
Задание 8 № 3247

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM K, S AS INTEGER

S = 5

K = 0

WHILE K < 15

    K = K + 2

    S = S + K

WEND

PRINT S

s = 5

k = 0

while k < 15:

    k += 2

    s += k

print(s)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=5;

       k:=0;

      while k < 15 do begin

            k:=k+2;

            s:=s+k;

       end;

      write(s);

end.

алг

нач

    цел k, s

    s := 5

    k := 0

    нц пока k < 15

        k := k + 2

        s := s + k

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 5, k = 0;

    while (k < 15) {

        k = k + 2;

        s = s + k;

    }

    cout << s << endl;

    return 0;

}

 


7
Задание 8 № 3249

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 8

    S = S + N

    N = N + 1

WEND

PRINT S

n = 4

s = 0

while n <= 8:

    s += n

    n += 1

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 8 do

    begin

        s := s + n;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 4

    s := 0

    нц пока n <= 8

        s := s + n

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 4, s = 0;

    while (n <= 8) {

        s := s + n;

        n := n + 1;

    }

    cout << s << endl;

    return 0;

}

 


8
Задание 8 № 3250

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM K, S AS INTEGER

S = 0

K = 0

WHILE S < 100

    S = S + K

    K = K + 4

WEND

PRINT K

s = 0

k = 0

while s < 100:

    s += k

    k += 4

print(k)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=0;

       k:=0;

      while s < 100 do begin

            s:=s+k;

            k:=k+4;

       end;

      write(k);

end.

алг

нач

    цел k, s

    s := 0

    k := 0

    нц пока s < 100

        s := s + k

        k := k + 4

    кц

    вывод k

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 0, k = 0;

    while (s < 100) {

        s = s + k;

        k = k + 4;

    }

    cout << k << endl;

    return 0;

}

 


9
Задание 8 № 3255

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM K, S AS INTEGER

S = 2

K = 2

WHILE S < 50

    S = S + K

    K = K + 2

WEND

PRINT K

s = 2

k = 2

while s < 50:

    s += k

    k += 2

print(k)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=2;

       k:=2;

      while s < 50 do begin

            s:=s+k;

            k:=k+2;

       end;

      write(k);

end.

алг

нач

    цел k, s

    s := 2

    k := 2

    нц пока s < 50

        s := s + k

        k := k + 2

    кц

    вывод k

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 2, k = 2;

    while (s < 50) {

        s = s + k;

        k = k + 2;

    }

    cout << k << endl;

    return 0;

}

 


10
Задание 8 № 3772

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM K, S AS INTEGER

S = 3

K = 1

WHILE K < 25

    S = S + K

    K = K + 2

WEND

PRINT S

s = 3

k = 1

while k < 25:

    s += k

    k += 2

print(s)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=3;

       k:=1;

      while k < 25 do begin

            s:=s+k;

            k:=k+2;

       end;

      write(s);

end.

алг

нач

    цел k, s

    s := 3

    k := 1

    нц пока k < 25

        s := s + k

        k := k + 2

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 3, k = 1;

    while (k < 25) {

        s = s + k;

        k = k + 2;

    }

    cout << s << endl;

    return 0;

}

 


11
Задание 8 № 3507

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 3

S = 0

WHILE N <= 7

S = S + N

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n := 3;

    s := 0;

    while n <= 7 do

    begin

        s := s + n;

        n := n + 1

    end;

    write(s)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 3;

    s = 0;

    while (n <= 7)

    {

        s = s + n;

        n = n + 1;

    }

    cout « s « endl;

}

алг

нач

цел n, s

n := 3

s := 0

нц пока n <= 7

    s := s + n

    n := n + 1

кц

вывод s

кон

Python

n = 3

s = 0

while n <= 7:

    s += n

    n += 1

print(s)

 


12
Задание 8 № 3513

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 8

S = S + N

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 8 do

    begin

        s := s + n;

        n := n + 1

    end;

    write(s)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 4;

    s = 0;

    while (n <= 8)

    {

        s = s + n;

        n = n + 1;

    }

    cout « s « endl;

}

алг

нач

цел n, s

n := 4

s := 0

нц пока n <= 8

    s := s + n

    n := n + 1

кц

вывод s

кон

Python

n = 4

s = 0

while n <= 8:

    s += n

    n += 1

print(s)

 


13
Задание 8 № 3529

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

Dim s, k As Integer

s = 0

k = 1

while k < 11

    s = s + k

    k = k + 1

End While

Console.Write(s)

var s, k : integer;

begin

    s:=0;

    k:=1;

    while k<11 do

    begin

        s:=s+k;

        k:=k+1;

    end;

    write(s);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

 

int main(){

    int s, k;

    s = 0;

    k = 1;

    while (k < 11) {

        s = s + k;

        k = k + 1;

    }

    cout « s « endl;

}

нач

цел s, k

s:=0

k:=1

нц пока k < 11

    s:=s+k; k:=k+1

кц

вывод s

кон

Python

s = 0

k = 1

while k < 11:

    s += k

    k += 1

print(s)

 


14
Задание 8 № 3538

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

БейсикПаскаль

DIM s, k As Integer

s = 0

k = 0

WHILE k < 30

    k = k + 3

    s = s + k

END While

Console.Write(s)

var s, k : integer;

begin

    s:=0;

    k:=0;

    while k < 30 do

    begin

        k:=k+3;

        s:=s+k;

    end;

    write(s);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

 

int main(){

    int s, k;

    s = 0;

    k = 0;

    while (k < 30) {

        k = k + 3;

        s = s + k;

    }

    cout « s « endl;

}

нач

цел s, k

s:=0

k:=0

нц пока k < 30

    k:=k+3; s:=s+k

кц

вывод s

кон

Python

s = 0

k = 0

while k < 30:

    k += 3

    s += k

print(s)

 


Пройти тестирование по этим заданиям