СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Каталог заданий.
Арифметическая прогрессия

Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 8 № 3199

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­ще­го фраг­мен­та про­грам­мы:

 

 

Бей­сикPython

DIM K, S AS INTEGER

S = 0

K = 1

WHILE S < 66

    K = K + 3

    S = S + K

WEND

PRINT K

s = 0

k = 1

while s < 66:

    k += 3

    s += k

print(k)

Пас­кальАл­го­рит­ми­че­ский язык

var k, s: integer;

begin

       s:=0;

       k:=1;

      while s < 66 do begin

             k:=k+3;

            s:=s+k;

       end;

      write(k);

end.

алг

нач

    цел k, s

    s := 0

    k := 1

    нц пока s < 66

        k := k + 3

        s := s + k

    кц

    вывод k

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 0, k = 1;

    while (s < 66) {

        k = k + 3;

        s = s + k;

    }

    cout << k << endl;

    return 0;

}

 


2
Задание 8 № 3239

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­ще­го фраг­мен­та про­грам­мы:

 

Бей­сикPython

DIM K, S AS INTEGER

S = 0

K = 0

WHILE K < 30

    K = K + 3

    S = S + K

WEND

PRINT S

s = 0

k = 0

while k < 30:

    k += 3

    s += k

print(s)

Пас­кальАл­го­рит­ми­че­ский язык

var k, s: integer;

begin

       s:=0;

       k:=0;

      while k < 30 do begin

             k:=k+3;

            s:=s+k;

       end;

      write(s);

end.

алг

нач

    цел k, s

    s := 0

    k := 0

    нц пока k < 30

        k := k + 3

        s := s + k

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 0, k = 0;

    while (k < 30) {

        k = k + 3;

        s = s + k;

    }

    cout << s << endl;

    return 0;

}

 


3
Задание 8 № 3245

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­ще­го фраг­мен­та про­грам­мы:

 

 

Бей­сикPython

DIM N, S AS INTEGER

N = 3

S = 0

WHILE N <= 7

    S = S + N

    N = N + 1

WEND

PRINT S

n = 3

s = 0

while n <= 7:

    s += n

    n += 1

print(s)

Пас­кальАл­го­рит­ми­че­ский язык

var n, s: integer;

begin

    n := 3;

    s := 0;

    while n <= 7 do

    begin

        s := s + n;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 3

    s := 0

    нц пока n <= 7

        s := s + n

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 3, s = 0;

    while (n <= 7) {

        s = s + n;

        n = n + 1;

    }

    cout << s << endl;

    return 0;

}

 


4
Задание 8 № 3247

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM K, S AS INTEGER

S = 5

K = 0

WHILE K < 15

    K = K + 2

    S = S + K

WEND

PRINT S

s = 5

k = 0

while k < 15:

    k += 2

    s += k

print(s)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=5;

       k:=0;

      while k < 15 do begin

            k:=k+2;

            s:=s+k;

       end;

      write(s);

end.

алг

нач

    цел k, s

    s := 5

    k := 0

    нц пока k < 15

        k := k + 2

        s := s + k

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 5, k = 0;

    while (k < 15) {

        k = k + 2;

        s = s + k;

    }

    cout << s << endl;

    return 0;

}

 


5
Задание 8 № 3249

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­ще­го фраг­мен­та про­грам­мы:

 

 

Бей­сикPython

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 8

    S = S + N

    N = N + 1

WEND

PRINT S

n = 4

s = 0

while n <= 8:

    s += n

    n += 1

print(s)

Пас­кальАл­го­рит­ми­че­ский язык

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 8 do

    begin

        s := s + n;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 4

    s := 0

    нц пока n <= 8

        s := s + n

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 4, s = 0;

    while (n <= 8) {

        s = s + n;

        n = n + 1;

    }

    cout << s << endl;

    return 0;

}

 


Пройти тестирование по этим заданиям