СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 3249

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 8

    S = S + N

    N = N + 1

WEND

PRINT S

n = 4

s = 0

while n <= 8:

    s += n

    n += 1

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 8 do

    begin

        s := s + n;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 4

    s := 0

    нц пока n <= 8

        s := s + n

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 4, s = 0;

    while (n <= 8) {

        s = s + n;

        n = n + 1;

    }

    cout << s << endl;

    return 0;

}

 

Решение.

Поскольку изначально n = 4, цикл while n <= 8 выполнится пять раз. Следовательно, s = 4 + 5 + 6 + 7 + 8 = 30.

 

Ответ: 30.