СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 3245

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM N, S AS INTEGER

N = 3

S = 0

WHILE N <= 7

    S = S + N

    N = N + 1

WEND

PRINT S

n = 3

s = 0

while n <= 7:

    s += n

    n += 1

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 3;

    s := 0;

    while n <= 7 do

    begin

        s := s + n;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 3

    s := 0

    нц пока n <= 7

        s := s + n

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 3, s = 0;

    while (n <= 7) {

        s = s + n;

        n = n + 1;

    }

    cout << s << endl;

    return 0;

}

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие n <= 7, т. е. переменная n определяет, сколько раз выполнится цикл.

 

Запишем последовательно значения s и n:

 

s 0 3 7 12 18 25

n 3 4 5  6   7   8

 

 

Цикл выполнится пять раз (так как действие n := n + 1 стоит в конце цикла, следовательно, для n=8 действие s := s + n не будет выполняться).