№№ заданий Пояснения Ответы Ключ Добавить инструкцию Критерии
Источник Раздел кодификатора ФИПИ Справка
PDF-версия PDF-версия (вертикальная) PDF-версия (крупный шрифт) PDF-версия (с большим полем) Версия для копирования в MS Word
Арифметическая прогрессия
1.

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­ще­го фраг­мен­та про­грам­мы:

 

 

Бей­сикPython

DIM K, S AS INTEGER

S = 0

K = 1

WHILE S < 66

    K = K + 3

    S = S + K

WEND

PRINT K

s = 0

k = 1

while s < 66:

    k += 3

    s += k

print(k)

Пас­кальАл­го­рит­ми­че­ский язык

var k, s: integer;

begin

       s:=0;

       k:=1;

      while s < 66 do begin

             k:=k+3;

            s:=s+k;

       end;

      write(k);

end.

алг

нач

    цел k, s

    s := 0

    k := 1

    нц пока s < 66

        k := k + 3

        s := s + k

    кц

    вывод k

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 0, k = 1;

    while (s < 66) {

        k = k + 3;

        s = s + k;

    }

    cout << k << endl;

    return 0;

}

 

2.

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­ще­го фраг­мен­та про­грам­мы:

 

Бей­сикPython

DIM K, S AS INTEGER

S = 0

K = 0

WHILE K < 30

    K = K + 3

    S = S + K

WEND

PRINT S

s = 0

k = 0

while k < 30:

    k += 3

    s += k

print(s)

Пас­кальАл­го­рит­ми­че­ский язык

var k, s: integer;

begin

       s:=0;

       k:=0;

      while k < 30 do begin

             k:=k+3;

            s:=s+k;

       end;

      write(s);

end.

алг

нач

    цел k, s

    s := 0

    k := 0

    нц пока k < 30

        k := k + 3

        s := s + k

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 0, k = 0;

    while (k < 30) {

        k = k + 3;

        s = s + k;

    }

    cout << s << endl;

    return 0;

}

 

3.

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­ще­го фраг­мен­та про­грам­мы:

 

 

Бей­сикPython

DIM N, S AS INTEGER

N = 3

S = 0

WHILE N <= 7

    S = S + N

    N = N + 1

WEND

PRINT S

n = 3

s = 0

while n <= 7:

    s += n

    n += 1

print(s)

Пас­кальАл­го­рит­ми­че­ский язык

var n, s: integer;

begin

    n := 3;

    s := 0;

    while n <= 7 do

    begin

        s := s + n;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 3

    s := 0

    нц пока n <= 7

        s := s + n

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 3, s = 0;

    while (n <= 7) {

        s = s + n;

        n = n + 1;

    }

    cout << s << endl;

    return 0;

}

 

4.

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­ще­го фраг­мен­та про­грам­мы:

 

 

Бей­сикPython

DIM K, S AS INTEGER

S = 5

K = 0

WHILE K < 15

    K = K + 2

    S = S + K

WEND

PRINT S

s = 5

k = 0

while k < 15:

    k += 2

    s += k

print(s)

Пас­кальАл­го­рит­ми­че­ский язык

var k, s: integer;

begin

       s:=5;

       k:=0;

      while k < 15 do begin

            k:=k+2;

            s:=s+k;

       end;

      write(s);

end.

алг

нач

    цел k, s

    s := 5

    k := 0

    нц пока k < 15

        k := k + 2

        s := s + k

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 5, k = 0;

    while (k < 15) {

        k = k + 2;

        s = s + k;

    }

    cout << s << endl;

    return 0;

}

 

5.

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­ще­го фраг­мен­та про­грам­мы:

 

 

Бей­сикPython

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 8

    S = S + N

    N = N + 1

WEND

PRINT S

n = 4

s = 0

while n <= 8:

    s += n

    n += 1

print(s)

Пас­кальАл­го­рит­ми­че­ский язык

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 8 do

    begin

        s := s + n;

        n := n + 1;

    end;

    writeln(s);

end.

алг

нач

    цел n, s

    n := 4

    s := 0

    нц пока n <= 8

        s := s + n

        n := n + 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 4, s = 0;

    while (n <= 8) {

        s = s + n;

        n = n + 1;

    }

    cout << s << endl;

    return 0;

}

 

6.

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­ще­го фраг­мен­та про­грам­мы:

 

 

Бей­сикPython

DIM K, S AS INTEGER

S = 0

K = 0

WHILE S < 100

    S = S + K

    K = K + 4

WEND

PRINT K

s = 0

k = 0

while s < 100:

    s += k

    k += 4

print(k)

Пас­кальАл­го­рит­ми­че­ский язык

var k, s: integer;

begin

       s:=0;

       k:=0;

      while s < 100 do begin

            s:=s+k;

            k:=k+4;

       end;

      write(k);

end.

алг

нач

    цел k, s

    s := 0

    k := 0

    нц пока s < 100

        s := s + k

        k := k + 4

    кц

    вывод k

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 0, k = 0;

    while (s < 100) {

        s = s + k;

        k = k + 4;

    }

    cout << k << endl;

    return 0;

}

 

7.

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­ще­го фраг­мен­та про­грам­мы:

 

 

Бей­сикPython

DIM K, S AS INTEGER

S = 2

K = 2

WHILE S < 50

    S = S + K

    K = K + 2

WEND

PRINT K

s = 2

k = 2

while s < 50:

    s += k

    k += 2

print(k)

Пас­кальАл­го­рит­ми­че­ский язык

var k, s: integer;

begin

       s:=2;

       k:=2;

      while s < 50 do begin

            s:=s+k;

            k:=k+2;

       end;

      write(k);

end.

алг

нач

    цел k, s

    s := 2

    k := 2

    нц пока s < 50

        s := s + k

        k := k + 2

    кц

    вывод k

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 2, k = 2;

    while (s < 50) {

        s = s + k;

        k = k + 2;

    }

    cout << k << endl;

    return 0;

}

 

8.

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­ще­го фраг­мен­та про­грам­мы:

 

 

Бей­сикPython

DIM K, S AS INTEGER

S = 3

K = 1

WHILE K < 25

    S = S + K

    K = K + 2

WEND

PRINT S

s = 3

k = 1

while k < 25:

    s += k

    k += 2

print(s)

Пас­кальАл­го­рит­ми­че­ский язык

var k, s: integer;

begin

       s:=3;

       k:=1;

      while k < 25 do begin

            s:=s+k;

            k:=k+2;

       end;

      write(s);

end.

алг

нач

    цел k, s

    s := 3

    k := 1

    нц пока k < 25

        s := s + k

        k := k + 2

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 3, k = 1;

    while (k < 25) {

        s = s + k;

        k = k + 2;

    }

    cout << s << endl;

    return 0;

}

 

9.

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (за­пи­сан­ной ниже на раз­ных язы­ках про­грам­ми­ро­ва­ния):

 

Бей­сикПас­каль

DIM N, S AS INTEGER

N = 3

S = 0

WHILE N <= 7

S = S + N

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n := 3;

    s := 0;

    while n <= 7 do

    begin

        s := s + n;

        n := n + 1

    end;

    write(s)

end.

Си++Ал­го­рит­ми­че­ский язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 3;

    s = 0;

    while (n <= 7)

    {

        s = s + n;

        n = n + 1;

    }

    cout « s « endl;

}

алг

нач

цел n, s

n := 3

s := 0

нц пока n <= 7

    s := s + n

    n := n + 1

кц

вывод s

кон

Python

n = 3

s = 0

while n <= 7:

    s += n

    n += 1

print(s)

 

10.

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (за­пи­сан­ной ниже на раз­ных язы­ках про­грам­ми­ро­ва­ния):

 

Бей­сикПас­каль

DIM N, S AS INTEGER

N = 4

S = 0

WHILE N <= 8

S = S + N

N = N + 1

WEND

PRINT S

var n, s: integer;

begin

    n := 4;

    s := 0;

    while n <= 8 do

    begin

        s := s + n;

        n := n + 1

    end;

    write(s)

end.

Си++Ал­го­рит­ми­че­ский язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 4;

    s = 0;

    while (n <= 8)

    {

        s = s + n;

        n = n + 1;

    }

    cout « s « endl;

}

алг

нач

цел n, s

n := 4

s := 0

нц пока n <= 8

    s := s + n

    n := n + 1

кц

вывод s

кон

Python

n = 4

s = 0

while n <= 8:

    s += n

    n += 1

print(s)

 

11.

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (за­пи­сан­ной ниже на раз­ных язы­ках про­грам­ми­ро­ва­ния):

 

Бей­сикПас­каль

Dim s, k As Integer

s = 0

k = 1

while k < 11

    s = s + k

    k = k + 1

End While

Console.Write(s)

var s, k : integer;

begin

    s:=0;

    k:=1;

    while k<11 do

    begin

        s:=s+k;

        k:=k+1;

    end;

    write(s);

end.

Си++Ал­го­рит­ми­че­ский язык

#include <iostream>

using namespace std;

 

int main(){

    int s, k;

    s = 0;

    k = 1;

    while (k < 11) {

        s = s + k;

        k = k + 1;

    }

    cout « s « endl;

}

нач

цел s, k

s:=0

k:=1

нц пока k < 11

    s:=s+k; k:=k+1

кц

вывод s

кон

Python

s = 0

k = 1

while k < 11:

    s += k

    k += 1

print(s)

 

12.

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­ще­го фраг­мен­та про­грам­мы:

 

Бей­сикПас­каль

DIM s, k As Integer

s = 0

k = 0

WHILE k < 30

    k = k + 3

    s = s + k

END While

Console.Write(s)

var s, k : integer;

begin

    s:=0;

    k:=0;

    while k < 30 do

    begin

        k:=k+3;

        s:=s+k;

    end;

    write(s);

end.

Си++Ал­го­рит­ми­че­ский язык

#include <iostream>

using namespace std;

 

int main(){

    int s, k;

    s = 0;

    k = 0;

    while (k < 30) {

        k = k + 3;

        s = s + k;

    }

    cout « s « endl;

}

нач

цел s, k

s:=0

k:=0

нц пока k < 30

    k:=k+3; s:=s+k

кц

вывод s

кон

Python

s = 0

k = 0

while k < 30:

    k += 3

    s += k

print(s)

 

13.

За­пи­ши­те число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей про­грам­мы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках про­грам­ми­ро­ва­ния.

 

 

Бей­сикPython

DIM S, N AS INTEGER

S = 0

N = 6

WHILE N > 1

S = S + N

N = N − 1

WEND

PRINT S

s = 0

n = 6

while n > 1:

    s = s + n

    n = n − 1

print(s)

Пас­кальАл­го­рит­ми­че­ский язык

var s, n: integer;

begin

    s := 0;

    n := 6;

    while n > 1 do

    begin

        s := s + n;

        n := n − 1;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 0

    n := 6

    нц пока n > 1

        s := s + n

        n := n − 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 6;

    while (n > 1) {

        s = s + n;

        n = n − 1;

    }

    cout << s;

    return 0;

}

 

 

14.

За­пи­ши­те число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей про­грам­мы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках про­грам­ми­ро­ва­ния.

 

 

Бей­сикPython

DIM S, N AS INTEGER

S = 0

N = 5

WHILE N > 0

S = S + N

N = N − 1

WEND

PRINT S

s = 0

n = 5

while n > 0:

    s = s + n

    n = n − 1

print(s)

Пас­кальАл­го­рит­ми­че­ский язык

var s, n: integer;

begin

    s := 0;

    n := 5;

    while n > 0 do

    begin

        s := s + n;

        n := n − 1;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 0

    n := 5

    нц пока n > 0

        s := s + n

        n := n − 1

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 0, n = 5;

    while (n > 0) {

        s = s + n;

        n = n − 1;

    }

    cout << s;

    return 0;

}