СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
Информатика
Cайты, меню, вход, новости


Варианты заданий
Версия для печати и копирования в MS Word
1
Задание 20 № 3508

Ниже на 5-ти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает начала 2, а потом 14.

 

Бэйсик Паскаль

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 1

WHILE X > 0

    A = A + 1

    B = B * (X MOD 10)

    X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b : integer;

begin

readln(x);

a := 0; b := 1;

while x > 0 do

    begin

        a := a + 1;

        b := b * (x mod 10);

        x := x div 10;

    end;

writeln(a); write(b);

end.

Си++ Алгоритмический
#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 1;

    while (x > 0){

        a = a + 1;

        b = b *(x%10);

        x= x / 10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a := 0; b := 1

нц пока x > 0

    a := a+1

    b := b * mod(x,10)

    x := div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 1

while x > 0:

    a += 1

    b *= x % 10

    x = x // 10

print(a)

print(b)

 


Аналоги к заданию № 7996: 3508 3531 3814 4694 4726 Все

Решение · · Видеокурс ·

2
Задание 20 № 3531

Ниже на 5-ти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 72.

 

Бэйсик Паскаль

DIM X, A, B AS INTEGER

INPUT X

A=0: B=1

WHILE X > 0

    A = A+1

    B = B*(X MOD 10)

    X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b: integer;

begin

    readln(x);

    a:=0; b:=1;

    while x>0 do

        begin

            a:=a+1;

            b:=b*(x mod 10);

            x:= x div 10;

        end;

writeln(a); write(b);

end.

Си++ Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a=0; b=1;

    while (x>0){

        a=a+1;

        b=b*(x%10);

        x= x/10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a:=0; b:=1

нц пока x>0

    a:=a+1

    b:=b*mod(x,10)

    x:=div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 1

while x > 0:

    a += 1

    b *= x % 10

    x = x // 10

print(a)

print(b)

 


Аналоги к заданию № 7996: 3508 3531 3814 4694 4726 Все


3
Задание 20 № 3814

Ниже на 5-ти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b.

 

Бэйсик Паскаль
DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 1

WHILE X > 0

    A = A + 1

    B = B * (X MOD 10)

    X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b : integer;

begin

    readln(x);

    a := 0; b := 1;

    while x > 0 do

        begin

            a := a + 1;

            b := b * (x mod 10);

            x := x div 10;

        end;

writeln(a); write(b);

end.

Си++ Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 1;

    while (x > 0){

        a = a + 1;

        b = b *(x%10);

        x= x / 10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a := 0; b := 1

нц пока x > 0

    a := a+1

    b := b * mod(x,10)

    x := div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 1

while x > 0:

    a += 1

    b *= x % 10

    x = x // 10

print(a)

print(b)

Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 5.


Аналоги к заданию № 7996: 3508 3531 3814 4694 4726 Все

Источник: Яндекс: Тренировочная работа ЕГЭ по информатике. Вариант 1.

4
Задание 20 № 4694

Ниже на 5-ти языках записан алгоритм. Получив на вход число х, этот алгоритм печатает два числа а и Ь. Укажите наибольшее из таких чисел х, при вводе которых алгоритм печатает сначала 2, а потом 35.

 

Бэйсик Паскаль

DIM X, А, В AS INTEGER

INPUT X

А=0 : B=1

WHILE X > 0

    А = A+1

    В = В * (X MOD 10)

    X = X \ 10

WEND

PRINT А

PRINT В

var х, а, b: integer;

begin

    readln (x);

    а := 0 ; b := 1;

    while x>0 do

        begin

            a := a + 1;

            b : = b * (x mod 10);

            х := x div 10;

        end;

writeln(a); write(b);

end.

Си++ Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a=0; b=1;

    while (x>0) {

        a = a+1;

        b = b * (x%10);

        x = x/10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел х, a, b

ввод x

а := 0; Ь := 1

нц пока х>0

    а := а+1

    b := b * mod(х, 10)

    х := div(х, 10)

кц

вывод а, нc, b

кон

Python

x = int(input())

a = 0

b = 1

while x > 0:

    a += 1

    b *= x % 10

    x = x // 10

print(a)

print(b)


Аналоги к заданию № 7996: 3508 3531 3814 4694 4726 Все


5
Задание 20 № 4726

Ниже на 5-ти языках записан алгоритм. Получив на вход число х, этот алгоритм печатает два числа а и Ь. Укажите наибольшее из таких чисел х, при вводе которых алгоритм печатает сначала 2, а потом 21.

 

Бэйсик Паскаль

DIM X, А, В AS INTEGER

INPUT X

А=0 : B=1

WHILE X > 0

    А = A+1

    В = В*(X MOD 10)

    X = X \ 10

WEND

PRINT А

PRINT В

var х, а, b: integer;

begin

    readln (x) ;

    а: = 0 ; b : = 1;

    while x>0 do

        begin

        а : = a + 1 ;

        b : = b*(x mod 10) ;

        х : = x div 10;

        end;

writeln(a); write(b);

end.

Си++ Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a=0; b=1;

    while (x>0){

        a = a+1 ;

        b = b*(x%10);

        x = x /10 ;

    }

    cout << a << endl << b endl;

}

алг

нач

цел х, a, b

ввод x

а : = 0; Ь : = 1

нц пока х>0

    а := а+1

    b := b*mod(х,10)

    х:=div(х,10)

кц

вывод а, нc, b

кон

Python

x = int(input())

a = 0

b = 1

while x > 0:

    a += 1

    b *= x % 10

    x = x // 10

print(a)

print(b)


Аналоги к заданию № 7996: 3508 3531 3814 4694 4726 Все