СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
Информатика
Cайты, меню, вход, новости


Варианты заданий
Версия для печати и копирования в MS Word
1
Задание 20 № 7704

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которого алгоритм печатает сначала 2, а потом 22.

 

БейсикPython

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

A = A+1

B = B + (X MOD 100)

X = X\100

WEND

PRINT A

PRINT B

x = int(input())

a, b = 0, 0

while x > 0:

a = a + 1

b = b + x%100

x = x//100

print(a)

print(b)

ПаскальАлгоритмический язык

var x, a, b: integer;

begin

readln(x);

a := 0; b := 0;

while x > 0 do

begin

a := a+1;

b := b+(x mod 100);

x := x div 100;

end;

writeln(a); write(b);

end.

алг

нач

цел x, a, b

ввод x

a:=0; b:=0

нц пока x > 0

a := a+1

b := b+mod(x,100)

x := div(x,100)

кц

вывод a, нс, b

кон

Си++

#include <iostream>

using namespace std;

int main()

{

int x, a, b;

cin >> x;

a = 0; b = 0;

while (x > 0) {

a = a+1;

b = b + (x%100);

x = x/100;

}

cout << a << endl << b endl;

}

 


Аналоги к заданию № 7677: 3544 4851 4939 6191 6236 6895 6927 7704 Все


2
Задание 20 № 3544

Ниже на 5-ти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 10.

 

Бэйсик Паскаль

DIM X, A, B AS INTEGER

INPUT X

A=0: B=0

WHILE X > 0

    A = A+1

    B = B +(X MOD 10)

    X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b: integer;

begin

    readln(x);

    a:=0; b:=0;

    while x>0 do

        begin

            a:=a+1;

            b:=b + (x mod 10);

            x:=x div 10;

        end;

    writeln(a); write(b);

end.

Си++ Алгоритмический

#include <iostream>

using namespace std;

int main()

{

int x, a, b;

    cin >> x;

    a=0; b=0;

    while (x>0){

        a = a+1;

        b = b + (x%10);

        x = x/10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a:=0; b:=0

нц пока x>0

    a:=a+1

    b:=b+mod(x,10)

    x:=div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 0

while x > 0:

    a += 1

    b += x % 10

    x = x // 10

print(a)

print(b)

 


Аналоги к заданию № 7677: 3544 4851 4939 6191 6236 6895 6927 7704 Все


3
Задание 20 № 4851

Ниже на 5-ти языках программирования записан алгоритм. Получив на вход число х, этот алгоритм печатает два числа а и Ь. Укажите наименьшее из таких чисел х. при вводе которых алгоритм печатает сначала 3. а потом 7.

 

 

БейсикПаскаль

DIM X, A, B AS INTEGER

INPUT X

A=0: B=0

WHILE X > 0

        A = A + 1

        B = B + (X MOD 10)

        X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b: integer;

begin

    readln(x);

    a: = 0; b: = 0;

    while x>0 do

        begin

            a : = a + 1;

            b : = b + (x mod 10);

            x : = x div 10

        end;

    writeln(a); write(b);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 0;

    while (x>0){

        a = a + 1;

        b=b+(x%10);

        x = x / 10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a: = 0; b: = 0

нц пока x>0

    a : = a + 1

    b : = b + mod(x,10)

    x : = div (x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 0

while x > 0:

    a += 1

    b += x % 10

    x = x // 10

print(a)

print(b)


Аналоги к заданию № 7677: 3544 4851 4939 6191 6236 6895 6927 7704 Все


4
Задание 20 № 4939

Ниже на 5-ти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 6, а потом 5.

 

Бэйсик Паскаль

DIM X, A, B AS INTEGER

INPUT X

A = 0: B = 0

WHILE X > 0

    A = A + 2

    B = B + (X MOD 10)

    X = X / 10

WEND

PRINT A

PRINT B

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 0;

    while x>0 do

        begin

            a := a + 2;

            b := b + (x mod 10);

            x:= x div 10;

        end;

    writeln(a); write(b);

end.

Си++ Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a = 0; b = 0;

    while (x > 0){

        a = a + 2;

        b = b + (x%10);

        x = x / 10;

        }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a:=0; b:=0

нц пока x > 0

    a := a + 2

    b := b+mod(x,10)

    x := div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 0

while x > 0:

    a += 2

    b += x % 10

    x = x // 10

print(a)

print(b)


Аналоги к заданию № 7677: 3544 4851 4939 6191 6236 6895 6927 7704 Все


5
Задание 20 № 6191

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 5.

 

БейсикПаскаль

DIM X, А, В AS INTEGER

INPUT X

А = 0: В = 0

WHILE X > 0

    A = A + 1

    B = B + (X MOD 10)

    X = X \ 10

WEND

PRINT А

PRINT В

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 0;

        while x>0 do

            begin

                a := a + 1;

                b := b + (x mod 10);

                x := x div 10;

            end;

        writeln(a); write(b);

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x ;

    a = 0; b = 0;

    while (x>0) {

        a = a + 1;

        b = b +(x%10);

        x = x / 10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел х, а, b

ввод x

а := 0; b := 0

нц пока х>0

    a := a+1

    b := b+mod(x,10)

    x := div(x,10)

кц

вывод а, нc, b

кон

Python

x = int(input())

a = 0

b = 0

while x > 0:

    a += 1

    b += x % 10

    x = x // 10

print(a)

print(b)


Аналоги к заданию № 7677: 3544 4851 4939 6191 6236 6895 6927 7704 Все


6
Задание 20 № 6236

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 9.

 

БейсикПаскаль

DIM X, А, В AS INTEGER

INPUT X

А = 0: В = 0

WHILE X > 0

    A = A + 1

    B = B + (X MOD 10)

    X = X \ 10

WEND

PRINT А

PRINT В

var x, a, b: integer;

begin

    readln(x);

    a := 0; b := 0;

    while x>0 do

        begin

            a := a + 1;

            b := b + (x mod 10);

            x := x div 10;

        end;

    writeln(a); write(b);

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x ;

    a = 0; b = 0;

    while (x>0) {

        a = a + 1;

        b = b +(x%10);

        x = x / 10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел х, а, b

ввод x

а := 0; b := 0

нц пока х>0

    a := a+1

    b := b+mod(x,10)

    x := div(x,10)

кц

вывод а, нc, b

кон

Python

x = int(input())

a = 0

b = 0

while x > 0:

    a += 1

    b += x % 10

    x = x // 10

print(a)

print(b)


Аналоги к заданию № 7677: 3544 4851 4939 6191 6236 6895 6927 7704 Все


7
Задание 20 № 6895

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которого алгоритм печатает сначала 3, а потом 13.

 

БейсикПаскаль

DIM X, A, B AS INTEGER

INPUT X

A=0: B=0

WHILE X > 0

    A = A+1

    B = B +(X MOD 10)

    X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b: integer;

begin

    readln(x);

    a:=0; b:=0;

    while x>0 do

        begin

            a:=a + 1;

            b:=b + (x mod 10);

            x:=x div 10;

        end;

    writeln(a); write(b);

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a=0; b=0;

    while (x>0){

        a = a+1;

        b = b +(x%10);

        x = x/10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a:=0; b:=0

нц пока x>0

    a:=a+1

    b:=b+mod(x,10)

    x:=div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 0

while x > 0:

    a += 1

    b +=x % 10

    x //= 10

print(a)

print(b)

 


Аналоги к заданию № 7677: 3544 4851 4939 6191 6236 6895 6927 7704 Все


8
Задание 20 № 6927

Ниже на пяти языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наименьшее из таких чисел x, при вводе которого алгоритм печатает сначала 3, а потом 12.

 

БейсикПаскаль

DIM X, A, B AS INTEGER

INPUT X

A=0: B=0

WHILE X > 0

    A = A+1

    B = B +(X MOD 10)

    X = X \ 10

WEND

PRINT A

PRINT B

var x, a, b: integer;

begin

    readln(x);

    a:=0; b:=0;

    while x>0 do

        begin

            a:=a + 1;

            b:=b + (x mod 10);

            x:=x div 10;

        end;

    writeln(a); write(b);

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int main()

{

    int x, a, b;

    cin >> x;

    a=0; b=0;

    while (x>0){

        a = a+1;

        b = b +(x%10);

        x = x/10;

    }

    cout << a << endl << b endl;

}

алг

нач

цел x, a, b

ввод x

a:=0; b:=0

нц пока x>0

    a:=a+1

    b:=b+mod(x,10)

    x:=div(x,10)

кц

вывод a, нс, b

кон

Python

x = int(input())

a = 0

b = 0

while x > 0:

    a += 1

    b +=x % 10

    x //= 10

print(a)

print(b)

 


Аналоги к заданию № 7677: 3544 4851 4939 6191 6236 6895 6927 7704 Все