СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Каталог заданий.
Обмен местами элементов массива

Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 19 № 7764

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 5; 1; 6; 7; 8; 8; 7; 7; 6; 9 соответственно, т.е. A[0] = 5; A[1] = 1 и т.д. Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

БейсикPython

c = 0

FOR i = 1 TO 9

    IF A(i - 1) >= A(i) THEN

        t = A(i)

        A(i) = A(i - 1)

        A(i - 1) = t

    ELSE

        c = c + 1

    ENDIF

NEXT i

c = 0

for i in range(1, 10):

    if A[i - 1] >= A[i]:

        t = A[i]

        A[i] = A[i - 1]

        A[i - 1] = t

    else:

        c = c + 1

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do

    if A[i - 1] >= A[i] then

        begin

            t := A[i];

            A[i] := A[i - 1];

            A[i - 1] := t

        end

    else

        c := c + 1;

c := 0

нц для i от 1 до 9

если A[i - 1] >= A[i] то

    t := A[i]

    A[i] := A[i - 1]

    A[i - 1] := t

иначе

    c := c + 1

все

кц

Си++

c = 0;

for (i = 1; i <= 9; i++)

    if (A[i-1] >= A[i])

    {

        t = A[i];

        A[i] = A[i - 1];

        A[i - 1] = t;

    }

    else

        c++;

 


Аналоги к заданию № 7764: 7791 Все


2
Задание 19 № 8107

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 8, 4, 3, 0, 7, 2, 1, 5, 9, 6 соответственно, т.е. A[0] = 8, A[1] = 4 и т. д. Определите значение переменной s после выполнения следующего фрагмента этой программы (записанного ниже на разных языках программирования).

 

БейсикPython

s = 0

FOR j = 0 TO 8

    IF A(j) > A(j+1) THEN

        s = s + 1

        t = A(j)

        A(j) = A(j+1)

        A(j+1) = t

    ENDIF

NEXT j

s = 0

for j in range(9):

    if A[j] > A[j+1]:

        s = s + 1

        t = A[j]

        A[j] = A[j+1]

        A[j+1] = t

ПаскальАлгоритмический язык

s := 0;

for j := 0 to 8 do

    if A[j] > A[j+1] then

    begin

        s := s + 1;

        t := A[j];

        A[j] := A[j+1];

        A[j+1] := t;

    end;

s := 0

нц для j от 0 до 8

    если A[j] > A[j+1] то

        s := s + 1

        t := A[j]

        A[j] := A[j+1]

        A[j+1] := t

    все

кц

Си++

s = 0;

for (j = 0; j < 9; j++) {

    if (A[j] > A[j+1])

    {

        s++;

        t = A[j];

        A[j] = A[j+1];

        A[j+1] = t;

    }

}

 

Источник: ЕГЭ 05.05.2015. До­сроч­ная волна.

3
Задание 19 № 8667

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 4; 2; 6; 6; 7; 7; 7; 5; 5; 9 соответственно, т.е. A[0] = 4; A[1] = 2 и т.д.

Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

Бейсик Python

c = 0

FOR i = 1 TO 9

    IF A(i - 1) >= A(i) THEN

        t = A(i)

        A(i) = A(i - 1)

        A(i - 1) = t

        c = c + 1

    ENDIF

NEXT i

c = 0

for i in range(1, 10):

    if A[i - 1] >= A[i]:

        t = A[i]

        A[i] = A[i - 1]

        A[i - 1] = t

        c = c + 1

Алгоритмический язык Паскаль

c := 0

нц для i от 1 до 9

    если A[i - 1] >= A[i] то

        t := A[i]

        A[i] := A[i - 1]

        A[i - 1] := t

        c := c + 1

    все

кц

c := 0;

for i := 1 to 9 do

    if A[i - 1] >= A[i] then

    begin

        t := A[i];

        A[i] := A[i - 1];

        A[i - 1] := t;

        c := c + 1;

    end;

Си++

c = 0;

for (i = 1; i <= 9; i++)

    if (A[i - 1] >= A[i])

    {

        t = A[i];

        A[i] = A[i - 1];

        A[i - 1] = t;

        c++;

    }


Аналоги к заданию № 8667: 9171 Все


4
Задание 19 № 9370

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 4, 7, 3, 8, 5, 0, 1, 2, 9, 6 соответственно, т.е. A[0] = 4, A[1] = 7 и т.д.

Определите значение переменной c после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

 c = 0

 FOR i = 1 TO 9

    IF A(i) < A(0) THEN

        c = c + 1

        t = A(i)

        A(i) = A(0)

        A(0) = t

    ENDIF

 NEXT i

 c = 0

 for i in range(1,10):

    if A[i] < A[0]:

        c = c + 1

        t = A[i]

        A[i] = A[0]

        A[0] = t

ПаскальАлгоритмический язык

 c := 0;

 for i := 1 to 9 do

    if A[i] < A[0] then

    begin

        c := c + 1;

        t := A[i];

        A[i] := A[0];

        A[0] := t;

    end;

 c := 0

 нц для i от 1 до 9

    если A[i] < A[0] то

        c := c + 1

        t := A[i]

        A[i] := A[0]

        A[0] := t

    все

 кц

Си++

 c = 0;

 for (i = 1;i < 10;i++)

    if (A[i] < A[0])

    {

        c++;

        t = A[i];

        A[i] = A[0];

        A[0] = t;

    }

 


Аналоги к заданию № 9370: 9769 9805 10295 10393 10420 10482 10509 Все

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2016 по информатике.

5
Задание 19 № 9769

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 6, 7, 3, 8, 5, 1, 2, 0, 9, 4 соответственно, т. е. A[0] = 6, A[1] = 7 и т. д.

Определите значение переменной c после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) < A(0) THEN

    c = c + 1

    t = A(i)

    A(i) = A(0)

    A(0) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i] < A[0]:

    c = c + 1

    t = A[i]

    A[i] = A[0]

    A[0] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do

  if A[i] < A[0] then

  begin

    c := c + 1;

    t := A[i];

    A[i] := A[0];

    A[0] := t;

end;

c := 0

нц для i от 1 до 9

  если A[i] < A[0] то

    c := c + 1

    t := A[i]

    A[i] := A[0]

    A[0] := t

  все

кц

Си++

c = 0;

for (i = 1;i < 10;i++)

  if (A[i] < A[0])

  {

    c++;

    t = A[i];

    A[i] = A[0];

    A[0] = t;

  }

 


6
Задание 19 № 11248

В про­грам­ме ис­поль­зу­ет­ся од­но­мер­ный це­ло­чис­лен­ный мас­сив A с ин­дек­са­ми от 0 до 10. Зна­че­ния эле­мен­тов равны 4, 3, 6, 8, 5, 8, 4, 2, 10, 9, 4 со­от­вет­ствен­но, т. е. A[0] = 4, A[1] = 3 и т. д. Опре­де­ли­те зна­че­ние пе­ре­мен­ной c после вы­пол­не­ния сле­ду­ю­ще­го фраг­мен­та про­грам­мы (за­пи­сан­но­го ниже на пяти язы­ках про­грам­ми­ро­ва­ния).

 

Бей­сикPython

c = 0

FOR i = 1 TO 9

  IF A(i) = A(0) THEN

    c = c + 1

    t = A(i+1)

    A(i+1) = A(i)

    A(i) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i] == A[0]:

    c = c + 1

    t = A[i+1]

    A[i+1] = A[i]

    A[i] = t

Ал­го­рит­ми­че­ский языкПас­каль

c := 0

нц для i от 1 до 9

  если A[i] = A[0] то

    c := c + 1

    t := A[i+1]

    A[i+1] := A[i]

    A[i] := t

  все

кц

c := 0;

for i := 1 to 9 do begin

  if A[i] = A[0] then begin

    c := c + 1;

    t := A[i+1];

    A[i+1] := A[i];

    A[i] := t;

  end;

end;

Си++

c = 0;

for (i = 1; i < 10; i++) {

  if (A[i] == A[0]) {

    c++;

    t = A[i+1];

    A[i+1] = A[i];

    A[i] = t;

  }

}

 


Аналоги к заданию № 11248: 11275 Все


7
Задание 19 № 11315

В программе описан одномерный целочисленный массив с индексами от 0 до 9. Ниже представлен фрагмент программы, обрабатывающей данный массив:

 

 

Бейсик Python

c = 0

FOR i = 1 TO 8

    IF A(i)=A(0) THEN

        c = c + 1

        t=A(i+1)

        A(i+1)= A(i)

        A(i)= t

    ENDIF

NEXT i

PRINT c

c = 0

for i in range(1, 9):

    if A[i] == A[0]:

        c += 1

        t=A[i+1]

        A[i+1]= A[i]

        A[i]= t

print(c)

Алгоритмический язык Паскаль

c := 0

нц для i от 1 до 8

    если A[i] = A[0] то

        c := c + 1

        t:=A[i+1]

        A[i+1]:= A[i]

        A[i]:= t

    все

кц

вывод c

c := 0;

for i := 1 to 8 do

    if A[i] = A[0] then

    begin

        inc(c);

        t:=A[i+1];

        A[i+1]:= A[i];

        A[i]:= t;

    end;

writeln(c);

Си++

c = 0;

for (i = 1; i <= 8; i++)

    if (A[i] == A[0])

    {

        c++;

        t=A[i+1];

        A[i+1]= A[i];

        A[i]= t;

    }

cout « c « endl;

 

В начале выполнения этого фрагмента в массиве находились числа 3, 2, 4, 6, 3, 10, 12, 14, 16, 18 т. е. А[0]=3, А[1]=2 и т. д. Чему будет равно значение переменной с после выполнения данной программы?

Источник: ЕГЭ 16.06.2016 по информатике. Основная волна.

8
Задание 19 № 11355

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 1, 2, 5, 8, 9, 3, 4, 0, 7, 6 соответственно, т. е. A[0] = 1, A[1] = 2 и т. д.

Определите значение переменной j после выполнения следующего фрагмента программы (записанного ниже на пяти языках программирования).

 

БейсикPython

j = 5

WHILE A(j) < A(j-1)

    t = A(j)

    A(j) = A(j-1)

    A(j-1) = t

    j = j - 1

WEND

j = 5

while A[j] < A[j-1]:

    A[j],A[j-1]=A[j-1],A[j]

    j -= 1

ПаскальАлгоритмический язык

j := 5;

while A[j] < A[j-1] do

    begin

        t := A[j];

        A[j] := A[j-1];

        A[j-1] := t;

        j := j - 1;

    end;

j := 5

нц пока A[j] < A[j-1]

    t := A[j]

    A[j] := A[j-1]

    A[j-1] := t

    j := j - 1

кц

Си++

j = 5;

while (A[j] < A[j-1])

    {

        t = A[j];

        A[j] = A[j-1];

        A[j-1] = t;

        j -= 1;

    }

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2017 по информатике.

9
Задание 19 № 13549

В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Значения элементов равны 4, 3, 16, 24, 35, 18, 4, 72, 10, 99, 44 соответственно, т. е. A[0] = 4, A[1] = 3 и т. д.

Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на пяти языках программирования.

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) MOD 10 = A(0) THEN

      c = c + 1

      t = A(i+1)

      A(i+1) = A(i)

      A(i) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i]%10 == A[0]:

      c = c + 1

      t = A[i+1]

     A[i+1] = A[i]

     A[i] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do begin

  if A[i] mod 10 = A[0] then

  begin

      c := c + 1;

      t := A[i+1];

      A[i+1] := A[i];

      A[i] := t;

  end;

end;

c := 0

нц для i от 1 до 9

  если mod(A[i],10) = A[0] то

      c := c + 1

      t := A[i+1]

      A[i+1] := A[i]

      A[i] := t

  все

кц

Си++

c = 0;

for (i = 1; i < 10; i++) {

  if (A[i]%10 == A[0]) {

      c++;

      t = A[i+1];

      A[i+1] = A[i];

      A[i] = t;

  }

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10103

10
Задание 19 № 13576

В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Значения элементов равны 8, 3, 16, 24, 35, 18, 4, 72, 8, 99, 44 соответственно, т. е. A[0] = 8, A[1] = 3 и т. д.

Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на пяти языках программирования.

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) MOD 10 = A(0) THEN

    c = c + 1

    t = A(i+1)

    A(i+1) = A(i)

    A(i) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i]%10 == A[0]:

    c = c + 1

    t = A[i+1]

    A[i+1] = A[i]

    A[i] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do begin

if A[i] mod 10 = A[0] then

  begin

    c := c + 1;

    t := A[i+1];

    A[i+1] := A[i];

    A[i] := t;

  end;

end;

c := 0

нц для i от 1 до 9

  если mod(A[i],10) = A[0] то

    c := c + 1

    t := A[i+1]

    A[i+1] := A[i]

    A[i] := t

  все

кц

Си++

c = 0;

for (i = 1; i < 10; i++) {

  if (A[i]%10 == A[0]) {

    c++;

    t = A[i+1];

    A[i+1] = A[i];

    A[i] = t;

  }

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10104

11
Задание 19 № 13746

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 3, 0, 4, 6, 5, 1, 8, 2, 9, 7 соответственно, т. е. A[0] = 3, A[1] = 0 и т. д. Определите значение переменной c после выполнения следующего фрагмента этой программы (записанного ниже на разных языках программирования)

 

БейсикPython

c = 0

FOR i = 1 TO 9

    IF A(i-1) > A(i) THEN

       c = c + 1

       t = A(i)

       A(i) = A(i-1)

       A(i-1) = t

    END IF

NEXT i

c = 0

for i in range(1,10):

    if A[i-1] > A[i]:

       c = c + 1

       t = A[i]

       A[i] = A[i-1]

       A[i-1] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do

    if A[i-1] > A[i] then

    begin

        c := c + 1;

        t := A[i];

        A[i] := A[i-1];

         A[i-1] := t;

    end;

c := 0

нц для i от 1 до 9

     если A[i-1] > A[i] то

       c := c + 1

       t := A[i]

       A[i] := A[i-1]

       A[i-1] := t

     все

кц

Си++

c = 0;

for (int i = 1; i < 10; i++) {

     if (A[i-1] > A[i]){

        c++;

        t = A[i];

        A[i] = A[i-1];

        A[i-1] = t;

    }

}

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2018 по информатике.

12
Задание 19 № 15804

Представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 1 до 10. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 3, 4, 4, 10, 4, 5, 6, 12, 9 (т.е. A[1] = 2, A[2] = 3, .., A[10] = 9). Определите значение переменной s после выполнения фрагмента этой программы (записанного ниже на разных языках программирования).

 

 

БейсикPython

n = 10

s = 0

FOR i = 2 TO n

    IF A(i-1) < A(i) THEN

        T = A(i−1)

        A(i−1) = A(i)

        A(i) = T + 1

        s = s + 1

    END IF

NEXT i

 

n = 10

s = 0

for i in range(1,n):

    if A[i-1] < A[i]:

        t = A[i−1]

        A[i−1] = A[i]

        A[i] = t + 1

        s = s + 1

 

 

 

ПаскальАлгоритмический язык

 

n := 10;

s := 0;

for i:=2 to n do begin

    if A[i-1] < A[i] then begin

        t := A[i−1];

        A[i−1] := A[i];

        A[i] := t + 1;

        s := s + 1

    end

end;

 

n := 10

s := 0

нц для i от 2 до n

    если A[i-1] < A[i] то

        t := A[i−1]

        A[i−1] = A[i]

        A[i] := t + 1

        s := s + 1

    все

кц

С++

n = 10;

s = 0;

for (i = 1; i < n; ++i) {

    if (A[i-1] < A[i]) {

        t = A[i-1];

        A[i-1] = A[i];

        A[i] = t + 1;

        s = s + 1;

    }

}

 


13
Задание 19 № 15831

Представленный ниже фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 1 до 10. Перед началом выполнения данного фрагмента эти элементы массива имели значения 7, 8, 8, 1, 2, 2, 3, 3, 8, 5 (т.е. A[1] = 7, A[2] = 8, …, A[10] = 5). Определите значение переменной s после выполнения фрагмента этой программы (записанного ниже на разных языках программирования).

 

 

БейсикPython

n = 10

s = 0

FOR i = 2 TO n

    IF A(i-1) < A(i) THEN

        T = A(i−1)

        A(i−1) = A(i)

        A(i) = T + 1

        s = s + 1

    END IF

NEXT i

 

n = 10

s = 0

for i in range(2,n+1):

    if A[i-1] < A[i]:

        t = A[i−1]

        A[i−1] = A[i]

        A[i] = t + 1

        s = s + 1

 

 

 

ПаскальАлгоритмический язык

 

n := 10;

s := 0;

for i:=2 to n do begin

    if A[i-1] < A[i] then begin

        t := A[i−1];

        A[i−1] = A[i];

        A[i] := t + 1;

        s := s + 1

    end

end;

 

n := 10

s := 0

нц для i от 2 до n

    если A[i-1] < A[i] то

        t := A[i−1]

        A[i−1] = A[i]

        A[i] := t + 1

        s := s + 1

    все

кц

С++

n = 10;

s = 0;

for (i = 2; i < n+1; ++i) {

    if (A[i-1] < A[i]) {

        t = A[i-1];

        A[i-1] = A[i];

        A[i] = t + 1;

        s = s + 1;

    }

}

 


14
Задание 19 № 15859

В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Значения элементов равны 3, 0, 9, 7, 8, 1, 5, 10, 2, 6, 4 соответственно, т.е. A[0] = 3, A[1] = 0 и т.д.

Определите значение переменной c после выполнения следующего фрагмента этой программы, записанного ниже на пяти языках программирования.

 

БейсикPython

с = 0

FOR i = 1 TO 10

    IF A(i − 1) > A(i) THEN

        c = c + 1

        t = A(i)

        A(i) = A(i − 1)

        A(i − 1) = t

    END IF

NEXT i

c = 0

for i in range(1, 11):

    if A[i − 1] > A[i]:

        c = c + 1

        t = A[i]

        A[i] = A[i − 1]

        A[i − 1] = t

ПаскальАлгоритмический язык

c := 0;

for i:=1 to 10 do

    if A[i − 1] > A[i] then

    begin

        c := c + 1;

        t := A[i];

        A[i] = A[i − 1];

        A[i − 1] = t;

    end;

c := 0

нц для i от 1 до 10

    если A[i − 1] > A[i] то

        c := c + 1

        t := A[i]

        A[i] := A[i − 1]

        A[i − 1] := t

     все

кц

Си++

c = 0;

for (i=1; i<11; i++)

      if (A[i − 1] > A[i])

      {

        c++;

        t = A[i];

        A[i] = A[i − 1];

        A[i − 1] = t;

      }

 

Источник: ЕГЭ — 2018. До­сроч­ная волна. Вариант 2., ЕГЭ — 2018. До­сроч­ная волна. Вариант 1.

15
Задание 19 № 15987

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 3, 5, 3, 7, 8, 4, 2, 5, 1 (т. е. A[0] = 2, A[1] = 3, …, A[9] = 1). Определите значение переменной b после выполнения фрагмента.

 

 

БейсикPython

b = 0

FOR i = 1 TO 9

    IF A(i-1) < A(i) THEN

        t = A(i)

        A(i) = A(i-1)

        A(i-1) = t

        b = b + 1

    END IF

NEXT i

 

b = 0

for i in range(1,10):

    if A[i-1] < A[i]:

        t = A[i]

        A[i] = A[i-1]

        A[i-1] = t

        b = b + 1

 

 

 

ПаскальАлгоритмический язык

b := 0;

for i:=1 to 9 do begin

    if A[i-1] < A[i] then begin

        t := A[i];

        A[i] := A[i-1];

        A[i-1] := t;

        b := b + 1

    end

end;

 

b := 0

нц для i от 1 до 9

    если A[i-1] < A[i] то

        t := A[i]

        A[i] := A[i-1]

        A[i-1] := t

        b := b + 1

    все

кц

С++

b = 0;

for (i = 1; i <= 9; ++i) {

    if (A[i-1] < A[i]) {

        t = A[i];

        A[i] = A[i-1];

        A[i-1] = t;

        b = b + 1;

    }

}

 

Источник: ЕГЭ по информатике 28.05.2018. Основная волна, вариант А. Имаева — «Котолис».

16
Задание 19 № 16046

В про­грам­ме ис­поль­зу­ет­ся од­но­мер­ный це­ло­чис­лен­ный мас­сив A с ин­дек­са­ми от 0 до 9. Зна­че­ния эле­мен­тов равны 2, 4, 3, 6, 3, 7, 8, 2, 9, 1 со­от­вет­ствен­но, т.е. A[0] = 2, A[1] = 4 и т.д.

Опре­де­ли­те зна­че­ние пе­ре­мен­ной c после вы­пол­не­ния сле­ду­ю­ще­го фраг­мен­та этой про­грам­мы, за­пи­сан­но­го ниже на пяти язы­ках про­грам­ми­ро­ва­ния.

 

Бей­сикPython

c = 0

FOR i = 1 TO 9

    IF A(i-1) < A(i) THEN

       c = c + 1

       t = A(i)

       A(i) = A(i-1)

       A(i-1) = t

    END IF

NEXT i

c = 0

for i in range(1,10):

    if A[i-1] < A[i]:

       c = c + 1

       t = A[i]

       A[i] = A[i-1]

       A[i-1] = t

Пас­кальАл­го­рит­ми­че­ский язык

c := 0;

for i := 1 to 9 do

    if A[i-1] < A[i] then

    begin

        c := c + 1;

        t := A[i];

        A[i] := A[i-1];

         A[i-1] := t;

    end;

c := 0

нц для i от 1 до 9

     если A[i-1] < A[i] то

       c := c + 1

       t := A[i]

       A[i] := A[i-1]

       A[i-1] := t

     все

кц

Си++

c = 0;

for (int i = 1; i < 10; i++) {

     if (A[i-1] < A[i]){

        c++;

        t = A[i];

        A[i] = A[i-1];

        A[i-1] = t;

    }

}

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2019 по информатике.

17
Задание 19 № 16822

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 3, 5, 4, 2, 7, 4, 3, 1, 2, 6 (т.е. A[0] = 3, A[1] = 5, …, A[9] = 6). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

N = 9

s = 0

FOR i = 0 TO N

    IF A(i) < A(N) THEN

        A(i) = A(i) + 1

        A(N) = A(N) − 1

        s = s + 1

    END IF

NEXT i

 

n = 9

s = 0

for i in range(n + 1):

    if A[i] < A[n]:

        A[i] += 1

        A[n] −= 1

        s += 1

 

 

 

ПаскальАлгоритмический язык

N := 9;

s := 0;

for i:=0 to N do begin

    if A[i] < A[N] then begin

        A[i] := A[i] + 1;

        A[N] := A[N] − 1;

        s := s + 1;

    end;

end;

 

N := 9

s := 0

нц для i от 0 до N

    если A[i] < A[N] то

        A[i] := A[i] + 1

        A[N] := A[N] − 1

        s := s + 1

    все

кц

С++

n = 9;

s = 0;

for (i = 0; i <= n; ++i) {

    if (A[i] < A[n]) {

        A[i] = A[i] + 1;

        A[n] = A[n] − 1;

        s = s + 1;

    }

}

 


18
Задание 19 № 16895

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 4, 8, 6, 1, 7, 2, 3, 2, 7 (т.е. A[0] = 2, A[1] = 4, …, A[9] = 7). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

N = 9

s = 0

FOR i = 0 TO N

    IF A(i) < A(N) THEN

        A(i) = A(i) + 1

        A(N) = A(N) − 1

        s = s + 1

    END IF

NEXT i

 

n = 9

s = 0

for i in range(n + 1):

    if A[i] < A[n]:

        A[i] += 1

        A[n] −= 1

        s += 1

 

 

 

ПаскальАлгоритмический язык

N := 9;

s := 0;

for i:=0 to N do begin

    if A[i] < A[N] then begin

        A[i] := A[i] + 1;

        A[N] := A[N] − 1;

        s := s + 1;

    end;

end;

 

N := 9

s := 0

нц для i от 0 до N

    если A[i] < A[N] то

        A[i] := A[i] + 1

        A[N] := A[N] − 1

        s := s + 1

    все

кц

С++

n = 9;

s = 0;

for (i = 0; i <= n; ++i) {

    if (A[i] < A[n]) {

        A[i] = A[i] + 1;

        A[n] = A[n] − 1;

        s = s + 1;

    }

}

 


19
Задание 19 № 17337

Пред­став­лен­ный ниже на пяти язы­ках про­грам­ми­ро­ва­ния фраг­мент про­грам­мы об­ра­ба­ты­ва­ет эле­мен­ты од­но­мер­но­го це­ло­чис­лен­но­го мас­си­ва A с ин­дек­са­ми от 0 до 9. Перед на­ча­лом вы­пол­не­ния дан­но­го фраг­мен­та эти эле­мен­ты мас­си­ва имели зна­че­ния 3, 5, 8, 2, 1, 4, 3, 1, 2, 6 (т.е. A[0] = 3, A[1] = 5, …, A[9] = 6). Опре­де­ли­те зна­че­ние пе­ре­мен­ной s после вы­пол­не­ния фраг­мен­та.

 

 

Бей­сикPython

s = 0

FOR i = 0 TO 8

    IF A(i) < A(9) THEN

        t = A(i)

        A(i) = A(8 − i)

        A(8 − i) = t

        s = s + t

    END IF

NEXT i

 

s = 0

for i in range(0, 9):

    if A[i] < A[9]:

        t = A[i]

        A[i] = A[8 − i]

        A[8 − i] = t

        s = s + t

 

 

 

Пас­кальАл­го­рит­ми­че­ский язык

s := 0;

for i:=0 to 8 do begin

    if A[i] < A[9] then begin

        t := A[i];

        A[i] := A[8 − i];

        A[8 − i] := t;

        s := s + t;

    end;

end;

 

s := 0

нц для i от 0 до 8

    если A[i] < A[9] то

        t := A[i]

        A[i] := A[8 − i]

        A[8 − i] := t

        s := s + t

    все

кц

С++

s = 0;

for (i = 0; i <= 8; ++i) {

    if (A[i] < A[9]) {

        t = A[i];

        A[i] = A[8 − i];

        A[8 − i] = t;

        s = s + t;

    }

}

 


20
Задание 19 № 17383

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения, 2, 4, 8, 6, 1, 7, 2, 3, 6, 7 ( т. е. A[0] = 2, A[1] = 4, …, A[9] = 7). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

s = 0

FOR i = 0 TO 8

    IF A(i) < A(9) THEN

        t = A(i)

        A(i) = A(8 − i)

        A(8 − i) = t

        s = s + t

    END IF

NEXT i

 

s = 0

for i in range(0, 9):

    if A[i] < A[9]:

        t = A[i]

        A[i] = A[8 − i]

        A[8 − i] = t

        s = s + t

 

 

 

ПаскальАлгоритмический язык

s := 0;

for i:=0 to 8 do begin

    if A[i] < A[9] then begin

        t := A[i];

        A[i] := A[8 − i];

        A[8 − i] := t;

        s := s + t;

    end;

end;

 

s := 0

нц для i от 0 до 8

    если A[i] < A[9] то

        t := A[i]

        A[i] := A[8 − i]

        A[8 − i] := t

        s := s + t

    все

кц

С++

s = 0;

for (i = 0; i <= 8; ++i) {

    if (A[i] < A[9]) {

        t = A[i];

        A[i] = A[8 − i];

        A[8 − i] = t;

        s = s + t;

    }

}

 


21
Задание 19 № 18088

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 11. Перед началом выполнения данного фрагмента эти элементы массива имели значения 20, 19, 33, 21, 42, 13, 12, 24, 4, 22, 6, 10 (т.е. A[0] = 20, A[1] = 19, …, A[11] = 10). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

N = 1

S = 1

FOR I = 1 TO 11

    IF A(I) < A(N) THEN

        S = S * I

        T = A(I)

        A(I) = A(N)

        A(N) = t

    END IF

NEXT I

 

n = 1

s = 1

for i in range(1, 12):

    if A[i] < A[n]:

        s = s * i

        t = A[i]

        A[i] = A[n]

        A[n] = t

 

 

 

ПаскальАлгоритмический язык

n:= 1;

s:= 1;

for i:=1 to 11 do

    if A[i] < A[n] then begin

        s := s * i;

        t := A[i];

        A[i] := A[n];

        A[n] := t;

    end;

 

s := 1

n := 1

нц для i от 1 до 11

    если A[i] < A[n] то

        s := s * i

        t := A[i]

        A[i] := A[n]

        A[n] := t;

    все

кц

С++

n = 1;

s = 1;

for (i = 1; i < 12; i++) {

    if (A[i] < A[n]) {

        s = s * i;

        t = A[i];

        A[i] = A[n];

        A[n] = t;

    }

}

 

Источник: ЕГЭ — 2019. До­сроч­ная волна. Вариант 1.

22
Задание 19 № 18447

В программе используется одномерный целочисленный массив A с индексами от 0 до 11. Значения элементов равны 5, 8, 7, 11, 10, 12, 9, 6, 4, 13, 3, 15 соответственно, т.е. A[0] = 5, A[1] = 8 и т.д. Определите значение переменной s после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

 

БейсикPython

N = 0

S = 0

FOR I = 1 TO 11

    IF A(I) > A(N) THEN

        S = S + 1

        T = A(I)

        A(I) = A(N)

        A(N) = t

    END IF

NEXT I

 

n = 0

s = 0

for i in range(1, 12):

    if A[i] > A[n]:

        s = s + 1

        t = A[i]

        A[i] = A[n]

        A[n] = t

 

 

 

ПаскальАлгоритмический язык

s:= 0;

n:= 0;

for i:=1 to 11 do

    if A[i] > A[n] then begin

        s := s + 1;

        t := A[i];

        A[i] := A[n];

        A[n] := t;

    end;

 

s := 0

n := 0

нц для i от 1 до 11

    если A[i] > A[n] то

        s := s + 1

        t := A[i]

        A[i] := A[n]

        A[n] := t;

    все

кц

С++

n = 0;

s = 0;

for (i = 1; i < 12; i++) {

    if (A[i] > A[n]) {

        s++;

        t = A[i];

        A[i] = A[n];

        A[n] = t;

    }

}

 

Источник: ЕГЭ — 2019. До­сроч­ная волна. Вариант 2.

23
Задание 19 № 18500

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 4, 6, 1, 7, 2, 3, 6, 7, 2 (т. е. A[0] = 2, A[1] = 4, …, A[9] = 2). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

s = 0

FOR i = 1 TO 9

    IF A(0) < A(i) THEN

        A(0) = A(0) + A(i)

    ELSE

        A(0) = A(0) - A(i)

    END IF

    s = s + A(0)

NEXT i

s = 0

for i in range(1,10):

    if A[0] < A[i]:

        A[0] += A[i]

    else:

        A[0] -= A[i]

    s += A[0]

 

 

 

ПаскальАлгоритмический язык

s := 0;

for i:=1 to 9 do begin

    if A[0] < A[i]

        then A[0] := A[0] + A[i]

        else A[0] := A[0] - A[i];

    s := s + A[0]

end;

 

s := 0

нц для i от 1 до 9

    если A[0] < A[i]

        то A[0] := A[0] + A[i]

        иначе A[0] := A[0] - A[i]

    все

    s := s + A[0]

кц

С++

s = 0;

for (i = 1; i < 10; ++i) {

    if (A[0] < A[i])

        A[0] += A[i];

    else

        A[0] -= A[i];

    s += A[0];

}

 


Аналоги к заданию № 18500: 18631 Все


24
Задание 19 № 18721

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 3, 4, 4, 10, 4, 5, 6, 12, 9 (т. е. A[0] = 2, A[1] = 3, …, A[9] = 9). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

n = 3

s = 0

FOR i = 0 TO 9

    IF A(i) <= A(n) THEN

        t = A(i MOD n)

        A(i MOD n) = A(n)

        A(n) = t

        s = s + 1

    END IF

NEXT i

 

n = 3

s = 0

for i in range(0,10):

    if A[i] <= A[n]:

        t = A[i % n]

        A[i % n] = A[n]

        A[n] = t

        s = s + 1

 

 

 

ПаскальАлгоритмический язык

n := 3;

s := 0;

for i:=0 to 9 do begin

    if A[i] <= A[n] then begin

        t := A[i mod n];

        A[i mod n] := A[n];

        A[n] := t;

        s := s + 1

    end

end;

 

n := 3

s := 0

нц для i от 1 до 9

    если A[i] <= A[n] то

        t := A[mod(i,n)]

        A[mod(i,n)] := A[n]

        A[n] := t

        s := s + 1

    все

кц

С++

n = 3;

s = 0;

for (i = 1; i <= 9; ++i) {

    if (A[i] <= A[n]) {

        t = A[i % n];

        A[i % n] = A[n];

        A[n] = t;

        s = s + 1;

    }

}

 

Источник: ЕГЭ по информатике 13.06.2019. Основная волна, Восток. Вариант Имаева-Зубовой — «Котолис».

25
Задание 19 № 18798

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 3, 5, 6, 10, 4, 8, 6, 12, 9 (т. е. A[0] = 2, A[1] = 3, …, A[9] = 9). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

n = 6

s = 0

FOR i = 0 TO 9

    IF A(i) > A(n) THEN

        s = s + (A(i) MOD A(n))

        t = A(i)

        A(i) = A(n)

        A(n) = t

    END IF

NEXT i

 

n = 6

s = 0

for i in range(0,10):

    if A[i] > A[n]:

        s += A[i] % A[n]

        t = A[i]

        A[i] = A[n]

        A[n] = t

 

 

 

ПаскальАлгоритмический язык

n := 6;

s := 0;

for i:=0 to 9 do begin

    if A[i] > A[n] then begin

        s := s + (A[i] mod A[n]);

        t := A[i];

        A[i] := A[n];

        A[n] := t;

    end

end;

 

n := 6

s := 0

нц для i от 1 до 9

    если A[i] > A[n] то

        s := s + mod(A[i], A[n])

        t := A[i]

        A[i] := A[n]

        A[n] := t

    все

кц

С++

n = 6;

s = 0;

for (i = 1; i <= 9; ++i) {

    if (A[i] > A[n]) {

        s += A[i] % A[n];

        t = A[i];

        A[i] = A[n];

        A[n] = t;

    }

}

 

Источник: ЕГЭ по информатике 13.06.2019. Основная волна, Центр. Вариант Имаева-Зубовой — «Котолис».

26
Задание 19 № 19068

В программе используется одномерный целочисленный массив A с индексами от 0 до 11. Значения элементов равны 20, 19, 17, 41, 23, 12, 24, 16, 4, 13, 6, 15 соответственно, т.е. A[0] = 20, A[1] = 19 и т.д. Определите значение переменной s после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

s = 0

n = 0

FOR i = 0 TO 11

    IF A(i) <= A(n) THEN

        s = s + i

        t = A(i)

        A(i) = A(n)

        A(n) = t

    END IF

NEXT i

s = 0

n = 0

for i in range(12):

    if A[i] <= A[n]:

        s += i

        t = A[i]

        A[i] = A[n]

        A[n] = t

ПаскальАлгоритмический язык

s := 0;

n := 0;

for i := 0 to 11 do

    if A[i] <= A[n] then

    begin

        s := s + i;

        t := A[i];

        A[i] := A[n];

        A[n] := t

    end;

s := 0

n := 0

нц для i от 0 до 11

    если A[i] <= A[n] то

        s := s + i

        t := A[i]

        A[i] := A[n]

        A[n] := t

    все

кц

Си++

n = 0;

for (int i = 0; i < 12; i++)

    if (A[i] <= A[n]){

        s += i;

        t = A[i];

        A[i] = A[n];

        A[n] = t;

    }

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2020 по информатике.

Пройти тестирование по этим заданиям