СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
Информатика
Cайты, меню, вход, новости


Варианты заданий
Версия для печати и копирования в MS Word
1
Задание 19 № 9769

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 6, 7, 3, 8, 5, 1, 2, 0, 9, 4 соответственно, т. е. A[0] = 6, A[1] = 7 и т. д.

Определите значение переменной c после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) < A(0) THEN

    c = c + 1

    t = A(i)

    A(i) = A(0)

    A(0) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i] < A[0]:

    c = c + 1

    t = A[i]

    A[i] = A[0]

    A[0] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do

  if A[i] < A[0] then

  begin

    c := c + 1;

    t := A[i];

    A[i] := A[0];

    A[0] := t;

end;

c := 0

нц для i от 1 до 9

  если A[i] < A[0] то

    c := c + 1

    t := A[i]

    A[i] := A[0]

    A[0] := t

  все

кц

Си++

c = 0;

for (i = 1;i < 10;i++)

  if (A[i] < A[0])

  {

    c++;

    t = A[i];

    A[i] = A[0];

    A[0] = t;

  }

 


Аналоги к заданию № 9370: 9769 9805 10295 10393 10420 10482 10509 Все


2
Задание 19 № 9805

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 6, 7, 5, 8, 3, 2, 0, 1, 9, 4 соответственно, т. е. A[0] = 6, A[1] = 7 и т. д. Определите значение переменной c после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) < A(0) THEN

    c = c + 1

    t = A(i)

    A(i) = A(0)

    A(0) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i] < A[0]:

    c = c + 1

    t = A[i]

    A[i] = A[0]

    A[0] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do

  if A[i] < A[0] then

  begin

    c := c + 1;

    t := A[i];

    A[i] := A[0];

    A[0] := t;

end;

c := 0

нц для i от 1 до 9

  если A[i] < A[0] то

    c := c + 1

    t := A[i]

    A[i] := A[0]

    A[0] := t

  все

кц

Си++

c = 0;

for (i = 1;i < 10;i++)

  if (A[i] < A[0])

  {

    c++;

    t = A[i];

    A[i] = A[0];

    A[0] = t;

  }

 


Аналоги к заданию № 9370: 9769 9805 10295 10393 10420 10482 10509 Все


3
Задание 19 № 10295

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 6, 7, 3, 8, 5, 1, 2, 0, 9, 4 соответственно, то есть A[0] = 6, A[1] = 7 и так далее.

Определите значение переменной c после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) < A(0) THEN

    c = c + 1

    t = A(i)

    A(i) = A(0)

    A(0) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i] < A[0]:

    c = c + 1

    t = A[i]

    A[i] = A[0]

    A[0] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do

  if A[i] < A[0] then

  begin

    c := c + 1;

    t := A[i];

    A[i] := A[0];

    A[0] := t;

end;

c := 0

нц для i от 1 до 9

  если A[i] < A[0] то

    c := c + 1

    t := A[i]

    A[i] := A[0]

    A[0] := t

  все

кц

Си++

c = 0;

for (i = 1;i < 10;i++)

  if (A[i] < A[0])

  {

    c++;

    t = A[i];

    A[i] = A[0];

    A[0] = t;

  }

}

 


Аналоги к заданию № 9370: 9769 9805 10295 10393 10420 10482 10509 Все


4
Задание 19 № 10393

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 4, 4, 6, 8, 5, 8, 2, 10, 9, 14 соответственно, то есть A[0] = 4, A[1] = 4 и так далее.

Определите значение переменной c после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) > A(0) THEN

    c = c + 1

    t = A(i)

    A(i) = A(0)

    A(0) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i] > A[0]:

    c = c + 1

    t = A[i]

    A[i] = A[0]

    A[0] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do begin

  if A[i] > A[0] then

  begin

    c := c + 1;

    t := A[i];

    A[i] := A[0];

    A[0] := t;

  end;

end;

c := 0

нц для i от 1 до 9

  если A[i] > A[0] то

    c := c + 1

    t := A[i]

    A[i] := A[0]

    A[0] := t

  все

кц

Си++

c = 0;

for (i = 1; i < 10; i++) {

  if (A[i] > A[0]) {

    c++;

    t = A[i];

    A[i] = A[0];

    A[0] = t;

  }

}

 


Аналоги к заданию № 9370: 9769 9805 10295 10393 10420 10482 10509 Все


5
Задание 19 № 10420

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 4, 4, 6, 8, 5, 8, 2, 10, 13, 14 соответственно, то есть A[0] = 4, A[1] = 4 и так далее. Определите значение переменной c после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) > A(0) THEN

    c = c + 1

    t = A(i)

    A(i) = A(0)

    A(0) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i] > A[0]:

    c = c + 1

    t = A[i]

    A[i] = A[0]

    A[0] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do begin

  if A[i] > A[0] then

  begin

    c := c + 1;

    t := A[i];

    A[i] := A[0];

    A[0] := t;

  end;

end;

c := 0

нц для i от 1 до 9

  если A[i] > A[0] то

    c := c + 1

    t := A[i]

    A[i] := A[0]

    A[0] := t

  все

кц

Си++

c = 0;

for (i = 1; i < 10; i++) {

  if (A[i] > A[0]) {

    c++;

    t = A[i];

    A[i] = A[0];

    A[0] = t;

  }

}

 


Аналоги к заданию № 9370: 9769 9805 10295 10393 10420 10482 10509 Все


6
Задание 19 № 10482

В программе используется одномерный целочисленный массив А с индексами от 0 до 9. Значения элементов равны 5, 6, 5, 8, 5, 4, 1, 2, 9, 6 соответственно, т. е. А[0] = 5, А[1] = 6 и т. д.

Определите значение переменной с после выполнения следующего фрагмента этой программы (записанного ниже на разных языках программирования).

 

Бейсик Python

c = 0

FOR i = 0 TO 8

    IF A(i) <= A(9) THEN

        c = c + 1

        t = A(i)

        A(i) = A(9)

        A(9) = t

    ENDIF

NEXT i

c = 0

for i in range(0, 9):

    if A[i] <= A[9]:

        c = c + 1

        t = A[i]

        A[i] = A[9]

        A[9] = t

Алгоритмический язык Паскаль

c := 0

нц для i от 0 до 8

    если A[i] <= A[9] то

        c := c + 1

        t := A[i]

        A[i] := A[9]

        A[9] := t

    все

кц

c := 0;

for i := 0 to 8 do

    if A[i] <= A[9] then

    begin

        c := c + 1;

        t := A[i];

        A[i] := A[9];

        A[9] := t;

    end;

Си++

c = 0;

for (i = 0; i < 9; i++)

    if (A[i] <= A[9])

    {

        c++;

        t = A[i];

        A[i] = A[9];

        A[9] = t;

    }


Аналоги к заданию № 9370: 9769 9805 10295 10393 10420 10482 10509 Все


7
Задание 19 № 10509

В программе используется одномерный целочисленный массив А с индексами от 0 до 9. Значения элементов равны 5, 6, 5, 8, 5, 4, 1, 2, 9, 6 соответственно, т. е. А[0] = 5, А[1] = 6 и т. д.

Определите значение переменной с после выполнения следующего фрагмента этой программы (записанного ниже на разных языках программирования).

 

Бейсик Python

c = 0

FOR i = 0 TO 8

    IF A(i) >= A(9) THEN

        c = c + 1

        t = A(i)

        A(i) = A(9)

        A(9) = t

    ENDIF

NEXT i

c = 0

for i in range(0, 9):

    if A[i] >= A[9]:

        c = c + 1

        t = A[i]

        A[i] = A[9]

        A[9] = t

Алгоритмический язык Паскаль

c := 0

нц для i от 0 до 8

    если A[i] >= A[9] то

        c := c + 1

        t := A[i]

        A[i] := A[9]

        A[9] := t

    все

кц

c := 0;

for i := 0 to 8 do

    if A[i] >= A[9] then

    begin

        c := c + 1;

        t := A[i];

        A[i] := A[9];

        A[9] := t;

    end;

Си++

c = 0;

for (i = 0; i < 9; i++)

    if (A[i] >= A[9])

    {

        c++;

        t = A[i];

        A[i] = A[9];

        A[9] = t;

    }


Аналоги к заданию № 9370: 9769 9805 10295 10393 10420 10482 10509 Все