СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Каталог заданий.
Алгебраические операции с элементами массива, двумерные массивы

Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задания Д16 № 3354

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

A(0) = 1

FOR i = 1 TO 10

    A(i) = 2 + A[i-1]

NEXT i

FOR i = 0 TO 5

    A(10-i) = A(i)-1

NEXT i

 

A[0] = 1

for i in range(1, 11):

    A[i] = 2 + A[i-1]

for i in range(0, 6):

    A[10-i] = A[i]-1

ПаскальАлгоритмический язык

A[0] : = 1;

for i : = 1 to 10

    do A[i] : = 2 + A[i-1];

for i : = 0 to 5 do begin

    A[10-i] : = A[i] - 1;

end;

A[0] : = 1

нц для i от 1 до 10

    A[i] : = 2 + A[i-1]

кц

нц для i от 0 до 5

    A[10-i] : = A[i] - 1

кц

 

Си++

A[0] = 1;

for (i = 1; i <= 10; i++) {

    A[i] = 2+A[i-1];

}

for (i = 0; i <= 5; i++) {

    A[10-i] = A[i]-1;

}

 

 

Чему будут равны элементы этого массива?

 

1) 1 3 5 7 9 10 8 6 4 2 0

2) 1 3 5 7 9 11 13 15 17 19 21

3) 1 3 5 7 9 11 9 7 5 3 1

4) 1 3 5 7 9 11 8 6 4 3 0


2
Задания Д16 № 3364

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

 

FOR i = 0 TO 10

    A(i) = 2 + i

NEXT i

FOR i = 0 TO 4

    A(i) = A(10-i) - 1

    A(10-i) = A(i) + 3

NEXT i

 

 

for i in range(0, 11):

    A[i] = 2 + i

for i in range(0, 5):

    A[i] = A[10-i] - 1

    A[10-i] = A[i] + 3

ПаскальАлгоритмический язык

 

for i : = 0 to 10

    do A[i] : = 2 + i;

for i : = 0 to 4 do begin

    A[i]:= A[10-i]-1;

    A[10-i]:= A[i]+3;

end;

 

нц для i от 0 до 10

    A[i] : = 2 + i

кц

нц для i от 0 до 4

    A[i]:=A[10-i]-1

    A[10-i]:=A[i]+3

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = 2 + i;

}

for (i = 0; i <= 4; i++) {

    A[i] = A[10-i] - 1;

    A[10-i] = A[i]+3;

}

 

 

Чему будут равны элементы этого массива?

 

1) 11 10 9 8 7 5 6 7 8 9

2) 11 10 9 8 7 7 5 6 7 8 9

3) 11 10 9 8 7 7 10 11 12 13 14

4) 11 10 9 8 7 10 11 12 13 14


3
Задания Д16 № 3366

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

 

FOR i = 1 TO 10

    A(i) = 3*i

NEXT i

FOR i = 1 TO 10

    A(i) = A(i) MOD 3;

NEXT i

 

 

for i in range(0, 11):

    A[i] = 3*i

for i in range(1, 11):

    A[i] = A[i] % 3

ПаскальАлгоритмический язык

 

for i : = 1 to 10

    do A[i] : = 3*i;

for i : = 1 to 10 do begin

    A[i]:= A[i] mod 3;

end;

 

нц для i от 1 до 10

    A[i] : = 3*i

кц

нц для i от 1 до 10

    A[i]:= mod(A[i], 3)

кц

 

Си++

 

for (i = 1; i <= 10; i++) {

    A[i] = 3*i;

}

for (i = 1; i <= 10; i++) {

    A[i] = A[i] % 3;

}

 

 

Чему будут равны элементы этого массива?

 

1) Все элементы будут равны 3.

2) Все элементы будут равны 1.

3) Все элементы будут равны 0.

4) Все элементы будут равны своим индексам.


4
Задания Д16 № 7264

Значения элементов двумерного массива А были равны 0. Затем значения некоторых элементов были изменены (см. представленный фрагмент программы):

 

 

БейсикPython

n = 0

FOR i = 1 TO 5

    FOR j = 1 TO 6-i

        n = n + 1

        A(i,j) = n

    NEXT j

NEXT i

 

n = 0

for i in range(1, 6):

    for j in range(1, 7-i):

        n += 1

        A[i,j] = n

ПаскальАлгоритмический язык

n:=0;

for i:=1 to 5 do

    for j:=1 to 6-i do begin

        n := n + 1;

        A[i,j] := n;

    end;

n:=0

нц для i от 1 до 5

    нц для j от 1 до 6-i

        n := n + 1

        A[i,j] := n

    кц

кц

 

Си++

n = 0;

for (i = 1; i <= 5; i++) {

    for (j = 1; j <= 6-i; j++) {

        n += 1;

        A[i][j] = n;

    }

}

 

 

Какой элемент массива будет иметь в результате максимальное значение?

 

1) A[1,1]

2) A[1,5]

3) A[5,1]

4) A[5,5]


5
Задания Д16 № 3372

Значения двух массивов A и B с индексами от 1 до 100 задаются при помощи следующего фрагмента программы:

 

 

БейсикPython

n = 100

FOR i = 1 TO n

    A(i)=(i-75)*(i-75)

NEXT i

FOR i = 1 TO n

    B(101-i)=A(i)

NEXT i

 

n = 100

for i in range(1, n+1):

     A[i]=(i-75)*(i-75)

for i in range(1, n+1):

    B[101-i]=A[i]

ПаскальАлгоритмический язык

n:=100;

for i : = 1 to n

    do A[i]:=(i-75)*(i-75);

for i : = 1 to n do begin

    B[101-i]:=A[i];

end;

n:=100

нц для i от 1 до n

    A[i]:=(i-75)*(i-75)

кц

нц для i от 1 до n

    B[101-i]:=A[i]

кц

 

Си++

n = 100;

for (i = 1; i <= n; i++) {

    A[i]=(i-75)*(i-75);

}

for (i = 1; i <= n; i++) {

    B[101-i]=A[i];

}

 

 

Какой элемент массива B будет наибольшим?

 

1) B[1]

2) B[26]

3) B[75]

4) B[100]


Пройти тестирование по этим заданиям