СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задания Д 19 № 7264

Значения элементов двумерного массива А были равны 0. Затем значения некоторых элементов были изменены (см. представленный фрагмент программы):

 

 

БейсикPython

n = 0

FOR i = 1 TO 5

    FOR j = 1 TO 6-i

        n = n + 1

        A(i,j) = n

    NEXT j

NEXT i

 

n = 0

for i in range(1, 6):

    for j in range(1, 7-i):

        n += 1

        A[i,j] = n

ПаскальАлгоритмический язык

n:=0;

for i:=1 to 5 do

    for j:=1 to 6-i do begin

        n := n + 1;

        A[i,j] := n;

    end;

n:=0

нц для i от 1 до 5

    нц для j от 1 до 6-i

        n := n + 1

        A[i,j] := n

    кц

кц

 

Си++

n = 0;

for (i = 1; i <= 5; i++) {

    for (j = 1; j <= 6-i; j++) {

        n += 1;

        A[i][j] = n;

    }

}

 

 

Какой элемент массива будет иметь в результате максимальное значение?

 

1) A[1,1]

2) A[1,5]

3) A[5,1]

4) A[5,5]

Пояснение.

В переменной n накапливается сумма проходов цикла. Это число всё время растёт, следовательно, наибольшим элементом массива будет тот, значение которому будет присвоено последним. Это элемент A[5,1].