СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задания Д 19 № 3372

Значения двух массивов A и B с индексами от 1 до 100 задаются при помощи следующего фрагмента программы:

 

 

БейсикPython

n = 100

FOR i = 1 TO n

    A(i)=(i-75)*(i-75)

NEXT i

FOR i = 1 TO n

    B(101-i)=A(i)

NEXT i

 

n = 100

for i in range(1, n+1):

     A[i]=(i-75)*(i-75)

for i in range(1, n+1):

    B[101-i]=A[i]

ПаскальАлгоритмический язык

n:=100;

for i : = 1 to n

    do A[i]:=(i-75)*(i-75);

for i : = 1 to n do begin

    B[101-i]:=A[i];

end;

n:=100

нц для i от 1 до n

    A[i]:=(i-75)*(i-75)

кц

нц для i от 1 до n

    B[101-i]:=A[i]

кц

 

Си++

n = 100;

for (i = 1; i <= n; i++) {

    A[i]=(i-75)*(i-75);

}

for (i = 1; i <= n; i++) {

    B[101-i]=A[i];

}

 

 

Какой элемент массива B будет наибольшим?

 

1) B[1]

2) B[26]

3) B[75]

4) B[100]

Пояснение.

Итак, если рассмотреть массив A[i]:= (i - 75)2 как функцию у = (x - 75)2, то найдем максимальное значение на интервале [1, 100]: при i=1 A[1]:=(1 - 75)2=(-74)2;

 

По условию B[101 - 1]:=A[1] наибольшее, т. е. B[100] — наибольшее.

 

Правильный ответ указан под номером 4.