СДАМ ГИА






Каталог заданий. Алгебраические операции с элементами массива, двумерные массивы
Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 19 № 3354

В про­грам­ме описан од­но­мер­ный целочисленный мас­сив A с ин­дек­са­ми от 0 до 10. Ниже пред­став­лен фрагмент этой программы, в ко­то­ром значения эле­мен­тов массива сна­ча­ла задаются, а затем меняются.

 

A[0] : = 1;

for i : = 1 to 10 do

A[i] : = 2+A[i-1];

for i : = 0 to 5 do

A[10-i] : = A[i]-1;

 

Чему будут равны эле­мен­ты этого массива?

 

1) 1 3 5 7 9 10 8 6 4 2 0

2) 1 3 5 7 9 11 13 15 17 19 21

3) 1 3 5 7 9 11 9 7 5 3 1

4) 1 3 5 7 9 11 8 6 4 3 0


2
Задание 19 № 7676

В про­грам­ме опи­сан од­но­мер­ный це­ло­чис­лен­ный мас­сив с ин­дек­са­ми от 0 до 10. Ниже пред­став­лен за­пи­сан­ный на раз­ных язы­ках про­грам­ми­ро­ва­ния фраг­мент одной и той же программы, об­ра­ба­ты­ва­ю­щей дан­ный массив:

 

 

БейсикPython

s = 0

n = 10

FOR i = 0 TO n-3

    s = s+A(i)-A(i+2)

NEXT i

s = 0

n = 10

for i in range(0,n-2):

    s = s + A[i] - A[i+2]

ПаскальАлгоритмический язык

s:=0;

n:=10;

for i:=0 to n-3 do begin

    s:=s+A[i]-A[i+2]

end;

s:=0

n:=10

нц для i от 0 до n-3

    s:=s+A[i]-A[i+2]

кц

Си

s = 0;

n=10;

for (i = 0; i <= n-3; i++)

    s=s+A[i]-A[i+2];

 

В на­ча­ле вы­пол­не­ния этого фраг­мен­та в мас­си­ве на­хо­ди­лись трёхзначные на­ту­раль­ные числа. Какое наи­боль­шее зна­че­ние может иметь пе­ре­мен­ная s после вы­пол­не­ния дан­ной программы?


Аналоги к заданию № 7676: 7703 7930 7995 Все

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 26.11.2014 ва­ри­ант ИН10301.

3
Задание 19 № 8107

В про­грам­ме ис­поль­зу­ет­ся од­но­мер­ный це­ло­чис­лен­ный мас­сив A с ин­дек­са­ми от 0 до 9. Зна­че­ния эле­мен­тов равны 8, 4, 3, 0, 7, 2, 1, 5, 9, 6 соответственно, т.е. A[0] = 8, A[1] = 4 и т. д. Опре­де­ли­те зна­че­ние пе­ре­мен­ной s после вы­пол­не­ния сле­ду­ю­ще­го фраг­мен­та этой про­грам­мы (записанного ниже на раз­ных язы­ках программирования).

 

БейсикPython

s = 0

FOR j = 0 TO 8

    IF A(j) > A(j+1) THEN

        s = s + 1

        t = A(j)

        A(j) = A(j+1)

        A(j+1) = t

    ENDIF

NEXT j

s = 0

for j in range(9):

    if A[j] > A[j+1]:

        s = s + 1

        t = A[j]

        A[j] = A[j+1]

        A[j+1] = t

ПаскальАлгоритмический язык

s := 0;

for j := 0 to 8 do

    if A[j] > A[j+1] then

    begin

        s := s + 1;

        t := A[j];

        A[j] := A[j+1];

        A[j+1] := t;

end;

s := 0

нц для j от 0 до 8

    если A[j] > A[j+1] то

        s := s + 1

        t := A[j]

        A[j] := A[j+1]

        A[j+1] := t

    все

кц

Си

s = 0;

for (j = 0; j < 9; j++)

    if (A[j] > A[j+1])

    {

        s++;

        t = A[j];

        A[j] = A[j+1];

        A[j+1] = t;

    }

 

Источник: ЕГЭ 05.05.2015. До­сроч­ная волна.

4
Задание 19 № 3368

Значения элементов двухмерного массива A[1..100,1..100] задаются с помощью следующего фрагмента программы:

 

for i:=1 to 100 do

for k:=1 to 100 do

if i > k then

A[i,k] := i

else A[i,k] := -k;

 

Чему равна сумма элементов массива после выполнения этого фрагмента программы?


Аналоги к заданию № 3368: 3391 Все


5
Задание 19 № 3364

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

for i:=0 to 10 do

A[i]:=2+i;

for i:=0 to 4 do begin

A[i]:=A[10-i]-1;

A[10-i]:=A[i]+3;

end;

 

Чему будут равны элементы этого массива?

 

1) 11 10 9 8 7 5 6 7 8 9

2) 11 10 9 8 7 7 5 6 7 8 9

3) 11 10 9 8 7 7 10 11 12 13 14

4) 11 10 9 8 7 10 11 12 13 14


6
Задание 19 № 3357

Значения эле­мен­тов двух мас­си­вов А и В раз­ме­ром 1 х 100 за­да­ют­ся с по­мо­щью следующего фраг­мен­та программы:

 

for i:=1 tо 100 do

A[i] := 50 – i;

for i:=1 tо 100 do

B[i] := A[i] + 49;

 

Сколько эле­мен­тов массива В будут иметь от­ри­ца­тель­ные значения?

 


7
Задание 19 № 3358

Значения двух массивов A[1..100] и B[1..100] задаются с помощью следующего фрагмента программы:

 

for n:=1 to 100 do

A[n] := n - 10;

for n:=1 to 100 do

B[n] := A[n]*n;

 

Сколько элементов массива B будут иметь положительные значения?


Аналоги к заданию № 3358: 3360 Все


8
Задание 19 № 3365

Дан фрагмент программы, обрабатывающей двухмерный массив A[1..5,1..4]:

 

k:=4;

for m:=1 to 4 do begin

k:=k+1;

for n:=1 to 5 do begin

k:=m-k;

A[n,m]:=n*n+m*m-2*k;

end;

end;

 

Чему будет равно значение A[3,1]?


9
Задание 19 № 3366

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

for i:=0 to 10 do

A[i]:=3*i;

for i:=1 to 10 do

A[i]:=A[i] mod 3;

 

Чему будут равны элементы этого массива?

 

1) Все элементы будут равны 3.

2) Все элементы будут равны 1.

3) Все элементы будут равны 0.

4) Все элементы будут равны своим индексам.


10
Задание 19 № 3367

Элементы двухмерного массива A размером 10x10 первоначально были равны 1. Затем значения некоторых из них меняют с помощью следующего фрагмента программы:

 

for n:=1 to 4 do

for k:=1 to n+1 do begin

A[n,k]:=A[n,k]-1;

A[n,k+1]:=A[n,k]-1;

end;

 

Сколько элементов массива в результате будут равны 0?


11
Задание 19 № 7264

Значения эле­мен­тов дву­мер­но­го мас­си­ва А были равны 0. Затем зна­че­ния не­ко­то­рых эле­мен­тов были из­ме­не­ны (см. пред­став­лен­ный фраг­мент программы):

n := 0;

for i:=1 tо 5 do

for j:=1 tо 6-i do begin

n := n + 1;

A[i,j] := n;

end;

Какой эле­мент мас­си­ва будет иметь в ре­зуль­та­те мак­си­маль­ное значение?

 

1) A[1,1]

2) A[1,5]

3) A[5,1]

4) A[5,5]


12
Задание 19 № 3372

Значения двух массивов A и B с индексами от 1 до 100 задаются при помощи следующего фрагмента программы:

n:=100;

for i:=1 to n do

A[i]:=(i-75)*(i-75);

for i:=1 to n do

B[101-i]:=A[i];

 

Какой элемент массива B будет наибольшим?

 

1) B[1]

2) B[26]

3) B[75]

4) B[100]


13
Задание 19 № 3373

В про­грам­ме описан двух­мер­ный целочисленный мас­сив A [1..6,1..6]. Ниже пред­став­лен фрагмент этой программы, в ко­то­ром изменяются зна­че­ния элементов массива.

 

for n:=1 to 6 do

for m:=1 to 6 do

A[n,m]:=A[m,n]+2*n-m;

 

До вы­пол­не­ния данного фраг­мен­та программы зна­че­ние A[4,3] было равно 10, а зна­че­ние A[3,4] было равно 15. Чему будет равно зна­че­ние A[4,3] после вы­пол­не­ния этого фраг­мен­та программы?


14
Задание 19 № 3374

Значения двумерного массива задаются с помощью вложенного оператора цикла в представленном фрагменте программы:

 

for n:=1 to 5 do

for k:=1 to 5 do

B[n,k] := n + k;

 

Чему будет равно значение B[2,4]?


15
Задание 19 № 3375

Значения элементов двумерного массива А размером 5x5 задаются с помощью вложенного цикла в представленном фрагменте программы:

 

for i:=1 tо 5 do

for j:=1 tо 5 do begin

A[i,j] := i*j;

end;

 

Сколько элементов массива будут иметь значения больше 10?

 


16
Задание 19 № 3378

Значения элементов двухмерного массива A[1..10,1..10] сначала равны 4. Затем выполняется следующий фрагмент программы:

for i:=1 to 4 do

for j:=1 to 5 do begin

A[i,j]:=A[i,j]+4;

A[j,i]:=A[j,i]+5;

end;

 

Сколько элементов массива будут равны 9?


17
Задание 19 № 3379

Элементы двухмерного массива A размером NxN первоначально были равны 1000. Затем значения некоторых из них меняют с помощью следующего фрагмента программы:

 

k := 0;

for i:=1 to N do

for j:=N-i+1 to N do begin

k:= k + 1;

A[i,j]:= k;

end;

 

Какой элемент массива в результате будет иметь минимальное значение?

 

1) A[1,1]

2) A[1,N]

3) A[N,1]

4) A[N,N]


18
Задание 19 № 3385

Дан фрагмент программы:

 

for n : = 1 tо 5 do

for m : = 1 tо 5 do

C[n,m] : = (m – n)*(m – n);

 

Сколько элементов массива С будут равны 1?


19
Задание 19 № 3388

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

for i : = 0 to 10 do

A[i] : = 2*i;

for i : = 0 to 4 do begin

A[10-i] : = A[i]-1;

A[i] : = A[10-i]-1;

end;

 

Чему будут равны элементы этого массива?

 

1) 0 2 4 6 8 10 12 14 16 18 20

2) 19 17 15 13 11 10 -1 1 3 5 7

3) -2 0 2 4 6 10 7 5 3 1 -1

4) -1 1 3 5 7 9 11 13 15 17 19


20
Задание 19 № 3390

Все элементы двумерного массива A размером 10х10 элементов первоначально были равны 0. Затем значения элементов меняются с помощью вложенного оператора цикла в представленном фрагменте программы:

 

for n : = 1 to 4 do

for k : = n to 4 do begin

A[n,k] : = A[n,k] + 1;

A[k,n] : = A[k,n] + 1;

end;

 

Сколько элементов массива в результате будут равны 1?


21
Задание 19 № 3393

Значения элементов двухмерного массива A[1..10,1..10] сначала равны 0. Затем выполняется следующий фрагмент программы:

 

for i : = 1 to 4 do

for j : = 2 to 5 do begin

A[i,j] : = A[i,j]+4;

A[j,i] : = A[j,i]+5;

end;

 

Сколько элементов массива будут равны 9?

 


22
Задание 19 № 3394

Значения двух мас­си­вов A и B с ин­дек­са­ми от 1 до 100 за­да­ют­ся при по­мо­щи следующего фраг­мен­та программы:

 

for i : = 1 to 100 do

A[i] : = i*i;

for i : = 1 to 100 do

B[i] : = A[i]-100;

 

Сколько по­ло­жи­тель­ных значений будет в мас­си­ве B?

Пояснение · ·

23
Задание 19 № 3838

В про­грам­ме описан од­но­мер­ный целочисленный мас­сив с ин­дек­са­ми от 0 до n (т.е. пер­вый элемент имеет ин­декс 0, по­след­ний - ин­декс n). Ниже пред­став­лен фрагмент одной и той же программы, за­пи­сан­ный на раз­ных языках программирования, об­ра­ба­ты­ва­ю­щей данный массив:

 

БейсикПаскаль

s = n

z = A(0)

FOR i = 1 TO n

    IF A(i) = z THEN s = s - 1

NEXT i

s: = n;

z: = A[0];

for i: = 1 to n do

begin

    if A[i] = z then

        s: = s - 1;

end

СиАлгоритмический язык

s = n;

z = A[0];

for (i = 1; i <= n; i++){

    if (A[i] == z)

        s--;

}

s: = n

z: = A[0]

нц для i от 1 до n

если A[i] = z то

    s: = s - 1

все кц

 

Чему будет равно зна­че­ние переменной s после вы­пол­не­ния данной программы, при любых зна­че­ни­ях элементов массива?

 

1) Количеству эле­мен­тов массива A, боль­ших первого эле­мен­та массива

2) Количеству эле­мен­тов массива A, не пре­вос­хо­дя­щих первого эле­мен­та массива

3) Количеству эле­мен­тов массива A, не рав­ных первому эле­мен­ту массива

4) Количеству эле­мен­тов массива A, рав­ных первому эле­мен­ту массива

Источник: Яндекс: Тренировочная работа ЕГЭ по информатике. Ва­ри­ант 2.

24
Задание 19 № 4685

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив:

 

 

БейсикПаскаль

s = 0

n = 10

FOR i = 1 ТО n

    s = s + A(i) - A (i - 1)

NEXT i

s: = 0;

n : = 10 ;

for i : = 1 to n do begin

    s : = s + A[i] - A[i-1];

end

СиАлгоритмический язык

s = 0;

n = 10;

for (i = 1; i <= n; i++){

    s = s + A[i] - A[i - 1];

}

s: = 0

n : = 10

нц для i от 1 до n

    s := s + A[i] - A[i - 1]

кц

 

В начале выполнения этого фрагмента в массиве находились числа 0, 10, 20, 30, 40, 50, 60, 70, 80, 90, 100, т.е. А[0]=0, А[1]=10 и т.д. Чему будет равно значение переменной s после выполнения данной программы?

 

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 09.10.2012 ва­ри­ант 3.

25
Задание 19 № 4717

В про­грам­ме описан од­но­мер­ный целочисленный мас­сив с ин­дек­са­ми от 0 до 10. Ниже пред­став­лен записанный на раз­ных языках про­грам­ми­ро­ва­ния фрагмент одной и той же программы, об­ра­ба­ты­ва­ю­щей данный массив:

 

 

БейсикПаскаль

s = 0

n = 10

FOR i = 1 ТО n

    s = s + A(i) - A (i-1)

NEXT i

s: = 0;

n : = 10 ;

for i : = 1 to n do

begin

    s : = s + A[i] - A[i-1];

end

СиАлгоритмический язык

s = 0;

n = 10;

for (i = 1; i <= n; i++)

{

    s = s + A[i] - A[i - 1];

}

s: = 0

n : = 10

нц для i от 1 до n

    s := s + A[i] - A[i - 1]

кц

 

В на­ча­ле выполнения этого фраг­мен­та в мас­си­ве находились числа 0, 2, 4, 6, 8, 10, 12, 14, 16, 18, 20, т.е. А[0]=0, А[1]=2 и т. д. Чему будет равно зна­че­ние переменной s после вы­пол­не­ния данной программы?

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 09.10.2012 ва­ри­ант 4.

26
Задание 19 № 5050

В про­грам­ме описан од­но­мер­ный целочисленный мас­сив А, в пред­став­лен­ном фрагменте про­грам­мы обрабатываются эле­мен­ты массива с ин­дек­са­ми от 1 до 10.

 

n := 10;

for i := 1 to n do begin

A [n+1−i] := 2*A[i] ; end;

 

Перед на­ча­лом выполнения фраг­мен­та элементы мас­си­ва имеют зна­че­ния соответственно 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, т.е. А[1] = 1; А[2] = 2 и т.д. Ука­жи­те значение, ко­то­рое после вы­пол­не­ния указанного фраг­мен­та программы имеет два или более рас­смот­рен­ных в этом фраг­мен­те элемента массива. Если таких чисел несколько, ука­жи­те наибольшее из них.

 

1) такого зна­че­ния нет

2) 10

3) 8

4) 4

Источник: МИОО: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 22.03.2013 ва­ри­ант ИНФ1401.

27
Задание 19 № 5082

В про­грам­ме описан од­но­мер­ный целочисленный мас­сив А, в пред­став­лен­ном фрагменте про­грам­мы обрабатываются эле­мен­ты массива с ин­дек­са­ми от 1 до 10.

 

n := 10;

for i := 1 to n do begin

A [n+1-i] := 2*A[i] ; end;

 

Перед на­ча­лом выполнения фраг­мен­та элементы мас­си­ва имеют зна­че­ния соответственно 2, 4, 6, 8, 10, 12, 14, 16, 18, 20, т.е. А[1] = 2; А[2] = 4 и т.д. Ука­жи­те значение, ко­то­рое после вы­пол­не­ния указанного фраг­мен­та программы имеют два или более рас­смот­рен­ных в этом фраг­мен­те элемента массива. Если таких чисел несколько, ука­жи­те наибольшее из них.

 

1) 8

2) 16

3) 20

4) такого зна­че­ния нет

Источник: МИОО: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 22.03.2013 ва­ри­ант ИНФ1402.

28
Задание 19 № 5206

Ниже пред­став­лен за­пи­сан­ный на раз­ных язы­ках про­грам­ми­ро­ва­ния фраг­мент одной и той же программы. В про­грам­ме опи­сан од­но­мер­ный це­ло­чис­лен­ный мас­сив A, в пред­став­лен­ном фраг­мен­те про­грам­мы об­ра­ба­ты­ва­ют­ся эле­мен­ты мас­си­ва с ин­дек­са­ми от 1 до 10.

 

БейсикПаскаль

n = 10

FOR i = 1 ТО n

    s = A(n + 1 - i) * (n + 1 - i)

    A(n + 1 - i) = A(i) * (n + 1 - i)

    A(i) = s

NEXT i

n : = 10;

for i : = 1 to n do begin

    s : = A[n + 1 - i] * (n + 1 - i);

    A[n + 1 - i] : = A[i] * (n + 1 - i);

    A[i] : = s;

end;

СиАлгоритмический язык

n = 10;

for (i = 1; i <= n; i++){

    s = A[n + 1 - i] * (n + 1 - i);

    A[n + 1 - i] = A[i] * (n + 1 - i);

    A[i] = s;

}

n : = 10

нц для i от 1 до n

    s := A[n+1-i]*(n+1-i)

    A[n+1-i] := A[i]*(n+1-i)

    A[i] := s

кц

 

Перед на­ча­лом вы­пол­не­ния фраг­мен­та все эле­мен­ты мас­си­ва равны 1. Ука­жи­те утверждение, ко­то­рое будет верно после вы­пол­не­ния ука­зан­но­го фраг­мен­та про­грам­мы при из­ме­не­нии ин­дек­са от 1 до 10.

 

1) значения мас­си­ва постоянны

2) значения мас­си­ва сна­ча­ла возрастают, а потом убывают

3) значения мас­си­ва возрастают

4) значения мас­си­ва убывают

Источник: МИОО:Диагностическая ра­бо­та по ин­фор­ма­ти­ке 18.04.2013 ва­ри­ант ИНФ1502.

29
Задание 19 № 5238

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

 

БейсикПаскаль

n = 10

FOR i = 1 ТО n

s = A(n + 1 - i) * i

A(n + 1 - i) = A(i) * i

A(i) = s

NEXT i

n : = 10;

for i : = 1 to n do begin

s : = A[n + 1 - i] * i;

A[n + 1 - i] : = A[i] * i;

A[i] : = s;

end;

СиАлгоритмический язык

n = 10;

for (i = 1; i <= n; i++){

s = A[n + 1 - i] * i;

A[n + 1 - i] = A[i] * i;

A[i] = s;

}

n : = 10

нц для i от 1 до n

s : = A[n + 1 - i] * i

A[n + 1 - i] : = A[i] * i

A[i] : = s

кц

 

Перед началом выполнения фрагмента все элементы массива равны 1. Укажите утверждение, которое будет верно после выполнения указанного фрагмента программы при изменении индекса от 1 до 10.

 

1) значения массива возрастают

2) значения массива убывают

3) значения массива постоянны

4) значения массива сначала возрастают, а потом убывают

Источник: МИОО:Диагностическая ра­бо­та по ин­фор­ма­ти­ке 18.04.2013 ва­ри­ант ИНФ1501.

30
Задание 19 № 5271

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив А, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

БейсикПаскаль

n = 10

FOR i = 1 ТО n

А (n+1-i) = 2*A(i)

NEXT i

n := 10;

for i := 1 to n do begin

A [n+1-i] := 2*A[i];

end;

СиАлгоритмический язык

n = 10;

for (i = 1; i <= n; i++)

A [n+1-i] = 2*A[i];

n : = 10

нц для i от 1 до n

A[n+1-i] := 2*A[i]

кц

 

Перед началом выполнения фрагмента элементы массива имеют значения соответственно

 

1, 2, 4, 8, 16, 32, 64, 128, 256, 512, т.е. A[k] = 2k-1, k = 1, ..., 10.

 

Укажите значение, которое после выполнения указанного фрагмента программы имеют два или более рассмотренных в этом фрагменте элемента массива. Если таких чисел несколько, укажите наименьшее из них.

 

1) такого значения нет

2) 2

3) 8

4) 4

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 17.05.2013 ва­ри­ант ИНФ1601.

31
Задание 19 № 5303

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив А, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

БейсикПаскаль

n = 10

FOR i = 1 ТО n

A (n+1-i) = 2*A(i)

NEXT i

n := 10;

for i := 1 to n do begin

A [n+1-i] := 2*A[i];

end;

СиАлгоритмический язык

n = 10;

for (i = 1; i <= n; i++)

A [n+1-i] = 2*A[i];

n : = 10

нц для i от 1 до n

A[n+1-i] := 2*A[i]

кц

 

Перед началом выполнения фрагмента элементы массива имеют значения соответственно

 

1, 2, 4, 8, 16, 32, 64, 128, 256, 512, т.е. A[k] = 2k-1, k = 1, ..., 10.

 

Укажите значение, которое после выполнения указанного фрагмента программы имеют два или более рассмотренных в этом фрагменте элемента массива. Если таких чисел несколько, укажите наибольшее из них.

 

1) такого значения нет

2) 8

3) 32

4) 128

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 17.05.2013 ва­ри­ант ИНФ1602.
Пояснение · ·

32
Задание 19 № 6452

Ниже приведён фраг­мент программы, за­пи­сан­ный на четырёх язы­ках программирования. Мас­сив A двумерный; в про­грам­ме рас­смат­ри­ва­ет­ся его фрагмент, со­от­вет­ству­ю­щий зна­че­ни­ям ин­дек­сов от 1 до n.

 

БейсикПаскаль

FOR i = 1 TO n

    c = A(i,i)

    A(i,i) = A(i,n–i+1)

    A(i,n–i+1) = c

NEXT i

for i := 1 to n do

begin

    c := A[i,i];

    A[i,i] := A[i,n–i+1];

    A[i,n–i+1] := c

end;

СиАлгоритмический язык

for (i = 1; i <= n; i++) {

    c = A[i][i];

    A[i][i] = A[i][n-i+1];

    A[i][n-i+1] = c;

}

нц для i от 1 до n

    c := A[i,i]

    A[i,i] := A[i,n–i+1]

    A[i,n–i+1] := c

кц

 

 

Представим рас­смот­рен­ный фраг­мент мас­си­ва в виде квад­рат­ной таблицы, в ко­то­рой для эле­мен­та мас­си­ва A[i, j] ве­ли­чи­на i яв­ля­ет­ся но­ме­ром строки, а ве­ли­чи­на j — но­ме­ром столбца, в ко­то­ром рас­по­ло­жен элемент. Тогда дан­ный ал­го­ритм ме­ня­ет ме­ста­ми

 

1) два столб­ца в таблице

2) две стро­ки в таблице

3) элементы двух диа­го­на­лей таблицы

4) элементы диа­го­на­ли и стро­ки таблицы

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 603.

33
Задание 19 № 6494

Ниже приведён фраг­мент программы, за­пи­сан­ный на четырёх язы­ках программирования. Мас­сив A це­ло­чис­лен­ный двумерный. В про­грам­ме рас­смот­рен фраг­мент массива, со­от­вет­ству­ю­щий зна­че­ни­ям ин­дек­сов от 1 до n; n >= 3.

 

БейсикПаскаль

FOR i = n TO 1 STEP -1

    FOR j = n TO 1 STEP -1

        A(i,j) = i-j

    NEXT j

NEXT i

for i := n downto 1 do

    for j := n downto 1 do

        A[i,j] := i-j;

СиАлгоритмический язык

for (i = n; i >= 1; i--) {

    for (j = n; j >= 1; j--) {

        A[i][j] = i-j;

    }

}

нц для i от n до 1 шаг -1

    нц для j от n до 1 шаг -1

        A[i,j] := i-j

    кц

кц

 

Чему будет равно мак­си­маль­ное из зна­че­ний эле­мен­тов рас­смот­рен­но­го фраг­мен­та мас­си­ва посе вы­пол­не­ния фраг­мен­та программы?

 

1) n – 1

2) 1– n

3) n

4) 1

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 801.

34
Задание 19 № 6772

Ниже приведён фраг­мент программы, за­пи­сан­ный на четырёх язы­ках программирования. Мас­сив A одномерный; в про­грам­ме рас­смат­ри­ва­ет­ся его фрагмент, со­от­вет­ству­ю­щий зна­че­ни­ям ин­дек­са от 1 до n.

 

БейсикПаскаль

n = 10

FOR i = 0 TO n

    K = A(i)

    A(K) = 0

NEXT i

n:=10;

for i:=0 to n do begin

    K := A[i];

    A[K] := 0;

end;

СиАлгоритмический язык

n=10;

for (i = 0; i <= n; i++){

    K = A[i];

    A[K] = 0;

}

n:=10

нц для i от 0 до n

    K := A[i]

    A[K] := 0

кц

 

В на­ча­ле вы­пол­не­ния этого фраг­мен­та в мас­си­ве на­хо­ди­лись числа 10, 9, 8, 7, 6, 5, 4, 3, 2, 1, 0, т. е. A[0] = 10, A[1] = 9 и т. д. Сколь­ко эле­мен­тов мас­си­ва после вы­пол­не­ния про­грам­мы будут иметь не­ну­ле­вые значения?


Аналоги к заданию № 6772: 6804 Все

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 20.02.2014 ва­ри­ант ИН10601.

35
Задание 19 № 6886

В про­грам­ме опи­сан од­но­мер­ный це­ло­чис­лен­ный мас­сив с ин­дек­са­ми от 0 до 10. Ниже пред­став­лен за­пи­сан­ный на раз­ных язы­ках про­грам­ми­ро­ва­ния фраг­мент одной и той же программы, об­ра­ба­ты­ва­ю­щей дан­ный массив.

 

БейсикПаскаль

s = 0

n = 10

FOR i = 0 TO n-1

    s = s+A(i)-A(i+1)

NEXT i

s:=0;

n:=10;

for i:=0 to n-1 do begin

    s:=s+A[i]-A[i+1];

end;

СиАлгоритмический язык

s = 0;

n=10;

for (i = 0; i <= n-1; i++)

    s=s+A[i]-A[i+1];

}

s:=0

n:=10

нц для i от 0 до n-1

    s:=s+A[i]-A[i+1]

кц

 

В на­ча­ле вы­пол­не­ния этого фраг­мен­та в мас­си­ве на­хо­ди­лись числа 15, 10, 5, 0, 5, 10, 15, 10, 5, 0, 5, т. е. A[0]=15, A[1]=10 и т. д. Чему будет равно зна­че­ние пе­ре­мен­ной s после вы­пол­не­ния дан­ной программы?


Аналоги к заданию № 6886: 6918 Все

Источник: МИОО: Ди­а­гно­сти­че­ская работа по ин­фор­ма­ти­ке 11.12.2013 ва­ри­ант ИНФ10301.
Пояснение · ·

36
Задание 19 № 6951

Ниже пред­став­лен за­пи­сан­ный на раз­ных язы­ках про­грам­ми­ро­ва­ния фраг­мент одной и той же программы. В про­грам­ме опи­сан од­но­мер­ный це­ло­чис­лен­ный мас­сив A, в пред­став­лен­ном фраг­мен­те про­грам­мы об­ра­ба­ты­ва­ют­ся эле­мен­ты мас­си­ва с ин­дек­са­ми от 1 до 21.

 

БейсикПаскаль

s = 0

n = 21

FOR i = 2 TO n

    s = s+2*(A(i)-A(i-1))

NEXT i

s:=0;

n:=21;

for i:= 2 to n do begin

    s:=s+2*(A[i]-A[i-1]);

end;

СиАлгоритмический язык

s = 0;

n=21;

for (i = 2; i <= n; i++)

    s=s+2*(A[i]-A[i-1]);

s:=0

n:=21

нц для i от 2 до n

    s:= s+2*(A[i]-A[i-1])

кц

 

В на­ча­ле вы­пол­не­ния этого фраг­мен­та в эле­мен­те мас­си­ва с ин­дек­сом i на­хо­ди­лось число i (i = 1, …, 21), т. е. A[1] = 1, A[2] = 2 и т. д. Чему будет равно зна­че­ние пе­ре­мен­ной s после вы­пол­не­ния дан­ной программы?


Аналоги к заданию № 6951: 6983 Все

Источник: МИОО: Ди­а­гно­сти­че­ская ра­бо­та по ин­фор­ма­ти­ке 19.03.2014 Ва­ри­ант ИНФ10801.

37
Задание 19 № 7196

Ниже приведён фраг­мент программы, за­пи­сан­ный на четырёх язы­ках программирования.

Массив A двумерный; в про­грам­ме рас­смат­ри­ва­ет­ся его фрагмент, со­от­вет­ству­ю­щий зна­че­ни­ям каж­до­го ин­дек­са от 1 до 9.

 

БейсикПаскаль

FOR n=1 TO 9

    FOR k=1 TO 9

        A(n,k)=n+k+1

    NEXT k

NEXT n

for n:=1 to 9 do

    for k:=1 to 9 do

        A[n,k]:=n+k+1

СиАлгоритмический язык

for (n=1;n<=9;n++)

    for (k=1;k<=9;k++)

        A[n][k]=n+k+1;

нц для n от 1 до 9

    нц для k от 1 до 9

        A[n,k]=n+k+1

    кц

кц

 

Сколько эле­мен­тов ука­зан­но­го фраг­мен­та мас­си­ва A будут при­ни­мать нечётные зна­че­ния после вы­пол­не­ния дан­но­го фраг­мен­та программы?

Источник: ЕГЭ по ин­фор­ма­ти­ке 05.05.2014. До­сроч­ная волна. Ва­ри­ант 1.

38
Задание 19 № 7263

Дан фрагмент программы:

for n:=1 to 6 do

for m:=1 to 5 do begin

C[n,m]:=C[n,m]+(2*n-m);

end;

Чему будет равно зна­че­ние элемента двумерного массива С[4,3], если до выполнения этих команд С[4,3]=10?


39
Задание 19 № 7301

Ниже пред­став­лен за­пи­сан­ный на раз­ных язы­ках про­грам­ми­ро­ва­ния фраг­мент одной и той же программы. В про­грам­ме опи­сан од­но­мер­ный це­ло­чис­лен­ный мас­сив A, в пред­став­лен­ном фраг­мен­те про­грам­мы об­ра­ба­ты­ва­ют­ся эле­мен­ты мас­си­ва с ин­дек­са­ми от 1 до 25.

 

БейсикПаскаль

n = 25

A(1) = 2

FOR i = 2 TO n

    A(i) = 2*A(i–1) MOD 10

NEXT i

n:=25;

A[1]:=2;

for i:= 2 to n do begin

    A[i] := 2*A[i–1] mod 10;

end;

СиАлгоритмический язык

n=25;

A[1] = 2;

for (i = 2; i <= n; i++)

    A[i] = 2*A[i–1] % 10;

n:=25

A[1] := 2

нц для i от 2 до n

    A[i] = mod (2*A[i–1], 10)

кц

 

Чему будет равно зна­че­ние эле­мен­та A[25] (то есть эле­мен­та мас­си­ва с ин­дек­сом 25) после вы­пол­не­ния фраг­мен­та программы?

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 30.04.2014 ва­ри­ант ИН10901.

40
Задание 19 № 7333

Ниже пред­став­лен записанный на раз­ных языках про­грам­ми­ро­ва­ния фрагмент одной и той же программы. В про­грам­ме описан од­но­мер­ный целочисленный мас­сив A, в пред­став­лен­ном фрагменте про­грам­мы обрабатываются эле­мен­ты массива с ин­дек­са­ми от 1 до 24.

 

БейсикПаскаль

n = 24

A(1) = 4

FOR i = 2 TO n

    A(i) = 4*A(i–1) MOD 10

NEXT i

n:=24;

A[1]:=4;

for i:= 2 to n do begin

    A[i] := 4*A[i–1] mod 10;

end;

СиАлгоритмический язык

n=24;

A[1] = 4;

for (i = 2; i <= n; i++)

    A[i] = 4*A[i–1] % 10;

n:=24

A[1] := 4

нц для i от 2 до n

    A[i] = mod (4*A[i–1], 10)

кц

 

Чему будет равно зна­че­ние элемента A[24] (то есть эле­мен­та массива с ин­дек­сом 24) после вы­пол­не­ния фрагмента программы?

Источник: МИОО: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 30.04.2014 ва­ри­ант ИН10902.

41
Задание 19 № 7365

Ниже приведён фраг­мент программы, за­пи­сан­ный на четырёх язы­ках программирования.

Массив A двумерный; в про­грам­ме рассматривается его фрагмент, со­от­вет­ству­ю­щий значениям каж­до­го индекса от 1 до 9.

 

БейсикПаскаль

FOR n=1 TO 9

    FOR k=1 TO 9

    A(n,k)=2*n+k

    NEXT k

NEXT n

for n:=1 to 9 do

    for k:=1 to 9 do

        A[n,k]:=2*n+k

СиАлгоритмический язык

for (n=1;n<=9;n++)

    for (k=1;k<=9;k++)

        A[n][k]=2*n+k;

нц для n от 1 до 9

    нц для k от 1 до 9

        A[n,k]=2*n+k

кц

кц

 

Сколько эле­мен­тов указанного фраг­мен­та массива A будут при­ни­мать нечётные зна­че­ния после вы­пол­не­ния данного фраг­мен­та программы?

Источник: ЕГЭ по ин­фор­ма­ти­ке 05.05.2014. До­сроч­ная волна. Ва­ри­ант 2.

Пройти тестирование по этим заданиям



     О проекте · Редакция

© Гущин Д. Д., 2011—2017


СПб ГУТ! С! Ф! У!