информатика
Информатика
Русский язык
Английский язык
Немецкий язык
Французcкий язык
Испанский язык
Физика
Химия
Биология
География
Обществознание
Литература
История
сайты - меню - вход - новости




Каталог заданий.
Алгебраические операции с элементами массива, двумерные массивы
Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 19 № 3354

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

A(0) = 1

FOR i = 1 TO 10

    A(i) = 2 + A[i-1]

NEXT i

FOR i = 0 TO 5

    A(10-i) = A(i)-1

NEXT i

 

A[0] = 1

for i in range(1, 11):

    A[i] = 2 + A[i-1]

for i in range(0, 6):

    A[10-i] = A[i]-1

ПаскальАлгоритмический язык

A[0] : = 1;

for i : = 1 to 10

    do A[i] : = 2 + A[i-1];

for i : = 0 to 5 do begin

    A[10-i] : = A[i] - 1;

end;

A[0] : = 1

нц для i от 1 до 10

    A[i] : = 2 + A[i-1]

кц

нц для i от 0 до 5

    A[10-i] : = A[i] - 1

кц

 

Си++

A[0] = 1;

for (i = 1; i <= 10; i++) {

    A[i] = 2+A[i-1];

}

for (i = 0; i <= 5; i++) {

    A[10-i] = A[i]-1;

}

 

 

Чему будут равны элементы этого массива?

 

1) 1 3 5 7 9 10 8 6 4 2 0

2) 1 3 5 7 9 11 13 15 17 19 21

3) 1 3 5 7 9 11 9 7 5 3 1

4) 1 3 5 7 9 11 8 6 4 3 0


2
Задание 19 № 7676

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив:

 

 

БейсикPython

s = 0

n = 10

FOR i = 0 TO n-3

    s = s+A(i)-A(i+2)

NEXT i

s = 0

n = 10

for i in range(0,n-2):

    s = s + A[i] - A[i+2]

ПаскальАлгоритмический язык

s:=0;

n:=10;

for i:=0 to n-3 do begin

    s:=s+A[i]-A[i+2]

end;

s:=0

n:=10

нц для i от 0 до n-3

    s:=s+A[i]-A[i+2]

кц

Си++

s = 0;

n=10;

for (i = 0; i <= n-3; i++) {

    s=s+A[i]-A[i+2];

}

 

В начале выполнения этого фрагмента в массиве находились трёхзначные натуральные числа. Какое наибольшее значение может иметь переменная s после выполнения данной программы?


Аналоги к заданию № 7676: 7703 7930 7995 Все

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 26.11.2014 ва­ри­ант ИН10301.

3
Задание 19 № 8107

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 8, 4, 3, 0, 7, 2, 1, 5, 9, 6 соответственно, т.е. A[0] = 8, A[1] = 4 и т. д. Определите значение переменной s после выполнения следующего фрагмента этой программы (записанного ниже на разных языках программирования).

 

БейсикPython

s = 0

FOR j = 0 TO 8

    IF A(j) > A(j+1) THEN

        s = s + 1

        t = A(j)

        A(j) = A(j+1)

        A(j+1) = t

    ENDIF

NEXT j

s = 0

for j in range(9):

    if A[j] > A[j+1]:

        s = s + 1

        t = A[j]

        A[j] = A[j+1]

        A[j+1] = t

ПаскальАлгоритмический язык

s := 0;

for j := 0 to 8 do

    if A[j] > A[j+1] then

    begin

        s := s + 1;

        t := A[j];

        A[j] := A[j+1];

        A[j+1] := t;

end;

s := 0

нц для j от 0 до 8

    если A[j] > A[j+1] то

        s := s + 1

        t := A[j]

        A[j] := A[j+1]

        A[j+1] := t

    все

кц

Си++

s = 0;

for (j = 0; j < 9; j++) {

    if (A[j] > A[j+1])

    {

        s++;

        t = A[j];

        A[j] = A[j+1];

        A[j+1] = t;

    }

}

 

Источник: ЕГЭ 05.05.2015. До­сроч­ная волна.

4
Задание 19 № 3368

Значения элементов двухмерного массива A[1..100,1..100] задаются с помощью следующего фрагмента программы:

 

 

БейсикПаскаль

FOR i= 1 TO 100

    FOR k=1 TO 100

    IF i > k THEN A(i,k) = i

    ELSE

        A(i,k) = -k

    NEXT k

NEXT i

for i:=1 to 100 do

    for k:=1 to 100 do

        if i > k then

        A[i,k] := i

    else A[i,k] := -k;

Си++Алгоритмический язык

for (i=1;i<=100;i++) {

    for (k=1;k<=100;k++) {

        if (i > k) {

            A[i,k] = i;

        }

        else A[i,k] = -k;

    }

}

нц для i от 1 до 100

    нц для k от 1 до 100

        если i > k

        то A[i,k] := i

        иначе A[i,k] := -k

    кц

кц

Python

 

for i in range(1, 101):

    for k in range(1, 101):

        if i > k:

            A[i,k] = i

        else:

            A[i,k] = -k

 

 

Чему равна сумма элементов массива после выполнения этого фрагмента программы?


Аналоги к заданию № 3368: 3391 Все


5
Задание 19 № 3364

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

 

FOR i = 0 TO 10

    A(i) = 2 + i

NEXT i

FOR i = 0 TO 4

    A(i) = A(10-i) - 1

    A(10-i) = A(i) + 3

NEXT i

 

 

for i in range(0, 11):

    A[i] = 2 + i

for i in range(0, 5):

    A[i] = A[10-i] - 1

    A[10-i] = A[i] + 3

ПаскальАлгоритмический язык

 

for i : = 0 to 10

    do A[i] : = 2 + i;

for i : = 0 to 4 do begin

    A[i]:= A[10-i]-1;

    A[10-i]:= A[i]+3;

end;

 

нц для i от 0 до 10

    A[i] : = 2 + i

кц

нц для i от 0 до 4

    A[i]:=A[10-i]-1

    A[10-i]:=A[i]+3

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = 2 + i;

}

for (i = 0; i <= 4; i++) {

    A[i] = A[10-i] - 1;

    A[10-i] = A[i]+3;

}

 

 

Чему будут равны элементы этого массива?

 

1) 11 10 9 8 7 5 6 7 8 9

2) 11 10 9 8 7 7 5 6 7 8 9

3) 11 10 9 8 7 7 10 11 12 13 14

4) 11 10 9 8 7 10 11 12 13 14


6
Задание 19 № 3357

Значения элементов двух массивов А и В размером 1 х 100 задаются с помощью следующего фрагмента программы:

 

 

БейсикPython

 

FOR i = 1 TO 100

    A(i) = 50 - i

NEXT i

FOR i = 1 TO 100

    B(i) = A(i) + 49;

NEXT i

 

 

for i in range(1, 101):

    A[i] = 50 - i

for i in range(1, 101):

    B[i] = A[i] + 49

ПаскальАлгоритмический язык

 

for i : = 1 to 100

    do A[i] : = 50 - i;

for i : = 1 to 100 do begin

    B[i]:= A[i] + 49;

end;

 

нц для i от 1 до 100

    A[i] : = 50 - i

кц

нц для i от 1 до 100

    B[i]:=A[i] + 49

кц

 

Си++

 

for (i = 1; i <= 100; i++) {

    A[i] = 50 - i;

}

for (i = 1; i <= 100; i++) {

    B[i] = A[i] + 49;

}

 

 

Сколько элементов массива В будут иметь отрицательные значения?


7
Задание 19 № 3358

Значения двух массивов A[1..100] и B[1..100] задаются с помощью следующего фрагмента программы:

 

 

БейсикPython

 

FOR n = 1 TO 100

    A(n) = n - 10

NEXT n

FOR n = 1 TO 100

    B(n) = A(n)*n;

NEXT n

 

 

for n in range(1, 101):

    A[n] = n - 10

for n in range(1, 101):

    B[n] = A[n]*n

ПаскальАлгоритмический язык

 

for n : = 1 to 100

    do A[n] : = n - 10;

for n : = 1 to 100 do begin

    B[n]:= A[n]*n;

end;

 

нц для n от 1 до 100

    A[n] : = n - 10

кц

нц для n от 1 до 100

    B[n]:=A[n]*n

кц

 

Си++

 

for (n = 1; n <= 100; n++) {

    A[n] = n - 10;

}

for (n = 1; n <= 100; n++) {

    B[n] = A[n]*n;

}

 

 

Сколько элементов массива B будут иметь положительные значения?

 

Примечание. Нуль является ни положительным, ни отрицательным числом.


Аналоги к заданию № 3358: 3360 Все


8
Задание 19 № 3365

Дан фрагмент программы, обрабатывающей двухмерный массив A[1..5,1..4]:

 

 

БейсикPython

k = 4

FOR m = 1 TO 4

    k = k + 1

    FOR n = 1 TO 5

        k = m - k

        A(n,m) = n*n+m*m-2*k

    NEXT n

NEXT m

 

k = 4

for m in range(1, 5):

    k += 1

    for n in range(1, 6):

        k=m-k

        A[n,m]=n*n+m*m-2*k

ПаскальАлгоритмический язык

k:=4;

for m:=1 to 4 do begin

    k:=k+1;

    for n:=1 to 5 do begin

        k:=m-k;

        A[n,m]:=n*n+m*m-2*k;

    end;

end;

k:=4

нц для m от 1 до 4

    k:=k+1

    нц для n от 1 до 5

        k:=m-k

        A[n,m]:=n*n+m*m-2*k

    кц

кц

 

Си++

k = 4;

for (m = 1; m <= 4; m++) {

    k = k + 1;

    for (n = 1; n <= 5; n++) {

        k=m-k;

        A[n][m]=n*n+m*m-2*k;

    }

}

 

 

Чему будет равно значение A[3,1]?


9
Задание 19 № 3366

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

 

FOR i = 1 TO 10

    A(i) = 3*i

NEXT i

FOR i = 1 TO 10

    A(i) = A(i) MOD 3;

NEXT i

 

 

for i in range(0, 11):

    A[i] = 3*i

for i in range(1, 11):

    A[i] = A[i] % 3

ПаскальАлгоритмический язык

 

for i : = 1 to 10

    do A[i] : = 3*i;

for i : = 1 to 10 do begin

    A[i]:= A[i] mod 3;

end;

 

нц для i от 1 до 10

    A[i] : = 3*i

кц

нц для i от 1 до 10

    A[i]:= mod(A[i], 3)

кц

 

Си++

 

for (i = 1; i <= 10; i++) {

    A[i] = 3*i;

}

for (i = 1; i <= 10; i++) {

    A[i] = A[i] % 3;

}

 

 

Чему будут равны элементы этого массива?

 

1) Все элементы будут равны 3.

2) Все элементы будут равны 1.

3) Все элементы будут равны 0.

4) Все элементы будут равны своим индексам.


10
Задание 19 № 3367

Элементы двухмерного массива A размером 10x10 первоначально были равны 1. Затем значения некоторых из них меняют с помощью следующего фрагмента программы:

 

 

БейсикPython

FOR n = 1 TO 4

    FOR k = 1 TO n+1

        A(n,k) = A(n,k) - 1

        A(n,k+1) = A(n,k) - 1

    NEXT k

NEXT n

for n in range(1, 5):

    for k in range(1, n+2):

        A[n,k] = A[n,k]-1

        A[n,k+1] = A[n,k]-1

ПаскальАлгоритмический язык

for n:= 1 to 4 do

    for k:=1 to n+1 do begin

        A[n,k]:= A[n,k]-1;

        A[n,k+1]:= A[n,k]-1;

    end;

нц для n от 1 до 4

    нц для k от 1 до n+1

        A[n,k]:= A[n,k]-1

        A[n,k+1]:= A[n,k]-1

    кц

кц

Си++

for (n = 1; n <= 4; n++) {

    for (k = 1; k <= n+1; k++) {

        A[n][k]= A[n][k]-1;

        A[n][k+1]= A[n][k]-1;

    }

}

 

 

Сколько элементов массива в результате будут равны 0?


11
Задание 19 № 7264

Значения элементов двумерного массива А были равны 0. Затем значения некоторых элементов были изменены (см. представленный фрагмент программы):

 

 

БейсикPython

n = 0

FOR i = 1 TO 5

    FOR j = 1 TO 6-i

        n = n + 1

        A(i,j) = n

    NEXT j

NEXT i

 

n = 0

for i in range(1, 6):

    for j in range(1, 7-i):

        n += 1

        A[i,j] = n

ПаскальАлгоритмический язык

n:=0;

for i:=1 to 5 do

    for j:=1 to 6-i do begin

        n := n + 1;

        A[i,j] := n;

    end;

n:=0

нц для i от 1 до 5

    нц для j от 1 до 6-i

        n := n + 1

        A[i,j] := n

    кц

кц

 

Си++

n = 0;

for (i = 1; i <= 5; i++) {

    for (j = 1; j <= 6-i; j++) {

        n += 1;

        A[i][j] = n;

    }

}

 

 

Какой элемент массива будет иметь в результате максимальное значение?

 

1) A[1,1]

2) A[1,5]

3) A[5,1]

4) A[5,5]


12
Задание 19 № 3372

Значения двух массивов A и B с индексами от 1 до 100 задаются при помощи следующего фрагмента программы:

 

 

БейсикPython

n = 100

FOR i = 1 TO n

    A(i)=(i-75)*(i-75)

NEXT i

FOR i = 1 TO n

    B(101-i)=A(i)

NEXT i

 

n = 100

for i in range(1, n+1):

     A[i]=(i-75)*(i-75)

for i in range(1, n+1):

    B[101-i]=A[i]

ПаскальАлгоритмический язык

n:=100;

for i : = 1 to n

    do A[i]:=(i-75)*(i-75);

for i : = 1 to n do begin

    B[101-i]:=A[i];

end;

n:=100

нц для i от 1 до n

    A[i]:=(i-75)*(i-75)

кц

нц для i от 1 до n

    B[101-i]:=A[i]

кц

 

Си++

n = 100;

for (i = 1; i <= n; i++) {

    A[i]=(i-75)*(i-75);

}

for (i = 1; i <= n; i++) {

    B[101-i]=A[i];

}

 

 

Какой элемент массива B будет наибольшим?

 

1) B[1]

2) B[26]

3) B[75]

4) B[100]


13
Задание 19 № 3373

В программе описан двухмерный целочисленный массив A [1..6,1..6]. Ниже представлен фрагмент этой программы, в котором изменяются значения элементов массива.

 

БейсикPython

FOR n = 1 TO 6

    FOR m = 1 TO 6

        A(n,m) = A(m,n)+2*n-m

    NEXT m

NEXT n

for n in range(1, 7):

    for m in range(1, 7):

        A[n,m] = A[m,n]+2*n-m

ПаскальАлгоритмический язык

for n:= 1 to 6 do

    for m:=1 to 6 do begin

        A[n,m]:= A[m,n]+2*n-m;

    end;

нц для n от 1 до 6

    нц для m от 1 до 6

        A[n,m]:= A[m,n]+2*n-m

    кц

кц

Си++

for (n = 1; n <= 6; n++) {

    for (m = 1; m <= 6; m++) {

        A[n][m]= A[m,n]+2*n-m;

    }

}

 

 

До выполнения данного фрагмента программы значение A[4,3] было равно 10, а значение A[3,4] было равно 15. Чему будет равно значение A[4,3] после выполнения этого фрагмента программы?


14
Задание 19 № 3374

Значения двумерного массива задаются с помощью вложенного оператора цикла в представленном фрагменте программы:

 

 

БейсикPython

FOR n = 1 TO 5

    FOR k = 1 TO 5

        B(n,k) = n + k

    NEXT k

NEXT n

for n in range(1, 6):

    for k in range(1, 6):

        B[n,k] = n + k

ПаскальАлгоритмический язык

for n:= 1 to 5 do

    for k:=1 to 5 do begin

        B[n,k]:= n + k;

    end;

нц для n от 1 до 5

    нц для k от 1 до 5

        B[n,k]:= n + k

    кц

кц

Си++

for (n = 1; n <= 5; n++) {

    for (k = 1; k <= 5; k++) {

        B[n][k]= n + k;

    }

}

 

 

 

Чему будет равно значение B[2,4]?


15
Задание 19 № 3375

Значения элементов двумерного массива А размером 5x5 задаются с помощью вложенного цикла в представленном фрагменте программы:

 

 

БейсикPython

FOR i = 1 TO 5

    FOR j = 1 TO 5

        A(i,j) = i*j

    NEXT j

NEXT i

for i in range(1, 6):

    for j in range(1, 6):

        A[i,j] = i*j

ПаскальАлгоритмический язык

for i:= 1 to 5 do

    for j:=1 to 5 do begin

        A[i,j]:= i*j;

    end;

нц для i от 1 до 5

    нц для j от 1 до 5

        A[i,j]:= i*j

    кц

кц

Си++

for (i = 1; i <= 5; i++) {

    for (j = 1; j <= 5; j++) {

        A[i][j]= i*j;

    }

}

 

 

Сколько элементов массива будут иметь значения больше 10?


16
Задание 19 № 3378

Значения элементов двухмерного массива A[1..10,1..10] сначала равны 4. Затем выполняется следующий фрагмент программы:

 

БейсикPython

FOR i = 1 TO 4

    FOR j = 1 TO 5

        A(i,j) = A(i,j)+4

        A(j,i) = A(j,i)+5

    NEXT j

NEXT i

for i in range(1, 5):

    for j in range(1, 6):

        A[i,j] = A[i,j]+4

        A[j,i] = A[j,i]+5

ПаскальАлгоритмический язык

for i:= 1 to 4 do

    for j:=1 to 5 do begin

        A[i,j]:=A[i,j]+4;

        A[j,i]:=A[j,i]+5;

    end;

нц для i от 1 до 4

    нц для j от 1 до 5

        A[i,j]:=A[i,j]+4

        A[j,i]:=A[j,i]+5

    кц

кц

Си++

for (i = 1; i <= 4; i++) {

    for (j = 1; j <= 5; j++) {

        A[i][j]=A[i][j]+4;

        A[j][i]=A[j][i]+5;

    }

}

 

 

Сколько элементов массива будут равны 9?


17
Задание 19 № 3379

Элементы двухмерного массива A размером NxN первоначально были равны 1000. Затем значения некоторых из них меняют с помощью следующего фрагмента программы:

 

 

БейсикPython

k = 0

FOR i = 1 TO N

    FOR j = N-i+1 TO N

        k += 1

        A(i,j) = k

    NEXT j

NEXT i

 

k = 0

for i in range(1, n+1):

    for j in range(n-i+1, n+1):

        k = k + 1

        A[i,j] = k

 

ПаскальАлгоритмический язык

k := 0;

for i:= 1 to n do

    for j:=N-i+1 to n do begin

        k:= k + 1;

        A[i,j]:= k;

    end;

k := 0

нц для i от 1 до n

    нц для j от n-i+1 до n

        k:= k + 1

        A[i,j]:= k

    кц

кц

Си++

k = 0;

for (i = 1; i <= n; i++) {

    for (j = n-i+1; j <= n; j++) {

        k = k + 1;

        A[i][j] = k;

    }

}

 

 

Какой элемент массива в результате будет иметь минимальное значение?

 

1) A[1,1]

2) A[1,N]

3) A[N,1]

4) A[N,N]


18
Задание 19 № 3385

Дан фрагмент программы:

 

 

БейсикPython

FOR n = 1 TO 5

    FOR m = 1 TO 5

        C(n,m) = (m – n)*(m – n)

    NEXT m

NEXT n

 

for n in range(1, 6):

    for m in range(1, 6):

        C[n,m] = (m – n)*(m – n)

 

ПаскальАлгоритмический язык

for n:= 1 to 5 do

    for m:=1 to 5 do begin

        C[n,m] : = (m – n)*(m – n);

    end;

нц для n от 1 до 5

    нц для m от 1 до 5

        C[n,m] := (m – n)*(m – n)

    кц

кц

Си++

for (n = 1; n <= 5; n++) {

    for (m = 1; m <= 5; m++) {

        C[n][m] = (m – n)*(m – n);

    }

}

 

 

Сколько элементов массива С будут равны 1?


19
Задание 19 № 3388

В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

 

БейсикPython

 

FOR i = 0 TO 10

    A(i) = 2*i

NEXT i

FOR i = 0 TO 4

    A(10-i) = A(i) - 1;

    A(i) = A(10-i) - 1;

NEXT i

 

 

for i in range(0, 11):

    A[i] = 2*i

for i in range(1, 5):

    A[10-i] = A[i] - 1

    A[i] = A[10-i] - 1

ПаскальАлгоритмический язык

 

for i : = 0 to 10

    do A[i] : = 2*i;

for i : = 0 to 4 do begin

    A[10-i]:= A[i] - 1;

    A[i] : = A[10-i]-1;

end;

 

нц для i от 0 до 10

    A[i] : = 2*i

кц

нц для i от 0 до 4

    A[10-i]:= A[i] - 1

    A[i]:= A[10-i] - 1

кц

 

Си++

 

for (i = 0; i <= 10; i++) {

    A[i] = 2*i;

}

for (i = 0; n <= 4; i++) {

    A[10-i] = A[i] - 1;

    A[i] = A[10-i] - 1;

}

 

 

Чему будут равны элементы этого массива?

 

1) 0 2 4 6 8 10 12 14 16 18 20

2) 19 17 15 13 11 10 -1 1 3 5 7

3) -2 0 2 4 6 10 7 5 3 1 -1

4) -1 1 3 5 7 9 11 13 15 17 19


20
Задание 19 № 3390

Все элементы двумерного массива A размером 10х10 элементов первоначально были равны 0. Затем значения элементов меняются с помощью вложенного оператора цикла в представленном фрагменте программы:

 

 

БейсикPython

FOR n = 1 TO 4

    FOR k = n TO 4

        A(n,k) = A(n,k) + 1

        A(k,n) = A(k,n) + 1

 

    NEXT k

NEXT n

 

for n in range(1, 5):

    for k in range(n, 5):

        A[n,k] = A[n,k] + 1

        A[k,n] = A[k,n] + 1

ПаскальАлгоритмический язык

for n:=1 to 4 do

    for k:=n to 4 do begin

        A[n,k] : = A[n,k] + 1;

        A[k,n] : = A[k,n] + 1;

    end;

нц для n от 1 до 4

    нц для k от n до 4

        A[n,k] : = A[n,k] + 1

        A[k,n] : = A[k,n] + 1

    кц

кц

Си++

for (n = 1; n <= 4; n++) {

    for (k = n; k <= 4; k++) {

        A[n][k] = A[n][k] + 1;

        A[k][n] = A[k][n] + 1;

    }

}

 

 

Сколько элементов массива в результате будут равны 1?


21
Задание 19 № 3393

Значения элементов двухмерного массива A[1..10,1..10] сначала равны 0. Затем выполняется следующий фрагмент программы:

 

 

БейсикPython

FOR i = 1 TO 4

    FOR j = 2 TO 5

        A(i,j) = A(i,j)+4

        A(j,i) = A(j,i)+5

    NEXT j

NEXT i

 

for i in range(1, 5):

    for j in range(2, 6):

        A[i,j] = A[i,j]+4

        A[j,i] = A[j,i]+5

ПаскальАлгоритмический язык

for i:=1 to 4 do

    for j:=2 to 5 do begin

        A[i,j] : = A[i,j]+4;

        A[j,i] : = A[j,i]+5;

    end;

нц для i от 1 до 4

    нц для j от 2 до 5

        A[i,j] : = A[i,j]+4

        A[j,i] : = A[j,i]+5

    кц

кц

Си++

for (i = 1; i <= 4; i++) {

    for (j = 2; j <= 5; j++) {

        A[i][j] = A[i][j]+4;

        A[j][i] = A[j][i]+5;

    }

}

 

 

Сколько элементов массива будут равны 9?


22
Задание 19 № 3394

Значения двух массивов A и B с индексами от 1 до 100 задаются при помощи следующего фрагмента программы:

 

 

БейсикPython

 

FOR i = 1 TO 100

    A(i) = i*i

NEXT i

FOR i = 1 TO 100

    B(i) = A(i)-100

NEXT i

 

 

for i in range(1, 101):

    A[i] = i*i

for i in range(1, n+1):

    B[i] = A[i]-100

ПаскальАлгоритмический язык

 

for i : = 1 to 100

    do A[i] : = i*i;

for i : = 1 to 100 do begin

    B[i] : = A[i]-100;

end;

 

нц для i от 1 до 100

    A[i] : = i*i

кц

нц для i от 1 до 100

    B[i] : = A[i]-100

кц

 

Си++

 

for (i = 1; i <= 100; i++) {

    A[i] = i*i;

}

for (i = 1; i <= 100; i++) {

    B[i] = A[i]-100;

}

 

 

Сколько положительных значений будет в массиве B?

Пояснение · ·

23
Задание 19 № 3838

В программе описан одномерный целочисленный массив с индексами от 0 до n (т.е. первый элемент имеет индекс 0, последний - индекс n). Ниже представлен фрагмент одной и той же программы, записанный на разных языках программирования, обрабатывающей данный массив:

 

БейсикПаскаль

s = n

z = A(0)

FOR i = 1 TO n

    IF A(i) = z THEN s = s - 1

NEXT i

s: = n;

z: = A[0];

for i: = 1 to n do

begin

    if A[i] = z then

        s: = s - 1;

end

Си++Алгоритмический язык

s = n;

z = A[0];

for (i = 1; i <= n; i++){

    if (A[i] == z)

        s--;

}

s: = n

z: = A[0]

нц для i от 1 до n

если A[i] = z то

    s: = s - 1

все кц

Python

s = n

z = A[0]

for i in range(1, n+1):

    if A[i] == z:

        s: -= 1

 

 

Чему будет равно значение переменной s после выполнения данной программы, при любых значениях элементов массива?

 

1) Количеству элементов массива A, больших первого элемента массива

2) Количеству элементов массива A, не превосходящих первого элемента массива

3) Количеству элементов массива A, не равных первому элементу массива

4) Количеству элементов массива A, равных первому элементу массива

Источник: Яндекс: Тренировочная работа ЕГЭ по информатике. Ва­ри­ант 2.

24
Задание 19 № 4685

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив:

 

 

БейсикПаскаль

s = 0

n = 10

FOR i = 1 ТО n

    s = s + A(i) - A (i - 1)

NEXT i

s: = 0;

n : = 10 ;

for i : = 1 to n do begin

    s : = s + A[i] - A[i-1];

end

Си++Алгоритмический язык

s = 0;

n = 10;

for (i = 1; i <= n; i++){

    s = s + A[i] - A[i - 1];

}

s: = 0

n : = 10

нц для i от 1 до n

    s := s + A[i] - A[i - 1]

кц

Python

s = 0

n = 10

for i in range(1, n+1):

    s = s + A[i] - A[i - 1]

 

В начале выполнения этого фрагмента в массиве находились числа 0, 10, 20, 30, 40, 50, 60, 70, 80, 90, 100, т.е. А[0]=0, А[1]=10 и т.д. Чему будет равно значение переменной s после выполнения данной программы?

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 09.10.2012 ва­ри­ант 3.

25
Задание 19 № 4717

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив:

 

 

БейсикПаскаль

s = 0

n = 10

FOR i = 1 ТО n

    s = s + A(i) - A (i-1)

NEXT i

s: = 0;

n : = 10 ;

for i : = 1 to n do

begin

    s : = s + A[i] - A[i-1];

end

Си++Алгоритмический язык

s = 0;

n = 10;

for (i = 1; i <= n; i++) {

    s = s + A[i] - A[i - 1];

}

s: = 0

n : = 10

нц для i от 1 до n

    s := s + A[i] - A[i - 1]

кц

Python

s = 0

n = 10

for i in range(1, n+1):

    s = s + A[i] - A[i - 1]

 

 

В начале выполнения этого фрагмента в массиве находились числа 0, 2, 4, 6, 8, 10, 12, 14, 16, 18, 20, т.е. А[0]=0, А[1]=2 и т. д. Чему будет равно значение переменной s после выполнения данной программы?

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 09.10.2012 ва­ри­ант 4.

26
Задание 19 № 5050

В программе описан одномерный целочисленный массив А, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

 

БейсикPython

n = 10

FOR i = 1 TO n

    A (n+1-i) = 2*A(i)

NEXT i

 

n = 10

for i in range(1, n+1):

        A [n+1-i] = 2*A[i]

ПаскальАлгоритмический язык

n:= 10;

for i:=1 to n do

        A [n+1-i] := 2*A[i];

n:= 10

нц для i от 1 до n

        A [n+1-i] := 2*A[i]

кц

 

Си++

n = 10;

for (i = 1; i <= n; i++) {

        A [n+1-i] = 2*A[i];

}

 

 

Перед началом выполнения фрагмента элементы массива имеют значения соответственно 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, т.е. А[1] = 1; А[2] = 2 и т.д. Укажите значение, которое после выполнения указанного фрагмента программы имеет два или более рассмотренных в этом фрагменте элемента массива. Если таких чисел несколько, укажите наибольшее из них.

 

1) такого значения нет

2) 10

3) 8

4) 4

Источник: МИОО: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 22.03.2013 ва­ри­ант ИНФ1401.

27
Задание 19 № 5082

В программе описан одномерный целочисленный массив А, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

 

БейсикPython

n = 10

FOR i = 1 TO n

    A (n+1-i) = 2*A(i)

NEXT i

 

n = 10

for i in range(1, n+1):

        A [n+1-i] = 2*A[i]

ПаскальАлгоритмический язык

n:= 10;

for i:=1 to n do

        A [n+1-i] := 2*A[i];

n:= 10

нц для i от 1 до n

        A [n+1-i] := 2*A[i]

кц

 

Си++

n = 10;

for (i = 1; i <= n; i++) {

        A [n+1-i] = 2*A[i];

}

 

 

Перед началом выполнения фрагмента элементы массива имеют значения соответственно 2, 4, 6, 8, 10, 12, 14, 16, 18, 20, т.е. А[1] = 2; А[2] = 4 и т.д. Укажите значение, которое после выполнения указанного фрагмента программы имеют два или более рассмотренных в этом фрагменте элемента массива. Если таких чисел несколько, укажите наибольшее из них.

 

1) 8

2) 16

3) 20

4) такого значения нет

Источник: МИОО: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 22.03.2013 ва­ри­ант ИНФ1402.

28
Задание 19 № 5206

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

БейсикПаскаль

n = 10

FOR i = 1 ТО n

    s = A(n + 1 - i) * (n + 1 - i)

    A(n + 1 - i) = A(i) * (n + 1 - i)

    A(i) = s

NEXT i

n : = 10;

for i : = 1 to n do begin

    s : = A[n + 1 - i] * (n + 1 - i);

    A[n + 1 - i] : = A[i] * (n + 1 - i);

    A[i] : = s;

end;

Си++Алгоритмический язык

n = 10;

for (i = 1; i <= n; i++){

    s = A[n + 1 - i] * (n + 1 - i);

    A[n + 1 - i] = A[i] * (n + 1 - i);

    A[i] = s;

}

n : = 10

нц для i от 1 до n

    s := A[n+1-i]*(n+1-i)

    A[n+1-i] := A[i]*(n+1-i)

    A[i] := s

кц

Python

n = 10

for i in range(1, n+1):

    s = A[n + 1 - i] * (n + 1 - i);

    A[n + 1 - i] = A[i] * (n + 1 - i);

    A[i] = s;

 

 

Перед началом выполнения фрагмента все элементы массива равны 1. Укажите утверждение, которое будет верно после выполнения указанного фрагмента программы при изменении индекса от 1 до 10.

 

1) значения массива постоянны

2) значения массива сначала возрастают, а потом убывают

3) значения массива возрастают

4) значения массива убывают

Источник: МИОО:Диагностическая ра­бо­та по ин­фор­ма­ти­ке 18.04.2013 ва­ри­ант ИНФ1502.

29
Задание 19 № 5238

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

 

БейсикПаскаль

n = 10

FOR i = 1 ТО n

s = A(n + 1 - i) * i

A(n + 1 - i) = A(i) * i

A(i) = s

NEXT i

n : = 10;

for i : = 1 to n do begin

s : = A[n + 1 - i] * i;

A[n + 1 - i] : = A[i] * i;

A[i] : = s;

end;

Си++Алгоритмический язык

n = 10;

for (i = 1; i <= n; i++){

s = A[n + 1 - i] * i;

A[n + 1 - i] = A[i] * i;

A[i] = s;

}

n : = 10

нц для i от 1 до n

s : = A[n + 1 - i] * i

A[n + 1 - i] : = A[i] * i

A[i] : = s

кц

Python

n = 10

for i in range(1, n+1):

    s = A[n + 1 - i] * i

    A[n + 1 - i] = A[i] * i

    A[i] = s

 

 

Перед началом выполнения фрагмента все элементы массива равны 1. Укажите утверждение, которое будет верно после выполнения указанного фрагмента программы при изменении индекса от 1 до 10.

 

1) значения массива возрастают

2) значения массива убывают

3) значения массива постоянны

4) значения массива сначала возрастают, а потом убывают

Источник: МИОО:Диагностическая ра­бо­та по ин­фор­ма­ти­ке 18.04.2013 ва­ри­ант ИНФ1501.

30
Задание 19 № 5271

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив А, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

БейсикПаскаль

n = 10

FOR i = 1 ТО n

А (n+1-i) = 2*A(i)

NEXT i

n := 10;

for i := 1 to n do begin

A [n+1-i] := 2*A[i];

end;

Си++Алгоритмический язык

n = 10;

for (i = 1; i <= n; i++) {

A [n+1-i] = 2*A[i];

}

n : = 10

нц для i от 1 до n

A[n+1-i] := 2*A[i]

кц

Python

n = 10

for i in range(1, n+1):

    A [n+1-i] = 2*A[i]

 

 

Перед началом выполнения фрагмента элементы массива имеют значения соответственно

 

1, 2, 4, 8, 16, 32, 64, 128, 256, 512, т.е. A[k] = 2k-1, k = 1, ..., 10.

 

Укажите значение, которое после выполнения указанного фрагмента программы имеют два или более рассмотренных в этом фрагменте элемента массива. Если таких чисел несколько, укажите наименьшее из них.

 

1) такого значения нет

2) 2

3) 8

4) 4

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 17.05.2013 ва­ри­ант ИНФ1601.

31
Задание 19 № 5303

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив А, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

БейсикПаскаль

n = 10

FOR i = 1 ТО n

A (n+1-i) = 2*A(i)

NEXT i

n := 10;

for i := 1 to n do begin

A [n+1-i] := 2*A[i];

end;

Си++Алгоритмический язык

n = 10;

for (i = 1; i <= n; i++) {

A [n+1-i] = 2*A[i];

}

n : = 10

нц для i от 1 до n

A[n+1-i] := 2*A[i]

кц

Python

n = 10

for i in range(1, n+1):

    A [n+1-i] = 2*A[i]

 

 

Перед началом выполнения фрагмента элементы массива имеют значения соответственно

 

1, 2, 4, 8, 16, 32, 64, 128, 256, 512, т.е. A[k] = 2k-1, k = 1, ..., 10.

 

Укажите значение, которое после выполнения указанного фрагмента программы имеют два или более рассмотренных в этом фрагменте элемента массива. Если таких чисел несколько, укажите наибольшее из них.

 

1) такого значения нет

2) 8

3) 32

4) 128

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 17.05.2013 ва­ри­ант ИНФ1602.
Пояснение · ·

32
Задание 19 № 6452

Ниже приведён фрагмент программы, записанный на четырёх языках программирования. Массив A двумерный; в программе рассматривается его фрагмент, соответствующий значениям индексов от 1 до n.

 

БейсикПаскаль

FOR i = 1 TO n

    c = A(i,i)

    A(i,i) = A(i,n–i+1)

    A(i,n–i+1) = c

NEXT i

for i := 1 to n do

begin

    c := A[i,i];

    A[i,i] := A[i,n–i+1];

    A[i,n–i+1] := c

end;

Си++Алгоритмический язык

for (i = 1; i <= n; i++) {

    c = A[i][i];

    A[i][i] = A[i][n-i+1];

    A[i][n-i+1] = c;

}

нц для i от 1 до n

    c := A[i,i]

    A[i,i] := A[i,n–i+1]

    A[i,n–i+1] := c

кц

Python

for i in range(1, n+1):

    c = A[i,i]

    A[i,i] = A[i,n–i+1]

    A[i,n–i+1] = c

 

 

Представим рассмотренный фрагмент массива в виде квадратной таблицы, в которой для элемента массива A[i, j] величина i является номером строки, а величина j — номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

 

1) два столбца в таблице

2) две строки в таблице

3) элементы двух диагоналей таблицы

4) элементы диагонали и строки таблицы

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 603.

33
Задание 19 № 6494

Ниже приведён фрагмент программы, записанный на четырёх языках программирования. Массив A целочисленный двумерный. В программе рассмотрен фрагмент массива, соответствующий значениям индексов от 1 до n; n >= 3.

 

БейсикПаскаль

FOR i = n TO 1 STEP -1

    FOR j = n TO 1 STEP -1

        A(i,j) = i-j

    NEXT j

NEXT i

for i := n downto 1 do

    for j := n downto 1 do

        A[i,j] := i-j;

Си++Алгоритмический язык

for (i = n; i >= 1; i--) {

    for (j = n; j >= 1; j--) {

        A[i][j] = i-j;

    }

}

нц для i от n до 1 шаг -1

    нц для j от n до 1 шаг -1

        A[i,j] := i-j

    кц

кц

Python

for i in range(n, 0, -1):

    for j in range(n, 0, -1):

        A[i,j] = i-j

 

 

Чему будет равно максимальное из значений элементов рассмотренного фрагмента массива посе выполнения фрагмента программы?

 

1) n – 1

2) 1– n

3) n

4) 1

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 801.

34
Задание 19 № 6772

Ниже приведён фрагмент программы, записанный на четырёх языках программирования. Массив A одномерный; в программе рассматривается его фрагмент, соответствующий значениям индекса от 1 до n.

 

БейсикПаскаль

n = 10

FOR i = 0 TO n

    K = A(i)

    A(K) = 0

NEXT i

n:=10;

for i:=0 to n do begin

    K := A[i];

    A[K] := 0;

end;

Си++Алгоритмический язык

n=10;

for (i = 0; i <= n; i++){

    K = A[i];

    A[K] = 0;

}

n:=10

нц для i от 0 до n

    K := A[i]

    A[K] := 0

кц

Python

n = 10

for i in range(0, n+1):

    K = A[i];

    A[K] = 0

 

 

В начале выполнения этого фрагмента в массиве находились числа 10, 9, 8, 7, 6, 5, 4, 3, 2, 1, 0, т. е. A[0] = 10, A[1] = 9 и т. д. Сколько элементов массива после выполнения программы будут иметь ненулевые значения?


Аналоги к заданию № 6772: 6804 Все

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 20.02.2014 ва­ри­ант ИН10601.

35
Задание 19 № 6886

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив.

 

БейсикПаскаль

s = 0

n = 10

FOR i = 0 TO n-1

    s = s+A(i)-A(i+1)

NEXT i

s:=0;

n:=10;

for i:=0 to n-1 do begin

    s:=s+A[i]-A[i+1];

end;

Си++Алгоритмический язык

s = 0;

n=10;

for (i = 0; i <= n-1; i++) {

    s=s+A[i]-A[i+1];

}

s:=0

n:=10

нц для i от 0 до n-1

    s:=s+A[i]-A[i+1]

кц

Python

s = 0

n = 10

for i in range(0, n):

    s=s+A[i]-A[i+1]

 

 

В начале выполнения этого фрагмента в массиве находились числа 15, 10, 5, 0, 5, 10, 15, 10, 5, 0, 5, т. е. A[0]=15, A[1]=10 и т. д. Чему будет равно значение переменной s после выполнения данной программы?


Аналоги к заданию № 6886: 6918 Все

Источник: МИОО: Ди­а­гно­сти­че­ская работа по ин­фор­ма­ти­ке 11.12.2013 ва­ри­ант ИНФ10301.
Пояснение · ·

36
Задание 19 № 6951

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 21.

 

БейсикПаскаль

s = 0

n = 21

FOR i = 2 TO n

    s = s+2*(A(i)-A(i-1))

NEXT i

s:=0;

n:=21;

for i:= 2 to n do begin

    s:=s+2*(A[i]-A[i-1]);

end;

Си++Алгоритмический язык

s = 0;

n = 21;

for (i = 2; i <= n; i++) {

    s=s+2*(A[i]-A[i-1]);

}

s:=0

n:=21

нц для i от 2 до n

    s:= s+2*(A[i]-A[i-1])

кц

Python

s = 0

n = 21

for i in range(2, n+1):

     s=s+2*(A[i]-A[i-1])

 

 

В начале выполнения этого фрагмента в элементе массива с индексом i находилось число i (i = 1, …, 21), т. е. A[1] = 1, A[2] = 2 и т. д. Чему будет равно значение переменной s после выполнения данной программы?


Аналоги к заданию № 6951: 6983 Все

Источник: МИОО: Ди­а­гно­сти­че­ская ра­бо­та по ин­фор­ма­ти­ке 19.03.2014 Ва­ри­ант ИНФ10801.

37
Задание 19 № 7196

Ниже приведён фрагмент программы, записанный на четырёх языках программирования.

Массив A двумерный; в программе рассматривается его фрагмент, соответствующий значениям каждого индекса от 1 до 9.

 

БейсикПаскаль

FOR n=1 TO 9

    FOR k=1 TO 9

        A(n,k)=n+k+1

    NEXT k

NEXT n

for n:=1 to 9 do

    for k:=1 to 9 do

        A[n,k]:=n+k+1

Си++Алгоритмический язык

for (n=1;n<=9;n++) {

    for (k=1;k<=9;k++) {

        A[n][k]=n+k+1;

       }

}

нц для n от 1 до 9

    нц для k от 1 до 9

        A[n,k]=n+k+1

    кц

кц

Python

for n in range(1, 10):

    for k in range(1, 10):

        A[n,k] = n+k+1

 

 

Сколько элементов указанного фрагмента массива A будут принимать нечётные значения после выполнения данного фрагмента программы?

Источник: ЕГЭ по ин­фор­ма­ти­ке 05.05.2014. До­сроч­ная волна. Ва­ри­ант 1.

38
Задание 19 № 7263

Дан фрагмент программы:

 

 

БейсикPython

FOR n = 1 TO 6

    FOR m = 1 TO 5

        C(n,m)=C(n,m)+(2*n-m)

    NEXT m

NEXT n

 

for n in range(1, 7):

    for m in range(1, 6):

        C[n,m]=C[n,m]+(2*n-m)

ПаскальАлгоритмический язык

for n:=1 to 6 do

    for m:=1 to 5 do begin

        C[n,m]:=C[n,m]+(2*n-m);

    end;

нц для n от 1 до 6

    нц для m от 1 до 5

        C[n,m]:=C[n,m]+(2*n-m)

    кц

кц

Си++

for (n = 1; n <= 6; n++) {

    for (m = 1; m <= 5; m++) {

        C[n][m]=C[n][m]+(2*n-m);

    }

}

 

 

Чему будет равно значение элемента двумерного массива С[4,3], если до выполнения этих команд С[4,3]=10?


39
Задание 19 № 7301

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 25.

 

БейсикПаскаль

n = 25

A(1) = 2

FOR i = 2 TO n

    A(i) = 2*A(i–1) MOD 10

NEXT i

n:=25;

A[1]:=2;

for i:= 2 to n do begin

    A[i] := 2*A[i–1] mod 10;

end;

Си++Алгоритмический язык

n=25;

A[1] = 2;

for (i = 2; i <= n; i++) {

    A[i] = 2*A[i–1] % 10;

}

n:=25

A[1] := 2

нц для i от 2 до n

    A[i] = mod (2*A[i–1], 10)

кц

Python

n = 25

A[1] = 2

for i in range(2, n+1):

    A[i] = 2*A[i–1] % 10

 

 

Чему будет равно значение элемента A[25] (то есть элемента массива с индексом 25) после выполнения фрагмента программы?

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 30.04.2014 ва­ри­ант ИН10901.

40
Задание 19 № 7333

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 24.

 

БейсикПаскаль

n = 24

A(1) = 4

FOR i = 2 TO n

    A(i) = 4*A(i–1) MOD 10

NEXT i

n:=24;

A[1]:=4;

for i:= 2 to n do begin

    A[i] := 4*A[i–1] mod 10;

end;

Си++Алгоритмический язык

n=24;

A[1] = 4;

for (i = 2; i <= n; i++) {

    A[i] = 4*A[i–1] % 10;

}

n:=24

A[1] := 4

нц для i от 2 до n

    A[i] = mod (4*A[i–1], 10)

кц

Python

n = 24

A[1] = 4

for i in range(2, n+1):

    A[i] = 4*A[i–1] % 10

 

 

Чему будет равно значение элемента A[24] (то есть элемента массива с индексом 24) после выполнения фрагмента программы?

Источник: МИОО: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 30.04.2014 ва­ри­ант ИН10902.

41
Задание 19 № 7365

Ниже приведён фрагмент программы, записанный на четырёх языках программирования.

Массив A двумерный; в программе рассматривается его фрагмент, соответствующий значениям каждого индекса от 1 до 9.

 

БейсикПаскаль

FOR n=1 TO 9

    FOR k=1 TO 9

    A(n,k)=2*n+k

    NEXT k

NEXT n

for n:=1 to 9 do

    for k:=1 to 9 do

        A[n,k]:=2*n+k

Си++Алгоритмический язык

for (n=1;n<=9;n++) {

    for (k=1;k<=9;k++)

        A[n][k]=2*n+k;

    }

}

нц для n от 1 до 9

    нц для k от 1 до 9

        A[n,k]=2*n+k

кц

кц

Python

 

for n in range(1, 10):

    for k in range(1, 10):

            A[n,k] = 2*n+k

 

 

Сколько элементов указанного фрагмента массива A будут принимать нечётные значения после выполнения данного фрагмента программы?

Источник: ЕГЭ по ин­фор­ма­ти­ке 05.05.2014. До­сроч­ная волна. Ва­ри­ант 2.

Пройти тестирование по этим заданиям