СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
Информатика
Cайты, меню, вход, новости


Варианты заданий
Версия для печати и копирования в MS Word
1
Задание 19 № 4971

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования,фрагмент одной и той же программы, обрабатывающей данный массив:

 

 

БейсикПаскаль

s = 0

n = 10

FOR i = 0 TO n

    IF A(n − i)-A(i) > A(i) THEN

        s = s + A(i)

    END IF

NEXT i

s := 0;

n := 10;

for i:=0 to n do begin

    if A[n - i] - A[i] > A[i] then

        s := s + A[i];

end;

Си++Алгоритмический язык

s = 0;

n = 10;

for (i = 0; i <= n; i++ )

    if(A[n - i]-A[i] > A[i])

        s = s+ A[i];

s := 0

n:=10

нц для i от 0 до n

    если A[n - i] - A[i] > A[i]

        то s := s + A[i]

все

кц

Python

s = 0

n = 10

for i in range(0, n+1):

    if A[n - i]-A[i] > A[i]:

        s = s+ A[i]

 

 

В начале выполнения этого фрагмента в массиве находились числа 0,2,4,6,8,10,12,14,16,18,20 т. е. A[0] = 0, A[1] = 2 и т. д. Чему будет равно значение переменной s после выполнения данной программы?


Аналоги к заданию № 4930: 4971 Все