СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
Информатика
Cайты, меню, вход, новости


Варианты заданий
Версия для печати и копирования в MS Word
1
Задание 19 № 7703

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив:

 

 

БейсикPython

s = 0

n = 10

FOR i = 0 TO n-3

s = s+A(i)-A(i+2)

NEXT i

s = 0

n = 10

for i in range(0,n-2):

s = s + A[i] - A[i+2]

ПаскальАлгоритмический язык

s:=0;

n:=10;

for i:=0 to n-3 do begin

s:=s+A[i]-A[i+2]

end;

s:=0

n:=10

нц для i от 0 до n-3

s:=s+A[i]-A[i+2]

кц

Си++

s = 0;

n=10;

for (i = 0; i <= n-3; i++)

s=s+A[i]-A[i+2];

 

В начале выполнения этого фрагмента в массиве находились двузначные натуральные числа. Какое наибольшее значение может иметь переменная s после выполнения данной программы?


Аналоги к заданию № 7676: 7703 7930 7995 Все


2
Задание 19 № 7930

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив.

 

БейсикPython

s = 27

n = 10

FOR i = 0 TO n-1

    s = s+A(i)-A(i+1)

NEXT i

s = 27

n = 10

for i in range(0,n):

    s = s + A[i] - A[i+1]

ПаскальАлгоритмический язык

s:=27;

n:=10;

for i:=0 to n-1 do begin

    s:=s+A[i]-A[i+1]

end;

s:=27

n:=10

нц для i от 0 до n-1

    s:=s+A[i]-A[i+1]

кц

Си++

s = 27;

n=10;

for (i = 0; i <= n-1; i++)

    s=s+A[i]-A[i+1];

 

Известно, что в начале выполнения этого фрагмента в массиве находилась убывающая последовательность чисел, то есть A[0] > A[1] >…> A[10]. Какое наименьшее значение может иметь переменная s после выполнения данной программы?


Аналоги к заданию № 7676: 7703 7930 7995 Все


3
Задание 19 № 7995

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив.

 

БейсикPython

s = 29

n = 10

FOR i = 0 TO n-1

s = s+A(i)-A(i+1)

NEXT i

s = 29

n = 10

for i in range(0,n):

s = s + A[i] - A[i+1]

ПаскальАлгоритмический язык

s:=29;

n:=10;

for i:=0 to n-1 do begin

s:=s+A[i]-A[i+1]

end;

s:=29

n:=10

нц для i от 0 до n-1

s:=s+A[i]-A[i+1]

кц

Си++

s = 29;

n=10;

for (i = 0; i <= n-1; i++)

s=s+A[i]-A[i+1];

 

Известно, что в начале выполнения этого фрагмента в массиве находилась возрастающая последовательность чисел, то есть A[0] < A[1] <…< A[10]. Какое наибольшее значение может иметь переменная s после выполнения данной программы?


Аналоги к заданию № 7676: 7703 7930 7995 Все

Решение · · Видеокурс ·