информатика
Информатика
Русский язык
Английский язык
Немецкий язык
Французcкий язык
Испанский язык
Физика
Химия
Биология
География
Обществознание
Литература
История
сайты - меню - вход - новости




Каталог заданий.
Геометрическая прогрессия
Сортировка:
Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 8 № 3243

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM K, S AS INTEGER

S = 0

K = 0

WHILE S < 80

    S = S + 2*K

    K = K + 4

WEND

PRINT S

s = 0

k = 0

while s < 80:

    s += 2*k

    k += 4

print(s)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=0;

       k:=0;

      while s < 80 do begin

            s:=s+2*k;

            k:=k+4;

       end;

      write(s);

end.

алг

нач

    цел k, s

    s := 0

    k := 0

    нц пока s < 80

        s := s + 2*k

        k := k + 4

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 0, k = 0;

    while (s < 80) {

        s = s + 2*k;

        k = k + 4;

    }

    cout << s << endl;

    return 0;

}

 


2
Задание 8 № 7665

Определите, что будет напечатано в результате выполнения программы, записанной ниже на разных языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 100

S = S + 30

N = N * 2

WEND

PRINT S

n = 1

s = 0

while n <= 100:

    s = s + 30

    n = n * 2

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 100 do

    begin

        s := s + 30;

        n := n * 2

    end;

    write(s)

end.

алг

нач

цел n, s

n := 1

s := 0

нц пока n <= 100

    s := s + 30

    n := n * 2

кц

вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 100)

    {

        s = s + 30;

        n = n * 2;

    }

    cout « s « endl;

}

 


Аналоги к заданию № 7665: 7692 Все


3
Задание 8 № 3253

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

 

БейсикPython

DIM K, S AS INTEGER

S = 0

K = 0

WHILE K < 12

    S = S + 2*K

    K = K + 3

WEND

PRINT S

s = 0

k = 0

while k < 12:

    s += 2*k

    k += 3

print(s)

ПаскальАлгоритмический язык

var k, s: integer;

begin

       s:=0;

       k:=0;

      while k < 12 do begin

            s:=s+2*k;

            k:=k+3;

       end;

      write(s);

end.

алг

нач

    цел k, s

    s := 0

    k := 0

    нц пока k < 12

        s := s + 2*k

        k := k + 3

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int s, k;

    s = 0, k = 0;

    while (k < 12) {

        s = s + 2*k;

        k = k + 3;

    }

    cout << s << endl;

    return 0;

}

 


4
Задание 8 № 5088

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 26

WHILE S <= 205

    S = S + 20

    N = N * 2

WEND

PRINT N

n = 1

s = 26

while s <= 205:

    s += 20

    n *= 2

print(n)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 26;

    while s <= 205 do

    begin

        s := s + 20;

        n := n * 2;

    end;

    writeln(n);

end.

алг

нач

    цел n, s

    n := 1

    s := 26

    нц пока s <= 205

        s := s + 20

        n := n * 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main() {

    int n, s;

    n = 1, s = 26;

    while (s <= 205) {

        s = s + 20;

        n = n * 2;

    }

    cout << n << endl;

    return 0;

}

 


5
Задание 8 № 5056

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 6

WHILE S <= 365

S = S + 36

N = N * 2

WEND

PRINT N

var n, s: integer;

begin

    n : = 1;

    s : = 6;

    while s <= 365 do

    begin

        s : = s + 36;

        n : = n * 2

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 6;

    while (s <= 365)

    {

        s = s + 36;

        n = n * 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n : = 1

s : = 6

нц пока s <= 365

    s : = s + 36

    n : = n * 2

кц

вывод n

кон

Python

n = 1

s = 6

while s <= 365:

    s += 36

    n *= 2

print(n)

 


6
Задание 8 № 5277

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

    N = 30

    S = 1

    WHILE S < 500

        S = S * 2

        N = N + 10

    WEND

PRINT N

var n, s: integer;

begin

    n := 30;

    s := 1;

    while s < 500 do

    begin

        s := s * 2;

        n := n + 10

    end;

    write(n);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 30;

    s = 1;

    while (s < 500)

    {

        s = s * 2 ;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 30

s : = 1

нц пока s < 500

    s := s * 2

    n := n + 10

кц

вывод n

кон

Python

n = 30

s = 1

while s < 500:

    s *= 2

    n += 10

print(n)

 


7
Задание 8 № 5309

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

    N = 50

    S = 1

    WHILE S < 1000

        S = S * 2

        N = N + 10

    WEND

PRINT N

var n, s: integer;

begin

    n : = 50;

    s := 1;

    while s < 1000 do

    begin

        s := s * 2;

        n := n + 10

    end;

    write(n);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 50;

    s = 1;

    while (s < 1000)

    {

        s = s * 2 ;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 50

s : = 1

нц пока s < 1000

    s : = s * 2

    n := n + 10

кц

вывод n

кон

Python

n = 50

s = 1

while s < 1000:

    s *= 2

    n += 10

print(n)

 


8
Задание 8 № 6957

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE S <= 1024

S = S + 128

N = N * 2

WEND

PRINT N

program B05;

var n, s: integer;

begin

    n := 1;

    s := 0;

    while s <= 1024 do

    begin

        s := s + 128;

        n := n * 2;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (s <= 1024)

    {

        s = s + 128;

        n = n * 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 1

s := 0

нц пока s <= 1024

    s := s + 128

    n := n * 2

кц

вывод n

кон

Python

n = 1

s = 0

while s <= 1024

    s += 128

    n *= 2

print(n)

 


9
Задание 8 № 6989

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE S <= 1024

S = S + 256

N = N * 2

WEND

PRINT N

var n, s: integer;

begin

    n := 1;

    s := 0;

    while s <= 1024 do

    begin

        s := s + 256;

        n := n * 2;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (s <= 1024)

    {

        s = s + 256;

        n = n * 2;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 1

s := 0

нц пока s <= 1024

    s := s + 256

    n := n * 2

кц

вывод n

кон

Python

n = 1

s = 0

while s <= 1024

    s += 256

    n *= 2

print(n)

 

Пояснение · ·

10
Задание 8 № 7307

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 1

WHILE S <= 1000

S = S * 2

N = N + 2

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 1;

    while s <= 1000 do

    begin

        s := s * 2;

        n := n + 2;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 1;

    while (s <= 1000)

    {

        s = s * 2;

        n = n + 2;

    }

    cout << n << endl;

}

алг

нач

цел n, s

n := 0

s := 1

нц пока s <= 1000

    s := s * 2

    n := n + 2

кц

вывод n

кон

Python

n = 0

s = 1

while s <= 1000:

    s *= 2

    n += 2

print(n)

 


11
Задание 8 № 7339

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 1

WHILE S <= 1000

S = S * 3

N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 1;

    while s <= 1000 do

    begin

        s := s * 3;

        n := n + 3;

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 1;

    while (s <= 1000)

    {

        s = s * 3;

        n = n + 3;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 1

нц пока s <= 1000

    s := s * 3

    n := n + 3

кц

вывод n

кон

Python

n = 0

s = 1

while s <= 1000:

    s *= 3

    n += 3

print(n)

 


Пройти тестирование по этим заданиям