СДАМ ГИА






Каталог заданий. Геометрическая прогрессия
Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 8 № 3243

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

var k, s: integer;

begin

    s:=0;

    k:=0;

    while s < 80 do begin

        s:=s+2*k;

        k:=k+4;

    end;

    write(s);

end.


2
Задание 8 № 7665

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния программы, за­пи­сан­ной ниже на раз­ных язы­ках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 100

S = S + 30

N = N * 2

WEND

PRINT S

n = 1

s = 0

while n <= 100:

    s = s + 30

    n = n * 2

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 100 do

    begin

        s := s + 30;

        n := n * 2

    end;

    write(s)

end.

алг

нач

цел n, s

n := 1

s := 0

нц пока n <= 100

    s := s + 30

    n := n * 2

кц

вывод s

кон

Си

#include <stdio.h>

void main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 100)

    {

        s = s + 30;

        n = n * 2;

    }

    printf("%d", s);

}

 


Аналоги к заданию № 7665: 7692 Все

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 26.11.2014 ва­ри­ант ИН10301.

3
Задание 8 № 3253

Определите, что будет напечатано в результате работы следующего фрагмента программы:

 

var k, s: integer;

begin

    s:=0;

    k:=0;

    while k < 12 do begin

        s:=s+2*k;

        k:=k+3;

    end;

    write(s);

end.


4
Задание 8 № 5088

Определите, что будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

var n, s: integer;

begin

    n := 1;

    s := 26;

    while s <= 205 do

    begin

        s := s + 20;

        n := n * 2;

    end;

    write(n)

end.

Источник: МИОО: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 22.03.2013 ва­ри­ант ИНФ1402.

5
Задание 8 № 5056

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 6

WHILE S <= 365

S = S + 36

N = N * 2

WEND

PRINT N

var n, s: integer;

begin

    n : = 1;

    s : = 6;

    while s <= 365 do

    begin

        s : = s + 36;

        n : = n * 2

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 1;

    s = 6;

    while (s <= 365)

    {

        s = s + 36;

        n = n * 2;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n : = 1

s : = 6

нц пока s <= 365

    s : = s + 36

    n : = n * 2

кц

вывод n

кон

 

Источник: МИОО: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 22.03.2013 ва­ри­ант ИНФ1401.

6
Задание 8 № 5277

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

    N = 30

    S = 1

    WHILE S < 500

        S = S * 2

        N = N + 10

    WEND

PRINT N

var n, s: integer;

begin

    n := 30;

    s := 1;

    while s < 500 do

    begin

        s := s * 2;

        n := n + 10

    end;

    write(n);

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 30;

    s = 1;

    while (s < 500)

    {

        s = s * 2 ;

        n = n + 10;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 30

s : = 1

нц пока s < 500

    s := s * 2

    n := n + 10

кц

вывод n

кон

 

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 17.05.2013 ва­ри­ант ИНФ1601.

7
Задание 8 № 5309

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те выполнения про­грам­мы (записанной ниже на раз­ных языках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

    N = 50

    S = 1

    WHILE S < 1000

        S = S * 2

        N = N + 10

    WEND

PRINT N

var n, s: integer;

begin

    n : = 50;

    s := 1;

    while s < 1000 do

    begin

        s := s * 2;

        n := n + 10

    end;

    write(n);

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 50;

    s = 1;

    while (s < 1000)

    {

        s = s * 2 ;

        n = n + 10;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 50

s : = 1

нц пока s < 1000

    s : = s * 2

    n := n + 10

кц

вывод n

кон

 

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 17.05.2013 ва­ри­ант ИНФ1602.

8
Задание 8 № 6957

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE S <= 1024

S = S + 128

N = N * 2

WEND

PRINT N

program B05;

var n, s: integer;

begin

    n := 1;

    s := 0;

    while s <= 1024 do

    begin

        s := s + 128;

        n := n * 2;

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 1;

    s = 0;

    while (s <= 1024)

    {

        s = s + 128;

        n = n * 2;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 1

s := 0

нц пока s <= 1024

    s := s + 128

    n := n * 2

кц

вывод n

кон

 

Источник: МИОО: Ди­а­гно­сти­че­ская ра­бо­та по ин­фор­ма­ти­ке 19.03.2014 Ва­ри­ант ИНФ10801.

9
Задание 8 № 6989

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 1

S = 0

WHILE S <= 1024

S = S + 256

N = N * 2

WEND

PRINT N

var n, s: integer;

begin

    n := 1;

    s := 0;

    while s <= 1024 do

    begin

        s := s + 256;

        n := n * 2;

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 1;

    s = 0;

    while (s <= 1024)

    {

        s = s + 256;

        n = n * 2;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 1

s := 0

нц пока s <= 1024

    s := s + 256

    n := n * 2

кц

вывод n

кон

 

Источник: МИОО: Ди­а­гно­сти­че­ская ра­бо­та по ин­фор­ма­ти­ке 19.03.2014 Ва­ри­ант ИНФ10802.
Пояснение · ·

10
Задание 8 № 7307

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (записанной ниже на раз­ных язы­ках программирования):

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 1

WHILE S <= 1000

S = S * 2

N = N + 2

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 1;

    while s <= 1000 do

    begin

        s := s * 2;

        n := n + 2;

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 1;

    while (s <= 1000)

    {

        s = s * 2;

        n = n + 2;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 0

s := 1

нц пока s <= 1000

    s := s * 2

    n := n + 2

кц

вывод n

кон

 

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 30.04.2014 ва­ри­ант ИН10901.

11
Задание 8 № 7339

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те выполнения про­грам­мы (записанной ниже на раз­ных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 1

WHILE S <= 1000

S = S * 3

N = N + 3

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 1;

    while s <= 1000 do

    begin

        s := s * 3;

        n := n + 3;

    end;

    write(n)

end.

СиАлгоритмический язык

#include <stdio.h>

void main()

{

    int n, s;

    n = 0;

    s = 1;

    while (s <= 1000)

    {

        s = s * 3;

        n = n + 3;

    }

    printf("%d", n);

}

алг

нач

цел n, s

n := 0

s := 1

нц пока s <= 1000

    s := s * 3

    n := n + 3

кц

вывод n

кон

 

Источник: МИОО: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 30.04.2014 ва­ри­ант ИН10902.

Пройти тестирование по этим заданиям



     О проекте · Редакция

© Гущин Д. Д., 2011—2017


СПб ГУТ! С! Ф! У!