≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 6500

Определите число, которое будет напечатано в результате выполнения программы (записанной ниже на разных языках программирования).

 

БейсикПаскаль

DIM N, S AS INTEGER

N = 0

S = 0

WHILE S <= 249

S = S + 24

N = N + 10

WEND

PRINT N

var n, s: integer;

begin

    n := 0;

    s := 0;

    while s <= 249 do

    begin

        s := s + 24;

        n := n + 10

    end;

    write(n)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 0;

    s = 0;

    while (s <= 249)

    {

        s = s + 24;

        n = n + 10;

    }

    cout « n « endl;

}

алг

нач

цел n, s

n := 0

s := 0

нц пока s <= 249

    s := s + 24

    n := n + 10

кц

вывод n

кон

Python

n = 0

s = 0

while s <= 249:

    s += 24

    n += 10

print(n)

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s <= 249, т. е. переменная s определяет, сколько раз выполнится цикл.

Заметим, что На 11 шаге s станет равной 264 и условие s <= 249 окажется невыполненным, цикл прервется. Следовательно, значение n будет равно 11·10 = 110.

 

Ответ: 110.

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 801.