СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задания Д 19 № 6494

Ниже приведён фрагмент программы, записанный на четырёх языках программирования. Массив A целочисленный двумерный. В программе рассмотрен фрагмент массива, соответствующий значениям индексов от 1 до n; n >= 3.

 

БейсикПаскаль

FOR i = n TO 1 STEP -1

    FOR j = n TO 1 STEP -1

        A(i,j) = i-j

    NEXT j

NEXT i

for i := n downto 1 do

    for j := n downto 1 do

        A[i,j] := i-j;

Си++Алгоритмический язык

for (i = n; i >= 1; i--) {

    for (j = n; j >= 1; j--) {

        A[i][j] = i-j;

    }

}

нц для i от n до 1 шаг -1

    нц для j от n до 1 шаг -1

        A[i,j] := i-j

    кц

кц

Python

for i in range(n, 0, -1):

    for j in range(n, 0, -1):

        A[i,j] = i-j

 

 

Чему будет равно максимальное из значений элементов рассмотренного фрагмента массива посе выполнения фрагмента программы?

 

1) n – 1

2) 1– n

3) n

4) 1

Пояснение.

Команда «A[i,j] := i-j;» присваивает элементу разность между значениями индексов i и j. Максимальное значение элемент массива будет иметь в том случае, когда индекс i будет иметь максимальное значение, а индекс j — минимальное. Максимальное значение индекса i — n, минимальное индекса j — 1. Таким образом, максимальное из значений элементов будет равно n – 1.

 

Правильный ответ указан под номером 1.

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 801.