СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 13511

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE 2*S*S < 10*S

     S = S + 1

     N = N + 2

WEND

PRINT N

s = 0

n = 0

while 2*s*s < 10*s:

    s = s + 1

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while 2*s*s < 10*s do

begin

    s := s + 1;

    n := n + 2;

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока 2*s*s < 10*s

    s := s + 1

    n := n + 2

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{  int s = 0, n = 0;

    while (2*s*s < 10*s) { s = s + 1; n = n + 2; }

    cout << n << endl;

    return 0;

}

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие 2 · s · s < 10 · s. Заметим, что перед первым заходом в цикл переменная s равна 0, условие не выполняется. То есть переменная n будет равна 0.

 

Ответ: 0.

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10204