СДАМ ГИА






Каталог заданий. Алгоритмы с использованием условного оператора
Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 19 № 3361

Дан фраг­мент программы, об­ра­ба­ты­ва­ю­щий массив А из 10 элементов:

 

j := 1;

for i:=1 tо 10 do

if A[i] = A[j] then j := i;

s := j;

 

Чему будет равно зна­че­ние переменной s после вы­пол­не­ния этого алгоритма?

 

1) 1

2) 10

3) индексу элемента, рав­но­го первому, и име­ю­ще­му наибольший индекс

4) индексу элемента, рав­но­го последнему, и име­ю­ще­му наименьший индекс


2
Задание 19 № 8667

В про­грам­ме ис­поль­зу­ет­ся од­но­мер­ный це­ло­чис­лен­ный мас­сив A с ин­дек­са­ми от 0 до 9. Зна­че­ния эле­мен­тов равны 4; 2; 6; 6; 7; 7; 7; 5; 5; 9 соответственно, т.е. A[0] = 4; A[1] = 2 и т.д.

Определите зна­че­ние пе­ре­мен­ной c после вы­пол­не­ния сле­ду­ю­ще­го фраг­мен­та программы, за­пи­сан­но­го ниже на раз­ных язы­ках программирования.

 

Бейсик Python

c = 0

FOR i = 1 TO 9

    IF A(i - 1) >= A(i) THEN

        t = A(i)

        A(i) = A(i - 1)

        A(i - 1) = t

        c = c + 1

    ENDIF

NEXT i

c = 0

for i in range(1, 10):

    if A[i - 1] >= A[i]:

        t = A[i]

        A[i] = A[i - 1]

        A[i - 1] = t

        c = c + 1

Алгоритмический язык Паскаль

c := 0

нц для i от 1 до 9

    если A[i - 1] >= A[i] то

        t := A[i]

        A[i] := A[i - 1]

        A[i - 1] := t

        c := c + 1

    все

кц

c := 0;

for i := 1 to 9 do

    if A[i - 1] >= A[i] then

    begin

        t := A[i];

        A[i] := A[i - 1];

        A[i - 1] := t;

        c := c + 1;

    end;

Си

c = 0;

for (i = 1; i <= 9; i++)

    if (A[i - 1] >= A[i])

    {

        t = A[i];

        A[i] = A[i - 1];

        A[i - 1] = t;

        c++;

    }


Аналоги к заданию № 8667: 9171 Все

Источник: СтатГрад: Ре­пе­ти­ци­он­ная ра­бо­та по ин­фор­ма­ти­ке 01.04.2015 ИН10701

3
Задание 19 № 9203

Ниже пред­став­лен за­пи­сан­ный на раз­ных язы­ках про­грам­ми­ро­ва­ния фраг­мент одной и той же программы, об­ра­ба­ты­ва­ю­щей од­но­мер­ный це­ло­чис­лен­ный мас­сив с ин­дек­са­ми от 0 до 10.

 

Бейсик Python

s = 27

n = 10

FOR i = 0 TO n-1

    s = s+A(i)-A(i+1)+2

NEXT i

s = 27

n = 10

for i in range(0,n):

    s = s + A[i] - A[i+1]+2

Алгоритмический язык Паскаль

s := 27

n := 10

нц для i от 0 до n-1

    s:=s+A[i]-A[i+1]+2

кц

s := 27;

n := 10;

for i:=0 to n-1 do begin

    s:=s+A[i]-A[i+1]+2

end;

Си

s = 27;

n = 10;

for (i = 0; i <= n-1; i++)

    s=s+A[i]-A[i+1]+2;

 

Известно, что в на­ча­ле вы­пол­не­ния этого фраг­мен­та в мас­си­ве на­хо­ди­лась воз­рас­та­ю­щая по­сле­до­ва­тель­ность чисел, то есть A[0] < A[1] < … < A[10].

Какое наи­боль­шее зна­че­ние может иметь пе­ре­мен­ная s после выполнения данной программы?


Аналоги к заданию № 9203: 9311 Все

Источник: СтатГрад: Тренировочная работа по ин­фор­ма­ти­ке 06.05.2015 ИН10801

4
Задание 19 № 9370

В про­грам­ме ис­поль­зу­ет­ся од­но­мер­ный це­ло­чис­лен­ный мас­сив A с ин­дек­са­ми от 0 до 9. Зна­че­ния эле­мен­тов равны 4, 7, 3, 8, 5, 0, 1, 2, 9, 6 соответственно, т.е. A[0] = 4, A[1] = 7 и т.д.

Определите зна­че­ние пе­ре­мен­ной c после вы­пол­не­ния сле­ду­ю­ще­го фраг­мен­та этой про­грам­мы (записанного ниже на пяти язы­ках программирования).

 

БейсикPython

 c = 0

 FOR i = 1 TO 9

    IF A(i) < A(0) THEN

        c = c + 1

        t = A(i)

        A(i) = A(0)

        A(0) = t

    ENDIF

 NEXT i

 c = 0

 for i in range(1,10):

    if A[i] < A[0]:

        c = c + 1

        t = A[i]

        A[i] = A[0]

        A[0] = t

ПаскальАлгоритмический язык

 c := 0;

 for i := 1 to 9 do

    if A[i] < A[0] then

    begin

        c := c + 1;

        t := A[i];

        A[i] := A[0];

        A[0] := t;

    end;

 c := 0

 нц для i от 1 до 9

    если A[i] < A[0] то

        c := c + 1

        t := A[i]

        A[i] := A[0]

        A[0] := t

    все

 кц

Си

 c = 0;

 for (i = 1;i < 10;i++)

    if (A[i] < A[0])

    {

        c++;

        t = A[i];

        A[i] = A[0];

        A[0] = t;

    }

 


Аналоги к заданию № 9370: 9805 10295 10393 10420 10482 10509 9769 Все

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2016 по информатике.

5
Задание 19 № 9654

В про­грам­ме ис­поль­зу­ет­ся од­но­мер­ный це­ло­чис­лен­ный мас­сив A с ин­дек­са­ми от 1 до 10. Зна­че­ния эле­мен­тов равны 7; 3; 4; 8; 6; 9; 5; 2; 0; 1 соответственно, т. е. A[1] = 7; A[2] = 3 и т. д.

Определите зна­че­ние пе­ре­мен­ной j после вы­пол­не­ния сле­ду­ю­ще­го фраг­мен­та программы, за­пи­сан­но­го ниже на раз­ных язы­ках программирования.

 

БейсикПаскаль

j = 0

FOR k = 2 TO 10

  IF A(k) <= A(1) THEN

    A(1) = A(k)

    j = j + k

  END IF

NEXT k

j := 0;

for k := 2 to 10 do

begin

  if A[k] <= A[1] then

    begin

      A[1] := A[k];

      j := j + k

    end

end;

СиАлгоритмический язык

j = 0;

for (k = 2; k<= 10; k++) {

  if (A[k] <= A[1]) {

    A[1] = A[k];

    j = j + k;

  }

}

j := 0

нц для k от 2 до 10

  если A[k] <= A[1] то

    A[1] := A[k]

    j := j+k

  все

кц

 


Аналоги к заданию № 9654: 9700 Все

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 28.09.2015 ИН10103

6
Задание 19 № 9769

В про­грам­ме ис­поль­зу­ет­ся од­но­мер­ный це­ло­чис­лен­ный мас­сив A с ин­дек­са­ми от 0 до 9. Зна­че­ния эле­мен­тов равны 6, 7, 3, 8, 5, 1, 2, 0, 9, 4 соответственно, т. е. A[0] = 6, A[1] = 7 и т. д.

Определите зна­че­ние пе­ре­мен­ной c после вы­пол­не­ния сле­ду­ю­ще­го фраг­мен­та этой про­грам­мы (записанного ниже на пяти язы­ках программирования).

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) < A(0) THEN

    c = c + 1

    t = A(i)

    A(i) = A(0)

    A(0) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i] < A[0]:

    c = c + 1

    t = A[i]

    A[i] = A[0]

    A[0] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do

  if A[i] < A[0] then

  begin

    c := c + 1;

    t := A[i];

    A[i] := A[0];

    A[0] := t;

end;

c := 0

нц для i от 1 до 9

  если A[i] < A[0] то

    c := c + 1

    t := A[i]

    A[i] := A[0]

    A[0] := t

  все

кц

Си

c = 0;

for (i = 1;i < 10;i++)

  if (A[i] < A[0])

  {

    c++;

    t = A[i];

    A[i] = A[0];

    A[0] = t;

  }

 


7
Задание 19 № 3363

Дан фрагмент программы, обрабатывающий двухмерный массив A размером nxn.

 

for i:=1 to n-1 do

for j:= i+1 to n do

if A[i,1] < A[j,1] then begin

k:=A[i,1];

A[i,1]:=A[j,1];

A[j,1]:=k;

end;

 

В этом фрагменте:

 

1) упорядочивается первая строка массива по убыванию

2) упорядочивается первый столбец массива по убыванию

3) заменяются элементы k-ого столбца таблицы

4) заменяются элементы k-ой строки таблицы


8
Задание 19 № 3369

Значения эле­мен­тов двух­мер­но­го мас­си­ва A[1..100,1..100] за­да­ют­ся с по­мо­щью сле­ду­ю­ще­го фраг­мен­та программы:

 

for i:=1 to 100 do

for k:=1 to 100 do

if i = k then

A[i,k] := 1

else A[i,k] := -1;

 

Чему равна сумма эле­мен­тов мас­си­ва после вы­пол­не­ния этого фраг­мен­та программы?


9
Задание 19 № 3380

В программе описан одномерный целочисленный массив A с индексами от 1 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

 

for i:=1 to 10 do

A[i]:=5*i;

for i:=1 to 10 do begin

k:=A[i]-2;

A[10-i+1]:=k;

end;

 

Чему будут равны элементы этого массива?

 

1) 1 6 11 16 21 23 18 13 8 3

2) 3 8 13 18 23 28 33 38 43 48

3) 48 43 38 33 28 23 18 13 8 3

4) 1 6 11 16 21 26 31 36 41 46


10
Задание 19 № 3806

В программе описан одномерный целочисленный массив с индексами от 0 до n. Ниже представлен фрагмент одной и той же программы, записанный на разных языках программирования, обрабатывающей данный массив:

 

 

БейсикПаскаль

s = 0

z = A(n)

FOR i = 0 TO n

    IF A(i) > z THEN s = s + 1

NEXT i

s: = 0;

z: = A[n];

for i: = 0 to n do

    begin

        if A[i] > z then

            s: = s + 1;

    end

СиАлгоритмический язык
s = 0;

z = A[n];

for (i = 0; i <= n; i++){

    if (A[i] > z)

        s++;

}

s: = 0

z: = A[n]

нц для i от 0 до n

если A[i] > z то

    s: = s + 1

все

кц

 

Чему будет равно значение переменной s после выполнения данной программы, при любых значениях элементов массива?

 

1) Минимальному элементу в массиве A

2) Количеству элементов массива A, больших последнего элемента массива

3) Индексу последнего элемента массива А, который меньше A[0]

4) Количеству элементов массива A, меньших последнего элемента массива


Аналоги к заданию № 3806: 4583 Все

Источник: Яндекс: Тренировочная работа ЕГЭ по информатике. Ва­ри­ант 1.

11
Задание 19 № 4842

В про­грам­ме опи­сан од­но­мер­ный це­ло­чис­лен­ный мас­сив с ин­дек­са­ми от 0 до 10. Ниже пред­став­лен за­пи­сан­ный на раз­ных язы­ках про­грам­ми­ро­ва­ния фраг­мент одной и той же программы, об­ра­ба­ты­ва­ю­щей дан­ный массив.

 

БейсикПаскаль

s = 0

n = 10

FOR i = 1 ТО n

    IF i = n - i THEN

        s = s + A(i) + A (i + 1)

    END IF

NEXT i

s: = 0;

n : = 10 ;

for i : = 1 to n do

    begin

        if i = n - i then

            s : = s + A[i] + A[i + 1];

    end

СиАлгоритмический язык
s = 0;

n = 10;

for (i = 1; i <= n; i++){

    if (i == n - i)

        s = s + A[i] + A[i + 1];

}

s: = 0

n : = 10

нц для i от 1 до n

если i = n - i

    то s := s + A[i] + A[i + 1]

все

кц

 

В на­ча­ле вы­пол­не­ния этого фраг­мен­та в мас­си­ве на­хо­ди­лись числа 0, 2, 4, 6, 8, 10, 12, 14, 16, 18, 20, т. е. эле­мент А[0]=0, А[1]=2 и т. д. Чему будет равно зна­че­ние пе­ре­мен­ной s после вы­пол­не­ния дан­ной программы?

Источник: МИОО: Ди­а­гно­сти­че­ская работа по ин­фор­ма­ти­ке 14.12.2012 ва­ри­ант 3.

12
Задание 19 № 4930

В про­грам­ме описан од­но­мер­ный целочисленный мас­сив с ин­дек­са­ми от 0 до 10. Ниже пред­став­лен за­пи­сан­ный на раз­ных языках программирования,фрагмент одной и той же программы, об­ра­ба­ты­ва­ю­щей данный массив:

 

БейсикПаскаль

s=0

n = 10

FOR i = 0 TO n

    IF A(n − i)-A(i) > A(i) THEN

        s = s + A(i)

    END IF

NEXT i

s := 0;

n := 10;

for i:=0 to n do begin

    if A[n - i] - A[i] > A[i] then

        s := s + A[i];

end;

СиАлгоритмический язык

s = 0;

n = 10;

for (i = 0; i <= n; i++ )

    if(A[n - i]-A[i] > A[i])

        s = s+ A[i];

s := 0

n:=10

нц для i от 0 до n

    если A[n - i] - A[i] > A[i]

        то s := s + A[i]

все

кц

 

В на­ча­ле выполнения этого фраг­мен­та в мас­си­ве находились числа 0, 10, 20, 30, 40, 50, 60, 70, 80. 90, 100, т.е. A[0] = 0, A[1] = 10 и т. д. Чему будет равно зна­че­ние переменной s после вы­пол­не­ния данной программы?


Аналоги к заданию № 4930: 4971 Все

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 15.02.2013 ва­ри­ант 1.

13
Задание 19 № 5997

Ниже приведён фраг­мент программы, за­пи­сан­ный на четырёх язы­ках программирования.

Массив A одномерный; в про­грам­ме рас­смат­ри­ва­ет­ся его фрагмент, соот­вет­ству­ю­щий зна­че­ни­ям ин­дек­са от 1 до n.

 

 

БейсикПаскаль

J = 1

FOR I = 1 TO n

    IF A(I) < A(J) THEN J =I NEXT I

s = J

j :=1;

for i: = 0 to n do

    begin

        if A[i] < A[j] then

            j := i

    end;

s := j;

СиАлгоритмический язык

j = 1;

for (i = 1; i <= n; i++) {

    if (A[i] < A[j]) {

        j = i;

    }

}

s = j;

j := 1

нц для i от 1 до n

    если A[i] < A[j] то

        j := i

    все

кц

s := j

 

Чему будет равно зна­че­ние пе­ре­мен­ной s после вы­пол­не­ния дан­но­го фраг­мен­та программы?

 

1) ми­ни­маль­но­му эле­мен­ту в мас­си­ве A

2) ин­дек­су ми­ни­маль­но­го эле­мен­та в мас­си­ве A (наименьшему из таких индексов, если ми­ни­маль­ных эле­мен­тов несколько)

3) ин­дек­су ми­ни­маль­но­го эле­мен­та в мас­си­ве A (наибольшему из таких индексов, если ми­ни­маль­ных эле­мен­тов несколько)

4) ко­ли­че­ству элементов, рав­ных ми­ни­маль­но­му в мас­си­ве A

Источник: Демонстрационная версия ЕГЭ—2014 по информатике.

14
Задание 19 № 6182

В про­грам­ме опи­сан од­но­мер­ный це­ло­чис­лен­ный мас­сив с ин­дек­са­ми от 0 до 12. Ниже пред­став­лен за­пи­сан­ный на раз­ных язы­ках про­грам­ми­ро­ва­ния фраг­мент одной и той же программы, об­ра­ба­ты­ва­ю­щей дан­ный массив:

 

БейсикПаскаль

s = 0

n = 12

FOR i = 0 TO n

    IF A(n–i) – A(i) = A(i) THEN

        s = s+2*A(i)

    END IF

NEXT i

s := 0;

n := 12;

for i:=0 to n do begin

    if A[n–i] – A[i] = A[i] then

        s:=s+2*A[i];

end;

СиАлгоритмический язык

s = 0;

n = 12;

for (i = 0; i <= n; i++) {

    if (A[n–i] – A[i] == A[i])

        s = s+2*A[i];

}

s := 0

n := 12

нц для i от 0 до n

    если A[n–i] – A[i] = A[i]

        то s := s+2*A[i]

все

кц

 

В на­ча­ле вы­пол­не­ния этого фраг­мен­та в мас­си­ве на­хо­ди­лись числа 0, 10, 20, 30, 40, 50, 60, 70, 80, 90, 100, 110, 120, т. е. A[0] = 0, A[1] = 10 и т. д. Чему будет равно зна­че­ние пе­ре­мен­ной s после вы­пол­не­ния дан­ной программы?


Аналоги к заданию № 6182: 6227 Все

Источник: МИОО: Тре­ни­ро­воч­ная работа по ин­фор­ма­ти­ке 08.10.2013 ва­ри­ант ИНФ10101.

15
Задание 19 № 5355

Ниже приведён фраг­мент программы, за­пи­сан­ный на четырёх язы­ках программирования.

 

Массив А одномерный; в про­грам­ме рас­смат­ри­ва­ет­ся его фрагмент, со­от­вет­ству­ю­щий зна­че­ни­ям ин­дек­са от 1 до n.

 

Бейсик

Паскаль

J = 1

FOR I = 1 to n

    IF A(I) < A(J) THEN J = I

NEXT I

s = J

j := 1;

for i := 1 to n do

    begin

        if A[i] < A[j] then

            j := i

    end;

s := j;

Си

Алгоритмический язык

j = 1;

for (i = 1; i <= n; i++) {

    if (A[i] < A[j]){

        j = i;

    }

}

s = j;

j := 1

нц для i от 1 до n

если A[i] < A[j] то

    j := i

все

кц

s := j

 

Чему будет равно зна­че­ние пе­ре­мен­ной s после вы­пол­не­ния дан­но­го фраг­мен­та программы?

 

1) ин­дек­су ми­ни­маль­но­го эле­мен­та в мас­си­ве А (наименьшему из таких индексов, если ми­ни­маль­ных эле­мен­тов несколько)

2) ми­ни­маль­но­му эле­мен­ту в мас­си­ве А

3) ко­ли­че­ству элементов, рав­ных ми­ни­маль­но­му в мас­си­ве А

4) ин­дек­су ми­ни­маль­но­го эле­мен­та в мас­си­ве А (наибольшему из таких индексов, если ми­ни­маль­ных эле­мен­тов несколько)

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Дальний Восток. Ва­ри­ант 1.

16
Задание 19 № 6570

Ниже приведён фраг­мент программы, за­пи­сан­ный на четырёх язы­ках программирования. Мас­сив A одномерный; в про­грам­ме рас­смат­ри­ва­ет­ся его фрагмент, со­от­вет­ству­ю­щий зна­че­ни­ям ин­дек­са от 1 до n.

 

БейсикПаскаль

s = 0

FOR i = 1 TO n

    IF A(i)<0 THEN s = s – A(i)

NEXT i

s := 0;

for i := 1 to n do

    begin

        if A[i]<0 then

            s := s – A[i]

    end;

СиАлгоритмический язык

s = 0;

for (i = 1; i <= n; i++) {

    if (A[i] < 0) {

        s = s - A[i];

    }

}

s := 0

нц для i от 1 до n

    если A[i]<0 то

        s := s – A[i]

все

кц

 

Чему будет равно зна­че­ние пе­ре­мен­ной s после вы­пол­не­ния дан­но­го фраг­мен­та программы?

 

1) модулю суммы всех от­ри­ца­тель­ных эле­мен­тов мас­си­ва A

2) количеству от­ри­ца­тель­ных эле­мен­тов в мас­си­ве A

3) сумме всех от­ри­ца­тель­ных эле­мен­тов мас­си­ва A

4) среднему ариф­ме­ти­че­ско­му всех от­ри­ца­тель­ных эле­мен­тов в мас­си­ве A

Источник: ЕГЭ по информатике 08.07.2013. Вторая волна. Ва­ри­ант 802.

17
Задание 19 № 10322

Ниже пред­став­лен за­пи­сан­ный на раз­ных язы­ках про­грам­ми­ро­ва­ния фраг­мент одной и той же программы. В про­грам­ме опи­сан од­но­мер­ный це­ло­чис­лен­ный мас­сив A, в пред­став­лен­ном фраг­мен­те про­грам­мы об­ра­ба­ты­ва­ют­ся эле­мен­ты мас­си­ва с ин­дек­са­ми от 1 до 10.

 

БейсикPython

s = 0

n = 10

FOR i = 2 TO n

  s = s+A(i)*A(i)-A(i-1)*A(i-1)

NEXT i

s=0

n=10

for i in range(2,n+1):

  s=s + A[i]*A[i]-A[i-1]*A[i-1]

ПаскальАлгоритмический язык

s:=0;

n:=10;

for i:= 2 to n do begin

  s:=s+A[i]*A[i]-A[i-1]*A[i-1];

end;

s:=0

n:=10

нц для i от 2 до n

  s:=s + A[i]*A[i]-A[i-1]*A[i-1]

кц

Си

s = 0;

n=10;

for (i = 2; i <= n; i++)

  s=s + A[i]*A[i]-A[i-1]*A[i-1];

 

В на­ча­ле вы­пол­не­ния этого фраг­мен­та в мас­си­ве на­хо­ди­лись числа 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, то есть A[1] = 1, A[2] = 2 и так далее Чему будет равно зна­че­ние пе­ре­мен­ной s после вы­пол­не­ния дан­ной программы?

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 28.01.2016 ИН10304

18
Задание 19 № 11120

В про­грам­ме ис­поль­зу­ет­ся од­но­мер­ный це­ло­чис­лен­ный мас­сив A с ин­дек­са­ми от 0 до 9. Зна­че­ния эле­мен­тов равны 8, 4, 3, 0, 7, 2, 1, 5, 9, 6 соответственно, т.е. A[0] = 8, A[1] = 4 и т. д. Опре­де­ли­те зна­че­ние пе­ре­мен­ной s после вы­пол­не­ния сле­ду­ю­ще­го фраг­мен­та про­грам­мы (записанного ниже на раз­ных язы­ках программирования).

 

БейсикPython

s = 0

FOR j = 0 TO 9

  IF A(j) <=4 THEN

    s = j

  ENDIF

NEXT j

s = 0

for j in range(10):

    if A[j] <= 4:

      s = j

Алгоритмический языкПаскаль

s := 0

нц для j от 0 до 9

  если A[j] <= 4 то

    s := j

  все

кц

s := 0;

for j := 0 to 9 do

  if A[j] <= 4 then

    s := j;

Си

s = 0;

for (j = 0; j <= 9; j++)

    if (A[j] <= 4)

      s = j;

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 23.03.2016. До­сроч­ная волна
Пояснение · ·

19
Задание 19 № 11248

В про­грам­ме используется од­но­мер­ный целочисленный мас­сив A с ин­дек­са­ми от 0 до 10. Зна­че­ния элементов равны 4, 3, 6, 8, 5, 8, 4, 2, 10, 9, 4 соответственно, т. е. A[0] = 4, A[1] = 3 и т. д. Опре­де­ли­те значение пе­ре­мен­ной c после вы­пол­не­ния следующего фраг­мен­та программы (записанного ниже на пяти язы­ках программирования).

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) = A(0) THEN

    c = c + 1

    t = A(i+1)

    A(i+1) = A(i)

    A(i) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i] == A[0]:

    c = c + 1

    t = A[i+1]

    A[i+1] = A[i]

    A[i] = t

Алгоритмический языкПаскаль

c := 0

нц для i от 1 до 9

  если A[i] = A[0] то

    c := c + 1

    t := A[i+1]

    A[i+1] := A[i]

    A[i] := t

  все

кц

c := 0;

for i := 1 to 9 do begin

  if A[i] = A[0] then begin

    c := c + 1;

    t := A[i+1];

    A[i+1] := A[i];

    A[i] := t;

  end;

end;

Си

c = 0;

for (i = 1; i < 10; i++) {

  if (A[i] == A[0]) {

    c++;

    t = A[i+1];

    A[i+1] = A[i];

    A[i] = t;

  }

}

 


Аналоги к заданию № 11248: 11275 Все

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та по ин­фор­ма­ти­ке 21.05.2016 ИН10503.

20
Задание 19 № 11315

В программе описан одномерный целочисленный массив с индексами от 0 до 9. Ниже представлен фрагмент программы, обрабатывающей данный массив:

c:=0;

for i:=1 to 8 do

 begin

  if(A[i]=A[0]) then

   begin

    inc(c);

    t:=A[i+1];

    A[i+1]:= A[i];

    A[i]:= t;

   end;

 end;

writeln(c);

В начале выполнения этого фрагмента в массиве находились числа 3, 2, 4, 6, 3, 10, 12, 14, 16, 18 т. е. А[0]=3, А[1]=2 и т. д. Чему будет равно значение переменной с после выполнения данной программы?

Источник: ЕГЭ 16.06.2016 по информатике. Основная волна.

Пройти тестирование по этим заданиям



     О проекте · Редакция

© Гущин Д. Д., 2011—2017


СПб ГУТ! С! Ф! У!