информатика
Информатика
Русский язык
Английский язык
Немецкий язык
Французcкий язык
Испанский язык
Физика
Химия
Биология
География
Обществознание
Литература
История
сайты - меню - вход - новости




Каталог заданий.
Алгоритмы с использованием условного оператора

Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 19 № 8667

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 4; 2; 6; 6; 7; 7; 7; 5; 5; 9 соответственно, т.е. A[0] = 4; A[1] = 2 и т.д.

Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

Бейсик Python

c = 0

FOR i = 1 TO 9

    IF A(i - 1) >= A(i) THEN

        t = A(i)

        A(i) = A(i - 1)

        A(i - 1) = t

        c = c + 1

    ENDIF

NEXT i

c = 0

for i in range(1, 10):

    if A[i - 1] >= A[i]:

        t = A[i]

        A[i] = A[i - 1]

        A[i - 1] = t

        c = c + 1

Алгоритмический язык Паскаль

c := 0

нц для i от 1 до 9

    если A[i - 1] >= A[i] то

        t := A[i]

        A[i] := A[i - 1]

        A[i - 1] := t

        c := c + 1

    все

кц

c := 0;

for i := 1 to 9 do

    if A[i - 1] >= A[i] then

    begin

        t := A[i];

        A[i] := A[i - 1];

        A[i - 1] := t;

        c := c + 1;

    end;

Си++

c = 0;

for (i = 1; i <= 9; i++)

    if (A[i - 1] >= A[i])

    {

        t = A[i];

        A[i] = A[i - 1];

        A[i - 1] = t;

        c++;

    }


Аналоги к заданию № 8667: 9171 Все


2
Задание 19 № 9203

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей одномерный целочисленный массив с индексами от 0 до 10.

 

Бейсик Python

s = 27

n = 10

FOR i = 0 TO n-1

    s = s+A(i)-A(i+1)+2

NEXT i

s = 27

n = 10

for i in range(0,n):

    s = s + A[i] - A[i+1]+2

Алгоритмический язык Паскаль

s := 27

n := 10

нц для i от 0 до n-1

    s:=s+A[i]-A[i+1]+2

кц

s := 27;

n := 10;

for i:=0 to n-1 do begin

    s:=s+A[i]-A[i+1]+2

end;

Си++

s = 27;

n = 10;

for (i = 0; i <= n-1; i++) {

    s=s+A[i]-A[i+1]+2;

}

 

Известно, что в начале выполнения этого фрагмента в массиве находилась возрастающая последовательность чисел, то есть A[0] < A[1] < … < A[10].

Какое наибольшее значение может иметь переменная s после выполнения данной программы?


Аналоги к заданию № 9203: 9311 Все


3
Задание 19 № 9370

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 4, 7, 3, 8, 5, 0, 1, 2, 9, 6 соответственно, т.е. A[0] = 4, A[1] = 7 и т.д.

Определите значение переменной c после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

 c = 0

 FOR i = 1 TO 9

    IF A(i) < A(0) THEN

        c = c + 1

        t = A(i)

        A(i) = A(0)

        A(0) = t

    ENDIF

 NEXT i

 c = 0

 for i in range(1,10):

    if A[i] < A[0]:

        c = c + 1

        t = A[i]

        A[i] = A[0]

        A[0] = t

ПаскальАлгоритмический язык

 c := 0;

 for i := 1 to 9 do

    if A[i] < A[0] then

    begin

        c := c + 1;

        t := A[i];

        A[i] := A[0];

        A[0] := t;

    end;

 c := 0

 нц для i от 1 до 9

    если A[i] < A[0] то

        c := c + 1

        t := A[i]

        A[i] := A[0]

        A[0] := t

    все

 кц

Си++

 c = 0;

 for (i = 1;i < 10;i++)

    if (A[i] < A[0])

    {

        c++;

        t = A[i];

        A[i] = A[0];

        A[0] = t;

    }

 


Аналоги к заданию № 9370: 9769 9805 10295 10393 10420 10482 10509 Все

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2016 по информатике.

4
Задание 19 № 9654

В программе используется одномерный целочисленный массив A с индексами от 1 до 10. Значения элементов равны 7; 3; 4; 8; 6; 9; 5; 2; 0; 1 соответственно, т. е. A[1] = 7; A[2] = 3 и т. д.

Определите значение переменной j после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

 

БейсикПаскаль

j = 0

FOR k = 2 TO 10

  IF A(k) <= A(1) THEN

    A(1) = A(k)

    j = j + k

  END IF

NEXT k

j := 0;

for k := 2 to 10 do

begin

  if A[k] <= A[1] then

    begin

      A[1] := A[k];

      j := j + k

    end

end;

Си++Алгоритмический язык

j = 0;

for (k = 2; k<= 10; k++) {

  if (A[k] <= A[1]) {

    A[1] = A[k];

    j = j + k;

  }

}

j := 0

нц для k от 2 до 10

  если A[k] <= A[1] то

    A[1] := A[k]

    j := j+k

  все

кц

Python

j = 0

for k in range(2, 11):

    if A[k] <= A[1]:

        A[1] = A[k]

        j = j + k

 


Аналоги к заданию № 9654: 9700 Все


5
Задание 19 № 9769

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 6, 7, 3, 8, 5, 1, 2, 0, 9, 4 соответственно, т. е. A[0] = 6, A[1] = 7 и т. д.

Определите значение переменной c после выполнения следующего фрагмента этой программы (записанного ниже на пяти языках программирования).

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) < A(0) THEN

    c = c + 1

    t = A(i)

    A(i) = A(0)

    A(0) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i] < A[0]:

    c = c + 1

    t = A[i]

    A[i] = A[0]

    A[0] = t

ПаскальАлгоритмический язык

c := 0;

for i := 1 to 9 do

  if A[i] < A[0] then

  begin

    c := c + 1;

    t := A[i];

    A[i] := A[0];

    A[0] := t;

end;

c := 0

нц для i от 1 до 9

  если A[i] < A[0] то

    c := c + 1

    t := A[i]

    A[i] := A[0]

    A[0] := t

  все

кц

Си++

c = 0;

for (i = 1;i < 10;i++)

  if (A[i] < A[0])

  {

    c++;

    t = A[i];

    A[i] = A[0];

    A[0] = t;

  }

 


6
Задание 19 № 3369

Значения элементов двухмерного массива A[1..100,1..100] задаются с помощью следующего фрагмента программы:

 

 

БейсикPython

FOR i = 1 TO 100

    FOR k = 1 TO 100

        IF i = k THEN A(i,k)= 1

        ELSE A(i,k)= -1

    NEXT k

NEXT i

for i in range(1, 101):

    for k in range(1, 101):

        if i == k:

            A[i][k] = 1

        else:

            A[i][k] = -1

ПаскальАлгоритмический язык

for i:= 1 to 100 do

    for k:=1 to 100 do

        if i = k then

            A[i,k] := 1

        else A[i,k] := -1;

нц для i от 1 до 100

    нц для k от 1 до 100

        если i = k то

            A[i,k] := 1

        иначе A[i,k] := -1

    все

    кц

кц

Си++

for (i = 1; i <= 100; i++) {

    for (k = 1; k <= 100; k++) {

        if (i == k)

            A[i][k] = 1;

        else

            A[i][k] = -1;

    }

}

 

 

Чему равна сумма элементов массива после выполнения этого фрагмента программы?


7
Задание 19 № 4842

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив.

 

БейсикПаскаль

s = 0

n = 10

FOR i = 1 ТО n

    IF i = n - i THEN

        s = s + A(i) + A (i + 1)

    END IF

NEXT i

s: = 0;

n : = 10 ;

for i : = 1 to n do

    begin

        if i = n - i then

            s : = s + A[i] + A[i + 1];

    end

Си++Алгоритмический язык
s = 0;

n = 10;

for (i = 1; i <= n; i++){

    if (i == n - i)

        s = s + A[i] + A[i + 1];

}

s: = 0

n : = 10

нц для i от 1 до n

если i = n - i

    то s := s + A[i] + A[i + 1]

все

кц

Python

s = 0

n = 10

for i in range(1, n+1):

    if i == n - i:

        s = s + A[i] + A[i + 1];

 

 

 

В начале выполнения этого фрагмента в массиве находились числа 0, 2, 4, 6, 8, 10, 12, 14, 16, 18, 20, т. е. элемент А[0]=0, А[1]=2 и т. д. Чему будет равно значение переменной s после выполнения данной программы?


8
Задание 19 № 4930

В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже представлен записанный на разных языках программирования,фрагмент одной и той же программы, обрабатывающей данный массив:

 

БейсикПаскаль

s=0

n = 10

FOR i = 0 TO n

    IF A(n − i)-A(i) > A(i) THEN

        s = s + A(i)

    END IF

NEXT i

s := 0;

n := 10;

for i:=0 to n do begin

    if A[n - i] - A[i] > A[i] then

        s := s + A[i];

end;

Си++Алгоритмический язык

s = 0;

n = 10;

for (i = 0; i <= n; i++ ) {

    if(A[n - i]-A[i] > A[i]) {

        s = s+ A[i];

    }

}

s := 0

n:=10

нц для i от 0 до n

    если A[n - i] - A[i] > A[i]

        то s := s + A[i]

все

кц

Python

s = 0

n = 10

for i in range(0, n+1):

    if A[n - i]-A[i] > A[i]:

        s = s+ A[i]

 

 

В начале выполнения этого фрагмента в массиве находились числа 0, 10, 20, 30, 40, 50, 60, 70, 80. 90, 100, т.е. A[0] = 0, A[1] = 10 и т. д. Чему будет равно значение переменной s после выполнения данной программы?


Аналоги к заданию № 4930: 4971 Все


9
Задание 19 № 6182

В программе описан одномерный целочисленный массив с индексами от 0 до 12. Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы, обрабатывающей данный массив:

 

БейсикПаскаль

s = 0

n = 12

FOR i = 0 TO n

    IF A(n–i) – A(i) = A(i) THEN

        s = s+2*A(i)

    END IF

NEXT i

s := 0;

n := 12;

for i:=0 to n do begin

    if A[n–i] – A[i] = A[i] then

        s:=s+2*A[i];

end;

Си++Алгоритмический язык

s = 0;

n = 12;

for (i = 0; i <= n; i++) {

    if (A[n–i] – A[i] == A[i])

        s = s+2*A[i];

}

s := 0

n := 12

нц для i от 0 до n

    если A[n–i] – A[i] = A[i]

        то s := s+2*A[i]

все

кц

Python

s = 0

n = 12

for i in range(0, n+1):

    if A[n–i] – A[i] == A[i]:

        s = s+2*A[i]

 

 

В начале выполнения этого фрагмента в массиве находились числа 0, 10, 20, 30, 40, 50, 60, 70, 80, 90, 100, 110, 120, т. е. A[0] = 0, A[1] = 10 и т. д. Чему будет равно значение переменной s после выполнения данной программы?


Аналоги к заданию № 6182: 6227 Все


10
Задание 19 № 10322

Ниже представлен записанный на разных языках программирования фрагмент одной и той же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы обрабатываются элементы массива с индексами от 1 до 10.

 

БейсикPython

s = 0

n = 10

FOR i = 2 TO n

  s = s+A(i)*A(i)-A(i-1)*A(i-1)

NEXT i

s=0

n=10

for i in range(2,n+1):

  s=s + A[i]*A[i]-A[i-1]*A[i-1]

ПаскальАлгоритмический язык

s:=0;

n:=10;

for i:= 2 to n do begin

  s:=s+A[i]*A[i]-A[i-1]*A[i-1];

end;

s:=0

n:=10

нц для i от 2 до n

  s:=s + A[i]*A[i]-A[i-1]*A[i-1]

кц

Си++

s = 0;

n=10;

for (i = 2; i <= n; i++) {

  s=s + A[i]*A[i]-A[i-1]*A[i-1];

}

 

В начале выполнения этого фрагмента в массиве находились числа 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, то есть A[1] = 1, A[2] = 2 и так далее Чему будет равно значение переменной s после выполнения данной программы?


11
Задание 19 № 11120

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 8, 4, 3, 0, 7, 2, 1, 5, 9, 6 соответственно, т.е. A[0] = 8, A[1] = 4 и т. д. Определите значение переменной s после выполнения следующего фрагмента программы (записанного ниже на разных языках программирования).

 

БейсикPython

s = 0

FOR j = 0 TO 9

  IF A(j) <=4 THEN

    s = j

  ENDIF

NEXT j

s = 0

for j in range(10):

    if A[j] <= 4:

      s = j

Алгоритмический языкПаскаль

s := 0

нц для j от 0 до 9

  если A[j] <= 4 то

    s := j

  все

кц

s := 0;

for j := 0 to 9 do

  if A[j] <= 4 then

    s := j;

Си++

s = 0;

for (j = 0; j <= 9; j++) {

    if (A[j] <= 4) {

      s = j;

    }

}

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 23.03.2016. До­сроч­ная волна
Пояснение · ·

12
Задание 19 № 11248

В программе используется одномерный целочисленный массив A с индексами от 0 до 10. Значения элементов равны 4, 3, 6, 8, 5, 8, 4, 2, 10, 9, 4 соответственно, т. е. A[0] = 4, A[1] = 3 и т. д. Определите значение переменной c после выполнения следующего фрагмента программы (записанного ниже на пяти языках программирования).

 

БейсикPython

c = 0

FOR i = 1 TO 9

  IF A(i) = A(0) THEN

    c = c + 1

    t = A(i+1)

    A(i+1) = A(i)

    A(i) = t

  END IF

NEXT i

c = 0

for i in range(1,10):

  if A[i] == A[0]:

    c = c + 1

    t = A[i+1]

    A[i+1] = A[i]

    A[i] = t

Алгоритмический языкПаскаль

c := 0

нц для i от 1 до 9

  если A[i] = A[0] то

    c := c + 1

    t := A[i+1]

    A[i+1] := A[i]

    A[i] := t

  все

кц

c := 0;

for i := 1 to 9 do begin

  if A[i] = A[0] then begin

    c := c + 1;

    t := A[i+1];

    A[i+1] := A[i];

    A[i] := t;

  end;

end;

Си++

c = 0;

for (i = 1; i < 10; i++) {

  if (A[i] == A[0]) {

    c++;

    t = A[i+1];

    A[i+1] = A[i];

    A[i] = t;

  }

}

 


Аналоги к заданию № 11248: 11275 Все


13
Задание 19 № 11315

В программе описан одномерный целочисленный массив с индексами от 0 до 9. Ниже представлен фрагмент программы, обрабатывающей данный массив:

 

 

Бейсик Python

c = 0

FOR i = 1 TO 8

    IF A(i)=A(0) THEN

        c = c + 1

        t=A(i+1)

        A(i+1)= A(i)

        A(i)= t

    ENDIF

NEXT i

PRINT c

c = 0

for i in range(1, 9):

    if A[i] == A[0]:

        c += 1

        t=A[i+1]

        A[i+1]= A[i]

        A[i]= t

print(c)

Алгоритмический язык Паскаль

c := 0

нц для i от 1 до 8

    если A[i] = A[0] то

        c := c + 1

        t:=A[i+1]

        A[i+1]:= A[i]

        A[i]:= t

    все

кц

вывод c

c := 0;

for i := 1 to 8 do

    if A[i] = A[0] then

    begin

        inc(c);

        t:=A[i+1];

        A[i+1]:= A[i];

        A[i]:= t;

    end;

writeln(c);

Си++

c = 0;

for (i = 1; i <= 8; i++)

    if (A[i] == A[0])

    {

        c++;

        t=A[i+1];

        A[i+1]= A[i];

        A[i]= t;

    }

cout « c « endl;

 

В начале выполнения этого фрагмента в массиве находились числа 3, 2, 4, 6, 3, 10, 12, 14, 16, 18 т. е. А[0]=3, А[1]=2 и т. д. Чему будет равно значение переменной с после выполнения данной программы?

Источник: ЕГЭ 16.06.2016 по информатике. Основная волна.

14
Задание 19 № 16394

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 2, 4, 1, 6, 2, 7, 3, 2, 2, 1 (т. е. A[0] = 2, A[1] = 4, …, A[9] = 1). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

N = 10

s = 0

FOR i = 1 TO N − 1

    IF A(i-1) > 2*A(i) THEN

        A(i) = 2*A(i)

        s = s + A(i)

    END IF

NEXT i

 

n = 10

s = 0

for i in range(1,n):

    if A[i-1] > 2*A[i]:

        A[i] = 2*A[i1]

        s = s + A[i]

 

 

 

ПаскальАлгоритмический язык

N := 10;

s := 0;

for i:=1 to N-1 do begin

    if A[i-1] > 2*A[i] then begin

        A[i] = 2*A[i];

        s := s + A[i];

    end;

end;

 

N := 10

s := 0

нц для i от 1 до N-1

    если A[i-1] > 2*A[i] то

        A[i] = 2*A[i]

        s := s + A[i]

    все

кц

С++

n = 10;

s = 0;

for (i = 1; i < n; ++i) {

    if (A[i-1] > 2*A[i]) {

        A[i] = 2*A[i];

        s = s + A[i];

    }

}

 


15
Задание 19 № 16448

Представленный ниже на пяти языках программирования фрагмент программы обрабатывает элементы одномерного целочисленного массива A с индексами от 0 до 9. Перед началом выполнения данного фрагмента эти элементы массива имели значения 3, 1, 1, 5, 2, 9, 4, 3, 2, 1 (т. е. A[0] = 3, A[1] = 1, …, A[9] = 1). Определите значение переменной s после выполнения фрагмента.

 

 

БейсикPython

N = 10

s = 0

FOR i = 1 TO N − 1

    IF A(i-1) > 2*A(i) THEN

        A(i) = 2*A(i)

        s = s + A(i)

    END IF

NEXT i

 

n = 10

s = 0

for i in range(1,n):

    if A[i-1] > 2*A[i]:

        A[i] = 2*A[i1]

        s = s + A[i]

 

 

 

ПаскальАлгоритмический язык

N := 10;

s := 0;

for i:=1 to N-1 do begin

    if A[i-1] > 2*A[i] then begin

        A[i] = 2*A[i];

        s := s + A[i];

    end;

end;

 

N := 10

s := 0

нц для i от 1 до N-1

    если A[i-1] > 2*A[i] то

        A[i] = 2*A[i]

        s := s + A[i]

    все

кц

С++

n = 10;

s = 0;

for (i = 1; i < n; ++i) {

    if (A[i-1] > 2*A[i]) {

        A[i] = 2*A[i];

        s = s + A[i];

    }

}

 


Пройти тестирование по этим заданиям