информатика
Информатика
Русский язык
Английский язык
Немецкий язык
Французcкий язык
Испанский язык
Физика
Химия
Биология
География
Обществознание
Литература
История
сайты - меню - вход - новости




Каталог заданий.
Наименьшее значение функции
Сортировка:
Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 21 № 3330

Определите, какое число будет напечатано в результате выполнения следующего алгоритма:

 

 

Бэйсик Паскаль

DIM A, B, T, M, R AS INTEGER

A = -20: B = 20

M = A: R = F(A)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT R

 

FUNCTION F(x)

    F := 4*(x-5)*(x+3)

END FUNCTION

var a,b,t,M,R :integer;

    Function F(x: integer):integer;

    begin

        F := 4*(x-5)*(x+3);

    end;

BEGIN

    a := -20; b := 20;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t)< R) then begin

            M := t;

            R := F(t);

        end;

    end;

write(R);

END.

Си++ Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

    return 4*(x-5)*(x+3)

}

int main()

{

    int a, b, t, M, R;

    a = -20; b = 20;

    M = a; R = F(a);

    for (t=a; t<=b; t++){

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « R « endl;

}

алг

нач

цел a, b, t, R, M

a := -20; b := 20

M := a; R := F(a)

нц для t от a до b

если F(t) < R

то

M := t; R := F(t)

все

кц

вывод R

кон

алг цел F(цел x)

нач

знач := 4*(x-5)*(x+3)

кон

Python

def f(x):

    return 4*(x-5)*(x+3)

a = -20

b = 20

M = a

R = f(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(R)

 


2
Задание 21 № 7678

Напишите в ответе количество различных значений входной переменной k, при которых программа выдаёт тот же ответ, что и при входном значении k = 64. Значение k = 64 также включается в подсчёт различных значений k. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 12

WHILE I > 0 AND F(I) >= K

    I = I - 1

WEND

PRINT I

FUNCTION F(N)

    F = N * N + 20

END FUNCTION

def f(n):

    return n * n + 20

k = int(input())

i = 12

while i > 0 and f(i) >= k:

    i = i - 1

print(i)

ПаскальАлгоритмический язык

var k, i : longint;

    function f(n: longint) : longint;

        begin

            f := n * n + 20

        end;

begin

    readln(k);

    i := 12;

    while (i>0) and (f(i)>=k) do

        i := i-1;

    writeln(i)

end.

алг

нач

цел i, k

ввод k

i := 12

нц пока i > 0 и f(i) >= k

i := i - 1

кц

вывод i

кон

алг цел f(цел n)

нач

знач := n * n + 20

кон

Си++

#include <iostream>

using namespace std;

long f(long n) { return n * n + 20; }

int main()

{

    long k, i;

    cin >> k;

    i = 12;

    while (i>0 && f(i)>=k) i––;

    cout << i << endl;

}

 


Аналоги к заданию № 7678: 7705 7766 7793 8109 7467 Все


3
Задание 21 № 7932

При каком наименьшем значении входной переменной k программа выдаёт тот же ответ, что и при входном значении k = 64? Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 12

WHILE I > 0 AND F(I) > K

    I = I - 1

WEND

PRINT I

FUNCTION F(N)

    F = N * N - 20

END FUNCTION

def f(n):

    return n * n - 20

k = int(input())

i = 12

while i > 0 and f(i) > k:

    i = i - 1

print(i)

ПаскальАлгоритмический язык

var k, i : longint;

    function f(n: longint) : longint;

        begin

            f := n * n - 20

        end;

begin

    readln(k);

    i := 12;

    while (i>0) and (f(i)> k) do

        i := i-1;

    writeln(i)

end.

алг

нач

цел i, k

ввод k

i := 12

нц пока i > 0 и f(i) > k

i := i - 1

кц

вывод i

кон

алг цел f(цел n)

нач

знач := n * n - 20

кон

Си++

#include <iostream>

using namespace std;

long f(long n) { return n * n - 20; }

int main()

{

    long k, i;

    cin >> k;

    i = 12;

    while (i>0 && f(i)>k) i––;

    cout << i << endl;

    return 0;

}

 


Аналоги к заданию № 7932: 7997 9771 9807 9372 Все


4
Задание 21 № 9372

Напишите в ответе наименьшее значение входной переменной k, при котором программа выдаёт тот же ответ, что и при входном значении k = 10. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) < G(K)

    I = I + 1

WEND

PRINT I

 

FUNCTION F(N)

    F = N * N * N

END FUNCTION

 

FUNCTION G(N)

    G = 2*N + 3

END FUNCTION

def f(n):

    return n*n*n

 

def g(n):

    return 2*n+3

 

k = int(input())

i = 1

while f(i) < g(k):

    i+=1

print (i)

ПаскальАлгоритмический язык

var

    k, i : longint;

 

function f(n: longint): longint;

begin

    f := n * n * n;

end;

 

function g(n: longint): longint;

begin

    g := 2*n + 3;

end;

 

begin

    readln(k);

    i := 1;

    while f(i) < g(k) do

        i := i+1;

    writeln(i)

end.

алг

нач

    цел i, k

    ввод k

    i := 1

    нц пока f(i) < g(k)

        i := i + 1

    кц

    вывод i

кон

 

алг цел f(цел n)

нач

    знач := n * n * n

кон

 

алг цел g(цел n)

нач

    знач := 2*n + 3

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

    return n * n * n;

}

 

long g(long n) {

    return 2*n + 3;

}

 

int main()

{

    long k, i;

    cin >> k;

    i = 1;

    while(f(i) < g(k))

        i++;

    cout << i << endl;

    return 0;

}

 


5
Задание 21 № 9656

Напишите в ответе число, которое будет напечатано в результате выполнения следующего алгоритма (для Вашего удобства алгоритм представлен на пяти языках программирования).

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A = -15: B = 15

M = A: R = F(А)

FOR T = A TO B

  IF F(T) < R THEN

    M = T

    R = F(T)

  END IF

NEXT T

PRINT M+50

 

FUNCTION F(x)

F=10*x*x-100*ABS(x)+210

END FUNCTION

var a, b, t, M, R: integer;

Function

F(x:integer):integer;

  begin

    F := 10*x*x-100*abs(x)+210

    end;

 

begin

  a := -15; b := 15;

  M := a; R := F(a);

  for t := a to b do begin

    if (F(t) < R) then begin

      M := t;

      R := F(t)

    end

  end;

  write(M+50)

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int F(int x)

{

  return 10*x*x-100*abs(x)+210;

}

 

int main()

{

  int a, b, t, M, R;

  a = -15; b = 15;

  M = a; R = F(a);

  for (t = a; t <= b; t++) {

    if (F(t) < R) {

      M = t; R = F(t);

    }

  }

  cout << M+50 << endl;

}

алг

нач

  цел a, b, t, M, R

  a := -15; b := 15

  M := a; R := F(a)

  нц для t от a до b

    если F(t) < R

      то M := t; R := F(t)

    все

  кц

  вывод M+50

кон

 

алг цел F(цел x)

нач

  знач:=10*x*x-100*iabs(x)+210

кон

Python

def f(x):

    return 10*x*x-100*abs(x)+210

a = -15

b = 15

M = a

R = f(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(M+50)

 


Аналоги к заданию № 9656: 9702 Все


6
Задание 21 № 3512

Определите, какое число будет напечатано в результате выполнения следующего алгоритма (для Вашего удобства алгоритм представлен на четырех языках):

 

Бэйсик Паскаль

DIM A, B, T, M, R AS INTEGER

A = -20: B = 20

T = A: M = A: R = F(A)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    ENDIF

NEXT T

PRINT M

FUNCTION F(x)

    F = 2*(x-9)*(x-9);

END FUNCTION

var a,b,t,M,R :integer;

    Function F(x: integer):integer;

        begin

            F := 2*(x-9)*(x-9);

        end;

BEGIN

    a := -20; b := 20;

    M := a; R := F(a);

    for t := a to b do

        if (F(t)< R) then begin

            M := t;

            R := F(t);

        end;

    write(M);

END.

Си++ Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

    return 2*(x-9)*(x-9);

}

int main()

{

    int a, b, t, M, R;

    a = -20; b = 20;

    M = a; R = F(a);

    for (t=a; t<=b; t++){

        if (F(t) < R ) {

            M = t; R = F(t);

        }

    }

    cout « M « endl;

}

алг

нач

цел a, b, t, R, M

a := -20; b := 20

M := a; R := F(a)

нц для t от a до b

если F(t)< R

то

M := t; R := F(t)

все

кц

вывод M

кон

алг цел F(цел x)

нач

знач := 2*(x-9)*(x-9)

кон

Python

def f(x):

    return 2*(x-9)*(x-9)

a = -20

b = 20

M = a

R = f(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(M)

 


7
Задание 21 № 4566

Определите, какое число будет напечатано в результате выполнения следующего алгоритма (для Вашего удобства алгоритм представлен на четырёх языках).

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A = -20: B = 20

M = A: R = F(A)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    ENDIF

NEXT T

PRINT M

FUNCTION F(x)

    F = 3*(x-8)*(x-8)

END FUNCTION

var a,b,t,M,R :integer;

    Function F(x:integer):integer;

        begin

            F := 3*(x-8)*(x-8)

        end;

begin

    a := -20; b := 20;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t);

        end

    end;

    write(M);

end.

Си++Алгоритмический язык

#include <iostream>

using namespace std;

int F(int x)

{

    return 3*(x-8)*(x-8);

}

int main()

{

    int a, b, t, M, R;

    a = -20; b = 20;

    M = a; R = F(a);

    for (t=a; t<=b; t++){

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout « M « endl;

}

алг

нач

цел a, b, t, R, M

a := -20; b := 20

M := a; R := F(a)

нц для t от a до b

если F(t)< R

то

M := t; R := F(t)

все

кц

вывод M

кон

алг цел F(цел x)

нач

знач := 3*(x-8)*(x-8)

кон

Python

def f(x):

    return 3*(x-8)*(x-8)

a = -20

b = 20

M = a

R = f(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(M)

 


8
Задание 21 № 5754

Напишите в ответе число, которое будет напечатано в результате выполнения следующего алгоритма (для Вашего удобства алгоритм представлен на четырёх языках).

 

 

БейсикПаскаль

DIM А, В, Т, М, R AS INTEGER

А = -13: В = 13 М = A: R=F(А)

FOR Т = А ТО В

    IF F(Т) < R THEN

        М = Т

        R = F (Т)

    END IF

NEXT Т

PRINT M+18

FUNCTION F(x)

    F = (x*x-4)*(x*x-4)+11

END FUNCTION

var a,b,t,M,R :integer;

    Function F(x:integer):integer;

        begin

            F := (x*x-4)*(x*x-4)+11 end;

begin

    a := -13;

    b := 13;

    M := a;

    R := F(a);

    for t := a to b do

        begin

            if (F(t) < R) then

                begin

                    M := t;

                    R := F(t)

                end

        end;

    write(M+18)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

    return (x*x-4)*(x*x-4) +11;

}

int main() {

    int a, b, t, M, R;

    a = -13;

    b = 13;

    M = a;

    R = F (a);

    for (t = a; t <= b; t++) {

         if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout << M+18 << endl;

}

алг

нач

цел a, b, t, М, R

а := -13;

b := 13

М := a;

R := F(а)

нц для t от а до b

если F(t) < R

то М := t;

R := F(t)

все

кц

вывод М+18

кон

алг

цел Р(цел х)

нач

знач := (х*х-4)* (х*х-4)+11

кон

Python

def f(x):

    return (x*x-4)*(x*x-4)+11

a = -13

b = 13

M = a

R = f(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(M+18)

 

Источник: ЕГЭ по ин­фор­ма­ти­ке 30.05.2013. Ос­нов­ная волна. Урал. Ва­ри­ант 3.

9
Задание 21 № 6012

Напишите в ответе число, которое будет напечатано в результате выполнения следующего алгоритма (для Вашего удобства алгоритм представлен на четырёх языках).

 

 

БейсикПаскаль

DIM A, B, T, M, R AS INTEGER

A = -11: B = 11

M = A: R = F(А)

    FOR T = A TO B

        IF F(T) < R THEN

            M = T

            R = F(T)

        END IF

NEXT T

PRINT M+6

FUNCTION F(x)

    F = 2*(x*x-16)*(x*x-16)+5

END FUNCTION

var a,b,t,M,R :integer;

Function F(x:integer):integer;

    begin

        F := 2*(x*x-16)*(x*x-16)+5

    end;

begin

    a := -11; b := 11;

    M := a; R := F(a);

    for t := a to b do begin

        if (F(t) < R) then begin

            M := t;

            R := F(t)

        end

    end;

    write(M+6)

end.

Си++Алгоритмический

#include <iostream>

using namespace std;

int F(int x)

{

    return 2*(x*x-16)*(x*x-16)+5;

}

int main()

{

    int a, b, t, M, R;

    a = -11; b = 11;

    M = a; R = F(a);

    for (t = a; t <= b; t++) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout << M+6 << endl;

}

алг

нач

цел a, b, t, M, R

a := -11; b := 11

M := a; R := F(a)

нц для t от a до b

    если F(t) < R

        то M := t; R := F(t)

    все

кц

вывод M+6

кон

алг цел F(цел x)

нач

знач:=2*(x*x-16)*(x*x-16)+5

кон

Python

def f(x):

    return 2*(x*x-16)*(x*x-16)+5

a = -11

b = 11

M = a

R = f(a)

for t in range(a, b+1):

    if (f(t) < R):

        M = t

        R = f(t);

print(M+6)

 


10
Задание 21 № 7467

Напишите в ответе число различных значений входной переменной k, при которых программа выдаёт тот же ответ, что и при входном значении k = 64. Значение k = 64 также включается в подсчёт различных значений k. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 12

WHILE I > 0 AND F(I) >= K

    I = I - 1

WEND

PRINT I

FUNCTION F(N)

    F = N * N

END FUNCTION

def f(n):

    return n * n

 

k = int(input())

i = 12

while i > 0 and f(i) >= k:

    i = i - 1

print(i)

ПаскальАлгоритмический язык

var k, i : longint;

function f(n: longint) : longint;

    begin

        f := n * n

    end;

begin

    readln(k);

    i := 12;

    while (i>0) and (f(i)>=k) do

        i := i-1;

    writeln(i)

end.

нач

цел i, k

ввод k

i := 12

нц пока i > 0 и f(i) >= k

    i := i - 1

кц

вывод i

кон

алг цел f(цел n)

нач

    знач := n * n

кон

Си++

#include <iostream>

using namespace std;

 

int f(int n)

{

    return n * n;

}

 

int main(void)

{

    int k, i;

    cin >> k;

    i = 12;

    while (i > 0 && f(i) >= k)

        i––;

    cout « i « endl;

}

 


11
Задание 21 № 10297

Напишите в ответе наименьшее значение входной переменной k, при котором программа выдаёт ответ 21. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) <= K*G(I)

  I = I + 1

WEND

PRINT I

 

FUNCTION F(N)

  F = N * N * N

END FUNCTION

 

FUNCTION G(N)

  G = N * N

END FUNCTION

def f(n):

  return n*n*n

 

def g(n):

  return n*n

 

k = int(input())

i = 1

while f(i) <= k*g(i):

  i += 1

print (i)

ПаскальАлгоритмический язык

var

  k, i : longint;

 

function f(n: longint): longint;

begin

  f := n * n * n;

end;

 

function g(n: longint): longint;

begin

  g := n*n;

end;

 

begin

  readln(k);

  i := 1;

  while f(i) <= k*g(i) do

    i := i+1;

  writeln(i)

end.

алг

нач

  цел i, k

  ввод k

  i := 1

  нц пока f(i) <= k*g(i)

    i := i + 1

  кц

  вывод i

кон

 

алг цел f(цел n)

нач

  знач := n * n * n

кон

 

алг цел g(цел n)

нач

  знач := n * n

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

  return n * n * n;

}

 

long g(long n) {

  return n*n;

}

 

int main()

{

  long k, i;

  cin >> k;

  i = 1;

  while (f(i) <= k*g(i))

    i++;

  cout << i << endl;

  return 0;

}

 


Аналоги к заданию № 10297: 10324 Все


12
Задание 21 № 10484

Напишите в ответе наибольшее значение входной переменной k, при котором программа выдаёт тот же ответ, что и при входном значении k = 49. Для Вашего удобства программа приведена на пяти языках программирования.

 

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) < G(K)

    I = I + 1

WEND

PRINT I

 

FUNCTION F(N)

  F = N * N * N

END FUNCTION

 

FUNCTION G(N)

  G = 2*N + 1

END FUNCTION

def f(n):

  return n*n*n

 

def g(n):

  return 2*n + 1

 

k = int(input())

i = 1

while f(i) < g(k):

  i += 1

print (i)

ПаскальАлгоритмический язык

var

  k, i : longint;

 

function f(n: longint): longint;

begin

  f := n * n * n;

end;

 

function g(n: longint): longint;

begin

  g := 2*n + 1;

end;

 

begin

  readln(k);

  i := 1;

  while f(i) < g(k) do

    i := i + 1;

  writeln(i)

end.

алг

нач

  цел i, k

  ввод k

  i := 1

  нц пока f(i) < g(k)

    i := i + 1

  кц

  вывод i

кон

 

алг цел f(цел n)

нач

  знач := n * n * n

кон

 

алг цел g(цел n)

нач

  знач := 2*n + 1

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

  return n * n * n;

}

 

long g(long n) {

  return 2*n + 1;

}

 

int main()

{

  long k, i;

  cin >> k;

  i = 1;

  while (f(i) < g(k))

    i++;

  cout << i << endl;

  return 0;

}

 


Аналоги к заданию № 10484: 10511 Все

Источник: Типовые те­сто­вые за­да­ния по ин­фор­ма­ти­ке под ре­дак­ци­ей С. С. Крылова, Т. Е. Чуркиной. 2016. В. 1.

13
Задание 21 № 11250

Определите число, которое напечатает программа. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM I AS LONG

I = 1

WHILE F(I) < G(I)

  I = I * 2

WEND

PRINT I

FUNCTION F(N)

  F = N * N

END FUNCTION

FUNCTION G(N)

  G = 1000*N + 3

END FUNCTION

def f(n):

    return n*n

def g(n):

    return 1000*n+3

i = 1

while f(i) < g(i):

    i *= 2

print (i)

Алгоритмический языкПаскаль

алг

нач

  цел i

  i := 1

  нц пока f(i) < g(i)

    i := i * 2

  кц

  вывод i

кон

алг цел f(цел n)

нач

  знач := n * n

кон

алг цел g(цел n)

нач

  знач := 1000*n + 3

кон

var

  i : longint;

function f(n: longint): longint;

begin

  f := n * n;

end;

function g(n: longint): longint;

begin

  g := 1000*n + 3;

end;

begin

  i := 1;

  while f(i) < g(i) do

    i := i*2;

  writeln(i)

end.

Си++

#include <iostream>

using namespace std;

long f(long n) {

  return n * n;

}

long g(long n) {

  return 1000*n + 3;

}

int main()

{

  long i;

  i = 1;

  while (f(i) < g(i))

    i = i*2;

  cout << i << endl;

  return 0;

}

 


Аналоги к заданию № 11250: 11277 Все


14
Задание 21 № 11317

Напишите в ответе число, которое выведет программа в качестве ответа.

 

 

БейсикPython

DIM K, I AS LONG

I = 1

WHILE F(I) <= G(I)

    I = I*2

WEND

PRINT I

 

FUNCTION F(N)

    F = N * N

END FUNCTION

 

FUNCTION G(N)

    G = N*2000 + 3

END FUNCTION

def f(n):

    return n*n

 

def g(n):

    return n*2000 + 3

 

i = 1

while f(i) <= g(i):

    i*=2

print(i)

ПаскальАлгоритмический язык

var

    k, i : longint;

 

function f(n: longint): longint;

begin

    f := n * n;

end;

 

function g(n: longint): longint;

begin

    g := n*2000 + 3;

end;

 

begin

    i := 1;

    while f(i) <= g(i) do

        i := i*2;

    writeln(i)

end.

алг

нач

    цел i, k

    i := 1

    нц пока f(i) <= g(i)

        i := i*2

    кц

    вывод i

кон

 

алг цел f(цел n)

нач

    знач := n * n

кон

 

алг цел g(цел n)

нач

    знач := n*2000 + 3

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

    return n * n;

}

 

long g(long n) {

    return n*2000 + 3;

}

 

int main()

{

    long k, i;

    i = 1;

    while(f(i) <= g(i))

        i = i*2;

    cout << i << endl;

    return 0;

}

 

Источник: ЕГЭ 16.06.2016 по информатике. Основная волна.
Пояснение · ·

15
Задание 21 № 11357

Напишите в ответе число, которое будет напечатано в результате выполнения следующего алгоритма (для Вашего удобства алгоритм представлен на пяти языках программирования).

 

БейсикPython

DIM A, B, N, t AS INTEGER

A = -100: B = 100

N = 0

FOR t = A TO B

    IF F(t) <= 0 THEN

        N = N + 1

    END IF

NEXT t

PRINT N

 

FUNCTION F (x)

    F = (x - 16)*(x + 25)

END FUNCTION

def f(x):

    return (x - 16)*(x + 25)

 

a = -100

b = 100

n = 0

 

for t in range(a, b + 1):

    if f(t) <= 0:

        n = n + 1

print(n)

ПаскальАлгоритмический язык

var a, b, N, t: integer;

Function F(x: integer):integer;

    begin

        F := (x - 16)*(x + 25)

    end;

begin

    a := -100; b := 100;

    N := 0;

    for t := a to b do begin

        if (F(t) <= 0) then

            N := N + 1

    end;

    write(N)

end.

алг

нач

    цел a, b, N, t

    a := -100; b := 100

    N := 0

    нц для t от a до b

        если F(t) <= 0

            то

                N := N + 1

        все

    кц

    вывод N

кон

алг цел F(цел x)

нач

    знач := (x - 16)*(x + 25)

кон

Си++

#include <iostream>

using namespace std;

int F(int x) {

    return (x - 16)*(x + 25);

}

 

int main() {

    int a, b, N, t;

    a = -100; b = 100;

    N = 0;

    for (t = a; t <= b; t++) {

        if (F(t) <= 0) {

            N++;

        }

    }

    cout « N « endl;

}

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2017 по информатике.

16
Задание 21 № 13367

Напишите в ответе число, равное количеству различных значений входной переменной k, при которых приведённая ниже программа выводит тот же ответ, что и при входном значении k = 25. Значение k = 25 также включается в подсчёт количества различных значений k. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) < K

    I = I + 1

WEND

IF F(I)-K <= K-F(I-1) THEN

    PRINT I

ELSE

    PRINT I-1

END IF

FUNCTION F(N)

    F = N * N * N

END FUNCTION

def f(n):

    return n*n*n

i = 1

k = int(input())

while f(i) < k:

    i+=1

if (f(i)-k <= k-f(i-1)):

    print (i)

else:

    print (i - 1)

ПаскальАлгоритмический язык

var

    k, i : longint;

 

function f(n: longint) : longint;

begin

    f := n * n * n;

end;

begin

    readln(k);

    i := 1;

    while f(i) < k do

        i := i+1;

    if f(i)-k <= k-f(i-1) then

        writeln(i)

    else

        writeln(i-1);

end.

алг

нач

    цел i, k

    ввод k

    i := 1

    нц пока f(i) < k

        i := i + 1

    кц

    если f(i)-k <= k-f(i-1) то

    вывод i

    иначе

        вывод i-1

    все

кон

алг цел f(цел n)

нач

    знач := n * n * n

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

    return n * n * n;

}

 

int main()

{

    long k, i;

    cin >> k;

    i = 1;

    while (f(i) < k)

        i++;

    if (f(i)-k <= k-f(i-1)){

        cout << i << endl;

    } else {

        cout << i-1 << endl;

    }

}

 

Источник: ЕГЭ — 2017. До­сроч­ная волна по информатике

17
Задание 21 № 13417

Напишите в ответе наименьшее значение входной переменной k, при котором программа выдаёт ответ 10. Для Вашего удобства программа приведена на пяти языках программирования

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) < G(I)+K

    I = I + 1

WEND

  PRINT I

FUNCTION F(N)

  F = (N+1) * (N+1)

END FUNCTION

FUNCTION G(N)

    G = N * N

END FUNCTION

def f(n):

    return (n+1)*(n+1)

def g(n):

    return n*n

i = 1

k = int(input())

while f(i) < g(i) + k:

    i+=1

print (i)

ПаскальАлгоритмический язык

var

    k, i : longint;

 

function f(n: longint) : longint;

begin

    f := (n+1) * (n+1);

end;

function g(n: longint) : longint;

begin

    g:= n * n;

end;

begin

    readln(k);

    i := 1;

     while f(i) < g(i) + k

        i := i+1;

    writeln(i)

end.

алг

нач

    цел i, k

    ввод k

    i := 1

    нц пока f(i) < g(i) + k

        i := i + 1

    кц

    вывод i

    все

кон

алг цел f(цел n)

нач

    знач := (n+1) * (n+1)

кон

алг цел g(цел n)

нач

    знач := n * n

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

    return (n+1) * (n+1);

}

long g(long n) {

    return n * n ;

}

 

int main()

{

    long k, i;

    cin >> k;

    i = 1;

    while (f(i) < g(i)+ k) {

        i++;

    }

        cout << i << endl;

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10303

18
Задание 21 № 13470

Напишите в ответе наименьшее значение входной переменной k, при котором программа выдаёт ответ 15. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) < G(I)+K

    I = I + 1

WEND

  PRINT I

FUNCTION F(N)

  F = (N+1) * (N+1)

END FUNCTION

FUNCTION G(N)

    G = N * N

END FUNCTION

def f(n):

    return (n+1)*(n+1)

def g(n):

    return n*n

i = 1

k = int(input())

while f(i) < g(i) + k:

    i+=1

print (i)

ПаскальАлгоритмический язык

var

    k, i : longint;

 

function f(n: longint) : longint;

begin

    f := (n+1) * (n+1);

end;

function g(n: longint) : longint;

begin

    g:= n * n;

end;

begin

    readln(k);

    i := 1;

     while f(i) < g(i) + k

        i := i+1;

    writeln(i)

end.

алг

нач

    цел i, k

    ввод k

    i := 1

    нц пока f(i) < g(i) + k

        i := i + 1

    кц

    вывод i

    все

кон

алг цел f(цел n)

нач

    знач := (n+1) * (n+1)

кон

алг цел g(цел n)

нач

    знач := n * n

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

    return (n+1) * (n+1);

}

long g(long n) {

    return n * n ;

}

 

int main()

{

    long k, i;

    cin >> k;

    i = 1;

    while (f(i) < g(i)+ k) {

        i++;

    }

        cout << i << endl;

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 18 января 2017 года Вариант ИН10304

19
Задание 21 № 13497

Напишите в ответе наименьшее значение входной переменной k, при котором программа выдаёт ответ 29. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) < G(I)*K

    I = I + 1

WEND

  PRINT I

FUNCTION F(N)

  F = N * N * N

END FUNCTION

FUNCTION G(N)

    G = N * N

END FUNCTION

def f(n):

    return n * n * n

def g(n):

    return n*n

i = 1

k = int(input())

while f(i) < g(i) * k:

    i+=1

print (i)

ПаскальАлгоритмический язык

var

    k, i : longint;

 

function f(n: longint) : longint;

begin

    f := n * n * n;

end;

function g(n: longint) : longint;

begin

     g:= n * n;

end;

begin

     readln(k);

     i := 1;

     while f(i) < g(i) * k do

        i := i+1;

    writeln(i)

end.

алг

нач

     цел i, k

     ввод k

     i := 1

    нц пока f(i) < g(i) * k

         i := i + 1

     кц

     вывод i

     все

кон

алг цел f(цел n)

нач

    знач := n * n * n

кон

алг цел g(цел n)

нач

    знач := n * n

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

    return n * n * n;

}

long g(long n) {

    return n * n ;

}

 

int main()

{

    long k, i;

    cin >> k;

    i = 1;

    while (f(i) < g(i) * k) {

        i++;

    }

        cout << i << endl;

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10203

20
Задание 21 № 13524

Напишите в ответе наименьшее значение входной переменной k, при котором программа выдаёт ответ 23. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) < G(I)*K

    I = I + 1

WEND

  PRINT I

FUNCTION F(N)

  F = N * N * N

END FUNCTION

FUNCTION G(N)

    G = N * N

END FUNCTION

def f(n):

    return n * n * n

def g(n):

    return n*n

i = 1

k = int(input())

while f(i) < g(i) * k:

    i+=1

    print (i)

ПаскальАлгоритмический язык

var

    k, i : longint;

 

function f(n: longint) : longint;

begin

    f := n * n * n;

end;

function g(n: longint) : longint;

begin

     g:= n * n;

end;

begin

     readln(k);

     i := 1;

     while f(i) < g(i) * k

        i := i+1;

    writeln(i)

end.

алг

нач

     цел i, k

     ввод k

     i := 1

    нц пока f(i) < g(i) * k

         i := i + 1

     кц

     вывод i

     все

кон

алг цел f(цел n)

нач

    знач := n * n * n

кон

алг цел g(цел n)

нач

    знач := n * n

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

    return n * n * n;

}

long g(long n) {

    return n * n ;

}

 

int main()

{

    long k, i;

    cin >> k;

    i = 1;

    while (f(i) < g(i) * k) {

        i++;

    }

        cout << i << endl;

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 29 ноября 2016 года Вариант ИН10204

21
Задание 21 № 13551

Определите число, которое напечатает программа. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM I AS LONG

I = 1

WHILE F(I) < G(I)

  I = I * 2

WEND

PRINT I

 

FUNCTION F(N)

  F = N * N * N

END FUNCTION

 

FUNCTION G(N)

  G = 1000*N*N + 3

END FUNCTION

def f(n):

    return n*n*n

 

def g(n):

    return 1000*n*n +3

 

i = 1

while f(i) < g(i):

    i*=2

print (i)

ПаскальАлгоритмический язык

var

  i : longint;

function f(n: longint): longint;

begin

  f := n * n * n;

end;

 

function g(n: longint): longint;

begin

  g := 1000*n * n + 3;

end;

 

begin

  i := 1;

  while f(i) < g(i) do

    i := i*2;

  writeln(i)

end.

алг

нач

  цел i

  i := 1

  нц пока f(i) < g(i)

    i := i * 2

  кц

  вывод i

кон

 

алг цел f(цел n)

нач

  знач := n * n * n

кон

 

алг цел g(цел n)

нач

  знач := 1000*n * n + 3

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

    return n * n * n;

}

long g(long n) {

    return 1000*n * n + 3;

}

int main()

{

    long i;

    i = 1;

    while (f(i) < g(i))

      i = i*2;

    cout << i << endl;

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10103

22
Задание 21 № 13578

Определите число, которое напечатает программа. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM I AS LONG

I = 1

WHILE F(I) < G(I)

  I = I * 2

WEND

PRINT I

 

FUNCTION F(N)

  F = N * N * N

END FUNCTION

 

FUNCTION G(N)

  G = 500*N*N + 3

END FUNCTION

def f(n):

    return n*n*n

 

def g(n):

    return 500*n*n +3

i = 1

while f(i) < g(i):

    i*=2

print (i)

ПаскальАлгоритмический язык

var

  i : longint;

 

function f(n: longint): longint;

begin

  f := n * n * n;

end;

 

function g(n: longint): longint;

begin

  g := 500*n * n + 3;

end;

 

begin

  i := 1;

  while f(i) < g(i) do

    i := i*2;

  writeln(i)

end.

алг

нач

  цел i

  i := 1

  нц пока f(i) < g(i)

    i := i * 2

  кц

  вывод i

кон

 

алг цел f(цел n)

нач

  знач := n * n * n

кон

 

алг цел g(цел n)

нач

  знач :=500*n * n + 3

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

  return n * n * n;

}

 

long g(long n) {

  return 500*n * n + 3;

}

 

int main()

{

  long i;

  i = 1;

  while (f(i) < g(i))

    i = i*2;

  cout << i << endl;

  return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 30 сентября 2016 года Вариант ИН10104

23
Задание 21 № 13605

Определите, какое число будет напечатано в результате выполнения следующего алгоритма (для Вашего удобства алгоритм представлен на пяти языках):

 

 

БейсикPython

DIM A, B, T, M, R AS INTEGER

A = -10: B = 20

M = A: R = F(A)

FOR T = A TO B

    IF F(T) <= R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT M*R

 

FUNCTION F(x)

    F = 2*(x*x-9)*(x*x-9)+9;

END FUNCTION

def F(x):

    return 2*(x*x-9)*(x*x-9)+9

a=-10; b=20

M=a; R=F(a)

for t in range(a,b+1):

    if F(t)<=R:

        M=t; R=F(t)

print(M*R)

ПаскальАлгоритмический язык

var a,b,t,M,R :integer;

Function F(x:integer):integer;

    begin

        F := 2*(x*x-9)*(x*x-9)+9;

    end;

BEGIN

    a := -10; b := 20;

    M := a; R := F(a);

     for t := a to b do begin

        if F(t)<=R then begin

            M := t;

            R := F(t);

        end;

    end;

    write(M*R);

END.

алг

нач

    цел a, b, t, M, R

    a := -10; b := 20

    M := a; R := F(a)

    нц для t от a до b

        если F(t) <= R

            то

                M := t; R := F(t)

        все

    кц

    вывод M*R

кон

алг цел F(цел x)

нач

    знач := 2*(x*x-9)*(x*x-9)+9

кон

Си++

#include <iostream>

using namespace std;

int F(int x)

{

    return 2*(x*x-9)*(x*x-9)+9;

}

int main()

{

    int a, b, t, M, R;

    a = -10; b = 20;

    M = a; R = F(a);

    for (t=a; t<=b; t++) {

        if (F(t)<=R) {

            M = t; R = F(t);

        }

    }

    cout << M*R << endl;

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 12 мая 2017 года Вариант ИН10503

24
Задание 21 № 13632

Определите, какое число будет напечатано в результате выполнения следующего алгоритма (для Вашего удобства алгоритм представлен на пяти языках):

 

 

БейсикPython

DIM A, B, T, M, R AS INTEGER

A = -10: B = 20

M = A: R = F(A)

FOR T = A TO B

    IF F(T) <= R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT M

 

FUNCTION F(x)

    F = 2*(x*x-9)*(x*x-9)+10;

END FUNCTION

def F(x):

    return 2*(x*x-9)*(x*x-9)+10

a=-10; b=20

M=a; R=F(a)

for t in range(a,b+1):

    if F(t)<=R:

        M=t; R=F(t)

print(M)

ПаскальАлгоритмический язык

var a,b,t,M,R :integer;

Function F(x:integer):integer;

    begin

        F := 2*(x*x-9)*(x*x-9)+10;

    end;

BEGIN

    a := -10; b := 20;

    M := a; R := F(a);

     for t := a to b do begin

        if F(t)<=R then begin

            M := t;

            R := F(t);

        end;

    end;

    write(M);

END.

алг

нач

    цел a, b, t, M, R

    a := -10; b := 20

    M := a; R := F(a)

    нц для t от a до b

        если F(t) <= R

            то

                M := t; R := F(t)

        все

    кц

    вывод M

кон

алг цел F(цел x)

нач

    знач := 2*(x*x-9)*(x*x-9)+10

кон

Си++

#include <iostream>

using namespace std;

int F(int x)

{

    return 2*(x*x-9)*(x*x-9)+10;

}

int main()

{

    int a, b, t, M, R;

    a = -10; b = 20;

    M = a; R = F(a);

    for (t=a; t<=b; t++) {

        if (F(t)<=R) {

            M = t; R = F(t);

        }

    }

    cout « M « endl;

    return 0;

}

 

Источник: Тренировочная работа по ИНФОРМАТИКЕ 11 класс 12 мая 2017 года Вариант ИН10504

25
Задание 21 № 13748

Напишите в ответе число, которое будет напечатано в результате выполнения следующего алгоритма. Для Вашего удобства алгоритм представлен на пяти языках программирования.

 

БейсикPython

DIM A, B, T, M, R AS LONG

A = -20: B = 20

M = A: R = F(A)

FOR T = A TO B

    IF F(T) <= R THEN

         M = T

         R = F(T)

    END IF

NEXT t

PRINT M+R

 

FUNCTION F (x)

     F = 2*(x*x-1)*(x*x-1)+27

END FUNCTION

def f(x):

     return 2*(x*x-1)*(x*x-1)+27

a = -20; b=20

M=a; R=F(a)

for t in range(a,b+1):

    if (F(t) <= R):

         M=t; R=F(t)

print (M+R)

ПаскальАлгоритмический язык

var a, b, t, M, R :longint;

function F(x: longint) : longint;

    begin

         F:= 2*(x*x-1)*(x*x-1)+27;

    end;

begin

     a:=-20; b:=20;

     M:=a; R:=F(a);

     for t:= a to b do begin

         if (F(t) <= R) then begin

             M:=t;

             R:=F(t)

      end

    end;

     write(M+R)

end.

алг

нач

    цел a, b, t, M, R

    a:=-20; b:=20

    M:=a; R:=F(a)

    нц для t от a до b

         если F(t) <= R то

            то

                 M:=t; R:=F(t)

        все

    кц

    вывод M+R

кон

алг цел F(цел x)

нач

    знач :=2*(x*x-1)*(x*x-1)+27

кон

Си++

#include <iostream>

using namespace std;

 

long F(long x) {

     return 2*(x*x-1)*(x*x-1)+27;

}

 

int main() {

     long a = -20, b = 20, M = a, R = F(a);

     for (int t = a; t <= b; ++t) {

         if (F(t)<= R) {

            M = t; R = F(t);

        }

    }

     cout << M + R;

    return 0;

}

 

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2018 по информатике.

26
Задание 21 № 14236

Напишите в ответе наименьшее значение входной переменной k, при котором программа выдаёт ответ 11. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) < K

  I = I + 1

WEND

PRINT I

 

FUNCTION F(N)

  F = N * N

END FUNCTION

def f(n):

  return n*n

k = int(input())

i = 1

while f(i) < k:

  i += 1

print (i)

ПаскальАлгоритмический язык

var

  k, i : longint;

 

function f(n: longint): longint;

begin

  f := n * n;

end;

 

begin

  readln(k);

  i := 1;

  while f(i) < k do

    i := i+1;

  writeln(i)

end.

алг

нач

  цел k, i

  ввод k

  i := 1

  нц пока f(i) < k

    i := i + 1

  кц

  вывод i

кон

 

алг цел f(цел n)

нач

  знач := n * n

кон

Си++

#include <iostream>

using namespace std;

 

long f(long n) {

  return n * n;

}

int main()

{

  long k, i;

  cin >> k;

  i = 1;

  while (f(i) < k)

    i++;

  cout << i;

  return 0;

}

 


27
Задание 21 № 14280

Напишите в ответе наименьшее значение входной переменной k, при котором программа выдаёт ответ 10. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 1

WHILE F(I) < K

  I = I + 1

WEND

PRINT I

 

FUNCTION F(N)

  F = N * N

END FUNCTION

def f(n):

  return n*n

k = int(input())

i = 1

while f(i) < k:

  i += 1

print (i)

ПаскальАлгоритмический язык

var

  k, i : longint;

 

function f(n: longint): longint;

begin

  f := n * n;

end;

 

begin

  readln(k);

  i := 1;

  while f(i) < k do

    i := i+1;

  writeln(i)

end.

алг

нач

  цел k, i

  ввод k

  i := 1

  нц пока f(i) < k

    i := i + 1

  кц

  вывод i

кон

 

алг цел f(цел n)

нач

  знач := n * n

кон

Си++

#include <iostream>

using namespace std;

 

long f(long n) {

  return n * n;

}

int main()

{

  long k, i;

  cin >> k;

  i = 1;

  while (f(i) < k)

    i++;

  cout << i;

  return 0;

}

 


28
Задание 21 № 14707

Напишите в ответе наибольшее значение входной переменной k, при котором программа выдаёт ответ 7. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 20

WHILE F(I) > K

    I = I - 1

WEND

PRINT I

FUNCTION F(N)

    F = N * N * N

END FUNCTION

def f(n):

    return n * n * n

k = int(input())

i = 20

while f(i) > k:

    i -= 1

print(i)

ПаскальАлгоритмический язык

var

    k, i : longint;

function f(n: longint): longint;

begin

    f := n * n * n

end;

begin

    readln(k);

    i := 20;

    while f(i) > k do

        i := i-1;

    writeln(i)

end.

алг

нач

    цел k, i

    ввод k

    i := 20

    нц пока f(i) > k

        i := i - 1

    кц

    вывод i

кон

алг цел f(цел n)

нач

    знач := n * n * n

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

return n * n * n;

}

int main()

{

    long k, i;

    cin >> k;

    i = 20;

    while (f(i) > k) --i;

    cout << i;

    return 0;

}

 

Источник: СтатГрад: Тре­ни­ро­воч­ная ра­бо­та 28.11.2017 ИН10203

29
Задание 21 № 14782

Напишите в ответе наибольшее значение входной переменной k, при котором программа выдаёт ответ 9. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 20

WHILE F(I) > K

    I = I - 1

WEND

PRINT I

FUNCTION F(N)

    F = N * N * N

END FUNCTION

def f(n):

    return n * n * n

k = int(input())

i = 20

while f(i) > k:

    i -= 1

print(i)

ПаскальАлгоритмический язык

var

    k, i : longint;

function f(n: longint): longint;

begin

    f := n * n * n

end;

begin

    readln(k);

    i := 20;

    while f(i) > k do

        i := i-1;

    writeln(i)

end.

алг

нач

    цел k, i

    ввод k

    i := 20

    нц пока f(i) > k

        i := i - 1

    кц

    вывод i

кон

алг цел f(цел n)

нач

    знач := n * n * n

кон

Си++

#include <iostream>

using namespace std;

long f(long n) {

return n * n * n;

}

int main()

{

    long k, i;

    cin >> k;

    i = 20;

    while (f(i) > k) --i;

    cout << i;

    return 0;

}

 


30
Задание 21 № 15116

Напишите в ответе наибольшее значение входной переменной k, при котором программа выдаёт ответ 7. Для Вашего удобства программа приведена на пяти языках программирования.

 

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 20

WHILE F(I) > K

    I = I - 1

WEND

PRINT I

 

FUNCTION F(N)

    F = N * N + N

END FUNCTION

def f(n):

    return n * n + n

 

k = int(input())

i = 20

while f(i) > k:

    i -= 1

print(i)

 

ПаскальАлгоритмический язык

var

    k, i : longint;

 

function f(n: longint): longint;

begin

    f := n * n + n

end;

 

begin

    readln(k);

    i := 20;

    while f(i) > k do

        i := i-1;

    writeln(i)

end.

 

алг

нач

    цел k, i

    ввод k i := 20

    нц пока f(i) > k

        i := i - 1

    кц

    вывод i

кон

 

алг цел f(цел n)

нач

    знач := n * n + n

кон

 

С++

#include <iostream>

using namespace std;

long f(long n) {

    return n * n + n;

}

 

int main()

{

    long k, i;

    cin >> k;

    i = 20;

    while (f(i) > k) --i;

    cout << i;

    return 0;

}

 


31
Задание 21 № 15143

Напишите в ответе наибольшее значение входной переменной k, при котором программа выдаёт ответ 9. Для Вашего удобства программа приведена на пяти языках программирования.

 

 

БейсикPython

DIM K, I AS LONG

INPUT K

I = 20

WHILE F(I) > K

    I = I - 1

WEND

PRINT I

 

FUNCTION F(N)

    F = N * N + N

END FUNCTION

def f(n):

    return n * n + n

 

k = int(input())

i = 20

while f(i) > k:

    i -= 1

print(i)

 

ПаскальАлгоритмический язык

var

    k, i : longint;

 

function f(n: longint): longint;

begin

    f := n * n + n

end;

 

begin

    readln(k);

    i := 20;

    while f(i) > k do

        i := i-1;

    writeln(i)

end.

 

алг

нач

    цел k, i

    ввод k i := 20

    нц пока f(i) > k

        i := i - 1

    кц

    вывод i

кон

 

алг цел f(цел n)

нач

    знач := n * n + n

кон

 

С++

#include <iostream>

using namespace std;

long f(long n) {

    return n * n + n;

}

 

int main()

{

    long k, i;

    cin >> k;

    i = 20;

    while (f(i) > k) --i;

    cout << i;

    return 0;

}

 


32
Задание 21 № 15637

Какое значение будет выведено на экран после выполнения данной программы?

 

БейсикPython

DIM A, B, T, M, R AS INTEGER

    A = -20: B = 20

    M = A: R = F(A)

    FOR T = A TO B

        IF F(T) > R THEN

            M = T

            R = F(T)

        END IF

    NEXT T

    PRINT M+24

    FUNCTION F(x)

        F := 2*(x-19)*(x-19)+7

    END FUNCTION

def f(x):

    return 2*(x-19)*(x-19)+7

a = -20

b = 20

M = a

R = f(a)

for t in range(a, b+1):

    if (f(t) > R):

        M = t

        R = f(t);

print(M+24)

ПаскальАлгоритмический язык

var a,b,t,M,R :integer;

Function F(x: integer):integer;

    begin

        F := 2*(x-19)*(x-19)+7;

    end;

BEGIN

     a := -20; b := 20;

     M := a; R := F(a);

     for t := a to b do begin

         if (F(t) > R) then begin

             M := t;

            R := F(t);

        end;

    end;

write(M+24);

END.

алг

нач

    цел a, b, t, M, R

    a:=-20; b:=20

    M:=a; R:=F(a)

    нц для t от a до b

         если F(t) > R то

            то

                 M:=t; R:=F(t)

        все

    кц

    вывод M+24

кон

алг цел F(цел x)

нач

    знач :=2*(x-19)*(x-19)+7;

кон

Си++

#include <iostream>

using namespace std;

 

int F(int x)

{

    return 2*(x-19)*(x-19)+7

}

int main()

{

    int a, b, t, M, R;

    a = -20; b = 20;

    M = a; R = F(a);

    for (t=a; t<=b; t++){

        if (F(t) > R) {

            M = t; R = F(t);

        }

    }

    cout << (M+24) << endl;

}

 

Источник: ЕГЭ — 2018. До­сроч­ная волна. Вариант 1., ЕГЭ — 2018. До­сроч­ная волна. Вариант 2.

33
Задание 21 № 15806

Какое число будет напечатано в результате работы следующей программы? Для Вашего удобства программа приведена на пяти языках программирования.

 

 

БейсикPython

DIM A, B, T, M, R AS INTEGER

A = −9: B = 9

M = A : R = F(A)

FOR T = A TO B

    IF F(T) > R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT M+R

 

FUNCTION F(x)

    F = 2 * (x−1) * (x−3) + 7

END FUNCTION

def F(x):

    return 2 * (x−1) * (x−3) + 7

 

a = −9; b = 9

M = a; R = F(a)

for t in range(a,b+1):

    if F(t) > R:

        M = t; R = F(t)

print(M+R)

 

ПаскальАлгоритмический язык

var

    a, b, t, M, R: integer;

 

function F(x: integer): integer;

begin

    f := 2 * (x−1) * (x−3) + 7;

end;

 

begin

    a := −9; b := 9;

    M := a; R:= F(a)

    for t := a to b do begin

        if F(t) > R then begin

            M := t;

            R := F(t);

        end;

    end;

    write(M+R);

end.

 

алг

нач

    цел a, b, t, M, R

    a := −9; b := 9

    M := a; R := F(a)

    нц для t от a до b

        если F(t) > R

            то M := t; R := F(t)

        все

    кц

    вывод M + R

кон

 

алг цел f(цел x)

нач

    знач := 2 * (x−1) * (x−3) + 7

кон

 

С++

#include <iostream>

using namespace std;

long f(int x) {

    return 2 * (x−1) * (x−3) + 7;

}

 

int main()

{

    int a, b, t, M, R;

    a = −9; b = 9;

    M = a; R = F(a);

    for (t = a; t <=b; ++t) {

        if (F(t) > R) {

            M = t; R = F(t);

        }

    }

    cout << M + R;

    return 0;

}

 


34
Задание 21 № 15833

Какое число будет напечатано в результате работы следующей программы? Для Вашего удобства программа приведена на пяти языках программирования.

 

 

БейсикPython

DIM A, B, T, M, R AS INTEGER

A = −8: B = 8

M = A : R = F(A)

FOR T = A TO B

    IF F(T) > R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT M+R

 

FUNCTION F(x)

    F = 2 * (x−2) * (x−4) + 3

END FUNCTION

def F(x):

    return 2 * (x−2) * (x−4) + 3

 

a = −8; b = 8

M = a; R = F(a)

for t in range(a,b+1):

    if F(t) > R:

        M = t; R = F(t)

print(M+R)

 

ПаскальАлгоритмический язык

var

    a, b, t, M, R: integer;

 

function F(x: integer): integer;

begin

    f := 2 * (x−2) * (x−4) + 3;

end;

 

begin

    a := −8; b := 8;

    M := a; R:= F(a)

    for t := a to b do begin

        if F(t) > R then begin

            M := t;

            R := F(t);

        end;

    end;

    write(M+R);

end.

 

алг

нач

    цел a, b, t, M, R

    a := −8; b := 8

    M := a; R := F(a)

    нц для t от a до b

        если F(t) > R

            то M := t; R := F(t)

        все

    кц

    вывод M + R

кон

 

алг цел f(цел x)

нач

    знач := 2 * (x−2) * (x−4) + 3

кон

 

С++

#include <iostream>

using namespace std;

long f(int x) {

    return 2 * (x−2) * (x−4) + 3;

}

 

int main()

{

    int a, b, t, M, R;

    a = −8; b = 8;

    M = a; R = F(a);

    for (t = a; t <=b; ++t) {

        if (F(t) > R) {

            M = t; R = F(t);

        }

    }

    cout << M + R;

    return 0;

}

 


35
Задание 21 № 15861

Определите число различных значений входной переменной k, при которых программа выдаёт тот же ответ, что и при входном значении k = 8. Значение k = 8 также включается в подсчёт различных значений k. Для Вашего удобства программа приведена на пяти языках программирования.

 

БейсикPython

    DIM K, I AS LONG

    INPUT K

    I = 12

    WHILE I > 0 AND F(I) > K

        I = I − 1

    WEND

    PRINT I

 

    FUNCTION F(N)

        F = N * N * N

    END FUNCTION

def F(n):

    return n * n * n

 

k = int(input())

i = 12

while (i > 0 and F(i) > k):

    i = i − 1

print (i)

ПаскальАлгоритмический язык

var k, i :longint;

function F(n: longint) : longint;

begin

    F := n * n * n;

end;

 

begin

     readln(k);

     i := 12;

    while (i > 0) and (F(i) > k) do

         i := i − 1;

    writeln(i);

end.

алг

нач

    цел i, k

    ввод k

    i := 12

    нц пока i > 0 и f(i) > k

        i := i − 1

    кц

    вывод i

кон

алк цел f(цел n)

нач

    знач := n * n * n

кон

Си++

#include <iostream>

using namespace std;

 

long F(long n)

{

    return n * n * n

}

 

int main()

{

    int k, i;

    cin >> k;

    i = 12;

    while (i > 0 && F(i) > k)

        i−−

    cout << i;

return 0;

}

 

Источник: ЕГЭ — 2018. До­сроч­ная волна. Вариант 2., ЕГЭ — 2018. До­сроч­ная волна. Вариант 1.

36
Задание 21 № 15931

Какое число будет напечатано в результате работы следующей программы? Для Вашего удобства программа приведена на пяти языках программирования.

 

 

БейсикPython

DIM A, B, T, M, R AS INTEGER

A = −9: B = 7

M = A : R = F(A)

FOR T = A TO B

    IF F(T) <= R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT M+R

 

FUNCTION F(x)

    F = 2*(x*x−64)*(x*x−64)+17

END FUNCTION

def F(x):

    return 2*(x*x−64)*(x*x−64)+17

 

a = −9; b = 7

M = a; R = F(a)

for t in range(a,b+1):

    if F(t) <= R:

        M = t; R = F(t)

print(M+R)

 

ПаскальАлгоритмический язык

var

    a, b, t, M, R: integer;

 

function F(x: integer): integer;

begin

    f := 2*(x*x−64)*(x*x−64)+17;

end;

 

begin

    a := −9; b := 7;

    M := a; R:= F(a)

    for t := a to b do begin

        if F(t) <= R then begin

            M := t;

            R := F(t);

        end;

    end;

    write(M+R);

end.

 

алг

нач

    цел a, b, t, M, R

    a := −9; b := 7

    M := a; R := F(a)

    нц для t от a до b

        если F(t) <= R

            то M := t; R := F(t)

        все

    кц

    вывод M + R

кон

 

алг цел f(цел x)

нач

    знач := 2*(x*x−64)*(x*x−64)+17

кон

 

С++

#include <iostream>

using namespace std;

long f(int x) {

    return 2*(x*x−64)*(x*x−64)+17;

}

 

int main()

{

    int a, b, t, M, R;

    a = −9; b = 7;

    M = a; R = F(a);

    for (t = a; t <=b; ++t) {

        if (F(t) <= R) {

            M = t; R = F(t);

        }

    }

    cout << M + R;

    return 0;

}

 


37
Задание 21 № 15958

Какое число будет напечатано в результате работы следующей программы? Для Вашего удобства программа приведена на пяти языках программирования.

 

 

БейсикPython

DIM A, B, T, M, R AS INTEGER

A = −7: B = 9

M = A : R = F(A)

FOR T = A TO B

    IF F(T) < R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT M+R

 

FUNCTION F(x)

    F = 2*(x*x−64)*(x*x−64)+17

END FUNCTION

def F(x):

    return 2*(x*x−64)*(x*x−64)+17

 

a = −7; b = 9

M = a; R = F(a)

for t in range(a,b+1):

    if F(t) < R:

        M = t; R = F(t)

print(M+R)

 

ПаскальАлгоритмический язык

var

    a, b, t, M, R: integer;

 

function F(x: integer): integer;

begin

    f := 2*(x*x−64)*(x*x−64)+17;

end;

 

begin

    a := −7; b := 9;

    M := a; R:= F(a)

    for t := a to b do begin

        if F(t) < R then begin

            M := t;

            R := F(t);

        end;

    end;

    write(M+R);

end.

 

алг

нач

    цел a, b, t, M, R

    a := −7; b := 9

    M := a; R := F(a)

    нц для t от a до b

        если F(t) < R

            то M := t; R := F(t)

        все

    кц

    вывод M + R

кон

 

алг цел f(цел x)

нач

    знач := 2 * (x*x−64) * (x*x−64) + 17

кон

 

С++

#include <iostream>

using namespace std;

long f(int x) {

    return 2 * (x*x−64) * (x*x−64) + 17;

}

 

int main()

{

    int a, b, t, M, R;

    a = −7; b = 9;

    M = a; R = F(a);

    for (t = a; t <=b; ++t) {

        if (F(t) < R) {

            M = t; R = F(t);

        }

    }

    cout << M + R;

    return 0;

}

 


38
Задание 21 № 15989

Какое число будет напечатано в результате работы следующей программы? Для Вашего удобства программа приведена на пяти языках программирования.

 

 

БейсикPython

DIM A, B, T, M, R AS INTEGER

A = −20: B = 20

M = A : R = F(A)

FOR T = A TO B

    IF F(T) <= R THEN

        M = T

        R = F(T)

    END IF

NEXT T

PRINT M+R

 

FUNCTION F(x)

F=abs(abs(x−6)+abs(x+6)−16)+2

END FUNCTION

def F(x):

return(abs(abs(x−6)+abs(x+6)−16)+2)

 

a = −20; b = 20

M = a; R = F(a)

for t in range(a,b+1):

    if F(t) <= R:

        M = t; R = F(t)

print(M+R)

 

ПаскальАлгоритмический язык

var

    a, b, t, M, R: integer;

 

function F(x: integer): integer;

begin

f:=abs(abs(x−6)+abs(x+6)−16)+2;

end;

 

begin

    a := −20; b := 20;

    M := a; R:= F(a)

    for t := a to b do begin

        if F(t) <= R then begin

            M := t;

            R := F(t);

        end;

    end;

    write(M+R);

end.

 

алг

нач

    цел a, b, t, M, R

    a := −20; b := 20

    M := a; R := F(a)

    нц для t от a до b

        если F(t) <= R

            то M := t; R := F(t)

        все

    кц

    вывод M + R

кон

 

алг цел f(цел x)

нач

знач:=abs(abs(x−6)+abs(x+6)−16)+2

кон

 

С++

#include <iostream>

using namespace std;

long f(int x) {

return (abs(abs(x−6)+abs(x+6)−16)+2);

}

 

int main()

{

    int a, b, t, M, R;

    a = −20; b = 20;

    M = a; R = F(a);

    for (t = a; t <=b; ++t) {

        if (F(t) <= R) {

            M = t; R = F(t);

        }

    }

    cout << M + R;

    return 0;

}

 

Источник: ЕГЭ по информатике 28.05.2018. Основная волна, вариант А. Имаева — «Котолис».

Пройти тестирование по этим заданиям