СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 8 № 9359

За­пи­ши­те число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей про­грам­мы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках про­грам­ми­ро­ва­ния.

 

Бей­сикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 111

S = S + 8

N = N + 2

WEND

PRINT N

s = 0

n = 0

while s < 111:

s = s + 8

n = n + 2

print(n)

Пас­кальАл­го­рит­ми­че­ский язык

var s, n: integer;

begin

s := 0;

n := 0;

while s < 111 do

begin

s := s + 8;

n := n + 2

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока s < 111

s := s + 8

n := n + 2

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{ int s = 0, n = 0;

while (s < 111) { s = s + 8; n = n + 2; }

cout << n << endl;

return 0;

}

 

Ре­ше­ние.

Цикл while вы­пол­ня­ет­ся до тех пор, пока ис­тин­но усло­вие s < 111, т. е. пе­ре­мен­ная s опре­де­ля­ет, сколь­ко раз вы­пол­нит­ся цикл. По­сколь­ку из­на­чаль­но s = 0, цикл вы­пол­нит­ся 14 раз, сле­до­ва­тель­но, n = 2 * 14 = 28.

 

Ответ: 28.

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2016 по информатике.