≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 9359

Запишите число, которое будет напечатано в результате выполнения следующей программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 0

N = 0

WHILE S < 111

S = S + 8

N = N + 2

WEND

PRINT N

s = 0

n = 0

while s < 111:

s = s + 8

n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

s := 0;

n := 0;

while s < 111 do

begin

s := s + 8;

n := n + 2

end;

writeln(n)

end.

алг

нач

цел n, s

n := 0

s := 0

нц пока s < 111

s := s + 8

n := n + 2

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{ int s = 0, n = 0;

while (s < 111) { s = s + 8; n = n + 2; }

cout << n << endl;

return 0;

}

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s < 111, т. е. переменная s определяет, сколько раз выполнится цикл. Поскольку изначально s = 0, цикл выполнится 14 раз, следовательно, n = 2 * 14 = 28.

 

Ответ: 28.

Источник: Де­мон­стра­ци­он­ная вер­сия ЕГЭ—2016 по информатике.