≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 9192

Определите, что будет напечатано в результате выполнения программы, записанной ниже на разных языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 650

    S = S + 20

    N = N * 5

WEND

PRINT S

n = 1

s = 0

while n <= 650:

    s = s + 20

    n = n * 5

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 650 do

    begin

        s := s + 20;

        n := n * 5

    end;

    write(s)

end.

алг

нач

    цел n, s

    n := 1

    s := 0

    нц пока n <= 650

        s := s + 20

        n := n * 5

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 650)

    {

        s = s + 20;

        n = n * 5;

    }

    cout « s « endl;

    return 0;

}

 

Пояснение.

Промодулируем действия цикла:

 

ns
10
520
2540
12560
62580
3125100

 

Когда n станет равным 3125, цикл прекратится.