СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 9160

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 56

N = 0

WHILE n < 15

    S = S - 6

    N = N + 3

WEND

PRINT(S)

s = 56

n = 0

while n < 15:

    s = s - 6

    n = n + 3

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 56;

    n := 0;

    while n < 15 do

    begin

        s := s - 6;

        n := n + 3;

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 56

    n := 0

    нц пока n < 15

        s := s - 6

        n := n + 3

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main(void)

{

    int s, n;

    s = 56;

    n = 0;

    while (n < 15) {

        s = s - 6;

        n = n + 3;

    }

    cout << s << endl;

}

 

Решение.

Промоделируем действия цикла:

 

ns
056
350
644
938
1232
1526

 

Когда n станет равным 15, цикл прекратится.

 

Ответ: 26.