СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 8656

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 78

N = 0

WHILE N < 12

    S = S – 8

    N = N + 2

WEND

PRINT(S)

s = 78

n = 0

while n < 12:

    s = s - 8

    n = n + 2

print(s)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 78;

    n := 0;

    while n < 12 do

    begin

        s := s – 8;

        n := n + 2

    end;

    writeln(s)

end.

алг

нач

    цел s, n

    s := 78

    n := 0

    нц пока n < 12

        s := s — 8

        n := n + 2

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main(void)

{

    int s, n;

    s = 78;

    n = 0;

    while (n < 12) {

        s = s – 8;

        n = n + 2;

    }

    cout << s << endl;

}

 

Пояснение.

Цикл завершится, когда станет 12. То есть цикл выполнится 6 раз.