СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 8096

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 301

N = 0

WHILE S > 0

    S = S - 10

    N = N + 2

WEND

PRINT N

s = 301

n = 0

while s > 0:

    s = s - 10

    n = n + 2

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 301;

    n := 0;

    while s > 0 do

    begin

        s := s - 10;

        n := n + 2;

    end;

    writeln(n)

end.

алг

нач

    цел n, s

    s := 301

    n := 0

    нц пока s > 0

        s := s - 10

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 301, n = 0;

    while (s > 0) {

        s = s - 10;

        n = n + 2;

    }

    cout << n << endl;

    return 0;

}

 

Пояснение.

Заметим, что после 30 итераций цикла s = 1, а n = 60. После 31 итерации станет s = -9, n = 62, и цикл прекратится.

Источник: ЕГЭ 05.05.2015. До­сроч­ная волна.