СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 8 № 8096

За­пи­ши­те число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках про­грам­ми­ро­ва­ния.

 

Бей­сикPython

DIM S, N AS INTEGER

S = 301

N = 0

WHILE S > 0

    S = S - 10

    N = N + 2

WEND

PRINT N

s = 301

n = 0

while s > 0:

    s = s - 10

    n = n + 2

print(n)

Пас­кальАл­го­рит­ми­че­ский язык

var s, n: integer;

begin

    s := 301;

    n := 0;

    while s > 0 do

    begin

        s := s - 10;

        n := n + 2;

    end;

    writeln(n)

end.

алг

нач

    цел n, s

    s := 301

    n := 0

    нц пока s > 0

        s := s - 10

        n := n + 2

    кц

    вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s = 301, n = 0;

    while (s > 0) {

        s = s - 10;

        n = n + 2;

    }

    cout << n << endl;

    return 0;

}

 

Ре­ше­ние.

За­ме­тим, что после 30 ите­ра­ций цикла s = 1, а n = 60. После 31 ите­ра­ции ста­нет s = -9, n = 62, и цикл пре­кра­тит­ся.

Источник: ЕГЭ 05.05.2015. До­сроч­ная волна.