≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 7984

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

 N = 1

 S = 0

 WHILE N <= 300

    S = S + 30

    N = N * 3

 WEND

 PRINT S

n = 1

s = 0

while n <= 300:

    s = s + 30

    n = n * 3

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 300 do

    begin

        s := s + 30;

        n := n * 3

    end;

    write(s)

end.

алг

нач

    цел n, s

    n := 1

    s := 0

    нц пока n <= 300

        s := s + 30

        n := n * 3

    кц

    вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 300)

{

    s = s + 30;

    n = n * 3;

}

    cout « s « endl;

return 0;

}

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие n ≤ 300, т. е. переменная n определяет, сколько раз выполнится цикл. Поскольку изначально n = 1 и на каждом шаге n увеличивается в три раза, цикл выполниться шесть раз. Следовательно, после выполнения цикла s примет значение 30 · 6 = 180.

 

Ответ: 180.