СДАМ ГИА: РЕШУ ЕГЭ
Образовательный портал для подготовки к экзаменам
Информатика
≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 7919

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM N, S AS INTEGER

N = 1

S = 0

WHILE N <= 100

S = S + 30

N = N * 3

WEND

PRINT S

n = 1

s = 0

while n <= 100:

    s = s + 30

    n = n * 3

print(s)

ПаскальАлгоритмический язык

var n, s: integer;

begin

    n := 1;

    s := 0;

    while n <= 100 do

    begin

        s := s + 30;

        n := n * 3

    end;

    write(s)

end.

алг

нач

цел n, s

n := 1

s := 0

нц пока n <= 100

    s := s + 30

    n := n * 3

кц

вывод s

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int n, s;

    n = 1;

    s = 0;

    while (n <= 100)

    {

        s = s + 30;

        n = n * 3;

    }

    cout « s « endl;

    return 0;

}

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие n ≤ 100, т. е. переменная n определяет, сколько раз выполнится цикл. Поскольку изначально n = 1 и на каждом шаге n увеличивается в три раза, цикл выполнится пять раз. Следовательно, после выполнения цикла s примет значение 30 · 5 = 150.

 

Ответ: 150.