≡ информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 8 № 7780

Запишите число, которое будет напечатано в результате выполнения программы. Для Вашего удобства программа представлена на пяти языках программирования.

 

БейсикPython

DIM S, N AS INTEGER

S = 42

N = 1

WHILE S > 0

S = S – 5

N = N + 3

WEND

PRINT(N)

s = 42

n = 1

while s > 0:

    s = s - 5

    n = n + 3

print(n)

ПаскальАлгоритмический язык

var s, n: integer;

begin

    s := 42;

    n := 1;

    while s > 0 do

    begin

        s := s – 5;

        n := n + 3

    end;

    writeln(n)

end.

алг

нач

цел s, n

s := 42

n := 1

нц пока s > 0

    s := s — 5

    n := n + 3

кц

вывод n

кон

Си++

#include <iostream>

using namespace std;

int main()

{

    int s, n;

    s = 42;

    n = 1;

    while (s > 0) {

        s = s – 5;

        n = n + 3;

    }

    cout << n << endl;

}

 

Пояснение.

Цикл while выполняется до тех пор, пока истинно условие s > 0, т. е. переменная s определяет, сколько раз выполнится цикл. Поскольку изначально s = 42, цикл выполнится 9 раз, следовательно, n = 9 · 3 + 1 = 28.

 

Ответ: 28.